Information about this document

General
This document contains all information for installation, putting into operation, operation, and maintenance or trouble-shooting of the system delivered. This document is intended for persons with basic knowledge of installation and operation of software-controlled machines. General knowledge of operational safety as well as basic knowledge of using PCs running Microsoft Windows® are required.

Availability
A complete and legible copy of this document must be available at the operation station. Any person who is authorised to operate the system must have read and understood this document. The facility owner is required to ensure that all safety measures listed in this document are observed.

Notations
Various text attributes, notations, and structures are used to facilitate reading and understanding the document. The text attributes (highlighting) inside this document are defined as follows:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Important information</td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Brand name</td>
</tr>
<tr>
<td><strong>Bold italics</strong></td>
<td>LPKF brand name</td>
</tr>
<tr>
<td>[...]</td>
<td>Button</td>
</tr>
<tr>
<td>...\</td>
<td>Input/display field</td>
</tr>
<tr>
<td>&lt;...&gt;</td>
<td>Check box</td>
</tr>
<tr>
<td>{...}</td>
<td>Radio button</td>
</tr>
<tr>
<td>&gt;...&gt;...&gt;</td>
<td>Menu trail</td>
</tr>
<tr>
<td>/.../</td>
<td>Reference to a number in the figure</td>
</tr>
</tbody>
</table>

Figures
Figures (photos or drawings) are displayed in a frame. Each figure has a numbered figure title, e. g. “Fig. 1: Overview”. Numbers in the figure mark certain components or actions. Arrows in the figure show the direction of an action.

Tables
Data, facts, and important contexts are arranged in tables. Each table has a numbered table title, e. g. “Table 1: Scope of delivery”. Every table has a highlighted header row containing the column headings.
Procedures
In this document, procedures or workflows are compiled to step-by-step operation sequences. An individual operation sequence consists of at least three components: Title, step, and result.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ title</td>
<td>Description of the objective of the procedure marked by a preceding “■”</td>
</tr>
<tr>
<td>1. step</td>
<td>Consecutively numbered sequence of an procedure</td>
</tr>
<tr>
<td>⇨ intermediate result</td>
<td>Intermediate result of an operation step. The procedure continues.</td>
</tr>
<tr>
<td>♦ result</td>
<td>Result of the procedure marked by a preceding “♦”</td>
</tr>
</tbody>
</table>

Symbols and signal words
The following symbols are used to mark important information:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Safety note</td>
</tr>
<tr>
<td></td>
<td>WARNING – Hazard for persons</td>
</tr>
<tr>
<td></td>
<td>CAUTION – Damage to the system</td>
</tr>
<tr>
<td>📜</td>
<td>Note</td>
</tr>
<tr>
<td></td>
<td>A note is an information on the optimum usage of a feature.</td>
</tr>
<tr>
<td>📝</td>
<td>Tip</td>
</tr>
<tr>
<td></td>
<td>A tip contains additional information.</td>
</tr>
<tr>
<td>®</td>
<td>Copyright</td>
</tr>
<tr>
<td>®</td>
<td>Registered Trademark</td>
</tr>
</tbody>
</table>

Registered Trademarks and Brand names
The LPKF Logo and the LPKF product names are registered trademarks of LPKF Laser & Electronics AG.

Microsoft and Windows are brand names or registered trademarks of Microsoft Corporation in the USA and/or other countries.

All other trademarks belong to the respective owner.

Standards
The following standards and guidelines were observed when creating this document:

<table>
<thead>
<tr>
<th>Standard</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIN 5008 2011-04</td>
<td>Rules for writing and layouting</td>
</tr>
<tr>
<td>VDI 4500 Bl.1,2 11-2006</td>
<td>Technical documentation - Definitions and legal basics</td>
</tr>
<tr>
<td>DIN EN 82079-1 2011-04</td>
<td>Preparation of instructions for use. Structuring, content and presentation. General principles and detailed requirements</td>
</tr>
<tr>
<td>DIN EN ISO 12100 2011-03</td>
<td>Safety of machinery - General principles for design - Risk assessment and risk reduction</td>
</tr>
<tr>
<td>DIN EN 60204-1 2007-06</td>
<td>Safety of machinery - Electrical equipment of machines - Part 1: General requirements</td>
</tr>
</tbody>
</table>
## Contents

1. **Function** .......................................................................................................................... 11

2. **Safety notes** ...................................................................................................................... 12

   2.1 General safety notes........................................................................................................... 13

3. **Installation** ....................................................................................................................... 14

   3.1 System requirements .......................................................................................................... 14

   3.2 Installing and starting the software .................................................................................... 16

   3.3 Machine setup ................................................................................................................... 23

4. **Structure of the user interface** ......................................................................................... 25

   4.1 User interface ................................................................................................................... 25

   4.2 Views.................................................................................................................................. 27

      4.2.1 CAM View ................................................................................................................... 27

      4.2.2 Toolbar CAM view ....................................................................................................... 28

      4.2.3 Machining view E33 .................................................................................................... 30

      4.2.4 Machining view S43 .................................................................................................... 31

      4.2.5 Machining view S63/S103 ............................................................................................ 32

      4.2.6 Machining view ProtoMat D104 ................................................................................. 33

      4.2.7 Toolbar Machining view ............................................................................................. 34

      4.2.8 3D View ...................................................................................................................... 36

      4.2.9 Toolbar 3D view ........................................................................................................... 37

   4.3 Toolbars ............................................................................................................................. 38

      4.3.1 Toolbar Standard ........................................................................................................... 39

      4.3.2 Toolbar Insert .............................................................................................................. 40

      4.3.3 Toolbar Modify ............................................................................................................. 41

      4.3.4 Toolbar Prototyping .................................................................................................... 42

      4.3.5 Toolbar Layout ............................................................................................................. 42

   4.4 Panes .................................................................................................................................. 43

      4.4.1 Layers ......................................................................................................................... 44

      4.4.2 Geometry .................................................................................................................... 45

      4.4.3 Toolpath ...................................................................................................................... 45

      4.4.4 Processing ................................................................................................................... 46

      4.4.5 Properties .................................................................................................................... 48

      4.4.6 Tool Info ..................................................................................................................... 49

      4.4.7 Navigation ................................................................................................................... 50

      4.4.8 Camera (only if a camera is connected) ....................................................................... 51

      4.4.9 Messages ..................................................................................................................... 52

      4.4.10 Fault Monitor ............................................................................................................ 53
5 How to work with CircuitPro PM ................................................................. 54
  5.1 Menu File ................................................................................................ 55
    5.1.1 New .................................................................................................. 57
    5.1.2 Open ............................................................................................... 60
    5.1.3 Recent files ..................................................................................... 60
    5.1.4 Save ................................................................................................ 60
    5.1.5 Save As ........................................................................................... 61
    5.1.6 Save As Template ........................................................................... 62
    5.1.7 Import ............................................................................................... 63
    5.1.8 Import 3D shape ............................................................................. 71
    5.1.9 Import toolpath ............................................................................. 72
    5.1.10 Recent files imported ................................................................. 73
    5.1.11 Recent files 3D ............................................................................. 73
    5.1.12 Export ............................................................................................ 74
    5.1.13 Print preview ................................................................................ 75
    5.1.14 Print ............................................................................................... 77
    5.1.15 Export to image ............................................................................ 83
    5.1.16 Exit ................................................................................................ 84
  5.2 Menu Edit ................................................................................................. 85
    5.2.1 Undo ............................................................................................... 86
    5.2.2 Redo ................................................................................................ 86
    5.2.3 Cut ................................................................................................... 86
    5.2.4 Copy ................................................................................................. 86
    5.2.5 Insert ............................................................................................... 87
    5.2.6 Material properties ....................................................................... 87
    5.2.7 Material placement ....................................................................... 88
    5.2.8 Material Settings .......................................................................... 91
    5.2.9 Tool magazine ProtoMat D104 ..................................................... 94
    5.2.10 Tool magazine ProtoMat E33/S43 (manual tool change) ........... 105
    5.2.11 Tool magazine ProtoMat S63/S103 ........................................... 107
    5.2.12 Tool library ................................................................................ 117
    5.2.13 Aperture list library .................................................................... 126
    5.2.14 Design Rule Check ..................................................................... 129
    5.2.15 Measure ........................................................................................ 132
    5.2.16 Distance ....................................................................................... 133
    5.2.17 Set anchor point ......................................................................... 134
    5.2.18 Set Zero Point ............................................................................. 136
    5.2.19 Move anchor to center point ..................................................... 137
    5.2.20 Move layer to zero ....................................................................... 138
    5.2.21 Match up layers ......................................................................... 140
    5.2.22 Match up objects ....................................................................... 144
    5.2.23 Delete ........................................................................................... 147
5.3 Menu Insert .............................................................................................................. 148
  5.3.1 Open path ............................................................................................................. 149
  5.3.2 Closed path ......................................................................................................... 155
  5.3.3 Polygon ............................................................................................................... 162
  5.3.4 Rectangle .......................................................................................................... 171
  5.3.5 Circle ................................................................................................................ 173
  5.3.6 Circle path ....................................................................................................... 176
  5.3.7 Flash ............................................................................................................... 179
  5.3.8 Text .................................................................................................................. 181
  5.3.9 Polygon with cutouts ....................................................................................... 184
  5.3.10 Copper pouring ............................................................................................. 188
  5.3.11 Rubout area .................................................................................................. 192
  5.3.12 Fiducial .......................................................................................................... 197
  5.3.13 Topography .................................................................................................... 200
  5.3.14 Drill hole ........................................................................................................ 202
  5.3.15 Milling curve .................................................................................................. 206

5.4 Menu Toolpath ....................................................................................................... 208
  5.4.1 Dispense ............................................................................................................. 209
  5.4.2 Create 2.5D milling ........................................................................................ 216
  5.4.3 Technology Dialog ......................................................................................... 218
  5.4.4 Edit breakout tabs .......................................................................................... 225

5.5 Menu Modify ............................................................................................................ 230
  5.5.1 Close open path .............................................................................................. 232
  5.5.2 Combine open path ....................................................................................... 235
  5.5.3 Convert to polygon .......................................................................................... 237
  5.5.4 Convert to closed path .................................................................................... 238
  5.5.5 Draw to flash .................................................................................................. 240
  5.5.6 Combine to flash ........................................................................................... 241
  5.5.7 Compare to flash ........................................................................................... 243
  5.5.8 Explode flash .................................................................................................. 246
  5.5.9 2.5D operations .............................................................................................. 247
  5.5.10 Transform ..................................................................................................... 252
  5.5.11 Rotate/Mirror relative .................................................................................. 258
  5.5.12 Step Repeat .................................................................................................. 262

5.6 Menu View .............................................................................................................. 264

5.7 Menu Select ............................................................................................................. 266

5.8 Menu Wizards ......................................................................................................... 268
  5.8.1 Equipment configuration wizard .................................................................... 269
  5.8.2 Process planning wizard ............................................................................... 271
  5.8.3 Board Production Wizard ............................................................................. 273
  5.8.4 Dispense Preparation Wizard ...................................................................... 275
  5.8.5 Dispense process wizard .............................................................................. 279

5.9 Menu Machining ..................................................................................................... 281
  5.9.1 Process all ....................................................................................................... 282
  5.9.2 Stop processing .............................................................................................. 283
  5.9.3 Production phase ............................................................................................ 284
Contents

5.9.4  Placement .................................................................................................. 285
5.9.5  Fiducials .................................................................................................. 287
5.9.6  Measure milling width ProtoMat E33/S43 ................................................. 290
5.9.7  Measure milling width ProtoMat S63/S103 ............................................. 292
5.9.8  Measure milling ProtoMat D104 .............................................................. 293
5.9.9  Alignment (only if camera is present) ...................................................... 294
5.9.10 Drill reference holes ................................................................................ 296
5.9.11 Service .................................................................................................... 297
5.9.12 Determining the camera head offset ..................................................... 298
5.9.13 Teach tool-holder positions .................................................................... 302
5.9.14 Connect .................................................................................................. 305

5.10 Menu Camera ............................................................................................ 307
  5.10.1 Options ................................................................................................. 308
  5.10.2 Actions .................................................................................................. 315
  5.10.3 Movement ............................................................................................... 325
  5.10.4 Overlay ................................................................................................. 326
  5.10.5 Search .................................................................................................... 330

5.11 Menu Extras ............................................................................................... 336
  5.11.1 Options ................................................................................................. 336
  5.11.2 Customize .............................................................................................. 358

5.12 Menu Help .................................................................................................. 364
  5.12.1 Help ...................................................................................................... 364
  5.12.2 About ................................................................................................... 365
  5.12.3 System information ............................................................................... 366

6  Appendix ........................................................................................................ 367
  6.1 Table of figures .......................................................................................... 367
  6.2 List of tables ............................................................................................... 377
  6.3 Index .......................................................................................................... 379
1 Function

The system software LPKF CircuitPro PM is a powerful application that combines two important components of PCB production: Editing of design data and machine control. The circuit board plotters made by LPKF are controlled with this application running on Windows® computers.

LPKF CircuitPro PM imports your CAD data, aperture and tool lists and guides you step by step through the production of your PCB. Design data will be split up into the separate work steps and prepared for the production process. The integrated wizards will guide you through the whole PCB production process. They will inform you whenever you have to take action (e.g. manual tool change or turning over the material for producing a double-sided PCB).

Use the “Design Rule Check” for checking the width and the spacing of the conductor tracks. Violations of the rules will be shown in the message view and graphically in the CAM View. Thus, you can make corrections before starting the production process.

The current milling status and position are shown in the machining view, so that you can always keep an eye on the production process and progress.

LPKF CircuitPro PM allows you to create templates for solder resist masks and legend printing. Additionally the software supports the automatic tool exchange with tool adjustment (depending on the machine type).

The basic operation of the Windows® graphical user interface is not part of this manual. If you are not familiar with using Windows®, please refer to the Windows® user manual and online help.
2 Safety notes

The following chapter describes the most important safety notes while working with the software CircuitPro PM and the circuit board plotter.
## 2.1 General safety notes

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>The usage of the software CircuitPro PM without the circuit board plotter has a low risk potential.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DANGER</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Follow the safety notes!</strong></td>
</tr>
<tr>
<td>If you do not follow the safety notes injuries or accidents may occur.</td>
</tr>
<tr>
<td>Read the manuals of the circuit board plotter and accordingly the control software carefully and follow the safety notes.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DANGER</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Pay attention to a secure data transfer!</strong></td>
</tr>
<tr>
<td>A malfunction or interruption of data transmission between the PC and the circuit board plotter can cause uncontrolled machine reactions.</td>
</tr>
<tr>
<td>Check the connection and replace defective or damaged cables immediately.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DANGER</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Secure the machine against accidental switching on!</strong></td>
</tr>
<tr>
<td>Personal injuries may occur during manual tool exchange or maintenance if the machine is accidentally switched on.</td>
</tr>
<tr>
<td>Always secure the machine against unauthorized use and accidental switching on.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CAUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Follow the safety regulations!</strong></td>
</tr>
<tr>
<td>The non-observance of the operational and regulatory health and safety regulations can cause serious personal injuries.</td>
</tr>
<tr>
<td>Make sure that each operator knows the operational and regulatory health and safety regulations.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DANGER</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Handling only by trained personnel!</strong></td>
</tr>
<tr>
<td>Improper operation of the machine can cause serious personal injuries.</td>
</tr>
<tr>
<td>Instruct each user in handling the machine.</td>
</tr>
</tbody>
</table>
3 Installation

This chapter describes how to install the CircuitPro PM program.

3.1 System requirements

The following system requirements must be met for installing CircuitPro PM successfully:

**Minimum system requirements for working with CircuitPro PM**

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum system requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>2 GHz</td>
</tr>
<tr>
<td>RAM</td>
<td>2 GB</td>
</tr>
<tr>
<td>Hard disk memory</td>
<td>2 GB</td>
</tr>
<tr>
<td>Graphics board</td>
<td>with 128 MB dedicated memory (non-shared memory)</td>
</tr>
<tr>
<td></td>
<td>LPKF advises against using the following graphics boards as these cause problems:</td>
</tr>
<tr>
<td></td>
<td>• Intel 82945G</td>
</tr>
<tr>
<td>Screen resolution</td>
<td>1024 x 768 pixels</td>
</tr>
<tr>
<td>USB port</td>
<td>2 x USB 2.0</td>
</tr>
<tr>
<td>Supported operating systems</td>
<td>Windows XP (32bit) and newer</td>
</tr>
<tr>
<td></td>
<td>(Note: CircuitPro PM does not fully run under Windows XP (64bit).)</td>
</tr>
</tbody>
</table>

**Recommended system configuration for working with CircuitPro PM**

<table>
<thead>
<tr>
<th>Component</th>
<th>Recommended system configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>Dual core 2.6 GHz</td>
</tr>
<tr>
<td>RAM</td>
<td>8 GB</td>
</tr>
<tr>
<td>Hard disk memory</td>
<td>2 GB</td>
</tr>
<tr>
<td>Graphics board</td>
<td>with 1 GB dedicated memory (non-shared memory)</td>
</tr>
<tr>
<td></td>
<td>LPKF advises against using the following graphics boards as these cause problems:</td>
</tr>
<tr>
<td></td>
<td>• Intel 82945G</td>
</tr>
<tr>
<td>Screen resolution</td>
<td>1680 x 1050 pixels</td>
</tr>
<tr>
<td>USB port</td>
<td>2 x USB 2.0</td>
</tr>
<tr>
<td>Operating system</td>
<td>Windows 7 (64bit)</td>
</tr>
</tbody>
</table>
If you are using the Microsoft® Windows 8 operating system, please install the Microsoft® .NET Framework 3.5 contained on your Windows® 8 DVD before installing CircuitPro PM 2.1. The Microsoft® .NET Framework 3.5 cannot be installed automatically in Microsoft® Windows 8 due to changes in the operating system. For further information on installing the Microsoft®.NET Framework 3.5 please refer to http://support.microsoft.com/kb/2785188/en-us
3.2 Installing and starting the software

**ATTENTION**

**Improper installation causes machine damage!**

An incorrect or incomplete installation of the software can cause damage to the machine.

LPKF assumes no liability for damage to the machine caused by improper software installation.

---

**Note**

Please make sure that the machine is not connected to the computer.

The USB cable must not be connected!

---

- Installing CircuitPro PM
  1. Switch on the PC.
  2. Open the CD ROM drive and insert the CD ROM “CircuitPro PM” into the drive.

  ➔ The CD ROM is read. The LPKF setup wizard starts automatically and the installation and update information is displayed in your browser’s window:

  ![Installation and update information](image)

  - Follow these steps to get the latest software:
    2. Fill out the form; you will need your machine serial number and the software serial number. Note that the software serial number is located on the back of the CD.
    3. After receiving your account and license information, please use the following link to log in to the support website: [http://www.lpkf.com/support/loginsign.html](http://www.lpkf.com/support/loginsign.html)
    4. Please download the latest version of CircuitPro from there and install it.

  3. Close the browser window displaying the installation and update information.
4. Click on [Next] to start the installation procedure.

**Note**
Navigating in the installation program is done by clicking on [Back] and [Next]. Click on [Back] to go to the previous installation step. Click on [Next] to go to the next installation step. The installation is aborted by clicking on [Cancel].

5. Read the terms of the license agreement and click on [I Agree].
6. Click on [Next].
In the following step, you can choose the folder where CircuitPro PM is to be installed:

![Select Installation Folder](image)

When using Windows 7, the installation stores the program data by default in:

C:\Program Files (x86)\LPKF Laser & Electronics\LPKF CircuitPro PM 2.1\.

When using Windows XP, the installation stores the program data by default in:

C:\Programme\LPKF Laser & Electronics\LPKF CircuitPro PM 2.1\.

Click on [Browse] to install the program data in a folder of your choice.

Click on [Back] to review the settings of the previous screens. Click on [Cancel] to cancel the installation.

7. Click on [Next].
The dialog to confirm the installation is displayed:

Fig. 6: Confirm installation

8. Click on [Next].

The installation of CircuitPro PM is started:

Fig. 7: Installation of CircuitPro PM 2.1
The program is being installed on the PC. Progress of the installation is displayed. During the installation the following warning message is displayed:

9. Acknowledge the warning message by clicking on [OK].

When the installation is complete, the following dialog is displayed:

10. Click on [Close] to exit the installation program.

The CircuitPro PM program has been installed.

Note

A link to the CircuitPro PM program has been created on your desktop:
Starting CircuitPro PM

1. Switch on the machine.
2. Boot the PC.
   ➔ The PC boots and starts the operating system.
3. Start CircuitPro PM.
   ➔ The following splash screen is displayed:

![CircuitPro PM splash screen](image)

Note

If you already had installed a previous version of CircuitPro on your computer, you can decide at this point whether to use your previous configuration files. This means that settings that are stored in the following folder are also applied to currently installed version CircuitPro PM Version 2.1:

In Windows XP:

C:\Programme\LPKF Laser & Electronics\LPKF CircuitPro 1.X\config

In Windows 7:

C:\Program Files (x86)\LPKF Laser & Electronics\LPKF CircuitPro 1.X\config.

These settings apply – among others – to the language setting and the machine configuration.

4. In the list “Version”, click on the CircuitPro version whose configuration settings you want to use and subsequently click on [OK].
   Or
4. Click on [Default] if you want to use the default settings of CircuitPro PM 2.1.
The following dialog is displayed:

5. Select a template file.
6. Click on [OK].

◆ The CircuitPro PM program is started and the user interface is displayed.
3.3 Machine setup

After CircuitPro PM has been installed on your PC, it has to be configured once for the machine and the accompanying equipment. The equipment configuration wizard helps you setting up the machine.

■ Setting up the machine
1. Start CircuitPro PM.
   ➔ The equipment configuration wizard starts automatically.

![Start-up screen “Equipment configuration wizard”]

Fig. 12: Start-up screen “Equipment configuration wizard”

---

Note

You can also start the equipment configuration wizard manually. Click in the menu bar of CircuitPro PM on Wizards>Equipment configuration wizard…

2. Perform all the steps of the equipment configuration wizard and follow the corresponding instructions.
   ➔ The CAM view is displayed.
   ➔ The machine has been set up. The accompanying available equipment for producing PCB prototypes has been configured as well.
Tip

Language settings
CircuitPro PM is installed in English by default. If you want to change the language setting of CircuitPro PM, perform the following steps:

1. Click on Extras > Options.
2. In the row “Use OS culture”, change the value to “False”.
3. Click on the row “Language” and change the value to the desired language.
4 Structure of the user interface

The following pages describe in detail the structure of the CircuitPro PM user interface.

4.1 User interface

The CircuitPro PM user interface is divided into several information and display panes that can be displayed or hidden as necessary. The user interface is structured as follows:

Fig. 13: CircuitPro user interface
### Table 3: User interface

<table>
<thead>
<tr>
<th>No.</th>
<th>Pane</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td>Menu bar</td>
<td></td>
</tr>
<tr>
<td>/2/</td>
<td>“Standard” toolbar</td>
<td></td>
</tr>
<tr>
<td>/3/</td>
<td>“Modify” toolbar</td>
<td></td>
</tr>
<tr>
<td>/4/</td>
<td>“Prototyping” toolbar</td>
<td></td>
</tr>
<tr>
<td>/5/</td>
<td>“Layouts” toolbar</td>
<td></td>
</tr>
<tr>
<td>/6/</td>
<td>“Insert” toolbar</td>
<td></td>
</tr>
<tr>
<td>/7/</td>
<td>Layers</td>
<td>The “Layers” pane contains a table listing the individual layers of the circuit board to be processed.</td>
</tr>
<tr>
<td>/8/</td>
<td>Navigation</td>
<td>The “Navigation” pane displays an overview of the project with a zoom rectangle.</td>
</tr>
<tr>
<td>/9/</td>
<td>CAM view</td>
<td>Editing pane displaying a 2D representation of the project.</td>
</tr>
<tr>
<td>/10/</td>
<td>Status bar</td>
<td>The status bar displays the coordinates of the current cursor position and of the anchor point. Measurement results are displayed in the “Length” field.</td>
</tr>
</tbody>
</table>
4.2 Views

In the following, the different views in CircuitPro PM are described in detail.

4.2.1 CAM View

The CAM View allows you to regard the object to be processed two-dimensional and the corresponding layers.

Move your cursor to menu View > CAM 2D… or click “CAM” on the toolbar “Layout” to open the following window:

In this view you are able to regard both sides of the PCB. According to the colors in the pane “Layers” each object on the board is highlighted.
4.2.2 Toolbar CAM view

The toolbar “CAM view” provides following icons:

![Toolbar CAM view](image)

The following table provides a brief description of the toolbar’s icons:

<table>
<thead>
<tr>
<th>No.</th>
<th>Function description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td>Polygonal Selection: Click on this icon to select objects by drawing polygons. The context menu offers extended functions if this icon is enabled.</td>
</tr>
<tr>
<td>/2/</td>
<td>Selection: This arrow must be enabled to select or create objects in the CAM view.</td>
</tr>
<tr>
<td>/3/</td>
<td>Fit all: Click on this icon to fit the whole layout into the CAM view.</td>
</tr>
<tr>
<td>/4/</td>
<td>Zoom area: Click on this icon and select an area that will be zoomed in afterwards.</td>
</tr>
<tr>
<td>/5/</td>
<td>Zoom: Click on this icon and move your mouse to zoom in/out the layout.</td>
</tr>
<tr>
<td>/6/</td>
<td>Pan: Click on this icon to move your whole layout to a desired position.</td>
</tr>
<tr>
<td>/7/</td>
<td>Global Pan: The currently zoomed area will be zoomed out by clicking on this icon. If you click on an area in the layout again, this area will be zoomed in.</td>
</tr>
<tr>
<td>/8/</td>
<td>Set toolpath selection mode: Selects toolpaths within the created polygon. Three different modes are available: object, curve and element.</td>
</tr>
</tbody>
</table>

Context menu Polygonal selection

- Displaying the context menu Polygonal selection
  1. Click on the icon [Polygonal selection].
  2. The polygonal selection is activated.
- Right-click into the CAM view.
The following context menu is displayed:

Fig. 16: Context menu “Polygonal selection”

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Remove last point</td>
</tr>
<tr>
<td>2</td>
<td>Select</td>
</tr>
<tr>
<td>3</td>
<td>Cancel</td>
</tr>
</tbody>
</table>

The context menu Polygonal selection is displayed.

Table 5: Context menu “Polygonal selection”

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Remove last point</strong>: Removes the point added last to the polygon.</td>
</tr>
<tr>
<td>2</td>
<td><strong>Select</strong>: Selects the objects within the polygon.</td>
</tr>
<tr>
<td>3</td>
<td><strong>Cancel</strong>: Cancels the creation of the polygon.</td>
</tr>
</tbody>
</table>
4.2.3 Machining view E33

The machining view enables you to regard your process data. Click on View > Machining 2D or click on the button “Machining” to open the machining view.

Fig. 17: Machining view E33

If you start the production of a board the machine head’s movement, displayed as a cross line, is shown in the machining view.
4.2.4 Machining view S43

The machining view enables you to regard your process data.
Click on View > Machining 2D or on the button “Machining” to open the machining view.

![Machining view S43 diagram]

/1/ Work area  /3/ Object to be processed
/2/ Axis of reflection  /4/ Current head position

If you start the production of a board the machine head’s movement, displayed as a cross line, is shown in the machining view.
4.2.5 Machining view S63/S103

The machining view enables you to regard your process data. Click on View > Machining 2D or click on the button “Machining” to open the machining view.

The tool magazine of the circuit board plotter can pick up to 15 different tools. According to the colors of the tool’s distance rings of the LPKF tools, the circles in area /2/ are displayed in the same color.

If you start the production of a layer, the machine head’s movement, displayed as a cross line, is shown in the machining view.
4.2.6 Machining view ProtoMat D104

The machining view enables you to regard your process data. Click on View > Machining 2D to open this view… or click on “Machining view” in the toolbar “Layout”.

The tool magazine of the circuit board plotter can pick up to 15 different tools. According to the colors of the tool’s distance rings of the LPKF tools, the circles in area /2/ are displayed in the same color.

If you start the production of a layer, the machine head’s movement, displayed as a cross line, is shown in the machining view.

/1/ Work area  /4/ Object to be processed

/2/ Tool holder  /5/ Axis of reflection

/3/ Current head position
4.2.7 Toolbar Machining view

The toolbar “Machining view” provides following icons:

![Toolbar Machining view]

The following table provides a brief description of the toolbar’s icons:

<table>
<thead>
<tr>
<th>No.</th>
<th>Function description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td>Polygonal Selection: Click on this icon to select objects by drawing polygons. The context menu offers extended functions if this icon is enabled.</td>
</tr>
<tr>
<td>/2/</td>
<td>Select: This arrow must be enabled to select or create objects in the machine view.</td>
</tr>
<tr>
<td>/3/</td>
<td>Fit All only for Job Data: Only the job data is displayed. Other elements of the machining view are hidden.</td>
</tr>
<tr>
<td>/4/</td>
<td>Fit All for both Job Data and Machine Area: Scales and fits in the layout so that the elements of the machining view stay visible.</td>
</tr>
<tr>
<td>/5/</td>
<td>Zoom area: Click on this icon and select an area that will be zoomed in afterwards.</td>
</tr>
<tr>
<td>/6/</td>
<td>Zoom: Click on this icon and move your mouse to zoom in/out the layout.</td>
</tr>
<tr>
<td>/7/</td>
<td>Pan: Click on this icon to move your whole layout to a desired position.</td>
</tr>
<tr>
<td>/8/</td>
<td>Global Pan: The currently zoomed area will be zoomed out by clicking on this icon. If you click on a area in the layout again, this area will be zoomed in.</td>
</tr>
<tr>
<td>/9/</td>
<td>Set toolpath selection mode: Selects toolpaths within the created polygon. Three different modes are available: object, curve and element.</td>
</tr>
</tbody>
</table>

Context menu Polygonal selection

- Displaying the context menu Polygonal selection
  1. Click on the icon [Polygonal selection].
- The polygonal selection is activated.
  2. Right-click into the CAM view.
The following context menu is displayed:

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Remove last point</td>
</tr>
<tr>
<td>2</td>
<td>Select</td>
</tr>
<tr>
<td>3</td>
<td>Cancel</td>
</tr>
</tbody>
</table>

The context menu Polygonal selection is displayed.

The following table contains a brief description of the context menu's functions:

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td>Remove last point: Removes the point added last to the polygon.</td>
</tr>
<tr>
<td>/2/</td>
<td>Select: Selects the objects within the polygon.</td>
</tr>
<tr>
<td>/3/</td>
<td>Cancel: Cancels the creation of the polygon.</td>
</tr>
</tbody>
</table>
4.2.8 3D View

The 3D View allows you to regard the object to be processed three-dimensional.

Click on View > 3D View to open the following window:

Once you have imported a three-dimensional object, it will be shown in this view.

Note: Two-dimensional objects can also be shown in this 3D view. Therefore you have to highlight the corresponding toolpaths in the pane "Toolpath" and select "Display in 3D" in the context menu.
4.2.9 Toolbar 3D view

The toolbar “3D view” provides following icons:

![Toolbar 3D view](image)

The following table provides a brief description of the toolbar’s icons:

<table>
<thead>
<tr>
<th>No.</th>
<th>Function description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td><strong>Selection</strong>: This arrow must be enabled to select or create objects in the 3D view.</td>
</tr>
<tr>
<td>/2/</td>
<td><strong>Fit all</strong>: Click on this icon to fit the whole layout into the 3D view.</td>
</tr>
<tr>
<td>/3/</td>
<td><strong>Zoom area</strong>: Click on this icon and select an area that will be zoomed in afterwards.</td>
</tr>
<tr>
<td>/4/</td>
<td><strong>Zoom</strong>: Click on this icon and move your mouse to zoom in/out the layout.</td>
</tr>
<tr>
<td>/5/</td>
<td><strong>Pan</strong>: Click on this icon to move your whole layout to a desired position.</td>
</tr>
<tr>
<td>/6/</td>
<td><strong>Global Pan</strong>: The currently zoomed area will be zoomed out by clicking on this icon. If you click on a area in the layout again, this area will be zoomed in.</td>
</tr>
<tr>
<td>/7/</td>
<td><strong>Front view</strong>: Displays the front of the object.</td>
</tr>
<tr>
<td>/8/</td>
<td><strong>Top View</strong>: Displays the top side of the object.</td>
</tr>
<tr>
<td>/9/</td>
<td><strong>Left View</strong>: Displays the left side of the object.</td>
</tr>
<tr>
<td>/10/</td>
<td><strong>Rear View</strong>: Displays the rear side of the object.</td>
</tr>
<tr>
<td>/11/</td>
<td><strong>Right View</strong>: Displays the right side of the object.</td>
</tr>
<tr>
<td>/12/</td>
<td><strong>Bottom View</strong>: Displays the bottom side of the object.</td>
</tr>
<tr>
<td>/13/</td>
<td><strong>Axonometric View</strong>: Standard view that displays the object in a 30° angle.</td>
</tr>
<tr>
<td>/14/</td>
<td><strong>Rotate</strong>: Click on this icon to rotate your object in any direction by using your mouse.</td>
</tr>
<tr>
<td>/15/</td>
<td><strong>Reset View</strong>: Resets the current view of your object.</td>
</tr>
</tbody>
</table>
4.3 Toolbars

CircuitPro PM’s toolbars offer you a quick access to functions that are used most often.

The following toolbars exist in CircuitPro PM:
- Standard
- Insert
- Modify
- Layouts
- Prototyping

You are able to hide/display the toolbars. You can find this option under menu Tools > Customize... Go to tab “Toolbars” and enable/disable the corresponding checkboxes.

You can arrange the toolbars anywhere on the surface of CircuitPro PM.

Changing the toolbar’s position
1. Move the cursor to the top of the toolbar which is marked with several points.
   ➔ The cursor takes the shape of a cross.
2. Hold the left mouse button.
3. Move the toolbar to the desired location on the user interface.

You can arrange the toolbar on the left, bottom, right or top of the user interface.

4. Release the left mouse button.
   ➔ The toolbar is now fixed at the desired location of the user interface.
4.3.1 Toolbar Standard

The toolbar “Standard” provides following icons:

![Toolbar “Standard”](image)

The following table provides a brief description of the toolbar’s icons:

<table>
<thead>
<tr>
<th>No.</th>
<th>Icon</th>
<th>Function description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td>New…</td>
<td>Creates a new document in CircuitPro PM. Either you are able to create a document based on a standard template or you browse your hard disk for own templates.</td>
</tr>
<tr>
<td>/2/</td>
<td>Open…</td>
<td>Opens an existing CircuitPro PM document.</td>
</tr>
<tr>
<td>/3/</td>
<td>Save</td>
<td>Saves the currently edited document with all changes under the same name and location.</td>
</tr>
<tr>
<td>/4/</td>
<td>Cut</td>
<td>Cuts a selected area in the document.</td>
</tr>
<tr>
<td>/5/</td>
<td>Copy</td>
<td>Copies a selected area in the document.</td>
</tr>
<tr>
<td>/6/</td>
<td>Paste</td>
<td>Pastes the previously cut or copied region.</td>
</tr>
<tr>
<td>/7/</td>
<td>Print Preview</td>
<td>Opens a print preview of the current document.</td>
</tr>
<tr>
<td>/8/</td>
<td>Print</td>
<td>Opens the print dialogue. Make your settings for printing here.</td>
</tr>
<tr>
<td>/9/</td>
<td>Undo</td>
<td>Undo the last action in the document.</td>
</tr>
<tr>
<td>/10/</td>
<td>Redo</td>
<td>Redo the previously undone action.</td>
</tr>
<tr>
<td>/11/</td>
<td>Delete</td>
<td>Deletes the previously selected objects on the layer.</td>
</tr>
</tbody>
</table>
4.3.2 Toolbar Insert

The toolbar "Insert" provides following icons:

Fig. 27: Toolbar "Insert"

<table>
<thead>
<tr>
<th>No.</th>
<th>Icon</th>
<th>Function description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/</td>
<td></td>
<td>Create open path</td>
</tr>
<tr>
<td>2/</td>
<td></td>
<td>Create closed path</td>
</tr>
<tr>
<td>3/</td>
<td></td>
<td>Create polygon</td>
</tr>
<tr>
<td>4/</td>
<td></td>
<td>Create rectangle</td>
</tr>
<tr>
<td>5/</td>
<td></td>
<td>Create circle</td>
</tr>
<tr>
<td>6/</td>
<td></td>
<td>Create circle path</td>
</tr>
<tr>
<td>7/</td>
<td></td>
<td>Create flash</td>
</tr>
<tr>
<td>8/</td>
<td></td>
<td>Create text object</td>
</tr>
<tr>
<td>9/</td>
<td></td>
<td>Fiducial</td>
</tr>
<tr>
<td>10/</td>
<td></td>
<td>Rubout area</td>
</tr>
<tr>
<td>11/</td>
<td></td>
<td>Create polygon with cutouts</td>
</tr>
<tr>
<td>12/</td>
<td></td>
<td>Create copper pouring</td>
</tr>
<tr>
<td>13/</td>
<td></td>
<td>Switch line mode to 90°</td>
</tr>
<tr>
<td>14/</td>
<td></td>
<td>Switch line mode to 45°</td>
</tr>
</tbody>
</table>

The following table provides a brief description of the toolbar’s icons:

Table 10: Function description “Insert”
4.3.3 Toolbar Modify

The toolbar “Modify” provides following icons:

![Toolbar Modify](image)

The following table provides a brief description of the toolbar’s icons:

<table>
<thead>
<tr>
<th>No.</th>
<th>Icon</th>
<th>Function description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Close open path</td>
<td>Closes an open path.</td>
</tr>
<tr>
<td>2</td>
<td>Combine open paths</td>
<td>Combines several open paths into a single open path.</td>
</tr>
<tr>
<td>3</td>
<td>Convert closed path to polygon</td>
<td>Converts the selected object to a polygon.</td>
</tr>
<tr>
<td>4</td>
<td>Convert polygon to path</td>
<td>Converts the selected object to a closed path.</td>
</tr>
<tr>
<td>5</td>
<td>Draw to flash</td>
<td>Converts a drawn object to a flash.</td>
</tr>
<tr>
<td>6</td>
<td>Combine objects to flash</td>
<td>Connects objects to a flash.</td>
</tr>
<tr>
<td>7</td>
<td>Compare objects to flash</td>
<td>Converts objects on the same layer that have the same form and size as the selected flash object into flash objects.</td>
</tr>
<tr>
<td>8</td>
<td>Transformation</td>
<td>Translates, rotates, scales and inverts objects and toolpaths.</td>
</tr>
<tr>
<td>9</td>
<td>Rotate objects 90° counter-clockwise around the anchor point</td>
<td>Rotates the selected object 90° counter-clockwise around the anchor point.</td>
</tr>
<tr>
<td>10</td>
<td>Rotate objects 180° around the anchor point</td>
<td>Rotates the selected object 180° around the anchor point.</td>
</tr>
<tr>
<td>11</td>
<td>Rotate objects 270° counter-clockwise around the anchor point</td>
<td>Rotates the selected object 270° counter-clockwise around the anchor point.</td>
</tr>
<tr>
<td>12</td>
<td>Mirror objects along x axis</td>
<td>Mirrors the object at the anchor point along the x axis.</td>
</tr>
<tr>
<td>13</td>
<td>Mirror objects along y axis</td>
<td>Mirrors the object at the anchor point along the y axis.</td>
</tr>
<tr>
<td>14</td>
<td>Step and repeat</td>
<td>The selected objects are duplicated with a defined distance, vector and count.</td>
</tr>
<tr>
<td>15</td>
<td>Move selected objects</td>
<td>Moves the selected object.</td>
</tr>
<tr>
<td>16</td>
<td>Move a point or segment</td>
<td>Moves a point or a segment.</td>
</tr>
<tr>
<td>17</td>
<td>Cut a point or segment</td>
<td>Cuts a point or a segment.</td>
</tr>
<tr>
<td>18</td>
<td>Delete a point or segment</td>
<td>Deletes a point or a segment.</td>
</tr>
<tr>
<td>19</td>
<td>Create or move an arc</td>
<td>Creates or moves an arc.</td>
</tr>
<tr>
<td>20</td>
<td>Add a point or segment</td>
<td>Adds a point or a segment.</td>
</tr>
</tbody>
</table>
4.3.4 Toolbar Prototyping

The toolbar “Prototyping” provides following icons:

The following table provides a brief description of the toolbar’s icons:

<table>
<thead>
<tr>
<th>No.</th>
<th>Icon</th>
<th>Function description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td>Process planning wizard</td>
<td>Starts the process planning wizard.</td>
</tr>
<tr>
<td>/2/</td>
<td>Import</td>
<td>Imports all files of the formats CAM, Excellon, Gerber, GerberX, LMD, HPGL, DXF and Sieb &amp; Meyer.</td>
</tr>
<tr>
<td>/3/</td>
<td>Rubout area</td>
<td>Inserts a rubout area in the CAM view.</td>
</tr>
<tr>
<td>/4/</td>
<td>Fiducial</td>
<td>Inserts fiducials in the CAM view.</td>
</tr>
<tr>
<td>/5/</td>
<td>Technology Dialog</td>
<td>Generates insulation and contour routing toolpaths.</td>
</tr>
<tr>
<td>/6/</td>
<td>Tool magazine</td>
<td>Opens the dialog to edit the contents of the tool magazine.</td>
</tr>
<tr>
<td>/7/</td>
<td>Board Production Wizard</td>
<td>Starts the Board Production Wizard.</td>
</tr>
<tr>
<td>/8/</td>
<td>Tool library</td>
<td>Opens the tool library.</td>
</tr>
</tbody>
</table>

4.3.5 Toolbar Layout

The toolbar “Layout” provides following buttons:

The following table provides a brief description of the toolbar’s buttons:

<table>
<thead>
<tr>
<th>No.</th>
<th>Icon</th>
<th>Function description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td>CAM</td>
<td>Distinction between the views CAM and Compact CAM.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CAM: Displays all active views and panes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Compact CAM: Hides all views and panes except the CAM view and the panes “Navigation” and “Layers”.</td>
</tr>
<tr>
<td>/2/</td>
<td>Machining</td>
<td>Hides all views and panes except the machining view and the pane “Processing”.</td>
</tr>
</tbody>
</table>
4.4 Panes

CircuitPro PM allows arranging several individual panes on your screen. These are:

- Layers
- Geometry
- Toolpath
- Processing
- Properties
- Tool info
- Navigation
- Camera
- Messages
- Fault Monitor

Arranging the panes
1. First, open the desired pane in the menu “View”.
   ➔ The pane is displayed at the left bottom of the main window of CircuitPro PM.
2. Double-click on the title bar of the pane.
   ➔ The pane is now detached.
   ◆ You are able to maximize/minimize the pane and to arrange it as desired.

Fixing the pane
1. Click and hold the detached pane with the left mouse button.
2. Move the pane.
   ➔ In the main window of CircuitPro PM, icons appear at the top, bottom, right and left side.
3. Move the pane onto the icon at the desired window edge.
4. Release the left mouse button.
   ◆ The pane is now fixed at the desired position.

Note
Be sure to place the cursor exactly on the icon before you release the left mouse button.
4.4.1 Layers

The pane “Layers” lists the required layers for your project. Depending on the template that you select at the beginning of your project, the number and type of the layers diversify.

Click on View > Layers to open the pane “Layers”:

The following table provides a brief description of the pane’s columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Shows the name of the layer. The numbers shown in the brackets next to the layer name shows the number of the contained objects.</td>
</tr>
<tr>
<td>Visible</td>
<td>Shows/hides the corresponding layer in CAM View.</td>
</tr>
<tr>
<td>Selectable</td>
<td>Enable this function to make the layer selectable in CAM View.</td>
</tr>
<tr>
<td>Colors</td>
<td>In this column each layer is assigned to a colour. The layers' colours shown in the CAM View match these colours in the column.</td>
</tr>
<tr>
<td>Mode</td>
<td>This list enables you to determine in which display mode the layer shall be shown.</td>
</tr>
<tr>
<td>Tech</td>
<td>Determine the layer’s processing goal in this column. I.e. for example, if you select the value “Solder Paste”, you determine that this layer will be processed with solder paste later on.</td>
</tr>
<tr>
<td>Inverse</td>
<td>Mills the inside of the objects on the source layer. Example: In a letter or a number the inner area is milled.</td>
</tr>
<tr>
<td>Phase</td>
<td>Determines the phase in which the layer will be processed.</td>
</tr>
<tr>
<td>[Z]</td>
<td>Sorting function: sorts the layers by the display priority in Z direction.</td>
</tr>
</tbody>
</table>
4.4.2 Geometry

The pane “Geometry” lists all apertures, which were imported from the Gerber and Excellon files. CircuitPro PM names the aperture list after the file name by default.

Click on View > Geometry to open the pane “Geometry”.

![Geometry Pane](image)

4.4.3 Toolpath

The pane “Toolpath” shows the board’s individual production phases. Click on View > Toolpath to open the pane “Toolpath”.

![Toolpath Pane](image)

The phases are named after the production steps. After clicking on the arrow symbol to the left of a phase, the tools used for the phase are shown.
Note

Please note that several functions in sections “Select a Head” and “Head actions” are not available when using the ProtoMat S43/E33.

Also note that in section “Select a Head” a laser head is available when using the ProtoMat D104.

In the “Processing” pane you can control the processing head of the machine and determine its height.

Click on View > Processing to open the pane “Processing”:

![Processing pane](image)

### Table 15: Processing

<table>
<thead>
<tr>
<th>No.</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X/Y - positioning</td>
<td><img src="image" alt="10 mm button" /></td>
<td>Distance entry to move the machine head in X and Y direction. Enter the distance in the combo box and click on the arrow buttons. Each click moves the machine head at the specified distance in the preferred direction.</td>
</tr>
<tr>
<td><img src="image" alt="basic position button" /></td>
<td>Move head to the basic position: Click on this button to move the machine head to the basic position.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="pause position button" /></td>
<td>Move head to the pause position: Click on this button to move the machine head to the pause position.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="zero position button" /></td>
<td>Move head to the zero position: Click on this button to move the machine head to the zero position.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="mouse cursor button" /></td>
<td>Enables moving the head to the position selected by mouse click in the machining view.</td>
<td></td>
</tr>
</tbody>
</table>
### Table 15: Processing

<table>
<thead>
<tr>
<th>No.</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Z - positioning</strong></td>
<td><img src="image" alt="Z-Positioning" /></td>
<td>Distance entry to move the machine head in Z direction. Enter the distance in the combo box and click on the arrow buttons. Each click moves the machine head at the specified distance in the preferred direction.</td>
</tr>
<tr>
<td>/2/</td>
<td><img src="image" alt="Distance Entry" /></td>
<td>Enter the distance in the combo box and click on the arrow buttons. Each click moves the machine head at the specified distance in the preferred direction.</td>
</tr>
<tr>
<td><strong>Select head</strong></td>
<td><img src="image" alt="Select Head" /></td>
<td>Select the milling head as the active head.</td>
</tr>
<tr>
<td>/3/</td>
<td><img src="image" alt="Select Milling Head" /></td>
<td>Select the milling head as the active head.</td>
</tr>
<tr>
<td>/3/</td>
<td><img src="image" alt="Select Camera Head" /></td>
<td>Select the camera head as the active head.</td>
</tr>
<tr>
<td>/3/</td>
<td><img src="image" alt="Select Dispenser Head" /></td>
<td>Select the dispenser head as the active head.</td>
</tr>
<tr>
<td>/3/</td>
<td><img src="image" alt="Select Laser Head" /></td>
<td>Select the laser head as the active head.</td>
</tr>
<tr>
<td><strong>Head actions</strong></td>
<td><img src="image" alt="Head Action" /></td>
<td>Moves the machine head upwards or downwards.</td>
</tr>
<tr>
<td>/4/</td>
<td><img src="image" alt="Head Action" /></td>
<td>Moves the machine head upwards or downwards.</td>
</tr>
<tr>
<td>/4/</td>
<td><img src="image" alt="Switch Spindle" /></td>
<td>Switches the spindle on/off.</td>
</tr>
<tr>
<td>/4/</td>
<td><img src="image" alt="Clean Dispenser" /></td>
<td>Clean dispenser. The button is only visible when the dispenser has been selected as the active machine head.</td>
</tr>
<tr>
<td>/4/</td>
<td><img src="image" alt="Switch Suction" /></td>
<td>Switches the suction on/off.</td>
</tr>
<tr>
<td>/4/</td>
<td><img src="image" alt="Auto Focus" /></td>
<td>Executes the auto focus.</td>
</tr>
<tr>
<td>/4/</td>
<td><img src="image" alt="Decrease Brightness" /></td>
<td>Decreases the brightness of the camera.</td>
</tr>
<tr>
<td>/4/</td>
<td><img src="image" alt="Increase Brightness" /></td>
<td>Increases the brightness of the camera.</td>
</tr>
</tbody>
</table>
Process

Starts processing. Please note the phase that is selected in the field below.

Starts processing from the selected phase in the field below. All subsequent phases are processed one after another.

Stops processing

Tool info

Displays the tool information for the tool that is currently located in the clamp.

4.4.5 Properties

The pane “Properties” includes detailed information about the project. Click on View > Properties to open the pane “Properties”:

In this pane you find information about the tools, too. If you click on an aperture in the pane “Geometry”, you will get information about it, such as shape and diameter.
4.4.6 Tool Info

The “Tool Info” pane displays the parameters of the tool located in the clamp. Click on display > Tool Info to open the “Tool Info” pane.

Fig. 36: Pane “Tool info”

The tool information displayed here is identical to the information provided in the tool library.
4.4.7 Navigation

The pane “Navigation” is shown as soon as you have activated the CAM View or have clicked on View > Navigation:

You see the object to be processed in small format in this pane. If you click on a certain position using the mouse, you can zoom in on this position by means of the zoom function.

The following functions are available:

- Minimise/enlarge the area selected with the mouse by using the +/- magnifying glass icons /1/.
- Minimise/enlarge the area selected with the mouse by using the zoom bar /3/.
- Reset the zoom or adapt the layout to the CAM view by clicking on button /2/.
4.4.8 Camera (only if a camera is connected)

The pane “Camera” enables you to regard the object to be processed through the camera.

Click on View > Camera to open the pane “Camera”.

Please note that a camera image is only displayed when a camera is actually available. This must be installed and connected via USB properly.
4.4.9 Messages

Click on View > Messages to open the pane “Messages”. This pane contains information about:

![Messages pane](image)

**Table 16: Messages**

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Errors</td>
<td>Errors are critical bugs. Click [Errors] in order to correct the errors. If the error recovery is not successful please call the LPKF Support.</td>
</tr>
<tr>
<td>Warnings</td>
<td>Warnings are input errors caused by the user. For example this may be information about cancelled or not properly executed actions.</td>
</tr>
<tr>
<td>Messages</td>
<td>Messages are statistical information of the program. This may be feedback from CircuitPro PM on certain actions performed, such as: “create new document”.</td>
</tr>
<tr>
<td>Service Messages</td>
<td>Service messages are displayed when the machine maintenance is due. Please contact the LPKF support.</td>
</tr>
<tr>
<td>Raise selection</td>
<td>Highlights the corresponding action in the CAM view.</td>
</tr>
</tbody>
</table>

**Example:** You draw a rectangle. In the “Messages” pane appears a corresponding message (e.g. Rectangle Drawn_5 was created). Now if you click on the button “Raise selection” and hereafter on the message about the drawn rectangle, this rectangle is highlighted in the CAM view.
4.4.10 Fault Monitor

The machine errors which have occurred are listed in the “Fault Monitor” pane. This machine error must be rectified so that production can be continued.

Click on View > Fault Monitor to open the “Fault Monitor” pane:

The icons used signify the following:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>Displays the first error message.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>Displays the previous error message.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>Displays the next error message.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>Displays the last error message.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>Acknowledges the error message currently marked.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>Acknowledges all error messages.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>Deletes the error message currently marked.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>Deletes all error messages.</td>
</tr>
</tbody>
</table>
5 How to work with CircuitPro PM

The following chapter describes the usage of CircuitPro PM in detail. Each menu and submenu of CircuitPro PM is listed accordingly.

CircuitPro PM’s menu bar contains following menu items:

- File
- Edit
- Insert
- Toolpath
- Modify
- View
- Select
- Wizards
- Machining
- Camera (only if a camera is mounted)
- Extras
- Help
5.1 Menu File

The “File” menu contains the standard file operations of CircuitPro PM. Click on the “File” menu item to open the submenu:

Fig. 42: Menu “File”

The following table contains short descriptions of the functions of the individual menu items:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New…</td>
<td>Creates a new document in CircuitPro PM. You can either select one of the standard templates for your new document or browse your disk drive for your own templates.</td>
</tr>
<tr>
<td>Open…</td>
<td>Opens a CircuitPro PM document.</td>
</tr>
<tr>
<td>Recent files</td>
<td>Contains a list of the five CircuitPro PM documents that have been opened/edited most recently.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the document currently edited with all changes made under the same file name and location.</td>
</tr>
<tr>
<td>Save As…</td>
<td>Saves the document currently edited with all changes made under the specified file name and location.</td>
</tr>
<tr>
<td>Save As Template…</td>
<td>Saves the current document as a template (file extension .cbf). Thus, it is displayed in the select template dialog.</td>
</tr>
<tr>
<td>Import…</td>
<td>Imports the following file formats: CAM, Excellon, Gerber, GerberX, LMD, HPGL, DXF, and Sieb &amp; Meyer.</td>
</tr>
<tr>
<td>Import 3D shape…</td>
<td>Imports all 3D shapes in the STEP and IGES file formats.</td>
</tr>
<tr>
<td>Import toolpath…</td>
<td>Imports the toolpath data of an existing CircuitPro PM document.</td>
</tr>
</tbody>
</table>
### Table 18: “File” menu functions

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recent files imported</td>
<td>Contains a list of the five documents that have been imported most recently.</td>
</tr>
<tr>
<td>Recent files 3D</td>
<td>Contains a list of the CircuitPro PM 3D documents that have been opened/edited most recently.</td>
</tr>
<tr>
<td>Export…</td>
<td>Exports the toolpaths of the current document into an LMD file.</td>
</tr>
<tr>
<td>Print Preview…</td>
<td>Opens the print preview of the current document.</td>
</tr>
<tr>
<td>Print…</td>
<td>Opens the print dialog. Choose your settings for printing and start the print operation subsequently.</td>
</tr>
<tr>
<td>Export to image…</td>
<td>Exports the visual presentation or selected parts into an image file of the formats Bitmap, JPEG, or Windows Enhanced Metafile.</td>
</tr>
<tr>
<td>Exit</td>
<td>Closes CircuitPro PM.</td>
</tr>
</tbody>
</table>
5.1.1 New

The menu item “New” lets you create a new document based on a template.

- Creating a new document in CircuitPro PM
  1. Click on File > New.
  2. Select the tab “Templates”.
  - The dialog of the templates available in CircuitPro PM is displayed:

![Image of the New document dialog]

3. Select a template.
   - A new document is created based on the selected template.

   **Tip**

   If you want to define a template as default template, select the desired template and mark the check box “Set as default”. The corresponding template is underlined in the list of templates.

   **Tip**

   If you want to use none of the templates you can also start the project planning wizard. The wizard guides you through the steps to define your design.
Loading a custom template

1. Click on File > New.
2. Select the tab “Templates”.
   ➔ The dialog of the templates available in CircuitPro PM is displayed:

   ![Diagram of CircuitPro PM templates]

   /1/ List of custom templates created previously
   /2/ [Load custom template…] opens the file dialog “Open”

3. Click on a custom template /1/.
   ◆ A custom template is opened.

Or

3. Click on [Load custom template…].
The following dialog is displayed:

4. Select the appropriate CBF file on your drive.
5. Click on [Open].
   ◆ A custom template is opened.
5.1.2 Open

Use the menu item “Open” to open an existing CircuitPro PM document.

- Opening an existing document in CircuitPro PM
  1. Click on File > Open.
  2. Select the desired CBF document on your drive.
  3. Click on [Open].
  
- The selected document is opened.

5.1.3 Recent files

This menu item shows the five files that have been opened/edited in CircuitPro PM most recently.

5.1.4 Save

Saves the document currently edited with all changes made under the same file name and in the same folder.
5.1.5 Save As

Use the menu item “Save As” to save the file currently edited under a new name or in a different folder.

- Saving a document (under a new name/in a different folder)
  1. Click on File>Save As.
  - The following dialog is displayed:

2. Enter a file name.
3. Select the folder for saving the file.
4. Select the file type.

---

**Note**

CircuitPro PM (2.x) is downward compatible and can read and write files of older CircuitPro versions (1.x). However, CircuitPro (1.x) cannot read files of CircuitPro PM versions (2.x).

5. Click on [Save].
   - The document is saved.
5.1.6 Save As Template

Use the menu item “Save As Template” to save the current document as a custom template in CircuitPro.

- Saving a document as a template
  1. Click on File > Save As Template…
  2. The following dialog is displayed:

![Save As Template dialog]

   - Select the folder for saving the file.
   - Enter a file name for the template.
   - Select the file type.
   - Click on [Save].

Note CircuitPro PM (2.x) is downward compatible and can read and write files of older CircuitPro versions (1.x). However, CircuitPro (1.x) cannot read files of CircuitPro PM versions (2.x).

- The document is saved as a template.
If you subsequently create a new document via the menu item File > New, the dialog for selecting a template displays a section "My templates":

![Image of My templates dialog]

### 5.1.7 Import

The “Import” menu item lets you import CAD files of the following formats:

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
<th>Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAM</td>
<td>native data format of LPKF CircuitCAM</td>
<td>*.CAM</td>
</tr>
<tr>
<td>Excellon</td>
<td>data format used for drilling and milling on printed circuit boards</td>
<td>*.DRL / *.DRD</td>
</tr>
<tr>
<td>Gerber</td>
<td>data format used for printed circuit board image data</td>
<td>*.GBR</td>
</tr>
<tr>
<td>GerberX</td>
<td>extended data format used for printed circuit board image data</td>
<td>*.GBX</td>
</tr>
<tr>
<td>LMD</td>
<td>LPKF Mill Drill data format used for data transfer between LPKF software products</td>
<td>*.LMD</td>
</tr>
<tr>
<td>HPGL</td>
<td>data format used for drawings, formerly used to drive pen plotters</td>
<td>*.PLT</td>
</tr>
<tr>
<td>DXF</td>
<td>data format used for drawings from AutoCAD</td>
<td>*.DXF</td>
</tr>
<tr>
<td>Sieb &amp; Meyer</td>
<td>data format used for drilling and milling on printed circuit boards</td>
<td>*.DRL / *.SM?</td>
</tr>
<tr>
<td>ODB++</td>
<td>data format used for printed circuit board image, drill data, netlists and component data</td>
<td>*.ZIP</td>
</tr>
</tbody>
</table>
Importing CAD files

1. Click on File > Import…
   ➔ The import dialog is displayed:

2. Select the desired file(s) on your drive.
3. Click on [Open].
   ➔ The following contents are displayed corresponding to your imported file (Gerber in this case):

   /1/ List of the imported data
   /2/ Main tabs
   /3/ Sub-tabs
4. Check the loaded data and modify if necessary.
5. Click on [OK].
   - The CAD files have been imported.

**Section /1/** lists the files you imported. In this list, you define the layers in CircuitPro PM where each file's data are assigned to.

**Section /2/** contains the tabs that display detailed information on the imported data. These are structured as follows:
- 2D view
- Apertures/Tools
- Text View
- Message View

Depending on the active tab, **section /3/** displays the following sub-tabs:
- General
- Options
- Attributes (only if the “Apertures/Tools” tab is active)

---

You can change the import settings for the individual file types via menu item Extras > Options Import / Export.

---

The following pages show the contents of the tabs using Gerber files as examples. If you import other file formats, the contents of the tabs may differ.

**2D View tab**

The “2D View” tab displays the design and the dimensions of the imported file:
Apertures/Tools tab

The “Apertures/Tools” tab lists the apertures and tools required for the project.

<table>
<thead>
<tr>
<th>Image</th>
<th>Name</th>
<th>Mode</th>
<th>Rotation</th>
<th>a</th>
<th>b</th>
<th>c</th>
<th>d</th>
</tr>
</thead>
<tbody>
<tr>
<td>D11</td>
<td></td>
<td></td>
<td>0°</td>
<td>0.8</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>D12</td>
<td></td>
<td></td>
<td>0°</td>
<td>0.2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>D13</td>
<td></td>
<td></td>
<td>0°</td>
<td>0.2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>D15</td>
<td></td>
<td></td>
<td>0°</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>D16</td>
<td></td>
<td></td>
<td>0°</td>
<td>0.254</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The columns of this tab show the following:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image</td>
<td>Shows the shape of the individual aperture.</td>
</tr>
<tr>
<td>Name</td>
<td>Shows the name of the individual aperture.</td>
</tr>
<tr>
<td>Mode</td>
<td>Shows whether the aperture is imported as a drawn or flashed object.</td>
</tr>
<tr>
<td>Rotation</td>
<td>Shows the angle by which the aperture is rotated (meaningless in case of a circle shape).</td>
</tr>
<tr>
<td>A-D</td>
<td>These columns contain the parameters defining the size and shape of the aperture. Depending on the aperture shape, not all parameter columns are used.</td>
</tr>
</tbody>
</table>
Text View tab

The “Text View” tab displays the ASCII text of the imported file.

![Text View](image)

Message View tab

The “Message View” tab contains system messages of CircuitPro PM about the operations performed during the file import.

![Message View](image)
Data/Settings tab General

In the “General” tab, you can define the dimensions of the imported files:

**Fig. 56: General**

The following settings are possible:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>Displays the overall size of the imported design.</td>
</tr>
<tr>
<td>Unit</td>
<td>Displays the unit of measurement</td>
</tr>
<tr>
<td>Values</td>
<td>Defines whether absolute or relative values are used.</td>
</tr>
<tr>
<td>Decimal</td>
<td>Defines whether leading or trailing zeroes are to be omitted.</td>
</tr>
<tr>
<td>Digits m.n</td>
<td>Defines the number of digits.</td>
</tr>
<tr>
<td></td>
<td>m = digits before the decimal point</td>
</tr>
<tr>
<td></td>
<td>n = digits after the decimal point</td>
</tr>
</tbody>
</table>
Data/Settings tab Options

The “Options” tab lets you select various options:

The following options can be activated:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use layer name</td>
<td>Use the layer name defined in the Gerber file.</td>
</tr>
<tr>
<td>Use layer polarity</td>
<td>Activate/deactivate analysis of layer polarity during Gerber import.</td>
</tr>
<tr>
<td>Rotate Square</td>
<td>Activate/deactivate automatic rotation of square objects during Gerber import.</td>
</tr>
<tr>
<td>Step and Repeat to flash</td>
<td>Activate/deactivate combining object collections to flash objects for “Step &amp; Repeat” commands (in the file) when importing Gerber files.</td>
</tr>
<tr>
<td>Rotate AM Octagon</td>
<td>Always align octagon edges to axes.</td>
</tr>
<tr>
<td>Set 360 interpolation as default</td>
<td>Activates the 360° interpolation for circles as default, irrespective of corresponding commands in the file.</td>
</tr>
<tr>
<td>Apply to all Gerber files</td>
<td>Applies the settings of this tab to all imported Gerber files</td>
</tr>
</tbody>
</table>
Data/Settings tab Attributes

The “Attributes” tab displays and lets you modify the properties of the apertures and tools:

![Attributes Tab](image)

The attributes define the following:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Defines the type of the aperture.</td>
</tr>
<tr>
<td>Rotation</td>
<td>Defines the rotation angle of the aperture.</td>
</tr>
<tr>
<td>A-D</td>
<td>These fields contain the parameters defining the size and shape of the aperture. Depending on the aperture shape, not all parameter fields are used.</td>
</tr>
</tbody>
</table>
5.1.8 Import 3D shape

Use the menu item “Import 3D shape” if you want to import a file containing 3D shapes into CircuitPro PM.

The following file types containing 3D shapes can be imported:

- STEP files (*.stp, *.step)
- IGES files (*.igs, *.iges)
- BRep files (*.brep)

Importing a 3D shape

1. Click on File > Import 3D shape...

   ➔ The following dialog is displayed:

2. Select the desired document (STEP or IGES) on your drive.
3. Click on [Open].

   ◆ The 3D shape is imported.
5.1.9 Import toolpath

Use the menu item “Import toolpath” to import toolpaths from other CircuitPro PM files (.cbf).

- Importing toolpaths
  1. Click on File > Import toolpath…
  2. The following dialog is displayed:

Fig. 60: Import toolpath

- Select the desired document on your drive.
- Click on [Open].
  ➪ The toolpaths of the document are imported and displayed in the “toolpath” pane:

Fig. 61: “Toolpath” pane with imported toolpaths

- The toolpaths have been imported.
5.1.10 Recent files imported

This menu item shows the five files that have been imported into CircuitPro PM most recently.

5.1.11 Recent files 3D

This menu item shows the five 3D files that have been opened/edited in CircuitPro PM most recently.
5.1.12 Export

Use the function “Export” to export toolpaths in CircuitPro PM to LMD files.

- Export toolpaths to LMD file

1. Click on File > Export…

→ The following dialog is displayed.

2. Enter a file name in section “Parameters”.
3. Scroll down the list „Source objects“ until you see the phases of the current CircuitPro PM project.

In CircuitPro PM the toolpaths are assigned to the corresponding phases. You can check the assignments in the pane “Toolpath”.

4. Tick the checkbox of these phases whose toolpaths you want to export.
5. Click on [Save].

→ The toolpaths are exported in a LMD file. This file is saved in the folder of your current CircuitPro PM project.

Highlighting and exporting individual toolpaths

In the CAM/Machining view you are able to highlight the toolpaths to export or you click on the individual toolpaths in the pane “Toolpath”.

In the “Export” dialog, select “<Current selection>“ in the list “Source objects”.

Click on [Save], to export the toolpaths.

→ The toolpaths have been exported.
5.1.13 **Print preview**

Before printing a document in CircuitPro PM, you can use the print preview to get an overview of the pages to be printed.

- Starting the print preview
  1. Click on File > Print Preview…

  The following window is displayed:

![Print preview window](image)

The print preview has the following menu items:

<table>
<thead>
<tr>
<th>No.</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/1/</td>
<td>Print</td>
<td>Starts the printing process.</td>
</tr>
<tr>
<td>/2/</td>
<td>Settings</td>
<td>Opens the printer setup dialog.</td>
</tr>
<tr>
<td>/3/</td>
<td>Lens</td>
<td>Zooms in or out of the page(s) to be printed.</td>
</tr>
</tbody>
</table>

**View**

<table>
<thead>
<tr>
<th>No.</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/4/</td>
<td>2D/3D</td>
<td>Offers the choice between the objects in 2D view and in 3D view.</td>
</tr>
</tbody>
</table>
## Mode

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/5/ One Page</td>
<td>Displays only one page at a time of the document to be printed.</td>
</tr>
<tr>
<td>/5/ Two pages</td>
<td>Displays two pages at a time of the document to be printed.</td>
</tr>
<tr>
<td>/5/ Three pages</td>
<td>Displays three pages at a time of the document to be printed.</td>
</tr>
<tr>
<td>/5/ Four pages</td>
<td>Displays four pages at a time of the document to be printed.</td>
</tr>
<tr>
<td>/5/ Six pages</td>
<td>Displays six pages at a time of the document to be printed.</td>
</tr>
</tbody>
</table>

## Print area

<table>
<thead>
<tr>
<th>Print area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/6/ All visible</td>
<td>Restricts the print area to all visible objects.</td>
</tr>
<tr>
<td>/6/ View</td>
<td>Restricts the print area to the current view.</td>
</tr>
<tr>
<td>/6/ Full layout</td>
<td>Fits the print area to the full layout.</td>
</tr>
<tr>
<td>/6/ Selection</td>
<td>Restricts the print area to the current selection.</td>
</tr>
<tr>
<td>/7/ Page number</td>
<td>Displays the current page number.</td>
</tr>
<tr>
<td>/8/ Close</td>
<td>Closes the print preview.</td>
</tr>
</tbody>
</table>

2. Click on the print button /1/ in order to print the document.

Or

2. Click on [Close] in order to close the print preview window.

◆ The print preview window is closed.
5.1.14 Print

Use the menu item File > Print… if you want to print a document/artwork film in CircuitPro PM.

Use the different tabs to set your desired properties for a good printing result.

- Printing a document/artwork film

1. Click on File > Print…

   ➔ The print dialog is displayed.

2. Take your desired settings in the individual tabs as explained below:

### General tab

![Print dialog with numbered sections]

/1/ Printer selection  
/2/ Page Range  
/3/ Collate  
/4/ View  
/5/ Print Area

---

© 2014 LPKF AG  
V1.0 – 01.2014  
77
### Table 25: Print > General

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printer selection</td>
<td>Select the printer for the print job in this section.</td>
</tr>
<tr>
<td>Page Range</td>
<td>Select the pages that are to be printed. If the radio button “Selection” is activated only the current selection in the view are printed.</td>
</tr>
<tr>
<td>Number of copies and collate</td>
<td>Enter the number of copies to be printed. If more than one copy is selected, the “Collate” check box is available. This setting is for printing all pages of one copy before printing the next copy.</td>
</tr>
<tr>
<td>View</td>
<td>Select the view that is to be printed.</td>
</tr>
<tr>
<td>Print Area</td>
<td>Print area defines whether the current view, the whole design, the selection, or everything is to be printed.</td>
</tr>
</tbody>
</table>

### Button Description

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties</td>
<td>Opens the printer dialog to set the properties of the connected printer.</td>
</tr>
<tr>
<td>Preview</td>
<td>Creates a preview of the print job.</td>
</tr>
<tr>
<td>Print</td>
<td>Starts the printing process</td>
</tr>
<tr>
<td>Cancel</td>
<td>Closes the dialog.</td>
</tr>
<tr>
<td>Apply</td>
<td>Stores the settings.</td>
</tr>
</tbody>
</table>

#### Printing an artwork film

To print an artwork film (for a later usage in LPKF ProMask/ProLegend), enter the following settings in your printer properties:

1. Click on [Properties…].
2. Enter the following settings in the upcoming dialog:
   - Print quality: high
   - Color: gray shades
   - Paper quality: fine/film
   - The document size must be equal to actual size. i.e. the option “reduce/enlarge the page” must be disabled.
**Page Setup tab**

Table 26: Print > Page Setup

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview</td>
<td>Displays an example sheet of the current settings.</td>
</tr>
<tr>
<td>Paper</td>
<td>Select the paper size and the paper source of the printer.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Select the orientation of the pages: Portrait or Landscape.</td>
</tr>
<tr>
<td>Margins</td>
<td>Enter the page margins.</td>
</tr>
</tbody>
</table>
How to work with CircuitPro PM

CircuitPro PM 2.1

Settings tab

Table 27: Print > Settings

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing options</td>
<td>You can select the following options:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Enable colors</strong>: Activate this option for color printing.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Auto rotate</strong>: Adjusts the page orientation to the orientation setting in the printer setup.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Include file name in print output</strong>: Prints the file name of the project on every page.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Inverse</strong>: This function creates an inverted view of the milling area. I.e., the surface that is milled when producing the circuit board (e.g. rubout area) remains blank and the remaining copper areas are printed.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Mirror Y</strong>: Mirrors the object to be printed on the Y axis.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Scaling</th>
<th>You can choose between three options for scaling:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• <strong>Best fit according paper size</strong>: Select this option to have the print output scaled automatically to the paper size.</td>
</tr>
<tr>
<td></td>
<td>• <strong>1:1</strong>: If this option is selected, the print output has the actual size of the printed object. No scaling takes place. In case of large designs, these may be printed across several pages. In case of small designs, it can happen that details are printed so small that they become illegible.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Manual scaling</strong>: Enter a scaling value to scale the print output. If you enter e.g. “4” the output is enlarged by four.</td>
</tr>
<tr>
<td></td>
<td>If the scaling factor would result in a print output of more than 100 pages the scaling is aborted.</td>
</tr>
</tbody>
</table>
### Table 27: Print > Settings

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page count</td>
<td><strong>One page:</strong> If the output is enlarged (e.g. requires 3 pages) only the center part is printed on a single page. The remaining parts are cropped.</td>
</tr>
<tr>
<td></td>
<td><strong>Page count according to scaling:</strong> The output is printed exactly (if e.g. 3 pages are required) as displayed in the preview. The output is not cropped or limited.</td>
</tr>
</tbody>
</table>
How to work with CircuitPro PM

CircuitPro PM 2.1

Printer Calibration tab

Table 28: Print > Printer Calibration

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameters</td>
<td>Enter the parameters for printing a calibration rectangle:</td>
</tr>
<tr>
<td></td>
<td><strong>Rectangle size</strong>: Enter the size (X and Y values) of the calibration rectangle.</td>
</tr>
<tr>
<td></td>
<td>→ Start a test print by clicking on [Print calibration rectangle].</td>
</tr>
<tr>
<td></td>
<td><strong>Printed size</strong>: Enter the actual size of the printed calibration rectangle.</td>
</tr>
<tr>
<td></td>
<td>→ Use a ruler to measure the rectangle in the print output.</td>
</tr>
<tr>
<td></td>
<td><strong>Correction factor</strong>: This is computed automatically from the difference between the rectangle size and the actual printed size. You can also modify the factor manually.</td>
</tr>
<tr>
<td></td>
<td>→ Activate the check box &lt;Use Calibration&gt; to apply the correction factor.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print calibration rectangle</td>
<td>Prints a rectangle that can be adjusted to the desired rectangle size by entering the actual size in the parameters section.</td>
</tr>
</tbody>
</table>

3. Click on [Print] in order to print the document.
   ◆ The document is printed.
5.1.15 Export to image

CircuitPro PM offers to export designs into image files. The following file formats are available:

- Bitmap (*.bmp)
- JPEG (*.JPG, *.JPEG)
- Metafile (*.emf)
- Portable Network Graphics (*.png)

- Exporting a design to an image
  1. Click on File > Export to image…
  2. Select the file format for the image (bitmap, JPEG, metafile or Portable Network Graphics).
  3. In the parameters field, select whether 2D graphics or 3D graphics are to be exported.
     You can also select which area of the design are to be exported into the image file.
### Table 29: Parameters

<table>
<thead>
<tr>
<th>Selection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All visible</td>
<td>Exports all visible objects of the 2D/3D view</td>
</tr>
<tr>
<td>View</td>
<td>Exports the current CAM view.</td>
</tr>
<tr>
<td>Full layout</td>
<td>Exports the whole design in 2D and 3D view</td>
</tr>
<tr>
<td>Selection</td>
<td>Exports only the objects selected in 2D/3D view.</td>
</tr>
</tbody>
</table>

4. Select the folder for saving the image.
5. Click on [Save].

- The design is exported and stored into an image file.

### 5.1.16 Exit

The menu item “Exit” closes the CircuitPro PM program. Just click on File > Exit.
5.2 Menu Edit

The “Edit” menu contains the functions for editing objects in CircuitPro PM. Click on the menu item “Edit” to open the sub-menu:

![Menu Edit](image)

The following table contains short descriptions of the functions of the individual menu items:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Undoes the last operation in the document.</td>
</tr>
<tr>
<td>Redo</td>
<td>Restores the operation previously undone.</td>
</tr>
<tr>
<td>Cut</td>
<td>Cuts the selected object(s) from the document and stores it (them) in the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the selected object(s) to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Inserts the object(s) previously cut/copied at the selected position/on the selected layer.</td>
</tr>
<tr>
<td>Material properties…</td>
<td>Defines the properties (such as type and size) of the material used for 2.5D operations.</td>
</tr>
<tr>
<td>Material placement…</td>
<td>Defines the height and the position of the material used (2.5D objects)</td>
</tr>
<tr>
<td>Material Settings…</td>
<td>Opens the dialog &quot;Material settings&quot; where you can enter the parameters of the base material used.</td>
</tr>
<tr>
<td>Tool magazine…</td>
<td>Opens the dialog “Tool magazine” dialog. Enter the various tools that are/will be in the machine’s tool magazine in this dialog.</td>
</tr>
<tr>
<td>Tool Library…</td>
<td>Opens a dialog showing all available tools.</td>
</tr>
<tr>
<td>Aperture list library…</td>
<td>Opens a dialog showing all apertures of the current document.</td>
</tr>
<tr>
<td>Design Rule Check…</td>
<td>Opens a dialog for the setting options and starting the design rule check.</td>
</tr>
</tbody>
</table>
### Table 30: “Edit” menu items

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Measure</td>
<td>Activate this menu item to measure the distance between two points in the 2D/3D/Machining view. The values are shown in the status bar of CircuitPro PM. Press the ESC key on your keyboard to deactivate this function.</td>
</tr>
<tr>
<td>Distance…</td>
<td>Opens the “Distance” dialog. The dialog shows the exact distance between two objects.</td>
</tr>
<tr>
<td>Set anchor point…</td>
<td>Opens a dialog where you can define the coordinates of the anchor point.</td>
</tr>
<tr>
<td>Set zero point…</td>
<td>Moves the zero point to the current anchor point.</td>
</tr>
<tr>
<td>Move anchor to center point…</td>
<td>Moves the anchor point to the center point of a selected object.</td>
</tr>
<tr>
<td>Move layer to zero…</td>
<td>Aligns the objects of the selected layer to the zero point.</td>
</tr>
<tr>
<td>Match up layers…</td>
<td>Opens a dialog allowing to align the objects of two layers along a vertical line.</td>
</tr>
<tr>
<td>Match up objects…</td>
<td>Opens a dialog allowing to move a source object onto a target object.</td>
</tr>
<tr>
<td>Delete…</td>
<td>Deletes the selected object(s) of the layer.</td>
</tr>
</tbody>
</table>

### 5.2.1 Undo

Use this function to undo the last operation. By default, you can undo up to 10 operations. If you want to increase the number of undo operations change the setting in menu Extras > Options > General > Undo/Redo level (see page 336).

### 5.2.2 Redo

Use this function to restore the operation undone last. By default, you can restore up to 10 undone operations. If you want to increase the number of redo operations change the setting in menu Extras > Options > General > Undo/Redo level (see page 336).

### 5.2.3 Cut

Use this function to cut the selected object(s) and store it (them) in the clipboard.

### 5.2.4 Copy

Use this function to copy the selected object(s) and store it (them) in the clipboard.
5.2.5 Insert

Use this function to paste objects previously cut or copied from the clipboard to the current mouse position.

Note

If you insert the copied object on the same layer the new object will be placed on the original object. In this case activate the button on the left. Now click and move the copied object to the desired position.

5.2.6 Material properties

In the dialog “Material properties”, the properties of the 3D object to be processed can be determined.

- Determining material properties

1. Click on process > Material properties.

- The following dialog is shown:

2. Select the material type in the field \Type: \.

3. Enter the length of the material (in mm) in the field \Length: \.

4. Enter the material width (in mm) in the field \Width: \.

5. Enter the height of the material in the field \Height: \.

If you use the same material frequently, you can also set the specified values as default properties and save them. Activate the checkbox “Save as default properties”.

6. Click on [OK] to adopt the values.

- The material properties have been determined.
5.2.7 Material placement

You can place the material in the machining view by using this dialog. You define the corners of the material as well as the surface height.

- Placing the material
  1. Click on Edit > Material placement…
     ➤ The following dialog is displayed:

![Material placement dialog](image)

The individual sections contain the following information/functions:

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material properties</td>
<td>In this section, the material properties of the material to be processed are displayed. You previously entered these properties in the dialog &quot;Material properties&quot;.</td>
</tr>
<tr>
<td>Machine properties</td>
<td>In this section, the current material side to be processed, is displayed.</td>
</tr>
<tr>
<td>Location</td>
<td>In this section, the material corners are set. Please take the exact instructions from the following pages.</td>
</tr>
<tr>
<td>Surface level</td>
<td>In this section, please set the surface height. Please take the exact instructions from the following pages.</td>
</tr>
</tbody>
</table>

2. Modify the settings as required.
3. Click on [OK] to save the values.

➤ The dialog is closed.
◆ The material has been placed.
Set material corners

1. Move the camera head to the left, lower corner of your base material:
   a) Click in the “Processing” pane.
   b) Use the arrow buttons in the section “X/Y positioning” to move the camera head.

2. Perform autofocus for improved material alignment:
   a) To do this, click on the button "Autofocus" in the “Processing” pane:

3. Position the camera head so that the corner of your material is exactly at the crosshairs:
If you use the dark/reflective base materials (for example, POM), the display of the camera image can be too dark for the material to be recognised. In this case, turn the camera aperture to improve the incidence of light/lightness of the camera image.

4. In the dialog “Material placement”, click on the following icon:
   ➔ The value for the lower, left material corner was saved.
   ➔ The following message is displayed:

5. Confirm the message by clicking on “Yes”.
   ➔ The camera automatically moves in the opposite corner of the material.
6. Align the crosshairs with the material corner by using the X/Y buttons.
7. Click on the symbol for the upper, right-hand corner:
   ➔ The value was saved.
   ➔ The material corners have been set.
Setting the material height

In the next step, the Z height of the material must be determined.

- The following message is displayed after you have set the material corners:

1. Confirm the message by clicking on “Yes”.
2. Click on [Autofocus].
3. Now click on the button to set the material height:
   - The material height has been set.

### 5.2.8 Material Settings

Use this dialog to define the material properties of the object to be processed.
Section /1/ defines whether the material is used as a printed circuit board or as a front panel/engraving.

The properties of the material are defined in section /2/. This comprises:
• Material type (glass-reinforced epoxy laminate (FR4) or aluminium)
• Thickness of the copper layer in µm
• Material thickness in mm
• Thickness of the underlay in mm (none if vacuum table is mounted)

Section /3/ defines the location and size of the material area. In case of front panels/engravings, the Z height has to be determined by lowering the tool to the surface of the material. The following properties can also be defined:
• Material width in mm
• Material length in mm

→ When the material area is defined, the resulting surface height and the coordinates of the material's corners are displayed.

■ Defining the material area
1. Click on the upper right corner of the working area in the machining view of the project.

   ➔ The milling head moves to this position. The X and Y coordinates of this position are displayed in the “Material settings” dialog.

   ![Material settings > coordinates](image)

   If you have selected “Front panel/Engraving” in the “Application” section, you have to enter the Z coordinate at the material's corners.

   ➔ Move the milling head downwards by changing the Z value until the tool touches the material. Follow the further instructions from step 2 onwards.
2. Click on the icon representing the right rear corner, see /2/ in the following figure:

![Location](image)

- The coordinates of the material area are stored.

3. Click on the lower left corner of the working area in the machining view of the project.

- The milling head moves to this position. The X and Y coordinates of this position are displayed in the “Material settings” dialog.

4. Click on the icon representing the left front corner /1/.

Tip

After defining front left corner of the material area, you can also define the size of the material area by setting the “Material width” and “Material length”.

1. Follow the steps 3 and 4 of “Defining the material area”
2. Enter the values for `Material length` and `Material width` in millimetres.

→ The material area is adjusted automatically.

◆ The material area is defined.
5.2.9 Tool magazine ProtoMat D104

The tool magazine dialog lets you

- view a list of the tools required for the current project,
- view the tools currently present in the machine,
- load the tool magazine,
- view/put back the tool currently present in the clamp,
- pick up a tool with the clamp,
- check the milling width (Universal Cutter and Micro Cutter) or the milling depth (End Mill) of a tool,
- view the current state of the tool life spent, and
- replace an old tool with a new one.

Note

The “Tool magazine” dialog offers these options only for machines with automated tool change. This comprises the ProtoMat S63, the ProtoMat S103, and the ProtoMat D104.

To open the dialog, select the milling head as active head and click on Edit > Tool magazine… or click on the following icon of the toolbar to open the dialog as an alternative:
The following dialog is displayed:

It is necessary to load the tool magazine for processing a project. In section /1/, CircuitPro PM displays the tools that are required for processing the project. The required tools have to be inserted into the tool magazine manually. You can either

- insert the tools into the tool holders and then assign them to the tool holders accordingly in section /4/ or
- assign tools to the tool holders in the “Tool magazine” dialog and then insert the tools into the tool holders according to the list.
1. Click on the drop-down list of the first tool holder:

A list of all tools that you can use with the machine is displayed.

2. Select the required tool (in this case: Universal Cutter 0.2 mm, as in adjacent list):

The tool is marked with a green check mark in the list of the required tools. Also, a green check mark is displayed next to the corresponding drop-down list and the tool life spent is displayed on the right.
3. Repeat above steps for all tools that are required for your project with the other tool holders.

Fig. 86: Tool magazine loaded

- The tool magazine is loaded.

- Picking up a tool with the clamp

1. Click on the following button next to the drop-down list:

Fig. 87: Picking up a tool

- The following message is displayed while the clamp picks up the tool:

Fig. 88: Message picking up tool

- The symbol on the tool's button changes:

Fig. 89: Tool currently in clamp

- Now, the tool is in the clamp.
Putting the tool back to its magazine position

1. Click on the following button next to the drop-down list:

![Fig. 90: Putting down a tool](image)

The following message is displayed while the clamp puts down the tool:

![Fig. 91: Message tool release](image)

The symbol on the tool’s button changes:

![Fig. 92: Tool not in clamp](image)

The tool is back at its corresponding magazine position.
Checking the milling width

A tool has to be in the clamp to enable checking the milling width (Universal Cutter und Micro Cutter) or the milling depth (End Mill) of a tool.

A short line is milled that is subsequently measured with the camera or the caliper.

1. Pick up the tool with the clamp (see procedure “Picking up a tool with the clamp”).

   ➔ The tool is now in the clamp.

2. Activate the check box of the tool currently in the clamp:

   ➔ The button “Check milling width…” is active.

   Note

   If a tool the milling width of which cannot be checked (e.g. Spiral Drill etc.) is in the clamp the button is not activated.

3. Click on [Check milling width…].
The following message is displayed:

4. Click on a position outside the area to be used for the project (but inside the processing area) to mill a line (see figure above).

Note

Please make sure that the milled line is inside the working area of the camera so that the camera can measure the line.

The milling head moves to the corresponding position in the processing area.

5. Click on [OK].
The dust extraction of the machine is switched on, the milling head moves to the zero position and the spindle motor is warmed up:

![Image of warm-up of spindle motor](image1)

**Note**

The warm-up may already have taken place before, if the machine has already processed material after switching it on.

The line to be milled is displayed in the machining view and the line is milled:

![Image of machining view with milled line](image2)
After the line has been milled the camera moves to the corresponding position. The “Camera” pane displays the line just milled:

Fig. 97: “Camera” pane

The dialog with the measurement results is displayed:

Fig. 98: Measurement results

If there is a difference between the desired milling width and the measured width CircuitPro PM automatically proposes a correction value.

You can manually enter a correction value if you do not want to apply the value proposed by CircuitPro PM.

Note

6. Increase or decrease the value of the proposed correction by using the two arrow buttons.
7. To apply the proposed correction only for the current tool, click on [Store correction].

The correction value for the current tool has been applied. The dialog is closed.
or
8. To apply the proposed correction for all tools of the same tool type, click on [Save for all tools].
   ➔ The correction value for all tools of the same tool type has been applied. The dialog is closed.

---

Note

In CircuitPro PM it is possible to apply the correction value for all tools of the same tool type. If you check the milling width with an Universal Cutter and if you click on the button [Save for all tools], the correction value is applied for all Universal Cutters.

---

Note

If you do not want to apply any correction click on [Cancel].

---

Note

Please note that the tool has to be put back into the holder and picked up again in order to have the corrected settings be applied.

◆ The milling width has been checked.

■ Discarding a tool

If the tool life of a tool is spent, the tool should be discarded to ensure optimum milling results.

Note

Please note that all information on the tool to be discarded will be deleted.

1. Activate the check box of the tool to be discarded.
The button “Discard tool” is activated.

2. Click on [Discard tool].

The following message is displayed:

3. Confirm by clicking on [Yes].

Note

If the tool to be discarded is currently in the clamp, the tool is put back into its corresponding magazine position.

A message is displayed which prompts you to discard the tool.

4. Replace the old tool in the machine with a new one.

The old tool is discarded.
5.2.10 Tool magazine ProtoMat E33/S43 (manual tool change)

The “Tool magazine” dialog moves the milling head to the zero position to allow a manual tool change.

Click on Edit > Tool magazine… or the following icon of the toolbar to open the dialog:

The following dialog is displayed.

![Tool magazine dialog for E33 and S43](image)

/1/ Tool selection list /2/ Tool in clamp

- Performing a manual tool change

1. Select the tool that you want to mount into the clamp from the tool selection list /1/.

   This example uses the tool “Universal Cutter 0.2 mm”.

   Note

2. Click on [Continue].

   The following message is displayed:

3. Mount the tool.
4. Click on [OK].

   The manual tool change is finished.
Measuring the milling width

Please note, that you can only measure the milling width of a conical tool.

1. Click on [Milling Width].

   ➔ The following dialog is displayed:

   ![Measure Milling Width Dialog]

2. Click on the position in the Machining view where you want to mill the line.
3. Enter the length of the line to be milled.
4. Select an option:
   • Horizontal milling line
   • Vertical milling line
5. Click on [Mill a Line].
   ➔ The line is milled at the selected position.
6. Measure the milling width by using a microscope.

To determine the correct milling width, put on the microscope at the lower, inner edges of the copper:

7. Click on [Accept Width], if the milling width is okay.
   If not
7. Adjust the tool manually and mill a line again until the result of the milling width is okay.
   • The milling width is measured.
5.2.11 Tool magazine ProtoMat S63/S103

The tool magazine dialog lets you
• view a list of the tools required for the current project,
• view the tools currently present in the machine,
• load the tool magazine,
• view/put back the tool currently present in the clamp,
• pick up a tool with the clamp,
• check the milling width of a tool (only for Universal Cutter and Micro Cutter),
• view the current state of the tool life spent and
• replace an old tool with a new one.

Note

The “Tool magazine” dialog offers these options only for machines with automated tool change. This comprises the ProtoMat S63 and the ProtoMat S103.

Click on Edit > Tool magazine… or the following icon of the toolbar to open the dialog:
The following Dialog is displayed:

![Tool magazine dialog](image)

1. Required tools
2. Button “Check milling width…”
3. Button “Discard tool”
4. Tools in the machine

It is necessary to load the tool magazine for processing a project. In section /1/, CircuitPro PM displays the tools that are required for processing the project. The required tools have to be inserted into the tool magazine manually. You can either

- insert the tools into the tool holders and then assign them to the tool holders accordingly in section /4/ or
- assign tools to the tool holders in the “Tool magazine” dialog and then insert the tools into the tool Holders according to the list.
Loading the tool magazine

1. Click on the drop-down list of the first tool holder:

- A list of all tools that you can use with the machine is displayed.

2. Select the required tool (in this case: Universal Cutter 0.2 mm, as in adjacent list):

- The tool is marked with a green check mark in the list of the required tools. Also, a green check mark is displayed next to the corresponding drop-down list and the tool life spent is displayed on the right.

3. Repeat above steps for all tools that are required for your project with the other tool holders.
The tool magazine is loaded.

- Picking up a tool with the clamp

1. Click on the following button next to the drop-down list:

- The following message is displayed while the clamp picks up the tool:

- The symbol on the tool's button changes:

- The tool is now in the clamp.
Putting the tool back to its magazine position

1. Click on the following button next to the drop-down list:

Fig. 113: Putting down a tool

The following message is displayed while the clamp puts down the tool:

Fig. 114: Message tool release

The symbol on the tool's button changes:

Fig. 115: Tool not in clamp

The tool is back at its corresponding magazine position.
Checking the milling width
A tool has to be in the clamp to enable checking the milling width.
A short line is milled that is subsequently measured with the camera.

1. Pick up the tool with the clamp (see procedure “Picking up a tool with the clamp”).
  ➔ The tool is now in the clamp.

2. Activate the check box of the tool currently in the clamp:

Fig. 116: Check box activated

The button “Check milling width…” is active.

Note

If a tool the milling width of which cannot be checked (e.g. Spiral Drill etc.) is in the clamp the button is not activated.

3. Click on [Check milling width…].
The following message is displayed:

4. Click on a position outside the area to be used for the project (but inside the processing area) to mill a line (see figure above).

Note: Please make sure that the milled line is inside the working area of the camera so that the camera can measure the line.

The milling head moves to the corresponding position in the processing area.

5. Click on [OK].

The dust extraction of the machine is switched on, the milling head moves to the zero position and the spindle motor is warmed up:
The warm-up may already have taken place before, if the machine has already processed material after switching it on.

The line to be milled is displayed in the machining view and the line is milled:
After the line has been milled the camera moves to the corresponding position. The "Camera" pane displays the line just milled:

Fig. 120: "Camera" pane

The dialog with the measurement results is displayed:

Fig. 121: Measurement results

If there is a difference between the desired milling width and the measured width CircuitPro PM automatically proposes a correction value.
6. Click on [Store correction] to apply the proposed value.

You can manually enter a correction value if you do not want to apply the value proposed by CircuitPro PM.
7. Increase or decrease the value of the proposed correction by using the two arrow buttons.
8. Click on [Store Correction].

If you do not want to apply any correction click on [Cancel].

- The dialog is closed.
- The milling width of the tool currently in the clamp was checked.
Please note that the tool has to be put back into the holder and picked up again in order to have the corrected settings be applied.

- Discarding a tool

If the tool life of a tool is spent, the tool should be discarded to ensure optimum milling results.

Please note that all information on the tool to be discarded will be deleted.

1. Activate the check box of the tool to be discarded.
   ➔ The button “Discard tool” is activated.

2. Click on [Discard tool].
   ➔ The following message is displayed:

3. Confirm by clicking on [Yes].

If the tool to be discarded is currently in the clamp, the tool is put back into its corresponding magazine position.
4. Replace the old tool in the machine with a new one.
   ♦ The old tool is discarded.

5.2.12 Tool library

The tool library contains the tools that you selected when setting up the machine (equipment configuration wizard).

The dialog allows the following operations:
- Adding new tools
- Deleting existing tools
- Defining filters for displaying the categories, tool types, and materials
- Adding new materials or delete existing ones

![Tool library dialog]

- /1/ Display of available tools
- /2/ Detailed information on the selected tool
Displaying tool information

1. First select the type of your machine in the drop-down list "Machine type".
   - The tools which are assigned to your machine type are displayed in the section "Available tools".

2. In section /1/, click on the tool whose detailed information you would like to view.
   - In section /2/, now the relevant detailed information on the selected tool is shown with an image:

   ![Detailed information](image1)

   ![Detailed information on the laser](image2)

The materials which can be processed are listed under each tool.

3. Click on the arrow symbol next to the respective tool:
The materials are listed and the following information is displayed in section /2/:

**Fig. 127: Material display**

1. Feed Speed
2. Rotation Speed
3. Maximum Tool Life
4. Maximum penetration depth [mm]
5. Z penetration offset [mm]

**Fig. 128: Material display Laser**

1. Feed Speed [mm/s]
2. Maximum penetration depth [mm]
3. Z penetration step [mm]
4. Diameter [mm]
5. Laser power [W]
6. Laser on delay [ms]
7. Laser off delay [ms]
8. Runs

The detailed information has been displayed.
Removing an existing tool from the list
1. In section /1/, click on the tool that you want to remove from the list.
2. Click on [Remove tool].
   ◆ The tool is removed from the list.

Adding a new tool
1. Click on [Add tool…].
   ➔ The following dialog is displayed:

![Add tool dialog]

Adding LPKF tools
1. Click on “Add LPKF tools…”.
   ➔ The following dialog is displayed:

![Add LPKF tool dialog]
2. Select a tool from the list.
   ➔ The associated materials are displayed in the list.
3. Click on [Close].
   ◆ The tool has been added.

Adding custom tools
1. Click on “Add custom tools...”.
   ➔ The following dialog is displayed:

2. Select a tool type.
3. Enter a tool name.
4. If necessary, enter a tool description.
5. Set the tool diameter.
6. Select a base tool from the current list of available tools.
7. Click on the materials for which the tool is to be used.
   ➔ The "Add tool" button is active.
8. Click on [Add tool].
   ➔ The new tool appears in the tool list.
9. Click on [Close].
   ➔ The dialog is closed.
   ◆ The custom tool has been added.
Adding dispense tools
1. Click on “Add dispense tools...”.
   ➔ The following dialog is displayed:

2. Enter a tool name.
3. If necessary, enter a tool description.
4. Set the tool diameter.
5. Select a base tool from the current list of available tools.
6. Click on the materials for which the tool is to be used.
   ➔ The “Add tool” button is active.
7. Click on [Add tool].
   ➔ The new dispense tool appears in the tool list.
8. Click on [Close].
   ➔ The dialog is closed.
   ➔ The dispense tool has been added.
- Editing materials
  The dialog "Edit Materials" allows you to add new materials (optionally using tool parameters of other materials) or remove existing ones.
  1. Click on [Edit materials…].
  ➔ The following dialog is displayed:

In this dialog, the following options are available:
- Adding materials
- Adding materials with the tool parameters of materials already available
- Removing materials that are added individually.

- Adding materials
  1. Enter a name for the new material.
  2. Click on [Add material].
  ➔ The material is displayed in the list “Available materials”.
  3. Click on [Close].
  ➔ The dialog is closed.
  ◆ The new material has been added.
How to work with CircuitPro PM

Add materials with the tool parameters of materials already available

If you want to add a new material that has the same tool parameters as a material already available, please follow these steps:

1. Enter the name for the new material.
2. Mark the checkbox <Copy all tool parameters from:>
3. Now select the material whose properties you would like to copy from the drop-down list.
4. Click on [Add material].
   ➔ The new material, with the copied tool parameters, is added to the list of available materials.
5. Click on [Close].
   ➔ The dialog is closed.
   ◆ The new material, with the tool parameters for materials already available, has been added.

Removing materials that are added individually

1. In the list of the available materials, please click on the material that has been added individually.

   Only materials that have been added individually can be removed. Default materials of the LPKF tools cannot be removed.

2. Click on [Delete].
   ➔ The selected material is removed.
3. Click on [Close].
   ➔ The dialog is closed.
   ◆ The material that has been added individually has been removed.

   ◆ Material editing is complete.
Defining filters
You can define one filter each for the tool types and materials. The filter is used to display only information significant for you.
The tabs “Tool type” and “Material” contain your customised entries.

1. Click on [Define filter…].

The following dialog is displayed:

Fig. 134: Define filter

2. Click on the tool type/material that the filter shall apply to.

Note Each tab offers the option to select the standard filter for the tool type or the material. These standard filters are defined by the system and cannot be modified.

3. Click on [OK].

The changes were adopted and the dialog is closed.
The filters are defined.
5.2.13 Aperture list library

A dialog to manage the apertures of the current project and the apertures and aperture lists in the aperture list library can be started by clicking on Edit > Aperture list library.

Note

Please note that CircuitPro PM automatically loads the *.cbf file “ApertureListsLibrary.cbf” when the aperture library is opened for the first time. CircuitPro PM displays a corresponding message.

When using Windows XP, the file “ApertureListsLibrary.cbf” is stored in folder C:\Documents and Settings\User name\Local Settings\Application Data\LPKF Laser&Electronics\LPKF CircuitPro PM 2.1.

When using Windows 7, the file “ApertureListsLibrary.cbf” is stored in folder C:\Users\User name\AppData\Local\LPKF Laser&Electronics\LPKF CircuitPro PM 2.1.

Fig. 135: Aperture list library

/1/ File name /4/ Copy
/2/ Aperture lists /5/ Remove a single aperture
/3/ Detail section: contains the individual apertures of the selected aperture list. /6/ Remove aperture list
The following operations are available in the “Aperture list library” dialog:

- Copying aperture lists from the current project into the aperture list library (thus making them available in other projects).
- Copying aperture lists available in the aperture list library into the current project.
- Removing apertures from the library.

By default, the aperture library is stored as a *.cbf file.

You can also load custom *.cbf files in the dialog to edit the contained aperture libraries.

---

**Note**

Unless you open a new file in the “Aperture list” dialog, CircuitPro PM automatically loads the aperture library that was used last when opening the dialog.

---

You can load your own *.cbf files in the dialog to edit the contained aperture libraries.

---

**Note**

As long as you do not load a different file in the “Aperture lists” dialog, CircuitPro PM automatically loads the aperture library that was edited last.

---

- Copying an aperture list from the current project to the aperture list library
  1. Select the aperture list to be copied in /2/.
  2. Click on [Copy].
  3. The following dialog is displayed:

![Copy aperture list to library dialog](image)

3. Enter a name for the aperture list to be created.
4. Click on [OK].
   - The aperture list is copied to the aperture list library.
How to work with CircuitPro PM

CircuitPro PM 2.1

- Copying an aperture list from the aperture list library to the current project
  1. Select the aperture list to be copied in /2/.
  2. Click on [Copy].
  ➔ The following dialog is displayed:

```
Name of aperture list
  OK  Cancel
```

3. Enter a name for the aperture list to be created.
4. Click on [OK].
   • The aperture list is copied to the current project.

- Removing an aperture list from the library

  Please note that only aperture lists that are not used in the current *.cbf document can be removed from the aperture list library.

1. Click on the aperture list in /2/ that you want to remove.
2. Click on [Remove aperture list].
   • The aperture list is removed from the library.

- Removing an aperture from the aperture list

  Please note that only apertures that are in a library's aperture list can be removed.

1. Click on the aperture in /3/ that you want to remove.
2. Click on [Remove].
   • The aperture is removed from the aperture list.
5.2.14 Design Rule Check

The design rule check helps you to check whether the design meets defined and recommended standards for producing circuit boards.

You can check the following:

• Spacing between objects that are on different layers.
• Spacing between objects on the same layer.

This function enables you to check before isolation whether the object spacing matches the size of the tool used, thus ensuring flawless isolation.

Note

In order to check the object spacing, check the size of the tool you want to use for isolation first. You can find this information in the menu item “Technology dialog”.

For more information on the menu item “Technology dialog” see the corresponding chapter.
Checking the spacing between two layers

1. Click on the first layer in the drop-down list “Source objects”.
2. Click on the second layer in the drop-down list “Additional source objects”.

3. Select a result layer.

- It is recommended to create a new result layer.

4. Enter the minimum spacing to check in millimetres.
5. Click on [Run].

- The design rule check is started. A new result layer “DRC_Errors” is created in the “Layers” pane:

- The number next to the layer name “DRC_Errors” shows how often the design rules were violated
- The design rule check is finished.
Checking the spacing within a layer

1. In the drop-down list “Source objects”, select the first layer whose object spacing you want to check.
2. Select a result layer.

Fig. 142: Checking the spacing within a layer

It is recommended to create a new result layer.

Note

3. Enter the minimum spacing to check in mm.
4. Click on [Run].

The design rule check is started. A new result layer is created in the “Layers” pane:

Fig. 143: Result layer

The number next to the layer name “DRC_Errors” shows how often the design rules were violated.

Fig. 144: Violations count

The design rule check is finished.
5.2.15 Measure

Use this function to measure the distance between two points.

- Measuring the distance between two points
  1. Click on Edit > Measure.
  2. In the graphical view (CAM view/3D view/Machining view), click on the starting point from which to measure.
  3. Move the mouse to the second point in order to measure the distance.
  ➨ The mouse cursor draws a line.
  4. Read the length of the line from the status bar of CircuitPro PM.

Fig. 145: Measure

- The distance between the two points is measured.
5.2.16 Distance

Use the “Distance” dialog to measure the distance between two objects that are on the same layer.

- Measuring the distance between two objects
1. Click on Edit > Distance…
   - The following dialog is displayed:

   ![Distance Dialog](image)

2. Select an object in the drop-down list “First object”.
3. Select the second object in the drop-down list “Second object”.

   Tip
   - You can also click on the desired objects in the CAM view.
   1. Click on the radio button of “First object” in the dialog.
   2. Click on the desired object in the CAM view.
   → The name of the selected object is transferred to the “First object” field.
   3. Repeat steps one and two for the “Second object” field.

   ➔ The distance between the two objects is measured. Two distances are displayed:

   - **Between center of objects**: This value is the distance between the center points of the objects.
   - **Minimum**: This value is the shortest distance between the two objects.

   Tip
   - If you do not know the name of an object, you can find it in the “Properties” pane.
   Select the object and click on the item “General” in the “Properties” pane. The name property of the selected object is displayed.

   ➔ The distance between the two objects was measured.
5.2.17  Set anchor point

An anchor point is a reference point in the drawn object. In the CAM view, the anchor point is marked by a magenta-colored asterisk (see following figure).

Using the anchor point function, you can determine the object reference points. Click onto a reference point of the object and read the coordinates in the status bar of CircuitPro PM (Anchor point X and Y).

You can change the position of the anchor point by entering new X and Y values and thus setting a new starting point for a drawn object.
Setting an anchor point
1. Click on Edit > Set anchor point...

The following dialog is displayed:

2. Enter the “X value” of the anchor point.
3. Enter the “Y value” of the anchor point.
4. Click on [Apply].

The values of the anchor point are displayed in the status bar of CircuitPro PM.

The anchor point is set.
5.2.18 Set Zero Point

The zero point is a reference point used for measured and computed values. You can shift the zero point in the CAM view. This moves the zero point to the current anchor point. Thus, you can start new measurements/computations from this new zero point.

- Setting the zero point
  1. Click on Edit > Set zero point...
  2. The zero point is moved to the current anchor point.
5.2.19 Move anchor to center point

Using the function "Move anchor to center point", you can set the current anchor point to the central point of the object marked.

- Setting the anchor to the central point

1. Mark the center point of the object to which you would like to move the anchor point.

   ➔ The object is marked:

   ![Fig. 151: Mark object](image1)

   ![Fig. 152: Mark object](image2)

   /1/ Current anchor point

2. Click on Edit > Move anchor to center point…

   ➔ The anchor point is moved to the center point of the object:

   ![Fig. 151: Mark object](image3)

   ![Fig. 152: Mark object](image4)

   /1/ Moved anchor point

   ◆ The anchor point was moved to the center point.
5.2.20 Move layer to zero

Use “Move layer to zero” to move flash objects of a layer to the zero point of the layer:

- Moving a flash object to the layer’s zero point
  1. Select the flash object /2/ that you want to move to the layer's zero point /1/.
  - The object is highlighted in grey.
  2. Click on Edit > Move layer to zero.

Fig. 153: Move layer to zero

/1/ Cursor position=zero point
/2/ Object to be moved
The flash object is moved to the layer's zero point:

The flash object was successfully moved to the layer's zero point.
5.2.21 Match up layers

Use the function "Match up layers" to align flashed objects that are on different layers.

Use “Draw to flash” in the “Edit” menu to convert objects into flash objects. For a detailed procedure see the corresponding chapter.

The selected object is moved to the center of the object that is on the reference layer. The center points of the two objects are aligned.

Please note that the whole layer is moved together with the object to be aligned. Thus, all object of the layer are assigned new coordinates.

The following figure shows two flash objects. They are on the layers “TopLayer” and “BottomLayer” and are to be aligned:

Fig. 155: Flash objects

/1/ Flash object on TopLayer
/2/ Flash object on BottomLayer

The center point of the flash object on TopLayer (see /1/) has the coordinates X=7 and Y=7.
The center point of the flash object on BottomLayer (see /2/) has the coordinates X=15 and Y=2.
- Matching up layers

1. Click on Edit > Match up layers…

- The following dialog is displayed:

![Match up layers dialog](image)

/1/ Radio button for the layer to be aligned
/2/ Radio button for the reference layer

2. Activate the radio button /1/ for selecting the layer to be aligned.
3. In the CAM view, click on the object whose center point is to be aligned to the reference layer.

![Selecting the layer to be aligned](image)

/1/ Coordinates of the selected object and name of the layer

- The object is highlighted in grey. The coordinates of the object and the name of its layer are displayed in the dialog.

4. Activate the radio button /2/ (see figure above) for the reference layer.
5. Click on the object whose center point is to be used as the reference for the object to be aligned.
Fig. 158: Selecting the reference layer

/1/ Coordinates of the selected object and name of the layer

- The object is highlighted in grey. The coordinates of the object and the name of its layer are displayed in the dialog.

6. Click on [Apply].

- The layer to be aligned is aligned to the reference layer:

Fig. 159: Layer aligned
The center points of both objects have the coordinates X=15 and Y=2. You can find these values in the status bar of CircuitPro PM and also in the “Properties” pane of each object:

- The layers have been aligned successfully.
5.2.22 Match up objects

Use the function "Match up objects" to align any geometrical object (circle, rectangle, circle path, polygon etc.). The objects to be aligned do not have to be on the same layer.

This function places the object to be aligned on the center of the reference object.

The following figure shows a circle and a rectangle. They are on the layers “SolderMaskTop” and “BottomLayer” and are to be aligned:

1. Click on Edit > Match up objects…

   The following dialog is displayed:

   1. Activate the radio button /1/ for selecting the object to be aligned.

   2. In the CAM view, click on the object that is to be aligned:
Fig. 163: Selecting object to align

1

/1/ Coordinates and name of the selected object

- The object is highlighted in grey. The coordinates and the name of the object are displayed in the dialog.

4. Activate the radio button /2/.

5. Click on the object that is to serve as the reference object. The object to be moved will be centered on this object:
Fig. 164: Selecting reference object

1/ Coordinates and name of the selected object

- The reference object is highlighted in grey. The coordinates and the name of the object are displayed in the dialog.

6. Click on [Apply].

- The object to be aligned is moved onto the center of the reference object.

Fig. 165: Object aligned

- The operation “Match up objects” is finished successfully.
5.2.23 Delete

Use this function to delete the currently selected objects.

- Deleting selected objects in the CAM view

Please ensure that the selection mode (arrow icon /1/) is activated (see following figure).

Note

1. In the CAM view, click on the object to be deleted:

   - The object is highlighted in grey.

2. Click on Edit > Delete.
   - The selected object is deleted.
5.3 Menu Insert

The “Insert” menu contains several objects that can be created in the CAM view.

Click on the “Insert” menu item to open the submenu:

![Menu Insert](image)

The following table contains short descriptions of the functions of the individual menu items:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open path…</td>
<td>Creates an open path in the CAM view.</td>
</tr>
<tr>
<td>Closed path…</td>
<td>Creates a closed path in the CAM view.</td>
</tr>
<tr>
<td>Polygon…</td>
<td>Creates a polygon in the CAM view.</td>
</tr>
<tr>
<td>Rectangle…</td>
<td>Creates a rectangle in the CAM view.</td>
</tr>
<tr>
<td>Circle…</td>
<td>Creates a circle in the CAM view.</td>
</tr>
<tr>
<td>Circle path…</td>
<td>Creates a circle path in the CAM view.</td>
</tr>
<tr>
<td>Flash…</td>
<td>Creates a flash object in the CAM view.</td>
</tr>
</tbody>
</table>
### Table 32: “Insert” menu functions

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text…</td>
<td>Creates a text object in the CAM view.</td>
</tr>
<tr>
<td>Polygon with cutouts</td>
<td>Creates a polygon with cutouts in the CAM view.</td>
</tr>
<tr>
<td>Copper pouring…</td>
<td>Creates an insulated copper area around conductive tracks.</td>
</tr>
<tr>
<td>Rubout area</td>
<td>Creates an area where all unnecessary copper is removed.</td>
</tr>
<tr>
<td>Fiducial</td>
<td>Creates fiducials in the CAM view.</td>
</tr>
<tr>
<td>Topography</td>
<td>Creates grid points for recognizing the board topography.</td>
</tr>
<tr>
<td>Drill hole…</td>
<td>Inserts drill holes in the CAM view.</td>
</tr>
<tr>
<td>Milling curve…</td>
<td>Inserts a toolpath in the CAM view.</td>
</tr>
</tbody>
</table>

### 5.3.1 Open path

The menu item “Open Path” lets you create any open path consisting of line segments and arcs. You can combine line segments and arcs thus forming the open path:

There are different ways to create an open path:

- Entering the X and Y values of the segment in the dialog window.
- Moving the mouse pointer to the desired position in the CAM view thus drawing the segment/arc. Please ensure that the selection mode (arrow icon) is activated (see following figure):
You have to be in the CAM view of CircuitPro to be able to insert or modify geometrical forms (open paths, polygons, etc.) of the design!

Creating an open path with segments

1. Click on Insert > Open path.
2. In the drop-down list, select the layer where you want to create the open path.
3. Select either absolute or a relative start point by clicking on the corresponding radio button.

Note

- The **absolute start point** is computed using the X and Y coordinates starting from the zero point.
- If you want to create more than one open path you can make all paths start from the same starting point using the “Absolute” start point option.
- The **relative start point** is variable. Once you have created a segment, the relative start point moves automatically to the end of this segment to serve as start point for the next segment to be created.

Note

- Please note that the magenta-colored asterisk in the view always denotes the anchor point, not the zero point!

4. Enter the X and Y value of the start point in millimeters.
5. Enter the X and Y values of the segment.
6. Select the desired “curve width”:

Aperture:
- If your document contains an aperture list you can select an aperture for creating the open path.
- If no aperture list is stored in your document, a line without defined width is created.

Numeric:
- The “Numeric” option lets you define the line width in millimeters.
7. Click on [Set].

The segment is created.

Function of the “Apply” and “Set” buttons:
Once you have created a segment you can finish your entries using either [Apply] or [Set].
- If you use [Set] you can still remove the segment by clicking on [Remove last]. You can add as many segments as you like.
- If you use [Apply] for creating the segment, it cannot be removed afterwards. You also cannot add any more segments.

8. Repeat the above steps if you want to create another segment.
9. Click on [Apply] to create the open path.

Or
10. Press the right mouse button as an alternative.

- The context menu is displayed:

10. Click on “End” to finish creating the open path.

- The open path is created.

11. Click on [Close] in the dialog.

- The dialog is closed.

- The open path with segments is created.

**Procedure without entering X and Y values:**

You can also create segments in CircuitPro without entering coordinates. You can just use the mouse pointer.

1. Press the left mouse button at the desired start point of the segment in the CAM view.

2. Move the mouse pointer to the desired position in the CAM view.

3. Press the left mouse button.

- The segment is created.

- A left-click corresponds to clicking the [Set] button in the dialog.

- Pressing the right mouse button opens the context menu and you can finish creating the path by clicking on “End”. This corresponds to clicking on [Apply] in the dialog.
Creating an open path with arcs and segments
You can combine as many line segments and arcs as you like when creating an open path. This example describes how to create an arc that combined with a line segment forms an open path.

1. Perform the steps 1 to 7 of “Creating an open path with segments”.
   ➔ A line segment is created.
2. Activate the radio button “Make arc”
   Or
2. Press the right mouse button and select “Arc” in the context menu.

3. Select whether the direction of the arc should be “Clockwise” or “Counter-clockwise”.
4. Enter the radius of the arc.
5. Enter the opening angle of the arc.

Creating arcs with the mouse pointer
1. Activate the “Arc” option in the dialog or in the context menu.
2. In the CAM view, click on the desired end point of the arc.
3. Drag the mouse to the left or to the right until the arc has the desired size.

6. Click on [Apply].

If you want to abort creating the path press the ESC key.

Tip

Creating an open path with arcs and segments

Fig. 173: Selecting “Arc” in context menu
An arc is created:

7. Click on [Close] in the dialog.
   - The dialog is closed.
   - The open path with an arc and a segment is created.
5.3.2 Closed path

The menu item “Closed Path” lets you create any closed path consisting of line segments and arcs. You can combine as many line segments and arcs as you like. Creating a closed path requires at least two segments or two arcs or one segment plus one arc. These form the closed path in the end.

There are different ways to create a closed path:

- Entering the X and Y values of the segment in the dialog window.
- Moving the mouse pointer to the desired position in the CAM view thus drawing the segment/arc. Please ensure that the selection mode (arrow icon) is activated (see following figure):

Note

You have to be in the CAM view of CircuitPro PM to be able to insert or modify geometrical forms (open paths, polygons, etc.) of the design!
Creating a closed path with segments

1. Click on Insert > Closed path.

The following dialog is displayed:

2. In the drop-down list, select the layer where you want to create the closed path.
3. Select either absolute or a relative start point by clicking on the corresponding radio button.

Note

The absolute start point is computed using the X and Y coordinates starting from the zero point. If you want to create more than one closed path you can make all paths start from the same starting point using the “Absolute” start point option.

The relative start point is variable. Once you have created a segment, the relative start point moves automatically to the end of this segment to serve as start point for the next segment to be created.

Note

Please note that the magenta-colored asterisk in the view always denotes the anchor point, not the zero point.

4. Enter the X and Y value of the start point in millimeters.
5. Enter the X and Y values of the segment.
6. Select the desired “curve width”: 
Aperture:
- If your document contains an aperture list you can select an aperture for creating the open path.
- If no aperture list is stored in your document, a line without defined width is created.

Numeric:
- The “Numeric” option lets you define the line width in millimeters.

7. Click on [Set].

The segment is created.

Function of the “Apply” and “Set” buttons:
Once you have created a segment you can finish your entries using either [Apply] or [Set].

- If you use [Set] you can still remove the segment by clicking on [Remove last]. You can add as many segments as you like.
- If you use [Apply] for creating the segment, it cannot be removed afterwards. You also cannot add any more segments.

8. Repeat the steps above to create at least one more segment for creating the closed path:
9. Click on [Apply] to combine the segments created to a closed path. Or
10. Press the right mouse button as an alternative.
   ➔ The context menu is displayed:

10. Click on “Close” in the context menu.
11. Click on [Close] in the dialog.

- The dialog is closed.
- The closed path with segments is created.

---

**Procedure without entering X and Y values:**

You can also create segments in CircuitPro PM **without entering coordinates**. You can just use the mouse pointer.

1. Press the left mouse button at the start point of the segment.
2. Move the mouse pointer to the desired position in the CAM view.
3. Press the left mouse button.

- The segment is created.
  - A left-click corresponds to clicking the [Set] button in the dialog.
  - Pressing the right mouse button opens the context menu and you can finish creating the path by clicking on “End”. This corresponds to clicking on [Apply] in the dialog.

---

**Tip**

If you want to abort creating the path press the ESC key.
Creating a closed path with arcs and line segments
You can combine as many line segments and arcs as you like when creating a closed path. This example describes how to create an arc that combined with a line segment forms a closed path.

1. Perform the steps 1 to 7 of “Creating a closed path with segments”.
   ➔ A line segment is created.
2. Activate the radio button “Make arc” in the dialog.
   Or
2. Press the right mouse button and select “Arc” in the context menu.

3. Select whether the direction of the arc should be “Clockwise” or “Counterclockwise”.
4. Enter the radius of the arc.
5. Enter the opening angle of the arc.

<table>
<thead>
<tr>
<th>Creating arcs with the mouse pointer</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Activate the “Arc” option in the dialog or in the context menu.</td>
</tr>
<tr>
<td>2. In the CAM view, click on the desired end point of the arc.</td>
</tr>
<tr>
<td>3. Drag the mouse to the left or to the right until the arc has the desired size.</td>
</tr>
</tbody>
</table>

6. Click on [Set].
An arc is created:

Fig. 183: Creating an arc

7. Click on “Apply” in the dialog or “Close” in the context menu.

The path is closed:

Fig. 184: Closing an open path
8. Click on [Close] in the dialog.
   ➔ The dialog is closed.
   ➔ The closed path with an arc and a segment is created.

### 5.3.3 Polygon

The menu item “Polygon” lets you create any polygon area using line segments and arcs. Creating a polygon requires at least two segments or two arcs or one segment plus one arc. These are connected in a final step forming the polygon surface area.

There are different ways to create a polygon:
- Entering the X and Y values of the segments in the dialog.
- Moving the mouse pointer to the desired position in the CAM view thus drawing a segment/arc. Please ensure that the selection mode (arrow icon) is activated (see following figure):

Note: You have to be in the CAM view of CircuitPro PM to be able to insert or modify geometrical forms (open paths, polygons, etc.) of the design!
Creating a polygon with line segments
1. Click on Insert > Polygon.
   ➨ The following dialog is displayed:

   ![Create a Polygon dialog](image)

   - **Fig. 187: Polygon**

2. In the drop-down list, select the layer where you want to create the polygon.
3. Select either absolute or a relative start point by clicking on the corresponding radio button.

   **Note**
   - **The absolute start point** is computed using the X and Y coordinates starting from the zero point.
   - If you want to create more than one polygon you can make all polygons start from the same starting point using the “Absolute” start point option.
   - The **relative start point** is variable. Once you have created a segment, the relative start point moves automatically to the end of this segment to serve as start point for the next segment to be created.

   **Note**
   - Please note that the magenta-colored asterisk in the view always denotes the anchor point, not the zero point!

4. Enter the X and Y value of the start point in millimeters.
5. Enter the X and Y values of the segment.
6. Click on [Set].
   ➔ The segment is created.

Note

**Function of the “Apply” and “Set” buttons:**

Once you have created a segment you can finish your entries using either [Apply] or [Set].

If you use [Set] you can still remove the segment by clicking on [Remove last]. You can add as many segments as you like.

If you use [Apply] for creating the segment, it can **not** be removed afterwards. You also cannot add any more segments.

7. Repeat the steps above to create at least one more segment for creating the polygon area:
8. Click on [Apply] to combine the segments created to a polygon area.  
Or  
9. Press the right mouse button as an alternative.  

Fig. 189: Creating a second segment

The context menu is displayed:

Fig. 190: Close polygon

9. Click on “Close” in the context menu.
The polygon is created:

Fig. 191: Polygon area

Procedure without entering X and Y values:
You can also create segments in CircuitPro PM without entering coordinates. You can just use the mouse pointer.
1. Press the left mouse button at the start point of the segment.
2. Move the mouse pointer to the desired position in the CAM view.
3. Press the left mouse button.
   ➔ The segment is created.
   • A left-click corresponds to clicking the [Set] button in the dialog.
   • Pressing the right mouse button opens the context menu and you can finish creating the polygon by clicking on “Close”. This corresponds to clicking on [Apply] in the dialog.

If you want to abort creating the polygon press the ESC key.
Creating a polygon with arcs and line segments

You can combine as many line segments and arcs as you like when creating a polygon. This example shows how to create a polygon area with two line segments and two arcs.

1. Perform the steps 1 to 7 of “Creating a polygon with line segments”.
2. A line segment is created.

2. Activate the radio button “Make Arc” in the dialog.
Or
2. Press the right mouse button and select “Arc” in the context menu.
3. Select whether the direction of the arc should be “Clockwise” or “Counterclockwise”.
4. Enter the radius of the arc.
5. Enter the opening angle of the arc.
Creating arcs with the mouse pointer

1. Activate the “Arc” option in the dialog or in the context menu.
2. In the CAM view, click on the desired end point of the arc.
3. Drag the mouse to the left or to the right until the arc has the desired size.

6. Click on [Set].

An arc is attached to the line segment:

7. Create another line segment:
8. Insert another arc:

9. To finish the polygon, click on “Apply” in the dialog or “Close” in the context menu.
The polygon is created:

10. Click on [Close] in the dialog.
   - The dialog is closed.
   - The polygon with two line segments and two arcs is created.
5.3.4 Rectangle

The “Rectangle” function lets you create rectangles of any size.

Fig. 199: Rectangle

There are different ways to create a rectangle:

- Entering the X and Y values of the rectangle in the dialog.
- Moving the mouse pointer to the desired position in the CAM view thus drawing the rectangle. Please ensure that the selection mode (arrow icon) is activated (see following figure):

Fig. 200: Selection mode (arrow icon) activated

Note

You have to be in the CAM view of CircuitPro PM to be able to insert or modify geometrical forms (open paths, polygons, etc.) of the design!
Creating a rectangle

1. Click on Insert > Rectangle.

The following dialog is displayed:

2. In the drop-down list, select the layer where you want to create the rectangle.
3. Select either an absolute or a relative start point and end point by clicking on the corresponding radio button.

The **absolute start point** is computed using the X and Y coordinates starting from the zero point.
If you want to create more than one rectangle you can make all rectangles start from the same starting point using the “Absolute” start point option.

The **relative start point** is variable. Once you have created a rectangle, the relative start point moves automatically to the end of this rectangle to serve as start point for the next rectangle to be created.

Please note that the magenta-colored asterisk in the view always denotes the anchor point, not the zero point!

4. Enter the X and Y value of the start point in millimeters.
5. Enter the X and Y value of the end point in millimeters.
6. Click on [Create].

You can also create the rectangle using the mouse by clicking on the desired start point in the view and drawing the rectangle. Please ensure that the selection mode (arrow icon) is activated.

7. Click on [Close].
   ◆ The rectangle is created.
5.3.5 Circle

The “Circle” function lets you create circles of any size.

There are different ways to create a circle:

- Entering the circle center and the diameter in the dialog.
- Moving the mouse pointer to the desired position in the CAM view thus drawing the circle. Please ensure that the selection mode (arrow icon) is activated (see following figure):

Note

You have to be in the CAM view of CircuitPro PM to be able to insert or modify geometrical forms (open paths, polygons, etc.) of the design!
Creating a circle

1. Click on Insert > Circle.

The following dialog is displayed:

2. In the drop-down list, select the layer where you want to create the circle.
3. You can choose between the options “Absolute” and “Relative”:
   - **Absolute**: If “Absolute” is activated, the center point of the circle is computed using the X and Y coordinates starting from the zero point.
     - If, for example, the X and Y values are left at 0 mm and only a radius is entered, the center point of the circle is at the zero point.
     - If you enter an X and a Y value, the center point of the circle is computed from the zero point with the coordinates entered.
   - **Relative to anchor point**: If the option “Relative to anchor point” is activated, the center point of the circle is computed using the X and Y coordinates starting from the anchor point.

The figure above shows how a circle with a diameter of 10 mm is created. The center point of the circle (see /2/) is at the coordinates X=40 and Y=40 from the zero point (see /1/).
→ If, for example, the X and Y values are left at 0 mm and only a radius is entered, the center point of the circle is set to the current anchor point.
→ If you enter an X and a Y value, the center point of the circle is computed from the current anchor point with the coordinates entered.

4. Enter the X and Y value of the circle's center point in millimeters.
5. Enter the circle's diameter in millimeters.

Tip

You can also create the circle using the mouse by clicking on the desired center point in the view and drawing the circle.

6. Click on [Apply].
7. Click on [Close].

◆ The circle is created.
5.3.6 Circle path

The “Circle path” function lets you create circle paths of any size.

There are different ways to create a circle path:

• Entering the circle center and the diameter in the dialog.
• Moving the mouse pointer to the desired position in the CAM view thus drawing the circle path. Please ensure that the selection mode (arrow icon) is activated (see following figure):

Note

You have to be in the CAM view of CircuitPro PM to be able to insert or modify geometrical forms (open paths, polygons, etc.) of the design!
Creating a circle path

1. Click on Insert > Circle path.

The following dialog is displayed:

2. In the drop-down list, select the layer where you want to create the circle path.

3. You can choose between the options “Absolute” and “Relative”:
   - **Absolute**: If “Absolute” is activated, the center point of the circle path is computed using the X and Y coordinates starting from the zero point.
     - If, for example, the X and Y values are left at 0 mm and only a radius is entered, the center point of the circle path is at the zero point.
     - If you enter an X and a Y value, the center point of the circle path is computed from the zero point with the coordinates entered.

   - **Relative**: If “Relative” is activated, the center point of the circle path is computed using the X and Y coordinates starting from the anchor point.

The figure above shows how a circle path with a diameter of 10 mm is created. The center point of the circle path (see /2/) is at the coordinates X=40 and Y=40 from the zero point (see /1/).
→ If, for example, the X and Y values are left at 0 mm and only a radius is entered, the center point of the circle path is set to the current anchor point.

→ If you enter an X and a Y value, the center point of the circle path is computed from the current anchor point with the coordinates entered.

Fig. 211: “Relative” option

4. Enter the X and Y value of the circle path's center point in millimeters.
5. Enter the circle path's diameter in millimeters.

Tip

You can also create the circle path using the mouse by clicking on the desired center point in the view and drawing the circle path.

6. Click on [Apply].
7. Click on [Close].

◆ The circle path is created.
5.3.7 Flash

The “Flash” function lets you create flash objects on any layer.

Note

An aperture list library must be available for creating a flash object. For more information on the aperture list library see the corresponding chapter.

Creating a flash object

1. Click on Insert > Flash.
2. In the drop-down list, select the layer where you want to create the flash object.
3. Select an aperture.
4. Enter the X and Y value of the flash center point in millimeters.
5. Click on [Apply].
The newly created flash object is displayed in the CAM view:

![Image of CAM view with flash object](image)

The flashed object is at 10 mm in X direction and 5 mm in Y direction from the zero point.

**Note**

The above figure shows the flash object at a much larger scale for better illustration. The anchor point (magenta-coloured asterisk) was set to the zero point in order to illustrate the coordinates of the flash object.

* The flash object is created.
5.3.8 Text

The “Text” function lets you create any text object on the layers.

- Defining a text
  1. Click on Insert > Text. ➔
  2. Enter your text into the input field /2/. You can enter a maximum of 1000 characters.
  3. Format your text if necessary using the available text attributes under /1/:
     • Bold
     • Italic
     • Underline
     • Strike through

   Note
   Please note that you can only format the whole text and **not** individual characters or words (in case of multiple words).

   Note
   The entered text appears in the drop-down list "Text object". If you would like to enter another new text, please select <create new> here.

  4. In the drop-down list "Destination" select the layer onto which the text is to be placed.
  5. Select the text font.
6. Select the mode:
   - "Filled Area": The text's characters are complete.
   - "Outline": only the outline of the text's characters is created.

7. Select the character spacing.
8. Select the line spacing.

Note
The input field only shows the entered text and the attributes (bold, italic, etc.) All other settings only become visible in the CAM view when you click [Apply].

9. Enter the X and Y coordinates of the text field.
10. Determine the alignment of the text field.
11. Enter a value for rotating the text if necessary.
12. Click on [Apply].
   ➔ The view changes as follows:

13. If you want to mirror the text object along the X or Y axis, select the corresponding value in the drop-down list next to /Rotation/ and click on [Apply].
The view changes as follows:

The text is defined on the corresponding layer.
5.3.9 Polygon with cutouts

Use the function "Polygon with cutouts" to create cutouts of any form in a drawn polygon.

To create a polygon as shown in the figure above, you need a simple polygon plus the geometric objects (rectangle, paths, circles etc.) that you want to cut from the polygon.

Tip

For the steps how to create a polygon see the corresponding chapter.
Creating a polygon with cutouts

The following steps show how to create a polygon with two circular cutouts. A polygon and two circles are needed for this:

1. Click on Insert > Polygon with cutouts.

   ➔ The following dialog is displayed:

   ![Create polygon with cutouts dialog](image)

   ➔ The radio button {Outer} is active.

2. Select the polygon that shall remain.
The name of the polygon is displayed in `Outer`:

3. Click on `{Inner}`.
4. Select the two circles.

The names of the circles are displayed in `{Inner}`:

5. Click on `[Apply]`. 
The view changes as follows:

![Image of polygon with two circular cutouts]

6. Click on [Close] in the dialog.
   - The dialog is closed.
   - The polygon with cutouts has been created.

**Tip**
If you do not want the objects that are used for the cutout process (in this case, the circles) to be deleted, please select the option "Keep cut objects."
5.3.10 Copper pouring

Use the “Copper pouring” function to create isolated copper areas around conductive tracks.

For creating a copper pouring around a conductive track as depicted in the figure above, you need
- a geometric shape (rectangle, circle, polygon) that represents the copper area and
- a path (closed or open) that represents the conductive track.

Tip

For information on creating geometric shapes and paths see the corresponding chapters..
Creating a copper pouring

In the following steps, a rectangular copper area is created around a conductive track. A rectangle and an open path are needed for this:

1. Click on Insert > Copper pouring.

   ➔ The following dialog is displayed:

   ➔ The radio button {Outer} is active.

2. Select the copper area (the rectangle in this case).
3. Click on \(\text{Inner}\).
4. Select the open path:

\[ \text{The name of the path is displayed in } \text{\textbackslash Inner}\]:
5. Enter the offset value for the copper area. This value represents the width of the isolation.

![Create copper pouring](image1)

6. Click on [Apply].
   ➔ The area next to the conductive track is removed according to the offset value:

![Isolated open path](image2)

7. Click on [Close].
   ➔ The dialog is closed.
   ➔ The copper pouring is created.
5.3.11 Rubout area

Use the “Rubout” function to define areas of any shape for removal of unnecessary copper on the rubout layers, i.e., creating rubout areas. You can also create new rubout layers.

In order to create an area as depicted in the figure above, you need
• a defined BoardOutline (e.g. by creating a rectangle on the BoardOutline layer)
• at least one isolation object on the corresponding Top-/BottomLayer.

In CircuitPro PM, all rubout areas on the rubout layers are rectangular.
Creating a rubout area

1. Click on Insert > Rubout area > RuboutBottom.

The number of rubout layers depends on the type of circuit board (single-sided/multi-layer) that you want to produce. In case of a single-sided circuit board, CircuitPro PM creates only the RuboutBottom layer automatically. In case of a double-sided circuit board, two rubout layers are created: RuboutBottom und RuboutTop.

Note

You can create the rubout area on any rubout layer or all rubout layers depending on your project. You can also create a new rubout layer for the process. To do this, click on Click on Insert > Rubout > Create new layer.

The following dialog showing the selected layer is displayed:

![Create rectangle dialog](image)

You can change the layer for creating the rubout area at any time.

→ Just click on the drop-down list and select the desired layer.

2. Create the rectangle for the rubout area.

For the steps how to create a rectangle see the corresponding chapter.
3. Click on [Apply].
   ➔ The rectangle for the rubout area is created.
4. Click on [Close] in the dialog.
   ➔ The dialog is closed.

**Note**
For creating the toolpath, you have to go to the “Technology dialog”.
For more information on the menu item “Technology dialog” see corresponding chapter.

5. Click on Toolpath > Technology dialog.
The following dialog is displayed:

6. Click on the arrow buttons in the “Insulate” section until the isolation method “Partial rubout” or “Complete rubout” is displayed:

7. Select one of the two methods depending on your requirements.
For more information on the settings in the “Technology dialog” see the corresponding chapter.

If you want to create only the toolpath for the rubout area, deactivate the other processing steps (contour routing, convert to toolpath) by removing the check marks next to the respective functions.

8. Click on [Start].
The rubout area is created. The computation results are displayed.

Creating a new rubout layer
1. Click on Insert > Rubout area > Create new layer.

The following dialog is displayed:

The name of the layer is assigned automatically by CircuitPro PM.

Note
The first new layer is named “Rubout”. For the following layers, the name has a counter that is incremented thus creating “Rubout_1”, “Rubout_2” etc.

2. Perform the steps two to eight of “Creating a rubout area”.

A rubout area is created on the new rubout layer.
5.3.12 Fiducial

Fiducials are optical marks on the surface of the circuit board that are used for aligning the circuit board. The fiducials are drilled into the board and are recognised by the cameras of the ProtoMat systems.

The sub-menu “Fiducial” lets you create fiducials and fiducial layers. The following figure shows four fiducials placed near the corners of the circuit board.

Note

Creating fiducials corresponds to creating circles in CircuitPro. For more information on the creating circles see the corresponding chapter.
Creating fiducials

1. Click on Insert > Fiducial > Fiducial.

The following dialog is displayed:

![Create fiducial dialog](image)

The “Fiducial” layer is automatically created. If you have created other fiducial layers, these are displayed in the drop-down list.

2. Click on the position in the CAM view where you want to place the fiducial.

Or

2. Enter the coordinates for the center point of the circle in millimeters and click on [Apply].

Fiducials have a predefined diameter of 1.5 mm that cannot be changed.

The fiducials are created.

3. Click on [Close] in the dialog.

The fiducials are created.

Creating a new fiducial layer

1. Click on Insert > Fiducial > Create new layer.

The following dialog is displayed:

![Create fiducial dialog](image)

The name of the layer is assigned automatically by CircuitPro. The first new layer is named “Fiducial_1”. For the following layers, the name counter is incremented thus creating “Fiducial_2”, “Fiducial_3” etc.

The new fiducial layer is created.
5.3.13 Topography

The menu item "Topography" lets you define points on a separate topography layer that is used for determining the topography. Determining the topography is required for setting a defined distance between the dispenser needle and the surface of the material during the dispense process.

![Image of Circuit board with topography points](image)

Note: Defining topography points corresponds to creating circles in CircuitPro PM. For more information on creating circles see the corresponding chapter.
Defining topography points.

1. Click on Insert > Topography > Topography.

The following dialog is displayed:

![Create topography dialog](image)

- CircuitPro PM automatically creates a topography layer where you can define the points.

2. Click on the position in the CAM view where you want to define the topography point(s).

Or

2. Enter the coordinates for the center point of the circle in millimeters and click on [Apply].

- Topography points have a predefined diameter of 1.5 mm that cannot be changed.

- The topography point(s) is (are) defined.

3. Click on [Close] in the dialog.

- The topography point(s) is (are) defined.
Creating a new topography layer

1. Click on Insert > Topography > Create new layer.

The following dialog is displayed:

Fig. 245: Create new layer

The name of the layer is assigned automatically by CircuitPro PM.

Note
The first new layer is named “Topography”. For the following layers, the name has a counter that is incremented thus creating “Topography_1”, “Topography_2” etc.

2. Click on [Apply] in the dialog.

The topography layer is created.
5.3.14 Drill hole

Use the function "Drill hole" to insert holes of different sizes into your layout.

Fig. 246: Example for drilling holes

Note

The drill hole sizes correspond to the diameters of the available drilling tools.

Tip

- Place the holes that will be used for through-hole contact on the layer “Drill Plated”.
- Place all other holes on the layer “Drill Unplated”.
Creating a drill hole

1. Click on Insert > Drill hole…
   ➔ The following dialog is displayed:

   ![Create drill hole dialog](image)

2. First select the phase in which the whole is to be drilled during processing.
3. In the drop-down menu 'Layer', select the layer in which the hole shall be drilled:

   ![Select layer dialog](image)
4. In the drop-down menu ‘Tool’, select the drilling tool which is to be used to drill the hole:

![Select tool](image)

5. If you do not want to add marking drills, uncheck the option “Add marking drill” and continue with step 7.

6. In the dropdown list select a tool and a phase, the marking drills should be generated within.

![Add marking drill](image)

7. In the CAM view, click on where you would like to drill the hole.

Or

7. Enter the coordinates for the center point of the circle in mm and click on [Apply].

Note

The hole diameters correspond to the diameters of the drilling tools.

➨ The holes are positioned.

8. Click on [Close] in the dialog.

➨ The dialog is closed.

◆ The drill hole has been created.
5.3.15 Milling curve

Using the function “Milling curve” you can convert open/closed paths directly into milling curves or manually insert milling curves directly into the layout.

Note

The technology dialog, used to create toolpaths, does not convert paths directly into milling curves. Either insulation or contours are generated around the paths.

Creating a milling curve

1. Click on Insert > Milling curve…

The following dialog is displayed:

2. First select a phase in the field \Phase:\, in which the milling curve is to be created during processing.
3. Select the layer in the field \Layer\, on which the milling curve is to be created.
4. Select a tool in the field \Tool\, with which the milling curve is to be created.
5. Select either an absolute or a relative starting point by clicking on the corresponding setting.

The absolute start point is computed using the X and Y coordinates starting from the zero point.

If you want to create more than one open path you can make all paths start from the same starting point using the “Absolute” start point option.

The relative start point is variable. Once you have created a segment, the relative start point moves automatically to the end of this segment to serve as start point for the next segment to be created.

For more information on creating paths, please refer to the relevant chapters “Open path” and “Closed path”.

6. Enter the X and Y value of the starting point in mm.
7. Activate the radio button “Arc” if you want to create an arc.
8. Enter the radius and the angle of the arc.
   Or
8. Enter the X and Y coordinates of the segment.
9. Click on [Apply].
   ◆ The milling curve has been created.

---

Procedure without entering X and Y values:
You can also create segments in CircuitPro PM without entering coordinates. You can just use the mouse pointer.
1. Press the left mouse button at the desired start point of the segment in the CAM view.
2. Move the mouse pointer to the desired position in the CAM view.
3. Press the left mouse button.
   → The segment is created.
   • A left-click corresponds to clicking the [Set] button in the dialog.
   • Pressing the right mouse button opens the context menu and you can finish creating the path by clicking on “End”. This corresponds to clicking on [Apply] in the dialog.
5.4 Menu Toolpath

The “Toolpath” menu contains the functions for setting parameters and creating the paths for milling, routing, and dispensing solder paste.

Click on the “Toolpath” menu item to open the submenu:

The following table contains short descriptions of the functions of the individual menu items:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dispense…</td>
<td>Opens a dialog to create toolpaths for dispensing solder paste.</td>
</tr>
<tr>
<td>2.5D milling…</td>
<td>Creates toolpaths for 2.5D operations.</td>
</tr>
<tr>
<td>Technology Dialog…</td>
<td>Opens a dialog to create toolpaths for drilling and milling.</td>
</tr>
<tr>
<td>Edit breakout tabs…</td>
<td>Opens a dialog to modify the breakout tabs in the contour-routing toolpath.</td>
</tr>
</tbody>
</table>
5.4.1 Dispense

The “Dispense” function lets you create solder paste paths on a selected layer. Afterwards, you can place circuit components on the solder paste paths. Subsequently, the circuit boards can be soldered in a reflow oven (e.g. using the LPKF ProtoFlow).

Fig. 253: Dispense paths created on pads

Note

The dispenser has to be mounted on the machine in order to create solder paste dots on the circuit board!

This dialog “Dispense” allows the following operations:

- Creating new solder paste paths on the pads
- Assigning new parameter sets to the dispense tools in the tool library [Add…]
- Edit the parameters of the dispense tools [Edit…]
- Edit details for creating solder paste paths [Show details]
- Delete dispenser tools [Delete].
Creating a new solder paste path on the pads

1. Click on Toolpath > Dispense.

The following dialog is displayed:

![Dispense dialog](image)

/1/ List of the available dispense tools

The table contains following columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled</td>
<td>Activates/deactivates the corresponding dispense tool with a check mark.</td>
</tr>
<tr>
<td>Minimum size [µm]</td>
<td>Shows the minimum pad size of the pad to be filled in µm.</td>
</tr>
<tr>
<td>Dot distance [µm]</td>
<td>Shows the dot distance between the individual solder paste dots in µm.</td>
</tr>
<tr>
<td>Grid angle[°]</td>
<td>Shows the rotation of the solder dot grid on the pad.</td>
</tr>
<tr>
<td>Margin [µm]</td>
<td>Shows the minimum distance of the solder paste dots to the boundary of the pad in µm.</td>
</tr>
<tr>
<td>Tool</td>
<td>Shows the corresponding dispense tool.</td>
</tr>
</tbody>
</table>

2. In the “Source” drop-down list, select the layer where you want to create the solder paste path.

Create the solder paste dots on the designated solder paste layers (SolderPasteTop or SolderPasteBottom).

Tip

3. In the list, select the dispense tools that you want to use.
Take care that you have activated a suitable dispense tool for each pad size of your design.

**Note**  Several tools can be used for creating the solder paste paths.

4. Click on [Run].
5. Click on [Close].

* The solder paste path is created on the corresponding pads.

### Adding new parameter sets for existing tools

1. Click on [Add…] in the dialog.

#### The following dialog is displayed:

![Fig. 255: Adding solder paste path parameters](image)

2. Enter the minimum pad size of the pad in µm.
3. Select a dispense tool.

**Note**  If the desired dispense tool is not in the list, you can create it in the tool library.

* For more information on adding tools to the tool library see the corresponding chapter.

4. Enter the dot distance between the individual solder paste dots in µm.
5. Enter a grid angle if necessary.
6. Enter the margin width.
7. Click on [OK].

* The new pad size parameters are displayed in the list.
* The new pad size parameters are added.
Editing existing pad size parameters

1. Select the row where you want to edit the parameters and click on [Edit…].

Fig. 257: Editing pad size parameters

The dialog “Pad size parameters” with the details on pad size is displayed:

Fig. 258: Pad size parameters

2. Modify the parameters as desired.
3. Click on [OK].

The dialog “Pad size parameters” is closed.

The existing pad size parameters are modified.
Deleting existing pad size parameters

1. Select the row that you want to delete and click on [Delete].

The selected row of existing pad size parameters is deleted.

Showing details

1. Click on [Show details] to display the global settings for creating solder paste dots:
The view changes as follows:

Table 35: Global settings

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tolerance [mm]</td>
<td>Defines the tolerance used when checking the distance of the solder dot to the pad boundary.</td>
</tr>
<tr>
<td>Filling strategy</td>
<td>If a pad is filled with more than one solder dot, the solder dots can be placed based on three filling strategies:</td>
</tr>
<tr>
<td></td>
<td>- Cartesian grid</td>
</tr>
<tr>
<td></td>
<td>- Hexagonal grid</td>
</tr>
<tr>
<td></td>
<td>- Concentric</td>
</tr>
<tr>
<td>Process direction</td>
<td>Defines whether the pads are filled with solder paste “From center outwards” or “From boundary inwards”. Filling “From center outwards” is only available if you have selected the “Concentric” filling strategy.</td>
</tr>
<tr>
<td>Apply smoothing</td>
<td>This option is only active if you have selected the “Concentric” filling strategy. The solder paste dots are dispensed uniformly.</td>
</tr>
<tr>
<td>Replace existing toolpath</td>
<td>Replaces the existing solder paste path by the newly created solder paste path in the CAM view. If the option is deactivated, the new solder paste path is created over the existing one.</td>
</tr>
</tbody>
</table>

2. Modify the parameters if necessary.
3. Click on [Run].
The changes are stored.

Changes made in these fields are valid for all dispense tools.

Note

4. Click on [Close].

The dialog is closed.

The details were shown.
5.4.2 Create 2.5D milling

To create a 3D part you need to create 2.5D toolpaths with a defined Z value. After creating your design in the CAM view Circuit Pro PM generates the necessary 2.5D toolpaths to start the processing of your 3D part.

- Creating 2.5D milling
  1. Click on Toolpath > 2.5D milling…
  ➔ The following dialog is displayed:

![Create 2.5D milling dialog]

- Source: 3D Object
- Tool: End Mill (RF) 0.15 mm, End Mill (RF) 0.25 mm, End Mill (RF) 0.4 mm, End Mill 0.8 mm, End Mill 1 mm, End Mill 2 mm, End Mill 3 mm, End Mill long 1 mm
- Options:
  - Generate on both sides
  - Top side
  - Bottom side
  - Generate start drills
  - Replace existing toolpath
  - Generate fiducials
    - Source: <Fiducials> layers
    - Tool: <Automatically assigned>
    - Phase: <Automatically assigned>
    - Tolerance: 0.002 mm
- Buttons: Start, Cancel
The sections contain following information/options:

### Table 36: Create 2.5D milling

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Here the source object is displayed, the toolpaths are created for.</td>
</tr>
<tr>
<td>Tool</td>
<td>This list shows all available tools to generate 2.5D toolpaths.</td>
</tr>
</tbody>
</table>

#### Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generate on both sides</td>
<td>In case of a double-sided object you can specify if the toolpaths should only be created on the top or bottom side. By default the toolpaths are generated on both sides of an object.</td>
</tr>
<tr>
<td>Generate start drills</td>
<td>Here you can specify if start drills should be created. The start drills are used by the milling tools to start milling a line.</td>
</tr>
<tr>
<td>Replace existing toolpath</td>
<td>Here you can specify if already existing toolpaths should be replaced.</td>
</tr>
<tr>
<td>Generate fiducials</td>
<td>Here you can specify if fiducials should be generated for the toolpaths. Source: Indicates the layer where the fiducials should be generated. Tool: Indicates the tool that should generate the fiducials. Phase: Indicates the phase where the fiducial should be generated. Tolerance: Indicates the tolerance that is used to calculate or check the position and the distances of the toolpaths.</td>
</tr>
</tbody>
</table>

2. Activate the tool’s checkboxes that you want to use for creating the 2.5D toolpaths.

3. Enable/disable the options you need for creating the toolpaths.

Note

Please note that at least one drilling tool must be enabled if you want to create start drills.

4. Click on [OK].
   - The 2.5D toolpaths are created.
5.4.3 Technology Dialog

The technology dialog lets you create toolpaths that you can use in processing for the following steps:

- Insulate
- Contour routing
- Drilling holes
- Drilling fiducials
- Milling pockets

Creating toolpaths

1. Click on Toolpath > Technology Dialog.

The following dialog is displayed:

![Technology Dialog](image)

1. Material and processing settings
2. Insulation options
3. Contour routing options
4. Options for creating holes, fiducials and pockets

2. Select your material type in the corresponding drop-down list.
3. If your project is a radio frequency application, activate the corresponding check box <RF application>.

**Note**

If you process the project with the enabled option “RF application” the penetration depth of the cutter is optimized and the Universal Cutter is replaced by the End Mill (RF).

4. Activate the functions with check marks:
Insulate

The “Insulate” section offers four different insulation methods:

- **Basic**: Insulation with a single insulation channel and the shortest processing time.
- **Basic, pads double**: Insulation with a single insulation channel and a double insulation channel for pads. Processing takes a little more time than the “Basic” method.
- **Partial rubout**: Insulation with a single insulation channel and removal of copper in defined areas.
- **Complete rubout**: Entire removal of unnecessary copper. This is the most precise insulation method.

### Table 37: Insulate

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Defines the layers where the insulation will be created.</td>
</tr>
<tr>
<td>Primary</td>
<td>Shows the tool that is used as primary tool for the insulation process.</td>
</tr>
<tr>
<td>Available tools</td>
<td>This list contains the tools that are used as default for creating the individual toolpaths.</td>
</tr>
<tr>
<td>Insulation width</td>
<td>Defines the width of the insulation channel in mm.</td>
</tr>
<tr>
<td>Pads insulation</td>
<td>Defines the width of the pads insulation if an insulation method with an extra pads insulation is selected.</td>
</tr>
<tr>
<td>channels</td>
<td>Defines the number of additional insulations.</td>
</tr>
<tr>
<td>Rubout</td>
<td>Defines whether and on which layer a rubout is performed. In addition, you can select how the rubout area is going to be processed.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>Defines the tolerance used for computing and checking the positions and distances of the toolpaths.</td>
</tr>
<tr>
<td>Generate optimized rubout</td>
<td>Optimizes the toolpaths for rubout areas with regard to the number of tools used.</td>
</tr>
<tr>
<td>Remove Spikes</td>
<td>Automatically remove residual copper that</td>
</tr>
</tbody>
</table>
Table 37: Insulate

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>remains as spikes (e.g. between two connecting conductive tracks). This prevents that the copper in these areas is pulled off unintentionally by the cleaning pad during the final cleaning process.</td>
</tr>
<tr>
<td>Force insulation</td>
<td>Creates insulation paths for each individual insulation object. This guarantees insulation of every object even if the distance between two objects is smaller than the tool diameter.</td>
</tr>
<tr>
<td>Perform inner insulation</td>
<td>Defines for closed paths whether the inner contour is to be insulated in addition to the outer one.</td>
</tr>
<tr>
<td>Replace existing toolpath</td>
<td>If a toolpath already exists, it is replaced by the newly created one.</td>
</tr>
</tbody>
</table>
Contour Routing

The “Contour Routing” section offers six different routing methods:

- **Basic**: Contour routing without gaps
- **Horizontal gaps**: Contour routing with gaps on front and rear side.
- **Vertical gaps**: Contour routing with gaps on left and right side.
- **Edge gaps**: Contour routing with one gap on each edge.
- **Corner gaps**: Contour routing with one gap in each corner.
- **Equidistant gaps**: Contour routing with equally spaced gaps.

### Table 38: Contour Routing

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inside</td>
<td>The toolpath is inside the drawn BoardOutline.</td>
</tr>
<tr>
<td>Outside</td>
<td>The toolpath is outside the drawn BoardOutline.</td>
</tr>
<tr>
<td>Source</td>
<td>Defines the layer(s) where the contour will be routed.</td>
</tr>
<tr>
<td>Tool</td>
<td>Defines the tool used for contour routing.</td>
</tr>
<tr>
<td>Tabs position</td>
<td>Defines the positions of the tabs, i.e. gaps in the routing.</td>
</tr>
<tr>
<td>Gap width</td>
<td>Defines the width of the tabs in mm.</td>
</tr>
<tr>
<td>Distance</td>
<td>Defines the distance of the tabs in mm. This value is only used in the “Equidistant gaps” routing method.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>Defines the tolerance used for computing and checking the positions and distances of the toolpaths.</td>
</tr>
<tr>
<td>Replace existing toolpath</td>
<td>If a toolpath already exists, it is replaced by the newly created one.</td>
</tr>
<tr>
<td>Generate start drills</td>
<td>This option ensures that contour routing always starts with generating a start drill.</td>
</tr>
</tbody>
</table>
Drills

The “Drills” options are for creating the toolpaths for holes in the circuit board.

![Drills](image)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Defines the layer used for creating the holes.</td>
</tr>
<tr>
<td>Tool</td>
<td>Defines the tool used for drilling.</td>
</tr>
<tr>
<td></td>
<td>→ Usually, the tools are assigned to the holes automatically according to their diameters.</td>
</tr>
<tr>
<td>Assign to Phase</td>
<td>Defines the phase where the hole is created.</td>
</tr>
<tr>
<td></td>
<td>→ Usually, the holes are created in the phases “DrillingPlated” and “DrillingUnplated”.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>Defines the tolerance used for computing and checking the positions and distances of the toolpaths.</td>
</tr>
<tr>
<td>Replace existing toolpath</td>
<td>If a toolpath already exists, it is replaced by the newly created one.</td>
</tr>
</tbody>
</table>

Create marking drills

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marking tool</td>
<td>Defines the tool used for marking.</td>
</tr>
<tr>
<td>Assign to Phase</td>
<td>Defines the phase where the markings are created.</td>
</tr>
<tr>
<td></td>
<td>→ Usually, the markings are created in the phase “MarkingDrills”.</td>
</tr>
</tbody>
</table>
Fiducials

The “Fiducials” options are for creating the toolpaths for fiducial holes in the circuit board. The fiducials are used for correct alignment of the circuit board after it has been turned over for example.

Table 40: Fiducials

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Defines the layer used for creating the fiducials.</td>
</tr>
<tr>
<td>Tool</td>
<td>Defines the tool used for creating the fiducials.</td>
</tr>
<tr>
<td></td>
<td>→ The tool “Spiral Drill 1.5mm” is automatically used for creating the fiducials.</td>
</tr>
<tr>
<td>Assign to Phase</td>
<td>Defines the phase where the fiducials are created.</td>
</tr>
<tr>
<td></td>
<td>→ Usually, the fiducials are created in the phase “Drill Fiducial”.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>Defines the tolerance used for computing and checking the positions and distances of the toolpaths.</td>
</tr>
<tr>
<td>Replace existing toolpath</td>
<td>If a toolpath already exists, it is replaced by the newly created one.</td>
</tr>
</tbody>
</table>
The “Pockets” options are for creating the toolpaths for pockets in the circuit board.

Table 41: Pockets

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tool</td>
<td>Defines the tool used for milling the pockets.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>Defines the tolerance used for computing and checking the positions and distances of the toolpaths.</td>
</tr>
<tr>
<td>Replace existing toolpath</td>
<td>If a toolpath already exists, it is replaced by the newly created one.</td>
</tr>
</tbody>
</table>

5. Click on [Start].

The following message is displayed:

The work steps and results of creating the toolpaths are listed in this dialog. If necessary, you can save or print its contents.
6. Click on [Close] in the dialog.
   ♦ The dialog with the computation results of the technology dialog is closed.
   ♦ The toolpaths are created.

5.4.4 Edit breakout tabs

This function lets you modify the breakout tab positions in the contour-routing toolpath.

The circuit board milled through the whole material thickness during contour routing. When creating the toolpath, you can define tabs that keep the circuit board initially fixed to the material.

The dialog “Edit breakout tabs position” lets you
   • edit,
   • add or
   • remove the positions of the tabs.

---

**Note**
The contours have to be already created in order to use this function.

**Note**
Ensure that the “Replace existing toolpath” check box is checked so that your changes are stored.
- **Editing a breakout tab position**
  1. Click on Toolpath > Edit breakout tabs…

    ➔ The display of the contours in the CAM view changes and the following dialog is displayed:

    ![Edit breakout tabs position dialog](image)

    The circles on the contour lines in the CAM view represent the current positions of the breakout tabs.

    2. Enter the gap width in mm.
    3. Move the mouse pointer to the desired breakout tab position.

    ➔ The mouse pointer changes into a hand symbol.

    4. While pressing the left mouse button, drag the circle to the position where you want to place the breakout tab.
The X and Y values of the breakout tab position change accordingly:

5. Release the left mouse button at the desired position.

The position of the breakout tab is changed.

6. Click on [Apply].

7. Click on [Close].

The dialog is closed.

The breakout tab position is changed.
Adding a breakout tab

1. Click on [Add break] in the dialog:

Fig. 273: Add a breakout tab

- A new breakout tab (circle) is created.

Note

New breakout tabs are always created at the same position and must be moved to the desired position manually using the mouse.

2. Enter the gap width in mm.
3. Drag the circle with the mouse to the desired position.
4. Click on [Apply].
5. Click on [Close].

- The dialog is closed.
- A new breakout tab is created.
Removing a breakout tab position
1. Select the circle at the desired breakout tab position.
2. Click on [Remove break].
   ➔ The selected breakout tab is removed.
3. Click on [Apply].
4. Click on [Close].
   ➔ The dialog is closed.
   ◆ The breakout tab position is removed.
5.5 Menu Modify

The menu “Modify” contains the functions to edit geometrical objects. Click on the “Modify” menu item to open the submenu:

![Modify menu](image)

The following table provides a brief description of the menu item’s functions:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close open path</td>
<td>Closes an open path.</td>
</tr>
<tr>
<td>Combine open paths</td>
<td>Combines several open paths to a single open path.</td>
</tr>
<tr>
<td>Reduce number of element</td>
<td>Reduces the number of elements for opened and closed paths and polygons.</td>
</tr>
<tr>
<td>Convert to polygon</td>
<td>Converts a closed path into a polygon.</td>
</tr>
<tr>
<td>Convert to closed path</td>
<td>Converts a polygon into a closed path.</td>
</tr>
<tr>
<td>Draw to flash</td>
<td>Converts a drawn object into a flash object and creates a new aperture.</td>
</tr>
<tr>
<td>Combine to flash</td>
<td>Combines objects to a flash object and creates a new aperture.</td>
</tr>
<tr>
<td>Menu item</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Compare to flash</td>
<td>Converts all objects that have the same form and size and are on the same as the selected flash object.</td>
</tr>
<tr>
<td>Explode flash</td>
<td>Explodes complex flash objects into individual geometric forms.</td>
</tr>
<tr>
<td>2.5D operations</td>
<td>Opens the 2.5D operations sub-menu.</td>
</tr>
<tr>
<td>Convert to 2D:</td>
<td>This menu item applies a Z value to 2D objects thus converting them to 2.5D objects.</td>
</tr>
<tr>
<td>Change Z value:</td>
<td>This menu item allows you to change the Z value of a 2.5D object.</td>
</tr>
<tr>
<td>Transform…</td>
<td>Opens a dialog to translate, rotate, scale and invert objects.</td>
</tr>
<tr>
<td>Rotate/Mirror relative</td>
<td>Opens the Rotate/Mirror sub-menu.</td>
</tr>
<tr>
<td>• Rotate 90°</td>
<td></td>
</tr>
<tr>
<td>• Mirror horizontal</td>
<td></td>
</tr>
<tr>
<td>• Mirror vertical</td>
<td></td>
</tr>
<tr>
<td>Step Repeat…</td>
<td>Opens a dialog to multiply the selected objects with a defined spacing and count in X and/or Y direction.</td>
</tr>
</tbody>
</table>
5.5.1 Close open path

Use the function “Close open path” to convert open paths into closed paths.

- Closing an open path
  1. Select the open path in the CAM view:

  ![Selecting an open path](image)

  2. Click on Modify > Close open path.

  Or
2. Click on “Close open path” in the context menu:
The open path is closed:

The open path has been closed.
5.5.2 Combine open path

The function “Combine open paths” lets you combine two or more open paths into one open path.

Note

Please note that the distance between the open paths must not be larger than the tolerance value set in the options.
You can find the tolerance value in the branch “Miscellaneous” in the “Options” dialog (menu item Extras > Options).
If the distance is larger than the tolerance value, the open paths will not be combined!

- Combining open paths

1. Select at least two open paths in the CAM view:

2. Click on Modify > Combine open paths.

Or
2. Click on “Combine open paths” in the context menu.

Fig. 279: Combining open paths

The two open paths are combined:

Fig. 280: Closed path

❖ The open paths have been combined.
5.5.3 **Convert to polygon**

Use the function “Convert to polygon” to convert closed paths into polygon areas.

- **Converting to polygon**

1. Select the closed path in the CAM view:

2. Click on Modify > Convert to polygon.
   Or
2. Click on “Convert to polygon” in the context menu.
The closed path is converted into a polygon:

Fig. 283: Polygon

The closed path has been converted into a polygon.

5.5.4 Convert to closed path

Use the function “Convert to closed path” to convert polygons into closed paths.

- Converting into a closed path

1. Select the polygon in the CAM view:

Fig. 284: Select polygon

2. Click on Modify > Convert to closed path.
Or

2. Click on “Convert to closed path” in the context menu.

Fig. 285: Convert to closed path

The polygon is converted into a closed path:

Fig. 286: Closed path

The polygon has been converted into a closed path.
5.5.5 Draw to flash

Use “Draw to flash” to convert drawn objects (circles, circle paths, rectangles etc) into flash objects.

- Converting a rectangle into a flash object

1. Select the rectangle in the CAM view:

![Fig. 287: Select rectangle](image)

2. Click on Modify > Draw to flash.

   The rectangle is converted into a flash object. In addition, an aperture is created that is displayed in the “Geometry” pane.

![Fig. 288: Flashed rectangle](image)
The rectangle is converted into a flash object.

### 5.5.6 Combine to flash

The function “Combine to flash” lets you combine two or more drawn objects to one flash object.

- **Combining drawn objects to a flash object**
  1. Select the objects in the CAM view:

    - The objects do **not** have to be on the same layer.
    - The flashed object is placed on the layer of the object drawn last.

    ![Selected objects](image)

2. Click on Modify > Combine to flash.
The following dialog is displayed:

3. Enter a name for the new aperture to be created.
4. Select an aperture list for the new aperture to be created.
5. Click on [Apply].

The selected objects are combined to a flash object:

A new aperture is created with the specified name in the selected aperture list.

The objects are now on the same layer and are combined to a flash object. The center point of the flash object is defined.

The drawn objects are combined to a flash object.
5.5.7 Compare to flash

The function “Compare to flash” lets you convert objects of same shape (e.g. circles) into flash objects. If the objects have small differences in size or angle, you can have these converted into flash objects as well by entering tolerance values for size and angle.

- If the sizes of the objects differ from the size of the flash object, the size is adjusted. Thus, the drawn objects have the same size as the flash object after converting to flash.

The following conditions must be met:
- The objects to be compared must have the same shape as the flash object.
- All objects must be on the same layer.

All objects are on the same layer. The rectangles (see /2/ to /4/) are to be compared with the flash object and converted into flash objects. As the rectangles are not identical (rectangle /2/ is only 500 mm long and rectangle /4/ is rotated by 45°), using the function would only convert the identical rectangle /3/ into a flash object. In this case, it is necessary to enter tolerances for size and angle.
Comparing rectangles with a flash object
1. Select the flash object (see /1/).
2. Click on Modify > Compare to flash.
   ➨ The following dialog is displayed:

   ![Compare to flash dialog](image)

   3. Enter the tolerance value.
   ➨ As the rectangle /2/ is 50 mm shorter than the flash object, enter at least “50” so that rectangle /2/ is also converted into a flash object.
4. Enter the angle.
   ➨ As the rectangle /4/ is rotated by 45°, enter at least “45” so that this rectangle is also converted into a flash object.

   ![Enter values](image)

   5. Click on [Apply].
The rectangles /2/ to /4/ are converted into flash objects:

Fig. 295: Flashed rectangles

- The “Properties” pane now shows all rectangles having the object type “Flash/Drill”. As soon as you select one of the rectangles the center point is also displayed.
- The rectangles were compared with the flash object and converted into flash objects.
5.5.8 Explode flash

This function lets you convert flash objects back into their original object types.

- Exploding a flash object

1. Select the flash object that you want to explode:

2. Click on Modify > Explode flash.

   - The flash object is converted into its original type, a circle.

   - The flash object is exploded.
### 5.5.9 2.5D operations

The 2.5D operations in CircuitPro PM can apply a Z depth to any drawn 2D object. Use these operations to create pockets in a circuit board. You can also convert existing 2.5D objects in 2D objects.

The following operations are available:
- Convert to 2.5D
- Change Z value
- Convert to 2D

#### Convert to 2.5D

The objects that you convert to 2.5D objects are created on layers PocketTop or PocketBottom depending on the project type (single-sided or double-sided circuit board).

- Converting a drawn object into a 2.5D object
  1. Select the object to be converted:
  
  Fig. 298: Convert object

  ![Convert object](image)

  2. Click on Modify > 2.5D operations > Convert to 2.5D…

  ➔ The following dialog is displayed:

  ![Convert into 2.5D dialog](image)

  3. Select the destination layer (PocketBottom or PocketTop).
  4. Enter the Z value of the object.
5. Activate/deactivate the option “Create a copy” as desired.
6. Click on [Apply].

⇒ The 2.5D object is created according to the selected option:

- The drawn 2D object is converted into a 2.5D object.
Change Z value

If you want to change the Z value of a 2.5D object, you can use the function “Change Z value...”.

Changing the Z value of a 2.5D object
1. Select the 2.5 object whose Z value you want to change.
2. Click on Modify > 2.5D operations > Change Z value
   ➨ The following dialog is displayed:

   ![Change Z value dialog]

3. Enter the Z value.
4. Click on [Apply].
   ➨ The Z value of the object is changed. You can check this in the “Properties” pane of the 2.5D object.
5. Click on [Close].
   ➨ The Z value of the 2.5D object is changed.
Convert to 2D

This function enables you to convert existing geometrical 2.5D objects in 2D objects.

- Converting a 2.5D object into a 2D object

1. Select the 2.5D object to be converted:

2. Click on Modify > 2.5D operations > Convert to 2D…

   ➔ A drop down list containing all available layers, on which you can place your 2D object, is displayed:

3. Select the destination layer (in this case TopLayer).
The 2D object is created on the selected destination layer:

The 2.5D object is converted into a 2D object.
5.5.10 Transform

The “Transform” dialog lets you perform the following operations on objects in the CAM view:

- Translate
- Rotate
- Scale
- Mirror

Tab Translate

The “Translate” function lets you move objects in the CAM view as follows:

- Absolute translation a to a specified point from the zero point
- Relative translation of the object center
- Relative translation by entering a translation vector

Moving objects

1. Select the object to be moved.
2. Click on Modify > Transform…

The following dialog is displayed:

3. Activate the desired option.
4. Enter the absolute/relative X value.
5. Enter the absolute/relative Y value.
6. Click on [Apply].
7. Click on [Close].

The dialog is closed.

The object is moved.
Tab Rotate

The “Rotate” function lets you rotate objects counter-clockwise in the following ways:

- Rotate around the center of the group (if more than one object is selected)
- Rotate around individual centers
- Rotate around given point (selected)

Rotating objects

1. Select the object or objects to be rotated.
2. Click on Modify > Transform…
3. Select the “Rotate” tab.

The following dialog is displayed:

Fig. 307: Rotate

4. Enter the value of the angle.
5. Activate the desired option.

If you activated the option “Rotate around given point” you have to enter the X and Y value of the point. As an alternative, you can set the desired point in the CAM view using the mouse. The object will be rotated around that defined point.

6. Click on [Apply].
7. Click on [Close].

The dialog is closed.

The object is rotated.
Tab Scale

The “Scale” function lets you modify the size of the objects as follows:

- Scale the group (if more than one object is selected)
- Scale each object individually

Scaling objects
1. Select the object or objects to be scaled.
2. Click on Modify > Transform...
3. Select the “Scale” tab.

The following dialog is displayed:

4. Activate the desired option.
   - Scale group
   - Scale each object individually
Example:

Your layout in the Cam view includes an open path and two circles:

If you select all objects, activate the option “Scale group” and enter a new size of 200%, your layout will change as follows:
If you select all objects, activate the option “Scale each object individually” and enter a new size of 200%, your layout will change as follows:

The option “Scale each object individually” causes, that the objects' positions are not recalculated when entering a new size. These objects remain in the original position and could therefore lead to an incorrect layout.

5. Enter a scaling factor in percent.
6. Click on [Apply].
7. Click on [Close].

➨ The dialog is closed.
◆ The object is scaled.
Tab Mirror

The “Mirror” function lets you mirror objects in the CAM view as follows:

- Mirror along the X Axis
- Mirror along the Y Axis
- Mirror along an arbitrary axis

Mirroring an object
1. Select the object or objects to be mirrored.
2. Click on Modify > Transform…
3. Select the “Mirror” tab.
4. The following dialog is displayed:

   ![Mirror Dialog](image)

4. Activate the desired option.

   - If you activate the option “Mirror X” or “Mirror Y”, you can use the mouse to select the X or Y axis in the CAM view along which the object is to be mirrored.

   - If you activate the option “Mirror around arbitrary axis”, you can enter the X and Y values to define the arbitrary axis along which the object(s) is (are) to be mirrored. As an alternative, you can use the mouse in the CAM view to set two points that define the mirror axis.

5. Click on [Apply].
6. Click on [Close].

   ➔ The dialog is closed.
   ➔ The object is mirrored.
5.5.11 Rotate/Mirror relative

The “Rotate/Mirror relative” function enables you to rotate objects in the CAM view by 90° or mirror along the X or Y axis:

- Rotating an object by 90°
  1. Select the object to be rotated.
  2. Click on the object's point around which the object is to be rotated:

![Rotate object by 90°](image)

**Note**

CircuitPro PM rotates the object(s) around the current anchor point.

3. Click on Modify > Rotate/Mirror relative > Rotate 90°.
The object is rotated around the anchor point by 90°:

The above steps apply to all rotate functions in the sub-menu “Rotate/Mirror relative” accordingly.
Mirroring objects along the X axis
1. Select the object or objects to be mirrored.
2. Click on the object point through which the mirror axis is to be placed.

Fig. 315: Mirror object

Note
The figure above shows the anchor point of the object marked with a red arrow. This is where CircuitPro PM places the mirror axis.

3. Click on Modify > Rotate/Mirror relative > Mirror X.
The object(s) is (are) mirrored.

The object(s) is (are) mirrored along the X axis.

Note

The above steps apply to the “Mirror Y” function in the sub-menu “Rotate/Mirror relative” accordingly.
5.5.12 Step Repeat

The “Step Repeat” function lets you multiply the selected object(s)
• by any number in X direction,
• by any number in Y direction
• using a defined step distance.

Multiplying an object
1. Select the object that you want to multiply.

2. Click on Modify > Step Repeat…

The following dialog is displayed:

In this example, the object is to be multiplied by three in X direction and by two in Y direction with a step distance of 300 mm in x and Y direction.
3. Enter the repetition values in X and Y direction.
4. Enter the step distance in X and Y direction in mm.
If you check the option “Combine to flash”, the object or group to be multiplied is converted into a flash object.

You can select an aperture size for conversion into flash objects. The aperture list is displayed when you activate the option.

5. Click on [Apply].
   ➔ The object is multiplied:

6. Click on [Close].
   ◆ The object is multiplied.
5.6 Menu View

The menu “View” allows you to show/hide the different panes and open the layouts.

Click on the “View” menu item to open the submenu:

![Menu View](image)

The following table provides a brief description of the menu item’s functions:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
<th>For more information, see chapter “Pane”</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layers…</td>
<td>Shows/hides the pane “Layers”</td>
<td>see page 44</td>
</tr>
<tr>
<td>Geometry…</td>
<td>Shows/hides the pane “Geometry”</td>
<td>see page 45</td>
</tr>
<tr>
<td>Toolpath…</td>
<td>Shows/hides the pane “Toolpath”</td>
<td>see page 45</td>
</tr>
<tr>
<td>Processing…</td>
<td>Shows/hides the pane “Processing”</td>
<td>see page 46</td>
</tr>
<tr>
<td>Properties…</td>
<td>Shows/hides the pane “Properties”</td>
<td>see page 48</td>
</tr>
<tr>
<td>Tool info</td>
<td>Shows/hides the pane “Tool info”</td>
<td>see page 49</td>
</tr>
<tr>
<td>CAM 2D…</td>
<td>Opens the view “CAM 2D”</td>
<td>see page 27</td>
</tr>
<tr>
<td>Machining 2D…</td>
<td>Opens the view “Machining 2D”</td>
<td>see page 30, 31, 32, 33</td>
</tr>
<tr>
<td>3D View</td>
<td>Opens the view “3D View”</td>
<td>see page 36</td>
</tr>
<tr>
<td>Navigation</td>
<td>Shows/hides the pane “Navigation”</td>
<td>see page 50</td>
</tr>
<tr>
<td>Messages…</td>
<td>Shows/hides the pane “Messages”</td>
<td>see page 52</td>
</tr>
<tr>
<td>Fault monitor</td>
<td>Shows/hides the pane “Fault Monitor”</td>
<td>see page 53</td>
</tr>
<tr>
<td>Menu item</td>
<td>Description</td>
<td>For more information, see chapter “Pane”</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>Layouts</td>
<td>Opens the sub menu “Layouts”. Here you can open the different views with the different panes:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Standard CAM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Compact CAM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Machining</td>
<td></td>
</tr>
<tr>
<td>Toolbars</td>
<td>Opens the sub menu “Toolbars”. Here you can activate/deactivate the visibility of the individual toolbars:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Modify</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• STANDARD</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Process</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Insert</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Custom</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Status bar</td>
<td></td>
</tr>
</tbody>
</table>

You find more information about the details of the different submenus in the corresponding topics of the chapter “Panes”.

Table 43: Menu functions
5.7 Menu Select

The menu “Select” allows you to define the elements on the object which should be selected/highlighted by the mouse. Click on the “Select” menu item to open the submenu.

The following table provides a brief description of the menu item’s functions:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>By Polygon</td>
<td>Enable this option to create polygons by using your mouse and to select objects within the polygon.</td>
</tr>
<tr>
<td>Invert in 2D</td>
<td>Enable this option to invert your selection in the CAM View.</td>
</tr>
<tr>
<td>Select all</td>
<td>Selects all objects.</td>
</tr>
<tr>
<td>Open/Closed path</td>
<td>Selects open/closed path objects.</td>
</tr>
<tr>
<td>Polygon</td>
<td>Selects polygons.</td>
</tr>
<tr>
<td>Circle</td>
<td>Selects circles.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Selects rectangles.</td>
</tr>
</tbody>
</table>
### Table 44: Menu functions “Select”

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Selects text objects.</td>
</tr>
<tr>
<td>Flash</td>
<td>Selects flash objects.</td>
</tr>
<tr>
<td>Toolpath</td>
<td>Selects toolpaths.</td>
</tr>
<tr>
<td>Enable all</td>
<td>Enables the selection of all objects.</td>
</tr>
<tr>
<td>Disable all</td>
<td>Disables the selection for all objects in the CAM view.</td>
</tr>
</tbody>
</table>
5.8 Menu Wizards

This menu contains several wizards to help you in PCB manufacturing. Click on the “Wizards” menu item to open the submenu:

![Wizards Menu](image)

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equipment configuration wizard...</td>
<td>Use the Equipment configuration wizard to define the existing equipment for the manufacturing of PCBs.</td>
</tr>
<tr>
<td>Process planning wizard...</td>
<td>Use this wizard to set the properties of the prototype project (for example: double sided with through plating).</td>
</tr>
<tr>
<td>Board Production Wizard...</td>
<td>This wizard guides you through every step of the PCB manufacturing.</td>
</tr>
<tr>
<td>Dispense preparation wizard...</td>
<td>Starts a wizard, which guides through the preparation of a dispense process.</td>
</tr>
<tr>
<td>Dispense process wizard...</td>
<td>Starts a wizard, which guides through a dispense process.</td>
</tr>
</tbody>
</table>
5.8.1 Equipment configuration wizard

The equipment configuration wizard starts automatically when the program is started for the first time. This is where you define the equipment you are going to use.

- Opening the Equipment configuration wizard dialog
  1. Click on Wizards > Equipment configuration wizard…
  ➔ The dialog of the Equipment configuration wizard is displayed:

  ![Equipment configuration wizard dialog]

  /1/ List of configuration steps
  /2/ Section for descriptions or configuration options

  /3/ [Next] – Confirms the configuration step and switches to the next configuration step
  /4/ [Cancel] – Closes the Equipment configuration wizard without saving the settings

  2. Follow the prompts of the Equipment configuration wizard.
In the final step, the Equipment configuration wizard displays a summary of the settings you entered.

3. Click on [Done], to close the Equipment configuration wizard.
   ◆ The Equipment configuration wizard is finished.
5.8.2 Process planning wizard

Use the process planning wizard to define the process components you are going to use.

- Opening the Process planning wizard dialog
  1. Click on Wizards > Process planning wizard…
  ➔ The dialog of the process planning wizard is displayed:

![Process planning wizard dialog](image)

1/ Steps/Overview
2/ Section for descriptions or configuration options
3/ [Next] – Confirms the selection and switches to the next configuration step
4/ [Cancel] – Closes the process planning wizard without saving the settings

2. Follow the prompts of the process planning wizard.
In the final step, the process planning wizard displays a summary of the settings you entered.

3. Click on [Done] to close the Process planning wizard.
   The Process planning wizard is finished.
5.8.3 Board Production Wizard

The board production wizard guides you through the board production process.

- Opening the Board Production Wizard dialog
  1. Click on Wizards > Board Production Wizard…
  ➔ The dialog of the Board Production Wizard is displayed:

![Board Production Wizard](image)

1. List of the production phases
2. Section for prompts and display of progress
3. [Start] – Starts board production
4. [Cancel] – Closes the board production wizard and aborts the production process.

2. Follow the prompts of the board production wizard.
The progress of the current phase and the overall progress are displayed during the whole process of board production.

3. Click on [Finish], to close the Board Production Wizard.
   - The Board Production Wizard is finished.
5.8.4 Dispense Preparation Wizard

Please note, that you can only use the Dispense preparation wizard with a ProtoMat S63/S103.

The dispense preparation wizard guides you through the steps for preparing the dispense process.

- Opening the dispense preparation wizard dialog
  1. Click on Wizards > Dispense preparation wizard….
  ➔ The dialog of the dispense preparation wizard is displayed:

In order to determine the camera offset, 5 solder paste dots are applied. The last dot has a greater distance to the other dots. This last dot is used for measuring the offset. If this dot is not measured correctly the dispense process cannot be run correctly. Thus, it is essential that you check the camera image before confirming the offset in the wizard.

The following scenarios may occur when measuring the camera offset:
Scenario 1

- The camera finds the last applied dot and centers it in the camera image.

1. Click on [Accept Current Position] to apply the position.

![Alignment interface](image)

- The “Camera offset” phase is finished successfully.

Scenario 2

- The camera finds the last applied dot but does not center it in the camera image.

1. Click on [Find and Center].

- The camera centers the dot.

2. Click on [Accept Current Position].

- The “Camera offset” phase is finished successfully.
Scenario 3

The camera does not find the dot.

1. Use the X and Y buttons (/1/) in the “Processing” pane to position the last applied dot approximately at the center of the camera image.
2. Click on [Find and Center].
   ➔ The camera centers the dot.
3. Click on [Accept Current Position].

Fig. 331: Fiducial not recognized automatically

The “Camera offset” phase is finished successfully.
Scenario 4

- The camera finds one of the first four dots.

1. Use the X and Y buttons (/1/) in the “Processing” pane to position the last applied dot approximately at the center of the camera image.

2. Click on [Find and Center].
   - The camera centers the dot.

3. Click on [Accept Current Position].
   - The “Camera offset” phase is concluded successfully.

3. If the camera offset is successfully adjusted, follow the next instructions of the Dispense preparation wizard.
   - The following view is displayed, if the Dispense preparation wizard is finished:

4. Click on [Done], to close the Dispense preparation wizard.
   - The Dispense preparation wizard is finished.
5.8.5 Dispense process wizard

The dispense process wizard guides you through the steps of the dispense process.

Note

Beforehand you must have created the solder paste paths and passed through the Dispense preparation wizard.

Opening the dispense process wizard dialog
1. Click on Wizards > Dispense process wizard…

The dialog of the dispense process wizard is displayed:

2. Follow the prompts of the dispense process wizard.

2. Follow the prompts of the dispense process wizard.
3. Click on [Next board], if you want to dispense solder paste on another board.

Or

3. Click [Finish], if you want to close the Dispense process wizard.
   ◆ The Dispense process wizard is finished.
5.9 Menu Machining

The menu “Machining” allows you to start/stop the processing and to make settings for the PCB processing.

Click on the “Machining” menu item to open the submenu:

The following table provides a brief description of the menu item’s functions:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process all</td>
<td>Starts the production.</td>
</tr>
<tr>
<td>Stop processing</td>
<td>Stops the production.</td>
</tr>
<tr>
<td>Production phase…</td>
<td>Opens the dialog “Create new phase”. Then you can create a new production phase.</td>
</tr>
<tr>
<td>Placement…</td>
<td>Opens the dialog “Placement”.</td>
</tr>
<tr>
<td>Fiducials…</td>
<td>Inserts fiducials as toolpath in the machining view.</td>
</tr>
<tr>
<td>Measure milling width…</td>
<td>Only with conical surface milling tools (Universal Cutter and Micro Cutter):</td>
</tr>
<tr>
<td></td>
<td>the current milling width is measured.</td>
</tr>
<tr>
<td>Alignment…</td>
<td>Opens the dialog “Alignment”.</td>
</tr>
<tr>
<td>Drill reference holes…</td>
<td>Opens the dialog “Drill reference holes”.</td>
</tr>
<tr>
<td>Service…</td>
<td>Access to service functions for service staff.</td>
</tr>
<tr>
<td>Determine camera head offset…</td>
<td>Starts a dialog, which guides you through the procedure to determine the camera head offset.</td>
</tr>
<tr>
<td>Teach tool-holder positions…</td>
<td>Measures the tool position by camera.</td>
</tr>
</tbody>
</table>
5.9.1 Process all

The menu item “Process all” starts the circuit board production. The individual production phases are processed one after the other.

Click on Machining > Process all to start the board production.

- Starting the process
  1. Click on Machining > Process all.
  2. The processing has been started.
5.9.2 Stop processing

Use “Stop processing” in order to stop the current processing of the circuit board. The current phase is not completed. The milling head moves to the pause position.

To stop the machine processing the material, click on Machining > Stop processing.

If you want to resume processing the circuit board you have the following options:

• Restarting the whole phase where the process was interrupted [Resume].
• Continue the process from the selected phase onwards [Ignore].
• Cancel the process [Cancel].
5.9.3 Production phase

You can create new production phases for the circuit board production. These will be displayed in the “Phases” branch in the “Toolpath” pane.

Creating a new phase

1. Click on Machining > Production phase…

   ➔ The following dialog is displayed:

   ![New Phase Dialog](image)

   2. Enter a name for the new phase.
   3. Select a processing step.
   4. Select a linked phase if necessary.
   5. Select the processing order. This field defines when your newly created phase will be processed.

   **Option “The data should be mirrored”**
   Activate this check box if the phase to be created shall be processed after the circuit board has been turned over. The data are mirrored to achieve this.

   **Option “The phase contains toolpath data”**
   Activate this check box if the phase to be created shall contain toolpaths.

   6. Click on [Apply].

      ➔ The new phase is created and is displayed in the “Toolpath” pane.
   7. Click on [Close].

      ➔ The new phase is created.
5.9.4 Placement

Use “Placement” to move and/or multiply the processing data in the Machining view of CircuitPro PM.

Click on Machining > Placement to open the dialog.

The section “Relative translation” lets you move the whole circuit board design within the machining view.

Please note that you can move the processing data only as a whole and not individual toolpaths etc.

The “Step and Repeat” section lets you multiply the circuit board design as desired in X and Y direction with a defined step distance. Thus you can produce several circuits on one panel.

Moving the processing data (relative translation)

1. Enter a dX value.
2. Enter a dY value.
3. Click on [Apply].

Procedure without entering X and Y values

You can also move the processing data in the Machining view using your mouse.

To do this, click on the processing data and while pressing the left mouse button drag the circuit frame to the position where you want to place the circuit design.
The circuit board data are placed at the corresponding position.

If you want to move the processing data to the center of the working area, click on [Set center].

Note

4. Click on [Close].
   ➤ The processing data are moved.

Rotating the processing data
1. Enter the angle in the field ‘Angle’.
2. Click on the buttons beside to rotate the processing data in the desired direction.
   ➤ The processing data was rotated.

Multiplying the processing data
1. Enter the number of circuits that are to be produced in X and Y direction.
2. Enter the step distance of the circuits in X and Y direction.
3. Click on [Apply].
   ➤ The circuits are created according to the values entered.
4. Click on [Close].
   ➤ The processing data are multiplied.

Note

If you apply changes in the technology dialog that modify the bounding box of the current job (e.g. deactivating the contour routing or the fiducials) after having multiplied the circuit, you can adjust the job to the original placement values.

The following warning is displayed if the toolpaths are recomputed in the technology dialog prompting you to execute the placement again.

⇒ Click on [Reset] in the placement dialog. The current design is adjusted to the original placement values.
5.9.5 Fiducials

Using the function "Fiducials," you can set the optical markings in the machining view of CircuitPro PM. These fiducials are only inserted into the layout as toolpaths and are not present as geometrical objects. This means that in the CAM view of CircuitPro PM, the fiducials which were created by this function are not displayed.

In order to be able to perform this function, you must first generate the toolpaths so that the layout can be displayed in the machining view.

Using the function "Fiducials" you can
• set the fiducials in the machining view,
• process the fiducials in the machining view and
• delete the fiducials in the machine view.

Inserting fiducials

Ideally, set four fiducials in order to align the top and bottom side to each other.

However, you can also work with two fiducials. In this case, these should be diagonally aligned to one another.

1. Click on Machining > Fiducials…

The machining view of CircuitPro PM is activated.

The following dialog is displayed:

2. Select the processing phase in the field \Phase\, in which the fiducials are to be generated.
3. Select the drilling tool in the field \Tool\ for generating the fiducials.
4. If not active, activate the mode \Insert\.
5. Enter the X and Y coordinates of the fiducials and click on [Set coordinates].
Or
5. Using your mouse, on the machining view, click where you would like to place the fiducials.
→ The fiducial is inserted in the appropriate position in the machining view.

---

**Editing the coordinates of the fiducials**

If you would like to change the coordinates of a fiducial, proceed as follows:

1. Activate the mode "Edit".
   → The coordinates of the last fiducial set are shown.
2. Change the coordinates and click on [Set coordinates].
   or
2. Select the fiducial and move this to the desired position in the machining view.
   → The coordinates have been edited.

---

**Delete fiducial**

If you would like to delete a fiducial, proceed as follows:

1. Activate the mode "Edit".
   → The coordinates of the last fiducial set are shown.
2. Select the fiducial to be deleted.
3. Click on [Remove].

!!! If you have deleted the coordinates of the fiducial, the coordinates of the fiducial set previously are shown automatically!!!

→ The fiducial has been deleted.

---

6. Please repeat step 5 until you have generated the desired number of fiducials.
A rectangle, which highlights the position of the fiducials, is created around the layout:

Fig. 341: Fiducial marks in the machining view.

7. Click on [Close].
   - The dialog is closed.
   - The fiducials were inserted.
5.9.6 Measure milling width ProtoMat E33/S43

The menu item “Measure milling width” lets you mill a line in the base material and measure the milling width with the camera.

Click on Machining > Measure milling width…

The following dialog is displayed:

- Measuring the milling width
  1. Click on the position in the Machining view where you want to mill the line.
  2. Enter the length of the line to be milled.
  3. Select an option:
     - Horizontal milling line
     - Vertical milling line
  4. Click on [Mill a Line].
  ➔ The line is milled at the selected position.
  5. Check the milling width with a microscope:

     To determine the correct milling width, put on the microscope at the lower, inner edges of the copper:

  6. Click on [Accept Width], if the milling width is okay.
or
6. Adjust the tool manually and mill a line again until the result of the milling width is okay.

or
6. Install a new tool.
7. Click on [Try New Tool].
8. Repeat the steps 1 to 6.
◆ The milling width has been measured.
5.9.7 Measure milling width ProtoMat S63/S103

The menu item “Measure milling width” lets you mill a line in the base material and measure the milling width with the camera.

Click on Machining > Measure milling width.

The following dialog is displayed:

1. Click on the position in the Machining view where you want to mill the line.
2. Enter the length of the line to be milled.
3. Select an option:
   - Horizontal milling line
   - Vertical milling line
4. Click on [Start].
   - The line is milled at the selected position. The Camera pane displays the milled line.
   - The following dialog with the measurement results is displayed:

5. Click on [Close].
   - The milling width is measured.
5.9.8 Measure milling ProtoMat D104

The menu item “Measure milling width” enables you to mill a line in the base material and measure the milling width with the camera.

Click on Machining > Measure milling width….

The following dialog is displayed:

- Measuring the milling width
  1. Click on the position in the Machining view where you want to mill the line.
  2. Enter the length of the line to be milled.
  3. Select an option:
     - Horizontal milling line
     - Vertical milling line
  4. Click on [Start].
     - The line is milled at the selected position. The Camera pane displays the milled line.
     - The following dialog with the measurement results is displayed:

5. Click on [Close].

  - The milling width has been measured.
5.9.9  **Alignment (only if camera is present)**

The dialog “Alignment” allows you modify the settings for the “ReadFiducials” phase.

- Modifying the settings for phase “ReadFiducials”
  1. Click on Machining > Alignment.

  ➔ The following dialog is displayed:

  ![Alignment dialog](image)

  2. Select the existing fiducials in the design that are to be used in the “DrillFiducials” phase.
  3. Modify the individual parameters for the “ReadFiducials” phase as necessary.
### Table 47: Alignment

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fiducials for step-and-repeat</td>
<td>If the project has been multiplied with “Step and Repeat”, the fiducials are multiplied as well.</td>
</tr>
<tr>
<td>Use fiducials of original project only</td>
<td></td>
</tr>
<tr>
<td>Use outer fiducials of entire multiplied project</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diameter Tolerance</td>
<td>Defines the tolerance for the diameter of the fiducial.</td>
</tr>
<tr>
<td>Search Area Length</td>
<td>Defines the size of the search area.</td>
</tr>
<tr>
<td>Minimum Fiducial Quality</td>
<td>Defines the quality level that a found fiducial must meet in order to be centered.</td>
</tr>
<tr>
<td>Distance for Direct Acceptance</td>
<td>Defines how precisely the fiducial must be centered in the camera image.</td>
</tr>
<tr>
<td>Show Fiducial Time</td>
<td>Defines the time that the camera remains on a found fiducial before continuing the process.</td>
</tr>
<tr>
<td>Maximum No. of centering Tries</td>
<td>Defines the maximum number of tries to center a found fiducial in the camera image.</td>
</tr>
<tr>
<td>Manual Centering If Not Found</td>
<td>If no fiducial is found, a dialog for manual centering is displayed.</td>
</tr>
<tr>
<td>Ask for Confirmation</td>
<td>After finding and centering a fiducial, the fiducial must be confirmed.</td>
</tr>
</tbody>
</table>
4. Modify the settings as desired.
5. Click on [OK].
   ◆ The settings for the “ReadFiducials” phase are applied.

### 5.9.10 Drill reference holes

Use “Drill reference holes” to drill the holes for the reference pins.

---

**Note**

The reference hole system can be used for aligning the board if no camera is available.

The reference hole system is not used if a vacuum table is mounted.

---

Click on Machining > Drill reference holes to open following dialog:

![Drill Reference Holes dialog](image)

There are three options for drilling reference holes to choose from:

- **Drill Both Reference Holes**: One reference hole is drilled at the home position and one opposite to the home position.
- **Drill Reference Hole at Home Position**: A reference hole is drilled at the home position.
- **Drill Reference Hole Opposite To Home Position**: A reference hole is drilled at the position opposite to the home position.
Drilling reference holes

1. Select the desired option for drilling the reference holes in the “Operations” section.

The “Parameters” section contains LPKF standard settings. These settings are activated by default. If you want to use different values, remove the check mark at <Use LPKF Standard Settings>.

2. Enter the offset value and the distance between the reference holes in the “Parameters” section if necessary.

3. Click on [Start].

⇒ The milling head moves to the corresponding position(s) and drills the reference hole(s).

The reference holes are drilled using a Spiral Drill 2.95 mm. This tool must be present in the tool magazine or, in case of machines without tool magazine, must be inserted manually into the clamp (when prompted).

◆ The reference holes are drilled.

5.9.11 Service

Only qualified personnel authorized by LPKF can activate the “Service” menu item by entering a password.
5.9.12 Determining the camera head offset

This function lets you measure the offset between the camera and the milling head.

Click on Machining > Determine camera head offset…

The following dialog is displayed:

![Determine camera head offset dialog]

You can choose between determining the X/Y-Offset and the Z-Focus-Offset. The Z-Focus-Offset is used to determine the material height for 2.5D operations.

- Determining the X/Y-Offset
  1. Put the base material onto the table.
  2. Click on [Determine X/Y-Offset].
  3. Follow the instructions in the dialog window.

![Determine X/Y-Offset dialog and view]

Fig. 349: Determine camera-to-milling-head offset

Fig. 350: Determine camera-to-milling-head offset
4. Click on [Apply].
   ➔ A hole is drilled at the selected position. The camera moves to this drill hole and measures the position (see “Camera” pane).
   ➔ The following dialog is displayed:

   ![Image](image1.png)

5. Click on [OK].
   ➔ The following dialog is displayed:

   ![Image](image2.png)

6. Click on [Save].
   ➔ CircuitPro synchronizes the results with the machine. A corresponding message is displayed:

   ![Image](image3.png)

   ➔ The X/Y-Offset is determined.

   Determining the Z-Focus offset

   1. Click on [Determine Z-Focus-Offset].
   ➔ The following message is displayed:

   ![Image](image4.png)

   For more information about dismounting the depth limiter, please refer to the delivered ProtoMat S manual.

   2. Confirm the message by clicking on [OK].

© 2014 LPKF AG V1.0 – 01.2014 299
The following dialog is displayed:

3. Follow the instructions in the dialog.
4. Click on [OK].

The following dialog is displayed:

5. Follow the instructions in the dialog.
6. Click on [OK].

The following dialog is displayed:

7. Follow the instructions in the dialog.
8. Click on [OK].

The following message is displayed:
The result of the measurement procedure is displayed:

Fig. 359: Results

Follow the instructions in the dialog.

10. Click on [Yes] to set the proposed offset as current value.

The following message is displayed:

Fig. 360: Save results to machine

11. Click on [Save] to save the results into the machine memory.

The following message is displayed:

Fig. 361: Synchronising the results

The Z-Focus offset is determined.
5.9.13 **Teach tool-holder positions**

Use the menu item “Teach tool-holder positions” to measure the tool-holder positions of the ProtoMat machine.

Click on Machining > Teach tool-holder Positions…

- The following dialog is displayed:

![Teach tool holder position dialog](image)

The milling head moves to the position of the first tool holder. The camera focuses automatically and displays the following image in the “Camera” pane:

![Camera image of tool-holder position](image)
Measuring tool-holder positions and storing to machine memory

1. Move the cross-hairs to the center of the tool-holder position (black circle) using the X and Y buttons in the “Processing” pane:

2. Click on [Set current camera position as position of first holder].
   ➔ The position is stored as the first position. The milling head moves to the position of the last tool holder.

3. Repeat step 1.
4. Click on [Set current camera position as position of last holder].
   ➔ The position is stored as the last position. The camera moves to all tool-holder positions one after the other.
The following dialog showing the results is displayed:

The dialog allows the following operations:

- Restart teaching the tool-holder positions [Restart teaching]
- Stop the current operation (e.g. when storing or performing the measuring again) [Stop]
- Store the measurement results [Save And Close]
- Abort all operations and close the dialog [Cancel]

5. Click on [Save and close].

The following message is displayed:

6. Click on [Yes] in order to store the results to the machine's memory.

CircuitPro PM synchronizes the measurement results with the machine's memory. A corresponding message is displayed.

The tool-holder positions are measured and stored to the machine's memory.
5.9.14 Connect

The menu item “Connect” allows the following operations:
• Connect CircuitPro PM with an LPKF ProtoMat machine [Connect].
• Disconnect CircuitPro PM from the LPKF ProtoMat machine [Disconnect].
• If CircuitPro PM is currently connected to an LPKF ProtoMat machine:
  Select a different machine type [Switch To].

Note
This step is only necessary if you switch on the ProtoMat machine after starting CircuitPro PM or if you want to connect CircuitPro PM to a ProtoMat machine that differs from the one configured previously.

Connecting CircuitPro PM with an LPKF ProtoMat machine
1. Click on Machining > Connect…

   ➔ The following dialog is displayed:

   ![Connect the machine dialog]

2. Select your machine type in the drop-down list.

   CircuitPro PM provides a virtual machine for simulating processes. You can connect CircuitPro PM to the virtual machine at any time, even when no real machine is connected to the PC.

3. Click on [Connect].
The following message window is displayed:

---

4. Check if a tool is clamped and specify the position of the tool magazine.
5. Click on [OK].
   - CircuitPro PM is connected to the ProtoMat machine.

- Disconnecting CircuitPro PM from the LPKF ProtoMat machine
  1. Click on Machining > Connect…
  2. Click on [Disconnect].
     - CircuitPro PM is disconnected from the LPKF ProtoMat machine.

- Switching CircuitPro PM to a different LPKF ProtoMat machine
  1. Select the machine type in the drop-down list.
  2. Click on [Switch To].
     - The message window for the connection steps is displayed.
     - The connection of CircuitPro PM is switched to the other machine.
5.10 Menu Camera

The menu “Camera” is only visible if you are using a machine that is equipped with a camera.

The menu “Camera” allows you to change the settings of the camera. Click on the “Camera” menu item to open the submenu:

![Menu Camera Submenu](image)

The following table provides a brief description of the menu item’s functions:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options</td>
<td>Opens the submenu “Options”.</td>
</tr>
<tr>
<td>Actions</td>
<td>Opens the submenu “Actions”.</td>
</tr>
<tr>
<td>Movement</td>
<td>Opens the submenu “Movement”.</td>
</tr>
<tr>
<td>Overlay</td>
<td>Opens the submenu “Overlay”.</td>
</tr>
<tr>
<td>Search</td>
<td>Opens the submenu “Search”.</td>
</tr>
</tbody>
</table>
5.10.1 Options

The menu item “Options” allows you to modify the image acquisition settings of the camera.

Click on Camera > Options to open the following cascading menu:

The following functions are available in the “Options” sub-menu:

- Image settings
- Camera light
- Save settings
- Save parameter set
- Load parameter set
- Create parameter set
5.10.1.1 Image settings

The sub-menu “Image settings” allows you to modify specific camera settings. Click on Camera > Options > Image settings to open the following dialog:

The following settings are available:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Miscellaneous</strong></td>
<td></td>
</tr>
<tr>
<td>Gain (master)</td>
<td>Adjusts the signal amplification of the camera.</td>
</tr>
<tr>
<td>Brightness [%]</td>
<td>Adjusts the brightness of the camera image.</td>
</tr>
<tr>
<td>Contrast [%]</td>
<td>Adjusts the contrast of the camera image.</td>
</tr>
<tr>
<td>Exposure [%]</td>
<td>Adjusts the exposure time of the camera.</td>
</tr>
<tr>
<td>Backlight comp. [%]</td>
<td>Adjusts the backlight compensation.</td>
</tr>
<tr>
<td>Sharpness [%]</td>
<td>Adjusts the sharpness of the camera image.</td>
</tr>
<tr>
<td>Gamma corr. [%]</td>
<td>Adjusts the gamma correction of the camera image.</td>
</tr>
<tr>
<td>Mirror / Rotate</td>
<td>Allows to mirror and/or rotate the camera image.</td>
</tr>
<tr>
<td>Frame rate [1/s]</td>
<td>Sets the frame rate of the camera.</td>
</tr>
<tr>
<td><strong>ROI [Pixel]</strong></td>
<td></td>
</tr>
<tr>
<td>Offs X</td>
<td>Adjusts the offset of the region of interest within the camera image in X direction.</td>
</tr>
<tr>
<td>Offs Y</td>
<td>Adjusts the offset of the region of interest within the camera image in Y direction.</td>
</tr>
<tr>
<td>Size X</td>
<td>Sets the size of the camera image in X direction in pixels.</td>
</tr>
<tr>
<td>Size Y</td>
<td>Sets the size of the camera image in Y direction in pixels.</td>
</tr>
<tr>
<td>Digital gain</td>
<td>Allows to enter a value for digital amplification of the camera image.</td>
</tr>
<tr>
<td><strong>DirectShow camera selection</strong></td>
<td>Allows to select the active camera.</td>
</tr>
</tbody>
</table>
## Table 49: Image acquisition settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calibration</strong></td>
<td></td>
</tr>
<tr>
<td>X, Y, Angle</td>
<td>Shows the calibration factors of the camera.</td>
</tr>
<tr>
<td><strong>Calibrate</strong></td>
<td></td>
</tr>
<tr>
<td>X distance [mm]</td>
<td>Sets the size of the object in X direction that is to be used for calibration.</td>
</tr>
<tr>
<td>Y distance [mm]</td>
<td>Sets the size of the object in y direction that is to be used for calibration.</td>
</tr>
<tr>
<td>Angle offset</td>
<td>Sets the angle of the objects that are to be used for calibration.</td>
</tr>
<tr>
<td>X count</td>
<td>Sets the number of objects in X direction that are to be used for calibration.</td>
</tr>
<tr>
<td>Y count</td>
<td>Sets the number of objects in Y direction that are to be used for calibration.</td>
</tr>
<tr>
<td>Snap and calibrate</td>
<td>Starts the calibration and computes the calibration factors.</td>
</tr>
<tr>
<td><strong>Parameter sets</strong></td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>Adds camera parameter sets.</td>
</tr>
<tr>
<td>Load</td>
<td>Loads an existing camera parameter set or creates a new one.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the changed settings into the selected camera parameter set.</td>
</tr>
<tr>
<td>Load all</td>
<td>Loads all existing camera parameter sets into the drop-down list.</td>
</tr>
<tr>
<td>Save all</td>
<td>Saves the settings of all camera parameter set.</td>
</tr>
</tbody>
</table>
5.10.1.2 Camera light

The sub-menu “Camera light” allows you to change the brightness of camera light.

Click on Camera > Options > Camera light to open the following dialog:

![Camera light dialog]

You can change the brightness of the camera light as follows:

- Moving the slider using the mouse.
- Entering a value into the input field and confirming the value with the “Enter” key.
- Clicking on the scroll buttons.

Note: The camera light value is automatically reset to 2 when the program is restarted.

5.10.1.3 Save settings

The sub-menu “Save settings” allows you to save specific camera settings.

- Saving the camera settings
  1. Click on Camera > Options > Save settings.
  - The camera settings are saved.

5.10.1.4 Save parameter set

The sub-menu “Save parameter set” allows you to save specific camera settings.

- Saving the current parameter set
  1. Click on Camera > Options > Save parameter set.
  - The parameter set is saved.
5.10.1.5 Load parameter set

The sub-menu “Load parameter set” allows you to select specific camera parameter sets.

Loading a camera parameter set

1. Click on Camera > Options > Load parameter set.

The following dialog is displayed:

2. Click on the arrow button to open the list of camera parameter sets.

3. Select a camera parameter set:

The following pre-sets are available:

<table>
<thead>
<tr>
<th>Pre-set</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>drillHole_default</td>
<td>Pre-set for recognizing fiducials</td>
</tr>
<tr>
<td>millingLineWidth_5um_default</td>
<td>Pre-set for acquiring milled lines (5 µm copper thickness)</td>
</tr>
<tr>
<td>millingLineWidth_18um_default</td>
<td>Pre-set for acquiring milled lines (18 µm copper thickness)</td>
</tr>
<tr>
<td>millingLineWidth_35um_default</td>
<td>Pre-set for acquiring milled lines (35 µm copper thickness)</td>
</tr>
</tbody>
</table>
### Table 50: Pre-sets

<table>
<thead>
<tr>
<th>Pre-set</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>millingLineWidth_70um_default</td>
<td>Pre-set for acquiring milled lines (70 µm copper thickness)</td>
</tr>
<tr>
<td>toolHolderRecognition_default</td>
<td>Pre-set for teaching the tool-holder positions</td>
</tr>
<tr>
<td>drillHole_glasmaster_default</td>
<td>Pre-set for recognizing fiducials on the glass master</td>
</tr>
<tr>
<td>default</td>
<td>Pre-set with default settings</td>
</tr>
</tbody>
</table>

**Note**

If you have created other camera parameter sets, these are also displayed in the drop-down list.

4. Click on [OK].
   - The camera parameter set is loaded.
5.10.1.6 Create Camera Parameter Set

The sub-menu “Create parameter set” allows you to create new camera parameter sets.

Creating a camera parameter set

1. Click on Camera > Options > Create parameter set.

The following dialog is displayed:

2. Select a camera parameter set type:
   The following parameter set types are available:

<table>
<thead>
<tr>
<th>Parameter set type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active</td>
<td>Currently loaded parameter set</td>
</tr>
<tr>
<td>Fiducial Search</td>
<td>Parameter set for searching fiducials</td>
</tr>
<tr>
<td>Line Width Finder</td>
<td>Parameter set for measuring the width of a milled line</td>
</tr>
<tr>
<td>Tool Holder Recognition</td>
<td>Parameter set for teaching the tool-holder positions</td>
</tr>
<tr>
<td>Standard</td>
<td>Standard parameter set</td>
</tr>
<tr>
<td>Suffix used</td>
<td>User-defined suffix for the name</td>
</tr>
</tbody>
</table>

   Full Name | Type name + user-defined suffix

3. Confirm by clicking on [OK].
   Or
3. Close the dialog by clicking on [Cancel].
   The camera parameter set has been created.
5.10.2 Actions

The sub-menu “Actions” allows you to perform specific camera actions. Click on Camera > Actions to open the following cascading menu:

![Camera > Actions Menu]

The following functions are available:

- Measuring Mode
- Set fiducial parameters
- Find fiducial
- Calibrate camera
- Auto focus
- Save image
- Show cameras

5.10.2.1 Measuring mode

The sub-menu “Measuring mode” allows you to perform measurements. Click on Camera > Measuring mode to open the following cascading menu:

![Camera > Measuring mode Menu]

The following functions are available:

- None
- Point to point
- Milling width
- Circle diameter
None

This option deactivates all measurement options.

- Deactivating the measurement options
  1. Click on Camera > Actions > Measuring Mode > None
  • The measurement options are deactivated.

Point to Point

The “Point to Point“ function lets you measure the distance between two points of your choice.

- Measuring point to point
  1. Click on Camera > Actions > Measuring Mode > Point to Point.
  2. In the camera pane, click on the point that you want to use as the starting point for the measurement.
  3. In the camera pane, click on the point that you want to use as the end point for the measurement.
  ➔ CircuitPro PM connects the two points with a line.

The “Camera“ pane displays the following values:
  • Distance in X direction (DX)
  • Distance in Y direction (DY)
  • Direct distance (DXY)
The “Camera” pane displays the following image:

Fig. 378: Point to Point

1/ Starting point of the measurement  
2/ End point of the measurement  
3/ Measurement result

The point-to-point measurement is finished.

Note

For removing the overlay items in the “Camera” pane, please click on Camera > Overlay > Clear overlay.
Milling width

The “Milling width” function lets you measure the distance between two lines in the camera image.

- Measuring the width of the milled channel
  1. Click on Camera > Actions > Measuring Mode > Milling width.
  2. Mark one edge of the milled channel to be measured by clicking on two points of the edge.
  3. Click on a point on the opposite edge of the milled channel to be measured.

  CircuitPro PM computes the perpendicular line. The length of the perpendicular line represents the width of the milled channel:

  ![Diagram of milling width measurement](image)

  /1/ Measurement result  /3/ Line on edge of milled channel
  /2/ End point of the measurement

- The width of the milled channel has been measured.

---

For removing the overlay items in the “Camera” pane, please click on Camera > Overlay > Clear overlay.
Circle Diameter

The “Circle Diameter” function lets you measure the diameter of a circle in the camera image.

- Measuring the diameter of a circle
  1. Click on Camera > Actions > Measuring Mode > Circle Diameter.
  2. In the camera pane, click on a point on the outer edge of the circle whose diameter you want to measure.
  3. Repeat step 2 twice.

Tip
Select the points on the outer edge of the circle in such a way that they can form a virtual triangle (see following figure).

CircuitPro PM connects the three points and computes the center, circumference, and diameter of the circle.

Note
For removing the overlay items in the “Camera” pane, please click on Camera > Overlay > Clear overlay.
5.10.2.2 Set fiducial parameters

The sub-menu “Set fiducial parameters” allows you to set the fiducial parameters.

- Setting the fiducial parameters

1. Click on Camera > Actions > Set fiducial parameters.

The following settings are available in the “Fiducial search configuration” category:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fiducial search configuration</td>
<td></td>
</tr>
<tr>
<td>Best fitting fiducial only</td>
<td><strong>True</strong>: Display the fiducial that fits the settings best. <strong>False</strong>: Display all fiducials that meet the set limits.</td>
</tr>
<tr>
<td>Fiducial Diameter</td>
<td>Nominal diameter of the fiducial</td>
</tr>
<tr>
<td>Fiducial form factor</td>
<td>Factor for similarity to a circle</td>
</tr>
<tr>
<td>Maximum fiducial diameter</td>
<td>Maximum allowable diameter of the fiducial</td>
</tr>
<tr>
<td>Minimum contour length</td>
<td>Minimum contour length of an object in pixels required to be recognized as a fiducial</td>
</tr>
<tr>
<td>Minimum Fiducial Diameter</td>
<td>Minimum allowable diameter of the fiducial</td>
</tr>
<tr>
<td>Minimum fiducial quality (%)</td>
<td>Tolerance value in percent for the fiducial diameter</td>
</tr>
<tr>
<td>Search ROI</td>
<td>Allows you to define a region of interest, to search for fiducials.</td>
</tr>
<tr>
<td>Threshold factor</td>
<td>Factor for the brightness threshold to distinguish objects from the background.</td>
</tr>
</tbody>
</table>
### Table 53: Buttons

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply</td>
<td>Applies the settings in the current selected fiducial parameter set.</td>
</tr>
<tr>
<td>Apply and save</td>
<td>Applies and saves the settings for the next start of CircuitPro.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the dialog.</td>
</tr>
</tbody>
</table>

2. Modify the settings as desired.
3. Click on [Apply].
   Or
3. Click on [Apply and Save].
4. Click on [Close].
   ➔ The dialog is closed.
   ◆ The fiducial parameters have been set.

#### 5.10.2.3 Find Fiducial

The “Find Fiducial” function lets you find fiducials in the camera image.

- Finding a fiducial
  1. Click on Camera > Actions > Find Fiducial
     ➔ The camera searches for fiducials. When the search is finished the results are displayed in a dialog:

   ![Fiducial search result](image)

   ➔ The found fiducial is marked accordingly in the “Camera” pane:

   ![Fiducial marked](image)

   ◆ The fiducial is found.
5.10.2.4 Calibrate camera

The sub-menu “Calibrate camera” allows you to calibrate the camera.

Calibrating the camera
1. Click on Camera > Actions > Calibrate camera.

The following dialog is displayed:

An object of defined size, e.g. a hole of known diameter, should be visible in the camera image for calibrating the camera.

Enter the diameter or the size of the object in the fields “X distance” and “Y distance” and click on [Snap and calibrate].
The “Calibration” group contains the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calibration</strong></td>
<td></td>
</tr>
<tr>
<td>X, Y, Angle</td>
<td>Shows the calibration factors of the camera.</td>
</tr>
<tr>
<td><strong>Calibrate</strong></td>
<td></td>
</tr>
<tr>
<td>X distance [mm]</td>
<td>Sets the size of the object in X direction that</td>
</tr>
<tr>
<td></td>
<td>is to be used for calibration.</td>
</tr>
<tr>
<td>Y distance [mm]</td>
<td>Sets the size of the object in y direction that</td>
</tr>
<tr>
<td></td>
<td>is to be used for calibration.</td>
</tr>
<tr>
<td>Angle offset</td>
<td>Sets the angle of the objects that are to be</td>
</tr>
<tr>
<td></td>
<td>used for calibration.</td>
</tr>
<tr>
<td>X count</td>
<td>Sets the number of objects in X direction that</td>
</tr>
<tr>
<td></td>
<td>are to be used for calibration.</td>
</tr>
<tr>
<td>Y count</td>
<td>Sets the number of objects in Y direction that</td>
</tr>
<tr>
<td></td>
<td>are to be used for calibration.</td>
</tr>
<tr>
<td>Snap and calibrate</td>
<td>Starts the calibration and computes the</td>
</tr>
<tr>
<td></td>
<td>calibration factors.</td>
</tr>
</tbody>
</table>

2. Modify the settings as desired.
3. Click on [Snap and calibrate].
   ◆ The camera has been calibrated.

### 5.10.2.5 Auto Focus

The “Auto Focus” function starts the automatic focusing of the camera.

- Starting the automatic focusing procedure
  1. Click on Camera > Actions > Auto Focus.
  - The camera focuses automatically so that a crisp camera image is displayed.
  - The automatic focusing procedure is finished.
5.10.2.6  Save image

The “Save image” function lets you save the current camera image.

- Saving the current camera image
  1. Click on Camera > Actions > Save image.
  
- The following dialog is displayed:

2. Enter a file name and select a folder.
3. Click on [Save].
   - The current camera image is saved.

5.10.2.7  Show cameras

The “Show cameras” function shows you all cameras that are available to you.

Click on Camera > Actions > Show cameras to open the following dialog:

- Selecting a camera
  1. Click on the arrow button to open the drop-down list of the available cameras.
  2. Click on a camera in the drop-down list.
  3. Click on [Select].
  4. Click on [Close].
   - The camera has been selected.
5.10.3 Movement

The menu item “Movement” allows you change height settings and move the camera and milling head.

Click on Camera > Movement to open the following cascading menu:

![Camera > Movement menu](image)

The following functions are available:
- Set focus height
- Move to focus
- Move camera >> head
- Move head >> camera

5.10.3.1 Set focus height

The function “Set focus height” lets you set the current camera height as the focus height.

This function is best used after using the “Auto focus” function.

Tip

- Setting the current height as the focus height
  1. Click on Camera > Movement > Set focus height.
  - The current height is stored as the focus height.

5.10.3.2 Move to focus

The function “Move to focus” lets you move the camera to the set focus height.

- Moving to the focus height
  1. Click on Camera > Movement > Move to focus.
  - The camera moves to the set focus height.
5.10.3.3 Move camera >> head

The function “Move camera >> head” lets you move the camera to the current position of the milling head.

This function is useful for e.g. checking drilled holes.

Tip

- Moving the camera to the current position of the milling head
  1. Click on Camera > Movement > Move camera >> head.
  - The camera moves to the current position of the milling head.

5.10.3.4 Move head >> camera

The function “Move head >> camera” lets you move the milling head to the current position of the camera.

- Moving the milling head to the current position of the camera
  1. Click on Camera > Movement > Move head >> camera.
  - The milling head moves to the current position of the camera.

5.10.4 Overlay

The menu item “Overlay” allows you to modify the settings for the camera pane. Click on Camera > Overlay to open the following cascading menu:

![Camera Overlay Menu]

The following functions are available in the “Overlay” cascading menu:

- Switch Crosshair State
- Clear Overlay
- Set Color
5.10.4.1 Switch Crosshair State

The “Switch Crosshair State” function lets witch on or off the display of the crosshair in the “Camera” pane.

- Switching the crosshair on/off

1. Click on Camera > Overlay > Switch Crosshair State.

- The view in the “Camera” pane changes as follows:

- The crosshair serving as a centering aid is displayed/hidden in the “Camera” pane.
5.10.4.2 Clear Overlay

The “Clear Overlay” function lets you clear the camera pane of overlaid elements.

- Clearing the camera image of overlays
  1. Click on Camera > Overlay > Clear Overlay.
  ➔ Overlaid elements are removed from the “Camera” pane:

- The overlays are cleared.
5.10.4.3 Set color

The menu item “Set color” allows you to set the colors of the camera overlays.

- Setting the overlay color

1. Click on Camera > Overlay > Set color.

   ➔ The following dialog is displayed:

2. Click on the arrow to open the drop-down list of the settings:

3. Select a setting:

   The following settings are available:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overlay</td>
<td>Display color of the crosshair</td>
</tr>
<tr>
<td>Circle</td>
<td>Color for displaying the results of a fiducial search</td>
</tr>
<tr>
<td>Measure</td>
<td>Display color of the measure function</td>
</tr>
</tbody>
</table>

4. Confirm your selection by clicking on [OK].

   ➔ The following dialog for selecting the color is displayed:
5. Select a color.

For a wider choice of colors click on [More colors…].

Tipp

6. Click on [OK].

◆ The color has been set.

5.10.5 Search

The sub-menu “Search” allows you to set parameters the search functions and to perform search operations.

Click on Camera > Search to open the following cascading menu:

![Camera > Search](image)

The following functions are available in the “Search” sub-menu:

- Find Circles
- Find Lines
- Spiral Search
- Find Corner
5.10.5.1 Find Circles

The “Find Circles” function lets you find circles in the camera image.

- Finding circles
  1. Click on Camera > Search > Find Circles.
    - The number of circles found and their parameters are displayed in a dialog (/2/). In addition, the circle is displayed in the camera pane (/1/):

![Fig. 395: Find Circles](image)

/1/ Circle in camera pane  /2/ Message Find Circles Results

- The circles are found in the camera image.

**Note**

For removing the overlay items in the “Camera” pane, please click on Camera > Overlay > Clear overlay.
5.10.5.2 Find Lines

The “Find Lines” function lets you find lines in the camera image.

- Finding lines
  1. Click on Camera > Search > Find lines.

  ➔ The following message is displayed, showing the results if the line search and their parameters.

  ![Line search result](image)

  ➔ In addition, the line is displayed in the camera pane:

  ![Find Lines Camera pane](image)

  ➔ The lines are found in the camera image.

For removing the overlay items in the “Camera” pane, please click on Camera > Overlay > Clear overlay.
5.10.5.3  Spiral Search

The “Spiral search” function lets you search in a spiral over an area to find fiducials.

- Starting a spiral search
  1. Click on Camera > Search > Spiral search.

- The following dialog is displayed:

2. If necessary, modify the settings in category “Spiral search parameters”.

The following settings are available:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ask for acceptance</td>
<td>Specifies whether the user has to accept every found fiducial.</td>
</tr>
<tr>
<td>Backlash avoid distance</td>
<td>Specifies the distance that the camera head moves before centering the fiducial in order to avoid errors due to backlash.</td>
</tr>
<tr>
<td>X</td>
<td>Distance in X direction</td>
</tr>
<tr>
<td>Y</td>
<td>Distance in Y direction</td>
</tr>
<tr>
<td>Diameter tolerance</td>
<td>Specifies the allowable absolute size difference from the nominal diameter for the minimum and maximum recognized diameter.</td>
</tr>
<tr>
<td>Fiducial display time</td>
<td>Specifies the time the head rests over the fiducial after recognition.</td>
</tr>
<tr>
<td>Force manual centering</td>
<td>Specifies whether the dialog for manual centering is displayed even if a fiducial has been recognized.</td>
</tr>
<tr>
<td>Manual centering on fail</td>
<td>Specifies whether the dialog for manual centering is displayed if automatic centering has failed.</td>
</tr>
<tr>
<td>Max tries for centering</td>
<td>Specifies the maximum tries for centering until the fiducial is specified as not found.</td>
</tr>
<tr>
<td>Minimum valid quality</td>
<td>Defines the minimum quality that has to be reached at the start of the spiral search.</td>
</tr>
</tbody>
</table>
3. Click on [Start].

The camera searches for fiducials in spirals. When a fiducial is found, the following message is displayed:

![Service Info](image1)

If no fiducial is found the following message is displayed:

![Service Info](image2)

**Fiducial not found**
Check whether the camera head is really above the fiducials that are to be found. Otherwise move the head manually to that area and adjust the size of the search area “Search area size” if necessary.

The spiral search for fiducials is finished.

Click on Camera > Overlay > Clear overlay to clear the “Camera” pane of the overlays.

### Table 56: Spiral Search

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum quality improvement</td>
<td>Specifies the minimum quality improvement necessary for continuing the centering.</td>
</tr>
<tr>
<td>Search area size</td>
<td>Specifies size of the area around the start location where the fiducial is searched.</td>
</tr>
<tr>
<td>Threshold distance</td>
<td>Specifies the threshold distance for accepting the fiducial directly without further centering.</td>
</tr>
</tbody>
</table>
5.10.5.4 Find Corner

The “Find corner” function lets you find corners.

- Finding a corner
  1. Click on Camera > Search > Find corner.
  
  ➔ The number of corners found and their parameters are displayed in a dialog (/2/). In addition, the corner is displayed in the camera pane (/1/):

- The corners are found in the camera image.

---

For removing the overlay items in the “Camera” pane, please click on Camera > Overlay > Clear overlay.
5.11 Menu Extras

The menu “Extras” allows you to change the program settings. Click on the “Extras” menu item to open the submenu:

![Extras menu](image)

The following table provides a brief description of the menu item’s functions:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options…</td>
<td>Opens the dialog “Options”.</td>
</tr>
<tr>
<td>Customize…</td>
<td>Opens the dialog “Customize”.</td>
</tr>
</tbody>
</table>

5.11.1 Options

The “Options” dialog allows you to modify specific program settings. Click on Extras > Options to open the following dialog:

![Options dialog](image)
The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Application</strong></td>
<td></td>
</tr>
<tr>
<td>User level</td>
<td>Choice between “Advanced user” and “Service”.</td>
</tr>
<tr>
<td>Use OS culture</td>
<td>Choice between “True” and “False”.</td>
</tr>
<tr>
<td><strong>Language</strong></td>
<td>Sets the language of the application interface.</td>
</tr>
<tr>
<td></td>
<td>Choice is only available if “Use OS culture” is set to “False”.</td>
</tr>
<tr>
<td></td>
<td>• Deutsch (Deutschland)</td>
</tr>
<tr>
<td></td>
<td>• español (España)</td>
</tr>
<tr>
<td></td>
<td>• suomi (Suomi)</td>
</tr>
<tr>
<td></td>
<td>• français (France)</td>
</tr>
<tr>
<td></td>
<td>• italiano (Italia)</td>
</tr>
<tr>
<td></td>
<td>• 日本語 (日本)</td>
</tr>
<tr>
<td></td>
<td>• polski (Polska)</td>
</tr>
<tr>
<td></td>
<td>• português (Portugal)</td>
</tr>
<tr>
<td></td>
<td>• русский (Россия)</td>
</tr>
<tr>
<td></td>
<td>• slovenski (Slovenija)</td>
</tr>
<tr>
<td></td>
<td>• svenska (Sverige)</td>
</tr>
<tr>
<td></td>
<td>• English (United States)</td>
</tr>
<tr>
<td></td>
<td>• 中文 (简体)</td>
</tr>
<tr>
<td><strong>Units</strong></td>
<td>Units used in the application.</td>
</tr>
<tr>
<td></td>
<td>Choice is only available if “Use OS culture” is set to “False”.</td>
</tr>
<tr>
<td></td>
<td>• Meters [m]</td>
</tr>
<tr>
<td></td>
<td>• Centimeters [cm]</td>
</tr>
<tr>
<td></td>
<td>• Millimeters [mm]</td>
</tr>
<tr>
<td></td>
<td>• Micrometers [µm]</td>
</tr>
<tr>
<td></td>
<td>• Inches [inch]</td>
</tr>
<tr>
<td></td>
<td>• Mils [mil]</td>
</tr>
<tr>
<td><strong>Decimal separator</strong></td>
<td>Choice between dot (.) and comma (,) if “Use OS culture” is set to “False”.</td>
</tr>
<tr>
<td><strong>Auto save</strong></td>
<td></td>
</tr>
<tr>
<td>Time interval (min)</td>
<td>Defines the time until a document is saved.</td>
</tr>
<tr>
<td>Auto save mode</td>
<td>Switches auto saving on or off</td>
</tr>
<tr>
<td><strong>Undo/Redo</strong></td>
<td></td>
</tr>
<tr>
<td>Undo/Redo level</td>
<td>Undo/Redo level</td>
</tr>
<tr>
<td><strong>User and license information</strong></td>
<td>User name in the current application session</td>
</tr>
<tr>
<td><strong>User name</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Organization</strong></td>
<td>User organization of the current application runtime license.</td>
</tr>
<tr>
<td><strong>Location</strong></td>
<td>Organization location of the current application runtime license.</td>
</tr>
<tr>
<td><strong>Serial number</strong></td>
<td>Serial number of the current application runtime license.</td>
</tr>
</tbody>
</table>
### Table 58: Options “General”

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabling code</td>
<td>Enabling code of the current application runtime license.</td>
</tr>
</tbody>
</table>

### Table 59: Options “General” buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Closes the dialog and stores the settings.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Closes the dialog without storing the settings.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Check box</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use document preferences</td>
<td>Activate this check box if you want to use the standard settings stored the document.</td>
</tr>
</tbody>
</table>

You can modify further settings in the following categories:

- Display
- Measurement
- Import/Export
  - Import Assignments
  - Export configurations
  - Formats
    - Gerber
    - Excellon
    - LMD
    - HPGL
    - DXF
    - STEP
- Miscellaneous
- CAM settings
- Machine
Use the categories tree that is displayed in the left section of the dialog to navigate to the desired options (see the following figure).
Display

Click on “Display” in the “Options” dialog to display the following view:

Table 60: Options “Display”

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>2D CAM view</strong></td>
<td></td>
</tr>
<tr>
<td>Background color</td>
<td>Sets the background color of the CAM view.</td>
</tr>
<tr>
<td>Pan &amp; zoom rectangle color</td>
<td>Sets the color of the visible-area rectangle in the Navigation view.</td>
</tr>
<tr>
<td>Show grid</td>
<td>Activates/deactivates grid in CAM view. Choice between “True” and “False”</td>
</tr>
<tr>
<td>Show page outlines</td>
<td>Display how the printed region will be divided into several pages.</td>
</tr>
<tr>
<td>Snap to grid</td>
<td>Sets whether the cursor &quot;sticks to&quot; grid nodes in CAM view or not (only active if &quot;Show grid&quot; is set to “True”).</td>
</tr>
<tr>
<td>Spacing X</td>
<td>Sets the grid spacing in X direction in the CAM view.</td>
</tr>
<tr>
<td>Spacing Y</td>
<td>Sets the grid spacing in Y direction in the CAM view.</td>
</tr>
<tr>
<td>Transparency of major lines</td>
<td>Sets the transparency of the major lines</td>
</tr>
<tr>
<td>Transparency of minor lines</td>
<td>Sets the transparency of the minor lines.</td>
</tr>
<tr>
<td><strong>2D Machining view</strong></td>
<td></td>
</tr>
<tr>
<td>Auxiliary board length</td>
<td>Defines the length of rectangle of auxiliary board during dispensing operation.</td>
</tr>
</tbody>
</table>
### Table 60: Options “Display”

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auxiliary board rectangle color</td>
<td>Defines the color of the rectangle of the auxiliary board during dispensing operation.</td>
</tr>
<tr>
<td>Auxiliary board width</td>
<td>Defines the width of the rectangle of the auxiliary board during the dispensing operation.</td>
</tr>
<tr>
<td>Background color</td>
<td>Sets the background color of the 2D machining view.</td>
</tr>
<tr>
<td>Camera area color</td>
<td>Sets the display color of the camera area.</td>
</tr>
<tr>
<td>Camera area line style</td>
<td>Sets the line style of the boundary of the camera area.</td>
</tr>
<tr>
<td>Material area color</td>
<td>Sets the display color of the material area.</td>
</tr>
<tr>
<td>Material area line style</td>
<td>Sets the line style of the material area boundary.</td>
</tr>
<tr>
<td>Max processing area color</td>
<td>Sets the display color of the maximum processing area.</td>
</tr>
<tr>
<td>Max processing area line style</td>
<td>Sets the line style of the maximum processing area boundary.</td>
</tr>
<tr>
<td>Placement rectangle color</td>
<td>Defines the color for the rectangle of production data during placement operation.</td>
</tr>
<tr>
<td>Reference hole color</td>
<td>Sets the color of the positions where the reference holes have been drilled.</td>
</tr>
<tr>
<td>Show material</td>
<td>Activate/deactivate display of material area, max processing area and tool magazine.</td>
</tr>
<tr>
<td>Tool ramp color</td>
<td>Sets the color for the milling-width adjustment ramp.</td>
</tr>
<tr>
<td>Topography points color</td>
<td>Sets the color for displaying the points for a “Read topography” phase when the operation is active</td>
</tr>
<tr>
<td>Working area color</td>
<td>Sets the display color of the working area.</td>
</tr>
<tr>
<td>Working area line style</td>
<td>Sets the line style of the boundary of the working area.</td>
</tr>
</tbody>
</table>

#### 3D View

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background color</td>
<td>Sets the background color of the 3D view.</td>
</tr>
</tbody>
</table>

#### Common

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamic highlighting</td>
<td>Sets the tracking mode of objects under the mouse cursor in graphic views, also known as dynamic highlighting.</td>
</tr>
<tr>
<td>Performance and quality settings</td>
<td>Sets the priority for speed versus precision.</td>
</tr>
<tr>
<td>Show jumps in toolpath</td>
<td>Activate/deactivate display of jumps between toolpath lines.</td>
</tr>
</tbody>
</table>
Measurement

Click on “Measurement” in the “Options” dialog to display the following view:

![Options dialog](image)

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Measurement settings</td>
<td>Coordinate system used in the application: Cartesian or Polar.</td>
</tr>
<tr>
<td></td>
<td>Coordinates</td>
</tr>
<tr>
<td></td>
<td>Input of coordinates in the application: absolute or relative values.</td>
</tr>
</tbody>
</table>
Import / Export

Click on “Import / Export in the “Options” dialog to display the following view:

![Image of Import/Export settings]

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Import</strong></td>
<td></td>
</tr>
<tr>
<td>Compact data</td>
<td>If set to “True”, geometrical objects that are composed of a lot of smaller objects are replaced with a single polygon that fills the same area.</td>
</tr>
<tr>
<td>Reduce number of elements</td>
<td>If set to “True”, the number of elements for open/closed paths and polygons is reduced.</td>
</tr>
<tr>
<td><strong>Preview</strong></td>
<td></td>
</tr>
<tr>
<td>New layer's color</td>
<td>Preview color for objects that are assigned to the new layer.</td>
</tr>
</tbody>
</table>
Import assignments

Click on “Import assignments” in the “Options” dialog to display the following view:

Fig. 408: Extras > Options “Import assignments”

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aperture Templates</td>
<td>Selects the path of an existing aperture template file.</td>
</tr>
<tr>
<td>Import Assignments</td>
<td>Selects the path of an existing assignments file. You can also select a new XML file by entering a new file name.</td>
</tr>
</tbody>
</table>
**Table 64: Columns**

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Defines the file extension for assignment.</td>
</tr>
<tr>
<td>Format</td>
<td>Assigns the format for the import.</td>
</tr>
<tr>
<td>Layer/Template</td>
<td>Defines the destination layer for the import.</td>
</tr>
<tr>
<td>Aperture/Tool List</td>
<td>Defines the aperture / tool list.</td>
</tr>
</tbody>
</table>

**Table 65: Import Assignments - buttons**

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Allows to create new assignment rules. These assignment rules are written to the selected XML file. Thus, you can define for example that imported files having specific file extensions are always assigned to a specific layer.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected assignment rule(s).</td>
</tr>
</tbody>
</table>

**Table 66: Options**

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust Excellon files</td>
<td>This option affects the format settings of the Excellon file. CircuitPro PM automatically selects the settings that cause the best fit to those of the Gerber X data. <strong>Attention!</strong> If the Gerber X files contain further information (e.g. crosshairs or bounding box) except the PCB, the drill data could be scaled incorrectly. In such cases disable this option or adjust the format settings manually.</td>
</tr>
</tbody>
</table>
Export configurations

Click on “Export configurations” in the “Options” dialog to display the following view:

The following settings are available:

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configurations file</td>
<td>Enter the path to the configuration file. You can select/change the path by clicking the button next to it.</td>
</tr>
<tr>
<td>Configurations</td>
<td>The available configurations that are located in the current configuration file are listed. You can add or remove configurations by clicking the buttons “Add” and “Remove”.</td>
</tr>
<tr>
<td>Parameters</td>
<td></td>
</tr>
<tr>
<td>File Name</td>
<td>Enter the file name with which the file is to be exported.</td>
</tr>
<tr>
<td>Format</td>
<td>Enter the file format in which the file is to be exported.</td>
</tr>
<tr>
<td>Source objects</td>
<td>Enter the source objects which are to be exported in the file.</td>
</tr>
</tbody>
</table>
Gerber

Click on “Formats > Gerber” in the “Options” dialog to display the following view:

![Gerber Settings Dialog](image)

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import</td>
<td>Activate/deactivate 360-degree interpolation as default.</td>
</tr>
<tr>
<td>Rotate AM octagon</td>
<td>Always align octagon borders to axes.</td>
</tr>
<tr>
<td>Rotate Square</td>
<td>Activate/deactivate automatic rotation of square objects during Gerber import.</td>
</tr>
<tr>
<td>Step and repeat to flash</td>
<td>Activate/deactivate combining object collections to flash objects for step-and-repeat commands.</td>
</tr>
<tr>
<td>Use layer name</td>
<td>Use the layer name defined in the Gerber file.</td>
</tr>
<tr>
<td>Use layer polarity</td>
<td>Activate/deactivate analysis of layer polarity during Gerber import.</td>
</tr>
</tbody>
</table>
Excellon

Click on “Formats > Excellon” in the “Options” dialog to display the following view:

![Excellon Options](image)

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fiducial diameter</td>
<td>Sets the diameter of fiducial objects when importing Excellon files.</td>
</tr>
<tr>
<td>Pin hole diameter</td>
<td>Sets the diameter of the pin hole when importing Excellon files.</td>
</tr>
</tbody>
</table>
LMD

Click on “Formats > LMD” in the “Options” dialog to display the following view:

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools conversion file</td>
<td>Defines the path of the file for tool conversion. You can also select a new XML file by entering a new file name.</td>
</tr>
<tr>
<td>Tool to be replaced</td>
<td>Defines the tool to be replaced.</td>
</tr>
<tr>
<td>Tool to be used</td>
<td>Defines the tool to be used instead.</td>
</tr>
</tbody>
</table>
HPGL

Click on "Formats > HPGL" in the "Options" dialog to display the following view:

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data type</td>
<td>Defines how to import the HPGL data: as geometrical objects or toolpaths</td>
</tr>
<tr>
<td>Plotter resolution</td>
<td>Defines the plotter resolution used by the HPGL file.</td>
</tr>
<tr>
<td>Resolution unit</td>
<td>Defines the resolution units (mm or inch).</td>
</tr>
</tbody>
</table>
DXF

Click on "Formats > DXF" in the "Options" dialog to display the following view:

![DXF Options Dialog](image)

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import</td>
<td></td>
</tr>
<tr>
<td>Default font</td>
<td>The default font is used to replace fonts defined in a DXF file that are not installed on this PC.</td>
</tr>
</tbody>
</table>
STEP

Click on “Formats > STEP” in the “Options” dialog to display the following view:
Miscellaneous

Click on “Miscellaneous” in the “Options” dialog to display the following view:

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common</td>
<td></td>
</tr>
<tr>
<td>Bounding box if number of objects greater</td>
<td>Show a bounding box when moving objects in the CAM view if the number of objects exceeds this value.</td>
</tr>
<tr>
<td>Maximal printed pages</td>
<td>Defines the maximal count of pages that can be printed.</td>
</tr>
<tr>
<td>Message pop-up</td>
<td>Sets the types of messages shown as pop-up message boxes (in addition to a record in the Message View).</td>
</tr>
<tr>
<td>Message pop-up w/o Message View</td>
<td>Sets types of messages shown as pop-up message box when the Message view is closed.</td>
</tr>
<tr>
<td>Show conductor objects</td>
<td>Activates/deactivates (default) the display of conductor objects in the Geometry data view.</td>
</tr>
<tr>
<td>Store last choice of delete object operation: with dependent objects or without.</td>
<td>Defines whether the last choice of the “delete object operation: with dependent objects or without” is stored. Used when the warning delete dialog is not shown.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Fiducial</td>
<td></td>
</tr>
<tr>
<td>Diameter</td>
<td>Defines the diameter of fiducials.</td>
</tr>
<tr>
<td>Logging</td>
<td></td>
</tr>
<tr>
<td>Verbose</td>
<td>If “Verbose” is set to true, the application diagnostic messages are listed in the Message View as “Service messages”.</td>
</tr>
<tr>
<td>Read Topography</td>
<td></td>
</tr>
<tr>
<td>Grid spacing X</td>
<td>Sets the spacing of the grid in X direction for the operation 'Read topography'</td>
</tr>
<tr>
<td>Grid spacing Y</td>
<td>Sets the spacing of the grid in Y direction for the operation 'Read topography'</td>
</tr>
<tr>
<td>Tolerances</td>
<td></td>
</tr>
<tr>
<td>Accuracy for curve modifications</td>
<td>Precision value used for curve modification operations (all modify geometry operations, Close path, Convert to path, Combine open paths, Convert to polygon, Draw to flash).</td>
</tr>
<tr>
<td>Curve combine</td>
<td>Defines the tolerance for the maximum distance between two objects that are to be combined.</td>
</tr>
<tr>
<td>Tool library</td>
<td></td>
</tr>
</tbody>
</table>
| Save tools inside document    | **True:** All settings in the tool library are stored in the project's corresponding document file.  
**False:** All settings in the tool library are stored in the common "ToolLibrary.xml" file and are thus available to all projects. |
| Standard tool library file    | Path of the standard tool library file (ToolLibrary.xml), used for new projects.        |
| Tool instances library file   | Path of the tool library file that contains descriptions of real machine tools.        |
| Toolpath generation           |                                                                                           |
| Circular arc approximation    | Defines whether arc elements are approximated                                          |
| Default spike angle           | Sets the default spike angle for the insulation algorithm.                            |
| Default spike width           | Sets the default spike width for the insulation algorithm.                            |
| Default tolerance             | Sets the default tolerance for toolpath generation algorithms.                        |
| Max cutting link length       | Defines the maximum length of a cutting link between toolpath sections.                |
### Table 73: Options "Miscellaneous"

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Max joinable pin length</td>
<td>Defines the maximum pin movement length that is joined without jump to the adjacent curve.</td>
</tr>
<tr>
<td>Maximum size of remaining part</td>
<td>Maximum size of remaining part</td>
</tr>
</tbody>
</table>

### CAM settings

Click on “CAM settings” in the “Options” dialog to display the following view:

![CAM settings dialog](image)

The following settings are available:

### Table 74: Extras > Options “CAM settings”

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.5D mode settings</td>
<td></td>
</tr>
<tr>
<td><strong>Maximum Z level (2.5D milling)</strong></td>
<td>Defines the maximum value for the Z level for 2.5D milling.</td>
</tr>
<tr>
<td><strong>Maximum Z level (pocketing)</strong></td>
<td>Defines the maximum value for the Z level for pocketing.</td>
</tr>
<tr>
<td><strong>Overlap distance</strong></td>
<td>Defines the additional distance that the tool moves at the end of a closed milling path to overlap the start. The value is in percent of the tool diameter. 0% means that start and end only touch.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ramp distance</td>
<td>Defines the height to lift the tool above a surface already cut when the tool does a jump between cutting movements within a pocket.</td>
</tr>
<tr>
<td>Safety distance</td>
<td>Defines the height to lift the tool above the horizontal surface when the tool does a jump between cutting movements.</td>
</tr>
<tr>
<td>Tolerance</td>
<td>Tolerance used for computation.</td>
</tr>
<tr>
<td>Tool rotation</td>
<td>Defines the direction of tool rotation.</td>
</tr>
</tbody>
</table>

**PCB milling, drilling, contour routing**

| Use start drill for contour router | Indicates whether start drills should be generated for contour routing.                                                                       |
Machine

Click on “Machine” in the “Options” dialog to display the following view:

The following settings are available:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.5D fixture plate thickness</td>
<td>Thickness of fixture plate below the material. Only used in 2.5D jobs.</td>
</tr>
<tr>
<td>Camera lens type</td>
<td>If you are using an upgrade or replacement camera, you need to set your camera type here to work with the correct camera calibration parameters.</td>
</tr>
<tr>
<td>Default end mill depth</td>
<td>This is the default end mill depth. It is for uncalibrated end mills only. The real depth may vary up to ±15 µm.</td>
</tr>
<tr>
<td>Extraction system monitoring</td>
<td>If the extraction system is monitored, the machine stops processing if the extraction system is off. This is not possible with all types of extraction systems.</td>
</tr>
<tr>
<td>MKHP plate height</td>
<td>Defines the thickness of the MKHP plate.</td>
</tr>
<tr>
<td>MKHP plate mounted</td>
<td>Defines whether the MKHP plate is mounted or not.</td>
</tr>
<tr>
<td>Sinter plate thickness</td>
<td>Defines the thickness of the sinter plate.</td>
</tr>
<tr>
<td>Underlay plate thickness</td>
<td>Defines the thickness of the underlay plate.</td>
</tr>
<tr>
<td>Vacuum table mounted</td>
<td>Defines whether the vacuum table is mounted or not.</td>
</tr>
</tbody>
</table>
Table 75: Extras > Options

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vacuum-system turn-off delay</td>
<td>Defines the time that the vacuum system keeps running after end of processing.</td>
</tr>
</tbody>
</table>

**Process settings**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dust reduction</td>
<td>Reduces the dust produced during contour routing. This option will increase the processing time.</td>
</tr>
<tr>
<td>Keep tool during optical alignment</td>
<td>Determines whether the tool is kept in the clamp during optical alignments.</td>
</tr>
</tbody>
</table>

### 5.11.2 Customize

The menu item “Customize” allows you to adapt the operation of the program to your needs.

Click on Extras > Customize to open the following dialog:

![Customization dialog](image)

The dialog has 5 tabs with corresponding settings:

- Commands
- Toolbars
- Keyboard
- Options
- Layouts
Commands tab

Click on the “Commands” tab in the “Customization” dialog to display the following view:

The “Commands” tab allows you to customize the toolbars to your needs. When you click on a category the corresponding command lists are displayed. You can drag and drop the commands to the desired position in any toolbar. Thus you can have fast and easy access to frequently used functions in the toolbar.

Example:

- Inserting the “Polygon” command into the toolbar
  1. Click in “Category” on “Insert”.
     - The corresponding command list is displayed.
  2. Click in “Command” on “Polygon”.
  3. Drag the mouse pointer with the left mouse button pressed to the desired position in the toolbar.
The mouse pointer is displayed as follows:

4. Release the left mouse button.

The "Polygon" icon is displayed at the desired position in the toolbar:
You can insert separators between the icons in the toolbar by using the [Separator] button and drag and drop. Click on [Separator] and drag the mouse pointer with the left mouse button pressed to the desired position in the toolbar.

◆ The “Polygon” command has been inserted into the toolbar.

**Toolbars tab**

Click on the “Toolbars” tab in the “Customization” dialog to display the following view:

1. Activation of the toolbars
2. [New…] - creates a new toolbar
3. [Rename] - renames the selected toolbar
4. [Delete] - deletes the selected toolbar
5. [Close] - Closes the “Customization” dialog.
Keyboard tab

Click on the “Keyboard” tab in the “Customization” dialog to display the following view:

1/ Lists the menu items with their sub-menus and their assigned keyboard shortcuts
2/ [Assign] - assigns a new shortcut
3/ [Delete] - deletes the shortcut
4/ Description of the menu item currently selected in 1/
5/ [Close] - Closes the “Customization” dialog.

Options tab

Click on the “Options” tab in the “Customization” dialog to display the following view:

1/ Setting for the icon size
2/ Display mode of the toolbars (with/without text/icon)
3/ Activate/deactivate display of tooltips in toolbars
4/ Activate/deactivate display of keyboard shortcuts in tooltips
5/ [Close] - Closes the “Customization” dialog.
Layouts tab

Click on the “Layouts” tab in the “Customization” dialog to display the following view:

- **1** List of existing layouts
- **2** [Save current] - saves the current layout under its current name
- **3** [Rename] - saves the layout under a new name
- **4** [Delete selected] - deletes the selected layout
- **5** [Close] - closes the “Customization” dialog

This view allows you to save the settings made in the other tabs under a new layout name.

**Note**

You can find the layouts at View > Layouts where you can switch to the desired screen layout.
5.12 Menu Help

The menu “Help” provides information about the current software version. Click on the “Help” menu item to open the submenu:

![Help menu](image)

The following table provides a brief description of the menu item’s functions:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>Opens the CircuitPro PM offline help.</td>
</tr>
<tr>
<td>About…</td>
<td>Opens the dialog “About this program” that contains information about CircuitPro PM.</td>
</tr>
<tr>
<td>System information…</td>
<td>Contains information about the computer that CircuitPro PM is installed on.</td>
</tr>
</tbody>
</table>

5.12.1 Help

The menu item “Help” calls up the offline help of CircuitPro PM.
5.12.2 About

The menu item “About” contains information about the program.

1. Click on Help > About…

   The following dialog is displayed:

   ![About dialog](image)

   - Click on [License Contract] to view the license contract.
   - Click on [Third party] to view the list of third party licenses used by Circuit Pro PM.
   - Click on [Copy Info] to copy the program list to the clipboard.
   - Click on [Close] to close the dialog.
5.12.3 System information

The menu item “System information” contains information about your computer. Click on Help > System information.

The following dialog is displayed:
# 6 Appendix

## 6.1 Table of figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fig. 1</td>
<td>LPKF CircuitPro PM</td>
<td>11</td>
</tr>
<tr>
<td>Fig. 2</td>
<td>Installation and update information</td>
<td>16</td>
</tr>
<tr>
<td>Fig. 3</td>
<td>LPKF setup wizard</td>
<td>17</td>
</tr>
<tr>
<td>Fig. 4</td>
<td>License agreement</td>
<td>17</td>
</tr>
<tr>
<td>Fig. 5</td>
<td>Choosing the installation folder</td>
<td>18</td>
</tr>
<tr>
<td>Fig. 6</td>
<td>Confirm installation</td>
<td>19</td>
</tr>
<tr>
<td>Fig. 7</td>
<td>Installation of CircuitPro PM 2.1</td>
<td>19</td>
</tr>
<tr>
<td>Fig. 8</td>
<td>Warning message</td>
<td>20</td>
</tr>
<tr>
<td>Fig. 9</td>
<td>Installation complete</td>
<td>20</td>
</tr>
<tr>
<td>Fig. 10</td>
<td>CircuitPro PM splash screen</td>
<td>21</td>
</tr>
<tr>
<td>Fig. 11</td>
<td>New document</td>
<td>22</td>
</tr>
<tr>
<td>Fig. 12</td>
<td>Start-up screen “Equipment configuration wizard”</td>
<td>23</td>
</tr>
<tr>
<td>Fig. 13</td>
<td>CircuitPro user interface</td>
<td>25</td>
</tr>
<tr>
<td>Fig. 14</td>
<td>CAM View</td>
<td>27</td>
</tr>
<tr>
<td>Fig. 15</td>
<td>Toolbar CAM View</td>
<td>28</td>
</tr>
<tr>
<td>Fig. 16</td>
<td>Context menu “Polygonal selection”</td>
<td>29</td>
</tr>
<tr>
<td>Fig. 17</td>
<td>Machining view E33</td>
<td>30</td>
</tr>
<tr>
<td>Fig. 18</td>
<td>Machining view S43</td>
<td>31</td>
</tr>
<tr>
<td>Fig. 19</td>
<td>Machining view S63/S103</td>
<td>32</td>
</tr>
<tr>
<td>Fig. 20</td>
<td>Machining view D104</td>
<td>33</td>
</tr>
<tr>
<td>Fig. 21</td>
<td>Toolbar “Machining view”</td>
<td>34</td>
</tr>
<tr>
<td>Fig. 22</td>
<td>Context menu “Polygonal selection”</td>
<td>35</td>
</tr>
<tr>
<td>Fig. 23</td>
<td>3D View</td>
<td>36</td>
</tr>
<tr>
<td>Fig. 24</td>
<td>Toolbar “3D view”</td>
<td>37</td>
</tr>
<tr>
<td>Fig. 25</td>
<td>Toolbars</td>
<td>38</td>
</tr>
<tr>
<td>Fig. 26</td>
<td>Toolbar “Standard”</td>
<td>39</td>
</tr>
<tr>
<td>Fig. 27</td>
<td>Toolbar “Insert”</td>
<td>40</td>
</tr>
<tr>
<td>Fig. 28</td>
<td>Toolbar „Modify”</td>
<td>41</td>
</tr>
<tr>
<td>Fig. 29</td>
<td>Toolbar “Prototyping”</td>
<td>42</td>
</tr>
<tr>
<td>Fig. 30</td>
<td>Toolbar “Layout”</td>
<td>42</td>
</tr>
<tr>
<td>Fig. 31</td>
<td>Pane “Layers”</td>
<td>44</td>
</tr>
<tr>
<td>Fig. 32</td>
<td>Pane “Geometry”</td>
<td>45</td>
</tr>
<tr>
<td>Fig. 33</td>
<td>Pane “Toolpath”</td>
<td>45</td>
</tr>
<tr>
<td>Fig. 34</td>
<td>Pane “Processing”</td>
<td>46</td>
</tr>
<tr>
<td>Fig. 35</td>
<td>Pane “Properties”</td>
<td>48</td>
</tr>
<tr>
<td>Fig. 36</td>
<td>Pane “Tool info”</td>
<td>49</td>
</tr>
<tr>
<td>Fig. 37</td>
<td>Pane “Navigation”</td>
<td>50</td>
</tr>
<tr>
<td>Fig. 38</td>
<td>Pane “Camera”</td>
<td>51</td>
</tr>
<tr>
<td>Fig. 39</td>
<td>Pane “Messages”</td>
<td>52</td>
</tr>
<tr>
<td>Fig. 40</td>
<td>Pane “Fault Monitor”</td>
<td>53</td>
</tr>
<tr>
<td>Fig. 41</td>
<td>Menu bar CircuitPro PM</td>
<td>54</td>
</tr>
<tr>
<td>Fig. 42</td>
<td>Menu “File”</td>
<td>55</td>
</tr>
</tbody>
</table>
Fig. 137: Copy aperture list to document ................................................................. 128
Fig. 138: Design rule check ...................................................................................... 129
Fig. 139: Checking the spacing between 2 layers ...................................................... 130
Fig. 140: Result layer ................................................................................................. 130
Fig. 141: Violations count ......................................................................................... 130
Fig. 142: Checking the spacing within a layer ............................................................ 131
Fig. 143: Result layer ................................................................................................. 131
Fig. 144: Violations count ......................................................................................... 131
Fig. 145: Measure ..................................................................................................... 132
Fig. 146: Distance ..................................................................................................... 133
Fig. 147: Anchor point in CAM view ........................................................................ 134
Fig. 148: Anchor point in object ............................................................................... 134
Fig. 149: Set anchor point ......................................................................................... 135
Fig. 150: Set zero point on current anchor point ...................................................... 136
Fig. 151: Mark object ................................................................................................. 137
Fig. 152: Mark object ................................................................................................. 137
Fig. 153: Move layer to zero ..................................................................................... 138
Fig. 154: Flash object moved to the layer's zero point .............................................. 139
Fig. 155: Flash objects .............................................................................................. 140
Fig. 156: Match up layers ......................................................................................... 141
Fig. 157: Selecting the layer to be aligned ................................................................. 141
Fig. 158: Selecting the reference layer ..................................................................... 142
Fig. 159: Layer aligned ............................................................................................. 142
Fig. 160: Properties .................................................................................................. 143
Fig. 161: Drawn objects ............................................................................................ 144
Fig. 162: Match up objects ....................................................................................... 144
Fig. 163: Selecting object to align ........................................................................... 145
Fig. 164: Selecting reference object ...................................................................... 146
Fig. 165: Object aligned ............................................................................................ 146
Fig. 166: Selecting an object for deletion ................................................................. 147
Fig. 167: Menu “Insert” ......................................................................................... 148
Fig. 168: Open path examples ............................................................................... 149
Fig. 169: Selection mode (arrow icon) activated ..................................................... 150
Fig. 170: Open path ................................................................................................ 150
Fig. 171: Creating a segment .................................................................................. 151
Fig. 172: Creating a second segment ..................................................................... 152
Fig. 173: Selecting “Arc” in context menu ............................................................... 153
Fig. 174: Creating an arc ........................................................................................ 154
Fig. 175: Examples closed paths with segments and arcs ....................................... 155
Fig. 176: Selection mode (arrow icon) activated ..................................................... 155
Fig. 177: Closed path .............................................................................................. 156
Fig. 178: Creating a segment .................................................................................. 157
Fig. 179: Creating a second segment ..................................................................... 158
Fig. 180: Opening the context menu ...................................................................... 158
Fig. 181: Opening the context menu ...................................................................... 159
Fig. 182: Selecting “Arc” in context menu ............................................................... 160
Fig. 183: Creating an arc ........................................................................................ 161
Fig. 184: Closing an open path ................................................................. 161
Fig. 185: Polygon ........................................................................................ 162
Fig. 186: Selection mode (arrow icon) activated ..................................... 162
Fig. 187: Polygon ...................................................................................... 163
Fig. 188: Creating a segment ............................................................... 164
Fig. 189: Creating a second segment .................................................... 165
Fig. 190: Close polygon ........................................................................... 165
Fig. 191: Polygon area ............................................................................ 166
Fig. 192: Creating a segment ............................................................... 167
Fig. 193: Selecting “Arc” in context menu ........................................... 167
Fig. 194: Creating an arc ......................................................................... 168
Fig. 195: Attaching a segment to an arc ................................................ 169
Fig. 196: Attaching an arc to a segment ................................................ 169
Fig. 197: Selecting “Close” in context menu ........................................... 170
Fig. 198: Polygon area ............................................................................ 170
Fig. 199: Rectangle .................................................................................. 171
Fig. 200: Selection mode (arrow icon) activated .................................... 171
Fig. 201: Create Rectangle ................................................................. 172
Fig. 202: Circles ....................................................................................... 173
Fig. 203: Selection mode (arrow icon) activated .................................... 173
Fig. 204: Create Circle ........................................................................... 174
Fig. 205: “Absolute” option ............................................................... 174
Fig. 206: “Relative” option ............................................................... 175
Fig. 207: Circle paths ............................................................................. 176
Fig. 208: Selection mode (arrow icon) activated .................................... 176
Fig. 209: Create circle path ................................................................... 177
Fig. 210: “Absolute” option ............................................................... 177
Fig. 211: “Relative” option ............................................................... 178
Fig. 212: Create flash ............................................................................ 179
Fig. 213: Entering the flash coordinates .............................................. 179
Fig. 214: New flash object .................................................................... 180
Fig. 215: Define text .............................................................................. 181
Fig. 216: Text rotated by 90° .............................................................. 182
Fig. 217: Text mirrored on the Y axis .................................................. 183
Fig. 218: Polygons with cutouts ......................................................... 184
Fig. 219: Polygon and two circles ....................................................... 185
Fig. 220: Create polygon with cutouts .............................................. 185
Fig. 221: Select polygon ....................................................................... 186
Fig. 222: Select circles .......................................................................... 186
Fig. 223: Polygon with two circular cutouts ...................................... 187
Fig. 224: Copper pouring example .................................................... 188
Fig. 225: Rectangle and open path ..................................................... 189
Fig. 226: Create copper pouring ......................................................... 189
Fig. 227: Copper area (select rectangle) .............................................. 190
Fig. 228: Selecting the open path ....................................................... 190
Fig. 229: Entering offset ..................................................................... 191
Fig. 230: Isolated open path ............................................................... 191
<table>
<thead>
<tr>
<th>Figure Number</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>231</td>
<td>Rubout example</td>
<td>192</td>
</tr>
<tr>
<td>232</td>
<td>Create rubout area</td>
<td>193</td>
</tr>
<tr>
<td>233</td>
<td>Create rectangle</td>
<td>194</td>
</tr>
<tr>
<td>234</td>
<td>Technology dialog</td>
<td>195</td>
</tr>
<tr>
<td>235</td>
<td>Partial rubout</td>
<td>195</td>
</tr>
<tr>
<td>236</td>
<td>Complete rubout</td>
<td>195</td>
</tr>
<tr>
<td>237</td>
<td>Deactivated functions in the Technology dialog</td>
<td>196</td>
</tr>
<tr>
<td>238</td>
<td>Rubout area computation results</td>
<td>197</td>
</tr>
<tr>
<td>239</td>
<td>Create new layer</td>
<td>197</td>
</tr>
<tr>
<td>240</td>
<td>Circuit board with fiducials</td>
<td>198</td>
</tr>
<tr>
<td>241</td>
<td>Create circle</td>
<td>199</td>
</tr>
<tr>
<td>242</td>
<td>Creating a new fiducial layer</td>
<td>199</td>
</tr>
<tr>
<td>243</td>
<td>Circuit board with topography points</td>
<td>200</td>
</tr>
<tr>
<td>244</td>
<td>Defining topography points</td>
<td>201</td>
</tr>
<tr>
<td>245</td>
<td>Create new layer</td>
<td>202</td>
</tr>
<tr>
<td>246</td>
<td>Example for drilling holes</td>
<td>203</td>
</tr>
<tr>
<td>247</td>
<td>Create drill hole</td>
<td>204</td>
</tr>
<tr>
<td>248</td>
<td>Select layer</td>
<td>204</td>
</tr>
<tr>
<td>249</td>
<td>Select tool</td>
<td>205</td>
</tr>
<tr>
<td>250</td>
<td>Add marking drill</td>
<td>205</td>
</tr>
<tr>
<td>251</td>
<td>Create milling curve</td>
<td>206</td>
</tr>
<tr>
<td>252</td>
<td>Menu “Toolpath”</td>
<td>208</td>
</tr>
<tr>
<td>253</td>
<td>Dispense paths created on pads</td>
<td>209</td>
</tr>
<tr>
<td>254</td>
<td>Dispense</td>
<td>210</td>
</tr>
<tr>
<td>255</td>
<td>Adding solder paste path parameters</td>
<td>211</td>
</tr>
<tr>
<td>256</td>
<td>Pad size parameters</td>
<td>211</td>
</tr>
<tr>
<td>257</td>
<td>Editing pad size parameters</td>
<td>212</td>
</tr>
<tr>
<td>258</td>
<td>Pad size parameters</td>
<td>212</td>
</tr>
<tr>
<td>259</td>
<td>Deleting pad size parameters</td>
<td>213</td>
</tr>
<tr>
<td>260</td>
<td>Show details</td>
<td>213</td>
</tr>
<tr>
<td>261</td>
<td>Details</td>
<td>214</td>
</tr>
<tr>
<td>262</td>
<td>Create 2.5D milling</td>
<td>216</td>
</tr>
<tr>
<td>263</td>
<td>Technology Dialog</td>
<td>218</td>
</tr>
<tr>
<td>264</td>
<td>Insulate</td>
<td>219</td>
</tr>
<tr>
<td>265</td>
<td>Contour Routing</td>
<td>221</td>
</tr>
<tr>
<td>266</td>
<td>Drills</td>
<td>222</td>
</tr>
<tr>
<td>267</td>
<td>Fiducials</td>
<td>223</td>
</tr>
<tr>
<td>268</td>
<td>Pockets</td>
<td>224</td>
</tr>
<tr>
<td>269</td>
<td>Computation results</td>
<td>224</td>
</tr>
<tr>
<td>270</td>
<td>Contours of the circuit board</td>
<td>225</td>
</tr>
<tr>
<td>271</td>
<td>Edit breakout tabs position</td>
<td>226</td>
</tr>
<tr>
<td>272</td>
<td>X- and Y-values changed</td>
<td>227</td>
</tr>
<tr>
<td>273</td>
<td>Add a breakout tab</td>
<td>228</td>
</tr>
<tr>
<td>274</td>
<td>Menu “Modify”</td>
<td>230</td>
</tr>
<tr>
<td>275</td>
<td>Selecting an open path</td>
<td>232</td>
</tr>
<tr>
<td>276</td>
<td>Close open path</td>
<td>233</td>
</tr>
<tr>
<td>277</td>
<td>Closed path</td>
<td>234</td>
</tr>
<tr>
<td>Figure</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>Fig. 278</td>
<td>Selecting open paths</td>
<td></td>
</tr>
<tr>
<td>Fig. 279</td>
<td>Combining open paths</td>
<td></td>
</tr>
<tr>
<td>Fig. 280</td>
<td>Closed path</td>
<td></td>
</tr>
<tr>
<td>Fig. 281</td>
<td>Selecting the closed path</td>
<td></td>
</tr>
<tr>
<td>Fig. 282</td>
<td>Convert to polygon</td>
<td></td>
</tr>
<tr>
<td>Fig. 283</td>
<td>Polygon</td>
<td></td>
</tr>
<tr>
<td>Fig. 284</td>
<td>Select polygon</td>
<td></td>
</tr>
<tr>
<td>Fig. 285</td>
<td>Convert to closed path</td>
<td></td>
</tr>
<tr>
<td>Fig. 286</td>
<td>Closed path</td>
<td></td>
</tr>
<tr>
<td>Fig. 287</td>
<td>Select rectangle</td>
<td></td>
</tr>
<tr>
<td>Fig. 288</td>
<td>Flashed rectangle</td>
<td></td>
</tr>
<tr>
<td>Fig. 289</td>
<td>Selected objects</td>
<td></td>
</tr>
<tr>
<td>Fig. 290</td>
<td>New Aperture</td>
<td></td>
</tr>
<tr>
<td>Fig. 291</td>
<td>Objects combined to flash</td>
<td></td>
</tr>
<tr>
<td>Fig. 292</td>
<td>Initial situation</td>
<td></td>
</tr>
<tr>
<td>Fig. 293</td>
<td>Compare to flash</td>
<td></td>
</tr>
<tr>
<td>Fig. 294</td>
<td>Enter values</td>
<td></td>
</tr>
<tr>
<td>Fig. 295</td>
<td>Flashed rectangles</td>
<td></td>
</tr>
<tr>
<td>Fig. 296</td>
<td>Flash object</td>
<td></td>
</tr>
<tr>
<td>Fig. 297</td>
<td>Circle</td>
<td></td>
</tr>
<tr>
<td>Fig. 298</td>
<td>Convert object</td>
<td></td>
</tr>
<tr>
<td>Fig. 299</td>
<td>Convert into 2.5D</td>
<td></td>
</tr>
<tr>
<td>Fig. 300</td>
<td>2.5D object with “Create a copy”</td>
<td></td>
</tr>
<tr>
<td>Fig. 301</td>
<td>2.5D object without “Create a copy”</td>
<td></td>
</tr>
<tr>
<td>Fig. 302</td>
<td>Change Z value</td>
<td></td>
</tr>
<tr>
<td>Fig. 303</td>
<td>Selecting the object</td>
<td></td>
</tr>
<tr>
<td>Fig. 304</td>
<td>Selecting a destination layer</td>
<td></td>
</tr>
<tr>
<td>Fig. 305</td>
<td>2D object on destination layer</td>
<td></td>
</tr>
<tr>
<td>Fig. 306</td>
<td>Transform</td>
<td></td>
</tr>
<tr>
<td>Fig. 307</td>
<td>Rotate</td>
<td></td>
</tr>
<tr>
<td>Fig. 308</td>
<td>Scale</td>
<td></td>
</tr>
<tr>
<td>Fig. 309</td>
<td>Example</td>
<td></td>
</tr>
<tr>
<td>Fig. 310</td>
<td>Option “Scale group”</td>
<td></td>
</tr>
<tr>
<td>Fig. 311</td>
<td>Option “Scale each object individually”</td>
<td></td>
</tr>
<tr>
<td>Fig. 312</td>
<td>Mirror</td>
<td></td>
</tr>
<tr>
<td>Fig. 313</td>
<td>Rotate object by 90°</td>
<td></td>
</tr>
<tr>
<td>Fig. 314</td>
<td>Object rotated by 90°</td>
<td></td>
</tr>
<tr>
<td>Fig. 315</td>
<td>Mirror object</td>
<td></td>
</tr>
<tr>
<td>Fig. 316</td>
<td>Object mirrored</td>
<td></td>
</tr>
<tr>
<td>Fig. 317</td>
<td>Step and Repeat initial object</td>
<td></td>
</tr>
<tr>
<td>Fig. 318</td>
<td>Step &amp; Repeat dialog</td>
<td></td>
</tr>
<tr>
<td>Fig. 319</td>
<td>Multiplied objects</td>
<td></td>
</tr>
<tr>
<td>Fig. 320</td>
<td>Menu “View”</td>
<td></td>
</tr>
<tr>
<td>Fig. 321</td>
<td>Menu “Select”</td>
<td></td>
</tr>
<tr>
<td>Fig. 322</td>
<td>Menu “Wizards”</td>
<td></td>
</tr>
<tr>
<td>Fig. 323</td>
<td>Equipment configuration wizard</td>
<td></td>
</tr>
<tr>
<td>Fig. 324</td>
<td>Equipment configuration wizard - Summary</td>
<td></td>
</tr>
</tbody>
</table>
Fig. 325: Process planning wizard ................................................................. 271
Fig. 326: Process planning wizard - Summary ............................................. 272
Fig. 327: Board Production Wizard ............................................................... 273
Fig. 328: Board Production finished ............................................................... 274
Fig. 329: Dispense preparation wizard .......................................................... 275
Fig. 330: Fiducial recognized automatically .................................................. 276
Fig. 331: Fiducial not recognized automatically .............................................. 277
Fig. 332: Dispense preparation wizard finished .............................................. 278
Fig. 333: Dispense process wizard ................................................................. 279
Fig. 334: Dispense process wizard finished ................................................... 280
Fig. 335: Menu “Processing” .......................................................................... 281
Fig. 336: Checking the tools .......................................................................... 282
Fig. 337: Processing aborted .......................................................................... 283
Fig. 338: Create new Phase ........................................................................... 284
Fig. 339: Placement ....................................................................................... 285
Fig. 340: Fiducials ......................................................................................... 287
Fig. 341: Fiducial marks in the machining view .............................................. 289
Fig. 342: Measure milling width ..................................................................... 290
Fig. 343: Measure milling width ..................................................................... 292
Fig. 344: Result of milling width check .......................................................... 292
Fig. 345: Measure milling width ..................................................................... 293
Fig. 346: Result of milling width ..................................................................... 293
Fig. 347: Alignment ...................................................................................... 294
Fig. 348: Drill reference holes ........................................................................ 296
Fig. 349: Determine camera-to-milling-head offset ........................................ 298
Fig. 350: Determine camera-to-milling-head offset ........................................ 298
Fig. 351: Offset determined .......................................................................... 299
Fig. 352: Save results .................................................................................... 299
Fig. 353: Synchronizing the results ............................................................... 299
Fig. 354: Dismount the depth limiter .............................................................. 299
Fig. 355: Teach Z-Focus Offset ..................................................................... 300
Fig. 356: Refining Z position ......................................................................... 300
Fig. 357: Teach Z-Focus Offset ..................................................................... 300
Fig. 358: Auto-focus in progress .................................................................... 300
Fig. 359: Results ......................................................................................... 301
Fig. 360: Save results to machine ................................................................. 301
Fig. 361: Synchronising the results ............................................................... 301
Fig. 362: Teach Tool-holder Positions ........................................................... 302
Fig. 363: Camera image of tool-holder position ............................................. 302
Fig. 364: X/Y buttons ................................................................................... 303
Fig. 365: Results ......................................................................................... 304
Fig. 366: Save results to machine ................................................................. 304
Fig. 367: Connect the machine ..................................................................... 305
Fig. 368: Connection steps .......................................................................... 306
Fig. 369: Menu “Camera” ............................................................................ 307
Fig. 370: Camera > Options ......................................................................... 308
Fig. 371: Image acquisition settings .............................................................. 309
Fig. 372: Camera light .................................................................................................................. 311
Fig. 373: Load parameter set ........................................................................................................ 312
Fig. 374: Load parameter set - drop-down list ......................................................................... 312
Fig. 375: Create parameter set .................................................................................................... 314
Fig. 376: Camera > Actions ........................................................................................................... 315
Fig. 377: Camera > Actions > Measuring mode ......................................................................... 315
Fig. 378: Point to Point ................................................................................................................ 317
Fig. 379: Width of milled channel ............................................................................................... 318
Fig. 380: Circle Diameter ........................................................................................................... 319
Fig. 381: Set fiducial parameters ............................................................................................... 320
Fig. 382: Fiducial search result ................................................................................................. 321
Fig. 383: Fiducial marked ............................................................................................................ 321
Fig. 384: Calibrate camera ........................................................................................................ 322
Fig. 385: Save image .................................................................................................................. 324
Fig. 386: Select camera .............................................................................................................. 324
Fig. 387: Camera > Movement ................................................................................................. 325
Fig. 388: Camera > Overlay ....................................................................................................... 326
Fig. 389: Crosshair ..................................................................................................................... 327
Fig. 390: Clear Overlay .............................................................................................................. 328
Fig. 391: Set color ...................................................................................................................... 329
Fig. 392: Set color available settings ....................................................................................... 329
Fig. 393: Color selection ............................................................................................................ 329
Fig. 394: Camera > Search ........................................................................................................ 330
Fig. 395: Find Circles ................................................................................................................ 331
Fig. 396: Find Lines ................................................................................................................... 332
Fig. 397: Find Lines Camera pane ............................................................................................ 332
Fig. 398: Spiral Search .............................................................................................................. 333
Fig. 399: Spiral Search Result - fiducial found ....................................................................... 334
Fig. 400: Spiral Search Result - fiducial not found ................................................................. 334
Fig. 401: Find corner ................................................................................................................ 335
Fig. 402: Menu “Extras” ............................................................................................................. 336
Fig. 403: Extras > Options ........................................................................................................ 336
Fig. 404: Categories tree .......................................................................................................... 339
Fig. 405: Extras > Options “Display” ....................................................................................... 340
Fig. 406: Extras > Options “Measurement” .............................................................................. 342
Fig. 407: Extras > Options “Import / Export” ......................................................................... 343
Fig. 408: Extras > Options “Import assignments” ................................................................. 344
Fig. 409: Creating assignment rules ....................................................................................... 345
Fig. 410: Export configurations ............................................................................................... 346
Fig. 411: Extras > Options “Gerber” ....................................................................................... 347
Fig. 412: Extras > Options “Excellon” ..................................................................................... 348
Fig. 413: Extras > Options “LMD” ......................................................................................... 349
Fig. 414: Extras > Options “HPGL” ....................................................................................... 350
Fig. 415: Extras > Options “DXF” .......................................................................................... 351
Fig. 416: Extras > Options “STEP” ......................................................................................... 352
Fig. 417: Extras > Options “Miscellaneous” .......................................................................... 353
Fig. 418: Extras > Options “CAM settings” .......................................................................... 355
Fig. 419: Extras > Options “Machine” ................................................................. 357
Fig. 420: Extras > Customize… ............................................................................. 358
Fig. 421: Extras > Customize… > Commands ...................................................... 359
Fig. 422: Inserting Polygon into the toolbar ....................................................... 360
Fig. 423: Polygon icon in toolbar ....................................................................... 360
Fig. 424: Extras > Customize… > Toolbars ......................................................... 361
Fig. 425: Extras > Customize… > Keyboard ....................................................... 362
Fig. 426: Extras > Customize… > Options .......................................................... 362
Fig. 427: Extras > Customize… > Layouts ........................................................... 363
Fig. 428: Menu “Help” ....................................................................................... 364
Fig. 429: About this program ............................................................................. 365
Fig. 430: System information ............................................................................. 366
6.2 List of tables

Table 1: Minimum system requirements ................................................................................................. 14
Table 2: Recommended system configuration ............................................................................................. 14
Table 3: User interface ................................................................................................................................ 26
Table 4: Toolbar CAM view ....................................................................................................................... 28
Table 5: Context menu “Polygonal selection” .............................................................................................. 29
Table 6: Toolbar “Machining view” ............................................................................................................. 34
Table 7: Context menu “Polygonal selection” ............................................................................................. 35
Table 8: Toolbar “3D view” ......................................................................................................................... 37
Table 9: Function description “Standard” .................................................................................................... 39
Table 10: Function description “Insert” ....................................................................................................... 40
Table 11: Toolbar “Modify” ......................................................................................................................... 41
Table 12: Function description “Prototyping” .............................................................................................. 42
Table 13: Toolbar “Layout” ......................................................................................................................... 42
Table 14: Columns in the pane “Layers” ....................................................................................................... 44
Table 15: Processing ...................................................................................................................................... 46
Table 16: Messages ...................................................................................................................................... 52
Table 17: Error monitoring .......................................................................................................................... 53
Table 18: “File” menu functions ............................................................................................................... 55
Table 19: Formats ....................................................................................................................................... 63
Table 20: Apertures and tools ...................................................................................................................... 66
Table 21: General........................................................................................................................................ 68
Table 22: Options ....................................................................................................................................... 69
Table 23: Attributes .................................................................................................................................... 70
Table 24: Menu items in Print preview ........................................................................................................ 75
Table 25: Print > General ............................................................................................................................ 78
Table 26: Print > Page Setup ....................................................................................................................... 79
Table 27: Print > Settings ........................................................................................................................... 80
Table 28: Print > Printer Calibration .......................................................................................................... 82
Table 29: Parameters .................................................................................................................................. 84
Table 30: “Edit” menu items ....................................................................................................................... 85
Table 31: Material placement ...................................................................................................................... 88
Table 32: “Insert” menu functions ............................................................................................................. 148
Table 33: “Toolpath” menu functions ........................................................................................................... 208
Table 34: Dispense ....................................................................................................................................... 210
Table 35: Global settings ............................................................................................................................. 214
Table 36: Create 2.5D milling ...................................................................................................................... 217
Table 37: Insulate ....................................................................................................................................... 219
Table 38: Contour Routing .......................................................................................................................... 221
Table 39: Drills .......................................................................................................................................... 222
Table 40: Fiducials ..................................................................................................................................... 223
Table 41: Pockets ....................................................................................................................................... 224
Table 42: “Modify” menu functions .......................................................................................................... 230
Table 43: Menu functions “View” .............................................................................................................. 264
Table 44: Menu functions “Select” ............................................................................................................ 266
Table 45: Menu functions ........................................................................................................................... 268
Table 46: Menu functions “Machining” ................................................................. 281
Table 47: Alignment ............................................................................................. 295
Table 48: Menu functions “Camera” .................................................................. 307
Table 49: Image acquisition settings ................................................................. 309
Table 50: Pre-sets ............................................................................................... 312
Table 51: Create parameter set .......................................................................... 314
Table 52: Set fiducial parameters ....................................................................... 320
Table 53: Buttons ............................................................................................... 321
Table 54: Calibration .......................................................................................... 323
Table 55: Set color ............................................................................................. 329
Table 56: Spiral Search ....................................................................................... 333
Table 57: Menu functions “Extras” .................................................................... 336
Table 58: Options “General” .............................................................................. 337
Table 59: Options “General” buttons .................................................................. 338
Table 60: Options “Display” ................................................................................ 340
Table 61: Options “Measurement” ..................................................................... 342
Table 62: Options “Import / Export” ................................................................. 343
Table 63: Extras > Options “Import assignments” ............................................. 344
Table 64: Columns ............................................................................................. 345
Table 65: Import Assignments - buttons ......................................................... 345
Table 66: Options ............................................................................................... 345
Table 67: Export configurations ........................................................................ 346
Table 68: Extras > Options “Gerber” ............................................................... 347
Table 69: Extras > Options “Excellon” ............................................................. 348
Table 70: Options “LMD” ................................................................................ 349
Table 71: Options “HPGL” ............................................................................... 350
Table 72: Options “DXF” ................................................................................ 351
Table 73: Options “Miscellaneous” ................................................................. 353
Table 74: Extras > Options “CAM settings” .................................................... 355
Table 75: Extras > Options “Machine” .............................................................. 357
Table 76: Menu functions “Help” .................................................................... 364
6.3 Index

2.5D
- Material placement .............................. 88
- Create milling .................................. 216
- 2.5D milling ...................................... 216

3D shape
- import ............................................. 71

3D view
- activate .......................................... 264
- alignment ........................................ 294
- Anchor ........................................... 137
- anchor point ................................. 150, 258, 259
  - set ................................................ 134

Anchor point
  - to the center point .......................... 137

aperture ........................................... 66
- library .......................................... 126

arc
  - create ......................................... 153

auto focus ....................................... 323

breakout tab
  - add new position ......................... 228
  - change position .......................... 226
  - remove position ........................... 229

CAM view ........................................ 27
  - activate ...................................... 42, 264
  - toolbar ....................................... 28

camera overlay
  - clear .......................................... 328

camera parameter set
  - create ........................................ 314
  - load .......................................... 312

camera search
  - circle ......................................... 331
  - corners ...................................... 335
  - fiducial ..................................... 333
  - lines .......................................... 332
  - spiral search ............................... 333

contour routing ... see Technology Dialog

copper area
  - isolate ....................................... 188

- copper pouring ................................ 188

- crosshair .................................... 327

dispense
  - preparation ............................... 275
  - select head ................................. 46
  - set distance ..................... see Topography
  - start ........................................ 279
  - tool ......................................... 117
  - tool list .................................. 210

- Dispense Preparation Wizard .......... 275
- Dispense process wizard .............. 279

- Drills ........................................ 63
  - see Technology Dialog

- DXF ........................................... 63, 351

- Edit breakout tabs .......................... 225

- engraving .................................... 91

- Equipment configuration wizard ...... 23

- Excellon ..................................... 63, 348

- fiducial ...................................... 198, 223
  - create ....................................... 199
  - create new layer ......................... 199
  - find .......................................... 321
  - not recognized automatically ........ 277
  - recognized automatically .......... 276
  - set parameters .......................... 320
  - spiral search ............................ 333

fiducial phase "DrillFiducials" .......... 294

- Fiducials ................................... 287

flash object
  - create ....................................... 240
  - explode ..................................... 246
  - from multiple objects .................. 241

focus height
  - move to focus .............................. 325
  - set ......................................... 325

front panel .................................... 91

Geometry
- aperture list ................................ 45

- Gerber ......................................... 63, 347

- GerberX ....................................... 63

- HPGL ........................................... 63, 350

Insert
  - Milling curve .............................. 206

installation information .................. 16

insulate ........................................ see Technology Dialog

language
  - set ........................................... 336

layer ............................................ 44
  - match up layers .......................... 140
  - move layer to zero .................... 138
LMD .................................................. 63, 349
machining view
activate .............................................. 42, 264
ProtoMat D104 ................................ 33
ProtoMat E33 ..................................... 30
ProtoMat S43 ..................................... 31
ProtoMat S63/S103 ............................. 32
Marking drills ...... see Technology Dialog
Material placement ......................... 88
Material properties .......................... 87
material settings ................................ 91
measuring mode ................................. 315
milled channel
measuring the width ........................... 318
Milling curve ..................................... 206
insert ................................................. 206
pad size parameters
add .................................................... 211
delete ................................................. 213
edit .................................................... 212
path
close ............................................... 232
closed .............................................. 155
combine .......................................... 235
convert ............................................. 238
insert .............................................. 149, 155
open ................................................... 149
phase
create .............................................. 284
list .................................................... 45
placement ......................................... 285
pocket .............................................. 247
pocketing. ........... see Technology Dialog
polygon
convert to ......................................... 237
insert ................................................. 162
selection .......................................... 28
with cutouts .......................... 184
production phase ............ see phase
reference hole
drill ............................................... 296
reference hole .................................... 296
reference hole
choose color .................................... 341
reference point ............................... 136
Referenzpunkt ................................. 136
rubout area .............................. 192, 218
Safety note ................................. 13
segment
create ............................................. 150
setup wizard ................................. 16
Sieb&Meyer ..................................... 63
solder paste ................................... 209
apply ............................................. see dispense
solder paste dot ................................. 209
solder paste path ............................... 209
generate .......................................... 210
start point
absolute ........................................... 150
relative ............................................. 150
STEP .................................................. 352
Technology Dialog ......................... 218
contour routing ............................ 221
Drills .............................................. 222
insulate ........................................... 219
Marking drills ....................... 222
pockets ........................................... 224
tool change
ProtoMat S43/E33 .............................. 105
tool holder
machining view ............................. 32, 33
selection list ......................... 96, 109
teach position .............................. 302
tool library ....................................... 117
options .......................................... 354
tool life ............................................ 103, 107, 116
tool magazine
machining view ............................. 32, 33
ProtoMat S43/E33 ............................. 105
ProtoMat S63/S103 ........................... 107
Tool magazine
ProtoMat D104 .................................. 94
toolpath ........................................... 36, 45, 208
create ................... see Technology Dialog
import ............................................ 72
selection mode .............................. 28
Topography
set topography points ...................... 200
user level ........................................ 336
work area
ProtoMat D104 .................................. 33
ProtoMat E33 .................................. 30
ProtoMat S43 .................................. 31
ProtoMat S63/S103 ........................... 32
<table>
<thead>
<tr>
<th>Z value</th>
<th>zero point</th>
<th>136, 138, 150, 156</th>
</tr>
</thead>
<tbody>
<tr>
<td>change</td>
<td>set</td>
<td>136</td>
</tr>
<tr>
<td>Z value</td>
<td></td>
<td>249</td>
</tr>
</tbody>
</table>