CircuitPro PM 2.1
How-to guides
This document and its contents in whole and in part are subject to copyright. The reproduction, translation or duplication of the contents as photocopy or any digital form requires written permission of LPKF AG.
Information about this document

General
This document contains all information for installation, putting into operation, operation, and maintenance or trouble-shooting of the system delivered. This document is intended for persons with basic knowledge of installation and operation of software-controlled machines. General knowledge of operational safety as well as basic knowledge of using PCs running Microsoft Windows® are required.

Availability
A complete and legible copy of this document must be available at the operation station. Any person who is authorised to operate the system must have read and understood this document. The facility owner is required to ensure that all safety measures listed in this document are observed.

Notations
To facilitate the reading and understanding of the document information text attributes, text notations and text structures are used. Various text attributes, notations, and structures are used to facilitate reading and understanding the document. The text attributes (highlighting) inside this document are defined as follows:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Important information</td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Brand name</td>
</tr>
<tr>
<td><strong>Bold italics</strong></td>
<td>LPKF brand name</td>
</tr>
<tr>
<td>[...]</td>
<td>Button</td>
</tr>
<tr>
<td>..\</td>
<td>Input/display field</td>
</tr>
<tr>
<td>...&gt;</td>
<td>Check box</td>
</tr>
<tr>
<td>{...}</td>
<td>Radio button</td>
</tr>
<tr>
<td>&gt;...&gt;</td>
<td>Menu trail</td>
</tr>
<tr>
<td>/.../</td>
<td>Reference to a number in the figure</td>
</tr>
</tbody>
</table>

Figures
Figures (photos or drawings) are displayed in a frame. Each figure has a numbered figure title, e. g. “Fig. 1: Overview”. Numbers in the figure mark certain components or actions. Arrows in the figure show the direction of an action.

Tables
Data, facts, and important contexts are arranged in tables. Each table has a numbered table title, e. g. “Table 1: Scope of delivery”. Every table has a highlighted header row containing the column headings.
Procedures
In this document, procedures or workflows are compiled to step-by-step operation sequences. An individual operation sequence consists of at least three components: Title, step, and result.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ title</td>
<td>Description of the objective of the procedure marked by a preceding “■”</td>
</tr>
<tr>
<td>1. step</td>
<td>Consecutively numbered sequence of an procedure</td>
</tr>
<tr>
<td>♦ intermediate result</td>
<td>Intermediate result of an operation step. The procedure continues.</td>
</tr>
<tr>
<td>♦ result</td>
<td>Result of the procedure marked by a preceding “♦”</td>
</tr>
</tbody>
</table>

Symbols and signal words
The following symbols are used to mark important information:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Safety note</td>
</tr>
<tr>
<td></td>
<td>WARNING – Hazard for persons</td>
</tr>
<tr>
<td></td>
<td>CAUTION – Damage to the system</td>
</tr>
<tr>
<td></td>
<td>Note</td>
</tr>
<tr>
<td></td>
<td>A note is an information on the optimum usage of a feature.</td>
</tr>
<tr>
<td></td>
<td>Tip</td>
</tr>
<tr>
<td></td>
<td>A tip contains additional information.</td>
</tr>
<tr>
<td>©</td>
<td>Copyright</td>
</tr>
<tr>
<td>®</td>
<td>Registered Trademark</td>
</tr>
</tbody>
</table>

Registered Trademarks and Brand names
The LPKF Logo and the LPKF product names are registered trademarks of LPKF Laser & Electronics AG.

Microsoft and Windows are brand names or registered trademarks of Microsoft Corporation in the USA and/or other countries.

All other trademarks belong to the respective owner.

Standards
The following standards and guidelines were observed when creating this document:

<table>
<thead>
<tr>
<th>Standard</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DIN 5008 05-2005</td>
<td>Rules for writing and layouting</td>
</tr>
<tr>
<td>VDI 4500 Bl.1.2 11-2006</td>
<td>Technical documentation - Definitions and legal basics</td>
</tr>
<tr>
<td>DIN 62079 11-2001</td>
<td>Preparation of instructions - Structuring, content and presentation</td>
</tr>
<tr>
<td>ISO 12100-2 02-2003</td>
<td>Safety of machinery - Basic concepts, general principles for design - Part 2: Technical principles</td>
</tr>
<tr>
<td>DIN EN 60204 01-2005</td>
<td>Safety of machinery - Electrical equipment of machines - Part 1: General requirements</td>
</tr>
</tbody>
</table>
Contents

Part I: First steps in CircuitPro PM

1 How to produce a PCB ................................................................. 9
  1.1 Switching on the machine and starting CircuitPro .......................... 10
  1.2 Selecting a template and creating a new document ....................... 11
  1.3 Importing files .................................................................. 12
  1.4 Inserting rubout areas ......................................................... 15
  1.5 Multiplying the design if needed ............................................. 17
  1.6 Inserting fiducials ............................................................... 18
  1.7 Creating toolpaths ............................................................... 19
  1.8 Loading the tool magazine and assigning the tools to positions ........ 21
  1.9 Starting processing ............................................................. 23

2 Dispensing solder paste using the ProtoMat S63 or S103 ............. 31
  2.1 Starting the machine and CircuitPro ....................................... 32
  2.2 Selecting a template and creating a new document ....................... 33
  2.3 Importing data ................................................................ 34
  2.4 Creating solder paste paths .................................................... 37
  2.5 Creating toolpaths ............................................................... 39
  2.6 Dispense preparation ........................................................... 40
  2.7 Starting dispensing .............................................................. 46

Part II: How to do...

1 Creating a 3D part .................................................................. 53
  1.1 Starting the machine and CircuitPro ....................................... 54
  1.2 Selecting a template and creating a new document ....................... 55
  1.3 Creating the layout ............................................................... 57
  1.4 Creating 2.5D objects ........................................................... 62
  1.5 Creating toolpaths ............................................................... 65
  1.6 Loading the tool magazine and assigning tools to holder positions .... 67
  1.7 Starting processing .............................................................. 70

2 Creating a 3D part from a STEP file ........................................ 77
  2.1 Starting the machine and CircuitPro ....................................... 78
  2.2 Selecting a template and creating a new document ....................... 79
  2.3 Importing data ................................................................ 81
  2.4 Creating 2.5D toolpaths ........................................................ 85
  2.5 Inserting fiducials ............................................................... 87
  2.6 Creating toolpaths for fiducials ............................................... 89
  2.7 Loading the tool magazine and assigning tools to holder positions .... 90
  2.8 Starting processing .............................................................. 92
3 Creating a multi-layer PCB with galvanic through-hole plating ........ 101
  3.1 Starting the machine and CircuitPro .......................................................... 102
  3.2 Selecting a template and creating a new document ........................................ 103
  3.3 Importing data ................................................................................................. 105
  3.4 Inserting rubout areas ....................................................................................... 107
  3.5 Multiplying the design (if necessary) .................................................................. 109
  3.6 Creating toolpaths ............................................................................................ 111
  3.7 Loading the tool magazine and assigning tools to holder positions .................... 113
  3.8 Starting the processing ..................................................................................... 115

4 Creating a front panel ......................................................................................... 127
  4.1 Starting the machine and CircuitPro ................................................................. 128
  4.2 Selecting a template and creating a new document ............................................ 129
  4.3 Creating the front panel design ......................................................................... 130
  4.4 Creating toolpaths ............................................................................................ 150
  4.5 Loading the tool magazine and assigning tools to holder positions .................... 153
  4.6 Start processing ................................................................................................ 155

5 Creating a polyimide stencil .............................................................................. 161
  5.1 Starting the machine and CircuitPro ................................................................. 162
  5.2 Selecting a template and creating a new document ............................................ 163
  5.3 Importing data ................................................................................................. 164
  5.4 Processing data ................................................................................................ 166
  5.5 Creating toolpaths ............................................................................................ 168
  5.6 Loading the tool magazine and assigning tools to holder positions .................... 172
  5.7 Starting the processing ..................................................................................... 174

6 Creating a flex-rigid PCB .................................................................................... 181
  6.1 Starting the machine and CircuitPro ................................................................. 182
  6.2 Selecting a template and creating a new document ............................................ 183
  6.3 Importing data ................................................................................................. 187
  6.4 Processing the individual physical layers .......................................................... 192
    6.4.1 Drilling and milling the flexible material ..................................................... 193
    6.4.2 Processing the FR4 material ........................................................................ 203
    6.4.3 Processing the prepreg material .................................................................... 212
  6.5 Bonding the individual physical layers ................................................................ 225
  6.6 Contour routing the bonded PCB ...................................................................... 226
Part III: Basics

1 CircuitPro: Basic CAM operations .................................................. 245
   1.1 Executing Process planning wizard ............................................. 246
   1.2 Importing the Gerber files ...................................................... 250
   1.3 Importing the drill file .......................................................... 253
   1.4 Inserting a rubout area (optional) .............................................. 256
   1.5 Inserting fiducials (optional) .................................................. 258
   1.6 Creating toolpaths .............................................................. 260

2 CircuitPro: Basic machining operations .......................................... 267
   2.1 Switching to Machining view .................................................... 268
   2.2 Loading the tool magazine ..................................................... 269
   2.3 Starting processing .............................................................. 272

3 Processing DXF files in CircuitPro ................................................ 281
   3.1 Importing the DXF file .......................................................... 282
   3.2 Converting the DXF file ........................................................ 285

4 Processing Gerber and Excellon files ............................................ 293
   4.1 Selecting Gerber and Excellon files ........................................ 294
   4.2 Selecting the file format ....................................................... 296
   4.3 Selecting the desired target layer ......................................... 297
   4.4 Setting/correcting size and format ....................................... 298
   4.5 Viewing/modifying aperture properties ................................... 301
   4.6 Using the layer name defined in the Gerber file ....................... 303

List of figures .................................................................................. 307
1 How to produce a PCB

This tutorial shows you how to produce a double-sided circuit board without through plating.

The following steps are necessary to complete the tutorial successfully:

i. Switching on the machine and starting CircuitPro
ii. Selecting a template and creating a new document
iii. Importing data
iv. Inserting rubout areas
v. Multiplying the design if needed
vi. Setting fiducials
vii. Creating toolpaths
viii. Loading the tool magazine and assigning the tools to positions
ix. Starting production

Following material is required:

• Base material FR4 copper-clad (18µm) on both sides (order no. 115967)
1.1 Switching on the machine and starting CircuitPro

- Switching on the machine and starting CircuitPro
  1. Switch on the machine.
  2. Start CircuitPro.

  ➔ CircuitPro automatically connects to the machine. The connection steps are displayed.

  ![Connection steps](image)

  ➔ CircuitPro reads the settings from the machine.
  ➔ The machine moves to the reference points and stops at the Pause position.
1.2 Selecting a template and creating a new document

1. Click on File > New…

Following dialog is displayed:

2. In order to produce a double-sided PCB without through-hole plating, select the template “DoubleSided_NoTHP”.
3. Click on [OK].
4. Click on File > Save As…
5. Enter a file name.
6. Select the memory location.
7. Click on [Save].

The file was saved.

The template was selected and the new document was created.
1.3 Importing files

- Importing data
  1. Click on File > Import…

  ➔ Following dialog is displayed:

  2. Select all files in the folder “UseCase_DoubleSidedPCB”.
  3. Click on [Open].
4. Assign the imported file to their corresponding layers according to the following table:

<table>
<thead>
<tr>
<th>File</th>
<th>Layer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>.BOA</td>
<td>BoardOutline</td>
<td>This layer contains the data for the board outline of the PCB.</td>
</tr>
<tr>
<td>.BOT</td>
<td>BottomLayer</td>
<td>This layer contains the data for the bottom side of the PCB.</td>
</tr>
<tr>
<td>.TOP</td>
<td>TopLayer</td>
<td>This layer contains the data for the top side of the PCB.</td>
</tr>
<tr>
<td>.DRL</td>
<td>DrillUnplated</td>
<td>This layer contains the data for the drillings.</td>
</tr>
</tbody>
</table>

Fig. 4: Assigned layers

Instead of manually assigning the individual files to the layers, you can activate the options “Use layer name” and “Apply to all Gerber files”. Activate the corresponding checkboxes in the tab “Options”.

If a file contains layer names these are automatically assigned. Please note that this is only available for Gerber files. All other files require assigning the layers manually via the drop-down menu.

Note
5. Click on [OK].

The data is displayed in the CAM view:

Fig. 5: CAM view

- The data is imported.
1.4 Inserting rubout areas

Inserting rubout areas is used for creating a most precise isolation in certain areas by removing all redundant copper. This is a preferred option for fine-pitch arrays for example.

In the existing design, a rubout area around the terminals of the IC is needed.

- Inserting a rubout area.
  1. Click on Insert > Rubout area > RuboutTop.

Following dialog is displayed:

2. Draw a rectangle around the contact pads of the IC using your mouse (see arrow):
3. Click on [Close].
   ➤ The dialog is closed.
   ◆ The rubout area was inserted.

Note

Depending on which layer the rubout area is to be created, it can be useful to hide the other layers for drawing the rubout area.

The display mode of the objects on the individual layers can be set in the Layers pane. You can choose between

• True width (filled objects are displayed filled, polylines are displayed with their true width)
• Outline (only outlines of the filled objects and polylines are displayed)
• Thin line (outlines of filled objects and thin line without defined width in case of polylines are displayed) and
• Unknown (used when importing CAM files with undefined objects)
1.5 Multiplying the design if needed

For producing whole panels, the design can easily be multiplied and placed on the base material depending on the size of the design and of the base material.

- Multiplying the design
  1. Select the whole design

  Note
  Please make sure, that the layers’ option “selectable” is enabled if the layer contains data.
  You will find the option in the “layers” pane.

  2. Click on Modify > Step & Repeat.

  Following dialog is displayed:

  ![Step & Repeat dialog](image)

  3. Enter “2”, in the \Repetition X\ field.
  4. Enter “100”, in the \Distance X\ field.
  5. Enter “55” in the \Distance Y\ field.

  Note
  The “Distance” values reflect the size of the design. The value for spacing between the designs has to be added.

  6. Click on [Apply].

  The design is multiplied in X direction

  7. Click on [Close].

  The dialog is closed.

  ![Layout in CAM view](image)

  The design was multiplied.
1.6 Inserting fiducials

For aligning the top and bottom sides of the circuit board you need fiducials. Fiducials are optical marks or drill holes on the surface of the circuit board. The fiducials are drilled into the board and have a diameter of 1.5 mm. They are recognised by the cameras of the ProtoMat systems.

For working with fiducials you need the camera system for fiducial recognition.

Note

Ideally you insert four fiducials for aligning the top and the bottom sides.

You are also able to work with two fiducials. In this case you have to insert them diagonally into the layout.

**Inserting fiducials**

1. Click on Insert > Fiducial > Fiducial.

   ➤ Following dialog is displayed:

   ![Create circle dialog](image)

   2. Left click in the CAM view where you want to place each fiducial hole.
   Or

   2. Create the fiducial using the dialog “Create circle” and entering the X and Y position of each fiducial.

   ➤ The design now looks like follows:

   ![Four fiducials](image)

   3. Click on [Close].

   ➤ The dialog is closed.

   ➤ The fiducials were inserted.
1.7 Creating toolpaths

Toolpaths have to be created from the imported data, for producing the circuit board.

- Creating toolpaths
  1. Click on Toolpath > Technology Dialog...
  2. Following dialog is displayed:

![Technology Dialog](image)

In the technology dialog, several settings can be modified by clicking on the [Show details] buttons. For a detailed description of the individual functions of the technology dialog see the corresponding chapter in the CircuitPro compendium.

- Click on the right-pointing arrow button in the “Isolation” section until the “Partial rubout” method is selected.
- Disable the following function by clicking on the corresponding checkmark:
  - Pockets
4. Click on [Start].

* The results for the generated toolpaths are displayed:

![Computation Results](image)

In the computation results is a warning displayed. This means that there are no source objects for certain functions. This is not a malfunction but merely a hint for the user.

**Note**

**Required tools**

CircuitPro makes a recommendation to the computation results, which tools should be used for the creation of the calculated toolpaths.

- If some of the recommended tools are not available, you can subsequently assign other tools to the calculated toolpaths.
- Please note that using tools with another diameter can cause deviations from the computations results.
- In the pane „Toolpath“ you can assign other tools to the toolpaths.

5. Click on [Close].

* The dialog with the computation results is closed.
* The toolpaths were created.
1.8 Loading the tool magazine and assigning the tools to positions

- Loading the tool magazine and assigning the tools to positions

1. Click on Edit > Tool magazine...

   ➨ Following dialog is displayed:

   ![Tool magazine dialog](image)

   The tools shown in the tool magazine dialog must not correspond to your needed tools. These tools are examples.

   **Note**

   ➨ The required tools for the job are displayed. Missing tools which are required for the job are marked with a red “X”.

2. Insert the required tool into the tool magazine:
3. In the dialog, assign the tool to the respective tool magazine position used.
4. Repeat the steps 2 and 3 until all required tools are assigned:

![Fig. 17: Tools in the tool magazine](image)

5. Click on [OK].
   - The dialog is closed.
   - The tools were loaded and assigned to their positions.
1.9 Starting processing

- Starting processing

1. Click on Machining > Process all.

![Fig. 18: Machining > Process all]

Make sure that <Process All> is selected in the combo box, so that all phases are executed.

Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

After the production started, the machine will process following phases in order. The phases are displayed via prompts.

![Note]

Depending on which ProtoMat you use the following phases could differ from the phases and messages displayed on your screen. Please follow the instructions on your screen.

For machines with manual tool exchange you are regularly asked to change the tool in the collet, for example.

Phase “MountMaterial”

1. Place the base material onto the machine’s table top.

2. Fasten the base material onto the table top using the adhesive tape.
Phase “MaterialSettings”

Following dialog is displayed:

- Entering the material settings
  1. Enter the correct values for the material used.

Note

- PCB is selected as default.

  2. Change the values of copper thickness and material thickness necessary.
3. Define the processing area:
   a) Move the dialog „Material Settings“ off to the side.
   b) Using your mouse in the machining view, click on the right rear corner of your material:

   ![Fig. 20: Right rear corner](image1)

   /1/ Click in the machining view
   /2/ Material

   ➤ The machine head moves to this position.

   c) Now click on the corresponding button in the dialog “Material Settings”:

   ![Fig. 21: Click on button](image2)
The processing area is adapted.

d) Using your mouse in the machining view, click on the lower left corner of your material:

The machine head moves to this position.

e) Now click on the corresponding button in the dialog “Material Settings”:

The processing area was adapted to the material.

4. Click on [Continue].

The material settings were entered.
Phase “Placement”

In this phase, the job can be positioned, rotated and multiplied within the processing area.

Following dialog is displayed:

![Placement dialog](image)

1. Drag the job to the desired position or use the dialog to position the job.
2. If desired, rotate the job by entering a rotation angle.
3. If desired, multiply the job by using the settings in the “Step and Repeat” section of the dialog.
4. Click on [Continue].

Phase “Drill Fiducial”

The machine picks up the tool “Spiral Drill 1.5 mm” and drills the fiducials.

Note

If the spindle motor has not been used before, the motor is warmed up for 2 minutes.

Phase “Marking Drills”

The machine picks up the tool “Universal Cutter” and marks the positions for the drill holes.
Phase “Drilling Unplated”

- The machine picks up the required tool and drills the holes.

Note

This phase may use more than one tool.

Phase “Milling Bottom”

- The machine picks up the required tool and mills the isolation tracks.

Phase “Flip Material”

1. Flip the material.

Note

If you are using a ProtoMat S43, S63 or S103 flip the material along the machine’s X-axis.

If you are using a ProtoMat E33 flip the material along the machine’s Y-axis.

2. Confirm by clicking [OK].

Note

The display in the machining view changes. The position of the design is adjusted to the circuit board. The side of the circuit board to be processed is now the “Top” side.

Phase “Read Fiducials_Top”

S43, S63 and S103

Note

If the fiducial search is performed for the first time (after having started CircuitPro) the camera is performing an autofocus five times.

Afterwards the following message is displayed which prompts you to confirm the focus height:

- The camera moves to the positions of the fiducials and determines the exact position.
If the material is placed at nearly the same position as before, the positions of the fiducials are recognised automatically.

The Top side is thus aligned to the Bottom side.

The following dialog is displayed if the fiducials have not been recognized automatically:

1. Enlarge the search area by increasing the value of the field `Search Area Length`.
2. Start the search again.
3. Repeat above steps if necessary.

---

**Note**

Enlarging the search spiral increases the time required for searching the fiducials. Try to put the material at the same position as before when turning the material over (if this is not predetermined by reference pins).

**E33, S43 without camera**

If no camera is available for processing the “Read Fiducials_Top” phase, the Top side is aligned to the Bottom side using the reference pins. The “Read Fiducials_Top” phase is not processed in this case.

**Phase “Milling Top”**

- The machine picks up the required tools and mills the isolation tracks on the Top side.

**Phase “Contour Routing”**

- The machine picks up the required tools and drills and mills the outline of the circuit board.
Phase “Board Production Finished”

- A message informs you that the production is finished.
- The production of the circuit board is finished.

**Note**

If desired, continue with dispensing solder paste on your PCB. Therefore please refer to the tutorial “Dispensing solder paste using the ProtoMat S63 or S103”.

**Tip**

After PCB production you can carry on with inserting labeling or applying solder resist. For these cases you can purchase the LPKF systems ProMask and ProLegend. Furthermore LPKF offer systems for applying solder paste, equip and solder PCBs.
2 Dispensing solder paste using the ProtoMat S63 or S103

This tutorial shows you how to dispense solder paste on your board with CircuitPro.

The following steps are necessary to complete the tutorial successfully:

i. Starting the machine and CircuitPro
ii. Importing data
iii. Creating solder paste paths
iv. Dispense preparation
v. Starting dispensing

---

**Note**

Before you start dispensing, your PCB board's drilling and milling must be finished (for more information about milling and drilling, see the other tutorials in this document).

---

**Note**

This tutorial is based on the tutorial “How to produce a PCB”.

---

**Requirements:**

- Dispenser head
- Red plastic needle
- Solder paste (at room temperature)
- Calipers (capable of measuring in millimeters)
- Completed PCB
- Gerber Files (Solder Paste and Drill Layers)
- Compressed Air (3 bar)

---

**Tip**

For a more uniform dispensing of solder paste, we recommend to use the LPKF honeycomb plate (Order no. 116 148)
2.1 Starting the machine and CircuitPro

- Starting the machine and CircuitPro
  1. Switch on the machine.
  2. Start CircuitPro.

  ➤ CircuitPro automatically connects to the machine. The connection steps are displayed:

  ![Connection steps diagram]

  ➤ CircuitPro reads the settings from the machine.
  ➤ The machine moves to its reference points and subsequently moves to the Pause position.
2.2 Selecting a template and creating a new document

- Selecting a template and creating a new document
  1. Click on File > New…
  
  ➤ Following dialog is displayed:

  ![New document dialog]

  2. Select the template “DoubleSided_NoTHP”.
  3. Click on [OK].
  4. Click on File > Save As…
  5. Enter a file name.
  6. Select the memory location.
  7. Click on [Save].

  ➤ The file was saved.
  ➤ The template was selected and the new document was created.
2.3 Importing data

The LPKF tutor data are stored in folder “My documents\LPKF Laser & Electronics\LPKF CircuitPro 1.5\Example Data\UseCase_Dispensing”.

Before you start dispensing, your PCB board’s drilling and milling must be finished.

In this case, the PCB created in the tutorial “How to produce a double-sided PCB” is necessary to dispense solder paste on it. You can use another file as well if it includes solder paste data.

- Importing data
  1. Click on File > Import…
  ➔ The following dialog is displayed:

Fig. 28: Import
2. Select all files in the folder “UseCase_Dispensing”.
3. Click on [Open].
4. Assign the imported files to the corresponding layers according to the following table:

<table>
<thead>
<tr>
<th>File</th>
<th>Layer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>.BOA</td>
<td>BoardOutline</td>
<td>This layer contains the data for the board outline of the PCB.</td>
</tr>
<tr>
<td>.BOT</td>
<td>BottomLayer</td>
<td>This layer contains the data for the bottom side of the PCB.</td>
</tr>
<tr>
<td>.SPT</td>
<td>SolderPasteTop</td>
<td>This layer contains data for dispensing solder paste.</td>
</tr>
<tr>
<td>.TOP</td>
<td>TopLayer</td>
<td>This layer contains the data for the top side of the PCB.</td>
</tr>
<tr>
<td>.DRL</td>
<td>DrillPlated</td>
<td>This layer contains the data for the drillings.</td>
</tr>
</tbody>
</table>

For dispensing you only need the layers “Solder Paste Top” to dispense solder paste and “DrillPlated” to recognise the position. The data on the other layers may help you to determine the side/alignment of the circuit board.

To display the Exellon file “Tutor.DRL” correctly, the external dimensions of the PCB must be available. Therefore you have to import the file “Tutor.BOA”.

The files are shown in the table:

![Fig. 29: Assign layer](image)

Tip

Instead of manually assigning the individual files to the layers, you can activate the options “Use layer name” and “Apply to all Gerber files”. Activate this corresponding checkboxes in the tab “Options”.

If a file contains layer names these are automatically assigned. Please note that this is only available for Gerber files. All other files require assigning the layers manually via the drop-down menu.

5. Click on [OK].

The data are displayed in the CAM view:
The data are imported.

Tip

In the “Layers” pane you can hide the following for a clear display of the dispense data:
• TopLayer
• DrillPlated

Therefore you remove the checkmark in the column “visible” of the according layer.
2.4 Creating solder paste paths

- Creating solder paste paths
  1. Click on Toolpath > Dispense.
  
  ➔ Following dialog is displayed:

![Dispense dialog](image)

The dialog “Dispense” allows you to make different settings concerning solder paste paths. For a detailed description, see the chapter “Dispense” in the CircuitPro compendium or in the online help.

2. In the drop down list “Source” select the layer “SolderPasteTop”. This layer was assigned to the solder paste data.

3. Enable the desired dispenser tool you want to use by marking the corresponding checkbox.

The following table describes the properties of the dispenser tools:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled</td>
<td>Enables/Disables the corresponding tool via checkmark.</td>
</tr>
<tr>
<td>Minimale size [µm]</td>
<td>Specifies the minimum pad size of the pad to be filled.</td>
</tr>
<tr>
<td>Dot distance [µm]</td>
<td>Specifies the dot in µm distance between the single solder paste dots.</td>
</tr>
<tr>
<td>Grid angle [*]</td>
<td>Specifies the rotation of the solder dot grid on the pad.</td>
</tr>
<tr>
<td>Margin [µm]</td>
<td>Specifies the minimum margin in [µm] between the solder paste dots and the pad margin.</td>
</tr>
<tr>
<td>Tool</td>
<td>Specifies the corresponding dispenser tool. The dispenser tools relate to different pad sizes, which can be filled with the respective tool. This is realized by means of different parameter sets. For all dispenser tools the same dispenser and needle are used.</td>
</tr>
</tbody>
</table>
4. Click on [Run].
   ➔ The solder paste paths are created.
5. Click on [Close].
   ➔ The dialog is closed.
6. Click on the machining view tab.
   ➔ The created solder paste paths are shown in the machining view:

Fig. 32: Machining view with solder paste paths

◆ The solder paste paths were created.
2.5 Creating toolpaths

Before you start dispensing, you have to create the toolpaths for the drill data. The drill holes are necessary to align the structured and drilled PCB.

- Creating toolpaths
  1. Click on Toolpath > Technology Dialog...

    ➔ Following dialog is displayed:

    ![Technology Dialog]

    In the technology dialog, several settings can be modified by clicking on the [Show details] buttons. For a detailed description of the individual functions of the technology dialog see the chapter "Technology Dialog" in the CircuitPro compendium or online help.

    2. Disable the following functions by clicking on the corresponding checkmarks:
       - Insulate
       - Contour Routing
       - Fiducials (only if you do not use your own data including fiducials)
       - Pockets
    3. Click on [Start].

    ➔ The results for the generated toolpaths are displayed.
    4. Click on [Close].

    ➔ The dialog with the computation results is closed.
    ➔ The toolpaths were created.
2.6 Dispense preparation

In this chapter you will learn how to set the dispenser offset by using the “Dispense preparation wizard”.

You will pass through following steps:

i. Mounting the material
ii. Setting the material height
iii. Cleaning the dispenser needle
iv. Calculating the dispenser offset

1. Click on Wizards > Dispense preparation wizard:

Fig. 34: Wizards > Dispense preparation wizard

The following dialog is displayed:

Fig. 35: Prepare dispenser

Note

If there is a tool in the clamp, it will be placed back into the tool holder.
2. Prepare the solder paste as described in the wizard.
3. Assemble the dispenser as described in the wizard:

![Dispense preparation wizard](image)

4. Click on [Next].

- Mounting the auxiliary board
  1. Use a scrap piece of copper material that is at least 50 x 50 millimeters.
  2. Measure the overall thickness with a set of calipers and note this number.
  3. Enter the thickness of the material in the thickness field:

![Mount auxiliary board](image)

4. Click on [Next].
5. Close the machine cover.
6. Click on [Next], to start the positioning procedure.
   - The auxiliary board was mounted.
Dispensing solder paste using the ProtoMat S63 or S103

CircuitPro PM 2.1

- Setting the material height
  1. Move the wizard screen off to the side.
  2. Move the dispenser head to the center of your scrap piece by clicking on the working area with your mouse until the dispense needle is centered on the material:

![Position of auxiliary board](image)

**Note**

The machine will now search for the focus height of the material. It will repeat this 5 times, in a dice pattern.

3. Follow the instructions displayed in the wizard:
4. Take off the sheet of paper.
5. Click on [Next].
   ◆ The material height was set.

Cleaning the dispenser needle (or prepare needle)
1. Click on the dispense icon in the wizard:

   2. Repeat step 1 until a single stream of paste comes out of the needle.
   3. Clean off any paste that has been dispensed.
   4. Click on [Next].
   ◆ The dispenser needle was cleaned.
Calculating the dispenser offset

In this step, the machine is calculating the dispenser offset:

1. Click on [Next.]

   The machine will dispense 5 dots. Dot number 5 will be slightly offset from the first four. Then the camera will move over the dots and will zoom in.

   **Note**
   Make sure, that the camera zooms in the last of the five dispensed dots!
   Otherwise the offset is not calculated correctly.

   The following dialog is displayed:
Read in the dot manually if centering failed

1. If the camera did not find the last dot, move the camera head manually to the position of the dot by using the X-/Y-arrow-icons in the pane „Processing“.
2. If the dot is displayed centered in the pane “Camera” click on [Find and Center] in the dialog “Alignment”. → The camera zooms in the dot.

2. Click on [Accept Current Position].
   ➤ The view changes as follows:

3. Click on [Done].
   ◆ The dispenser offset was calculated.

The dispense preparation is finished now.
2.7 Starting dispensing

In this chapter you will learn how to dispense the solder paste by using the “Dispense process wizard”.
You have to perform following steps:
   i. Mounting the circuit board
   ii. Placement
   iii. Cleaning the needle
   iv. Dispensing the solder paste

1. Click on Wizards > Dispense process wizard…

The following dialog is displayed:

Fig. 44: Wizards > Dispense process wizard

Fig. 45: Mount board
Mounting the circuit board

1. Measure the thickness of your current board with a set of calipers and note this number.
2. Mount the material onto the machine with the top side of the board facing up.
3. Fasten the circuit board with adhesive tape.
4. Enter the board thickness into the thickness field:

5. Click on [Next].
   - The circuit board was mounted.
Dispensing solder paste using the ProtoMat S63 or S103

- **Placement**

In this step two existing drill holes will be read in to align the circuit board.

**Note**

If the fiducial search is performed for the first time (after having started CircuitPro) the camera is performing an autofocus five times.

Afterwards the following message is displayed which prompts you to confirm the focus height:

![Confirmation of focus height](image)

1. Follow the instructions displayed in the wizard:

![Select drill hole](image)

2. Click on [Next].

   ➔ Following message is displayed:

![Select drill hole](image)
3. Left click on one of the drill holes near a corner of the board.
   - The camera moves to the drill hole and reads in the position.
   - The “Alignment” dialog is displayed:

```
Fig. 49: Alignment

Note

Read in the drill hole manually if centering failed
1. If the camera did not find the drill hole, move the camera head
   manually to the position of the drill hole by using the X-/Y-arrow-icons in
   the pane „Processing“.
2. If the drill hole is displayed centered in the pane “Camera” click on
   [Find and Center] in the dialog “Alignment”.
   ⇒ The camera zooms in the drill hole

4. Click on [Accept Current Position].
5. Repeat the steps 1-4 for the second drill hole in the opposite corner.
   ⇒ The drill holes for aligning the circuit board have been read in.

In the next step the machine will find the focus height on the material, similar to
what it did during the “dispenser offset” step. Afterwards the wizard continues
with step “Dispenser cleaning”.
```
Cleaning the needle

1. Click on the dispense icon in the wizard screen:

   ![Dispense icon](image)

2. Repeat step 1 until a single stream of paste comes out of the needle.
3. Clean off any paste that has been dispensed.
4. Click on [Next].
   ◆ The dispenser needle was cleaned.
Dispensing solder paste

- The machine will now dispense solder paste on your pads.

**Note**

1. When dispensing is completed, you can decide if you want to apply solder paste to second board. In this case, click on [Next board]:

![Dispensing wizard](image)

2. After all boards are complete, click on [Finish].
3. Remove the paste dispenser from the machine.
   - The solder paste was dispensed.

**Note**

Close the solder paste cartridge by using the cap. Then store the cartridge in the refrigerator.

**Tip**

For further process steps we recommend the systems LPKF ProtoPlace for placing components and LPKF ProtoFlow for lead-free soldering.
Dispensing solder paste using the ProtoMat S63 or S103
1 Creating a 3D part

In this section you will learn how to create a 3D part of 5 mm-thick aluminum in CircuitPro. Pockets are placed on the top side. Furthermore there will be defined drill holes.

To create a 3D part you need a ProtoMat S63 or S103!

Note

Therefore you have to perform following steps:
  i. Starting the machine and CircuitPro
  ii. Selecting the template and creating the new document
  iii. Creating the layout
  iv. Creating 2.5D objects
  v. Creating toolpaths
  vi. Loading the tool magazine and assigning tools to holder positions
  vii. Start processing

The following material is required:
  • Base material with the dimensions 100 mm x 100 mm x 5 mm

You are able to use other base materials, too. Make sure that the used material has at least the dimensions 100 mm x 100 mm and a thickness of 5 mm +/- 1 mm.
1.1 Starting the machine and CircuitPro

- Starting the machine and CircuitPro
  1. Switch on the machine.
  2. Start CircuitPro.

  - CircuitPro automatically connects to the machine. The connection steps are displayed:

  ![Connection steps]

  - CircuitPro reads the settings from the machine.
  - The machine moves to its reference points and subsequently moves to the Pause position.
1.2 Selecting a template and creating a new document

- Selecting a template and creating a new document
  1. Click on File > New…
     - The following dialog is displayed:

   ![New Document Dialog](image)

   2. Select the template “2D_Top.cbf”.
   3. Click on [OK].
     - The following dialog is displayed:

   ![Material Properties Dialog](image)

   4. In the `Type` field, select the material type “AL (EN AW-6012)” or “AL (EN AW-5083). In this case these are two different aluminum alloys.
   5. Enter the dimensions of your material in the fields `Length`, `Width`, and `Height`.
   6. Click on [OK].
The CAM view is changing:

Note

You are able to change the material properties such as the dimensions of the base material. Therefore you have to right-click in the CAM view and click in the context menu on “Material properties…”.

7. Click on File > Save As…
8. Enter a file name for the new file.
9. Click on [Save].

The new document is created.
1.3 Creating the layout

In this section you will perform following steps:

i. Creating rectangles for the pockets
ii. Creating circles for drill holes
iii. Multiplying the circle

Creating rectangles for the pocket
1. Click on Insert > Rectangle…

▶ The following dialog is displayed:

Fig. 56: Create rectangle

2. Select the layer to create the rectangle on, e.g. “2.5D MillingTop”.
3. Select the option “Absolute” (start and end points are entered from the zero point).
4. Enter “50” in the fields \Start point X\ and \Start point Y\.
5. Enter “80” in the fields \End point X\ and \End point Y\.
6. Click on [Apply].

▶ The drawn rectangle is shown in the CAM view

Fig. 57: Rectangle in CAM view
7. For creating another rectangle, enter the following values in the corresponding fields:
   • Start point X: 30
   • Start point Y: 30
   • Endpoint X: 60
   • Endpoint Y: 60
8. Click on [Apply].
   ➔ The second rectangle is shown in the CAM view:

9. Click on [Close].
   ◆ The rectangles for the pockets are created.
Creating circles for drill holes

1. Click on Insert > Circle.

2. Select the layer „2.5D DrillingTop“ to create your circle.
3. Select the option “Absolute” (the circle’s center is entered from the zero point)
4. Enter “15” in the fields \Center X\ and \Center Y\.
5. Enter “2” in the field \Ø\.

Note
If you do not have a Spiral Drill 2 mm, you can enter the corresponding diameter of our drill tool used.
Therefore enter the diameter of your drill tool in the field \Ø\.

6. Click on [Apply].

7. Click on [Close].

The circle was created.
Multiplying the circle

1. Highlight the created circle in the CAM view.
- The circle is highlighted in grey.
2. Press your right mouse button.
- The context menu is shown.
3. Click on “Step and Repeat…”.

You can also click on Modify > Step and Repeat…

Tip

The following dialog is shown:

4. Enter “5” in the field \Repetition\ X.
5. Enter “5” in the field \Distance\ X.

The dimension of the selected object is automatically displayed in the fields \Distance\ X and \Distance\ Y.

The desired distance between the objects must be added to this value.

6. Click on [Apply].

The drawn circle is multiplied in X direction.
7. Click on [Close].
   - The dialog is closed.
   - The drawn circle was multiplied.

---

**Assign layer**

The layer which contain the drawn objects can be changed manually, if necessary.

1. Highlight the objects.
2. Press your right mouse button.
3. Click in the context menu on “Assign objects to layer”.
   → The layer’s list is shown.
4. Click on the desired layer on which you want to place the objects.
   → The objects were moved to the desired layer.

---

Note
1.4 Creating 2.5D objects

The opened file only contains 2D objects yet. The drawn 2D objects on the layers “Milling Top” and “Drilling Top” must be converted to 2.5D objects with a defined depth.

1. Creating 2.5D objects

1. Select all objects in the CAM view:

2. Press your right mouse button.

   ➔ The context menu is displayed.

3. Click on “Convert to 2.5D…“.

   ➔ The following dialog is displayed:
The value in field \textit{Destination layer} is preselected with “Same as source layer”. The objects will be converted into 2.5D objects and remain on their origin layer.

4. Enter “3” in field \textit{Z value}.
5. Click on [Convert].

\begin{itemize}
  \item The selected objects were converted to 2D objects. You can regard the object’s properties by highlighting them and clicking in the pane „Properties“:
\end{itemize}

6. Click on [Close].

\begin{itemize}
  \item The dialog is closed.
  \item The objects were converted in 2D objects.
\end{itemize}
**Note**

**Changing the object’s Z value**
You are able to change the object’s Z value afterwards:
1. Highlight the desired object.
2. Press your right mouse button.
   → The context menu is shown.
3. Click on “Change Z value...“.
   → The dialog „Change Z value” is shown.
4. Enter a new value in the field \New Z value\.
5. Click on [Apply].
   → The Z value was changed.
6. Click on [Close].
   → The dialog is closed.
1.5 Creating toolpaths

Before the machine can process the material, the 2.5D toolpaths have to be created.

- Creating 2.5D toolpaths
- Click on Toolpath > 2.5D milling…
- The following dialog is displayed:

![Create 2.5D milling dialog](image)

8. Activate the 3D object by checkmark in field 'Source'.
9. Activate the needed tools for the job by checkmark.

**Note**

Make sure, that you activate the drill tools with the appropriate diameter corresponding to the size of your drill holes. For example the Spiral Drill 1 mm if you want to create drill holes with a diameter of 1 mm.

For the milling of the pockets you need End Mill tools. Activate the available tools in the list.

You also need drill tools for generating start drills if you have not disabled this option. If the pocket should be milled with an End Mill 2 mm, you need to create the start drills with a Spiral Drill 2 mm.

10. Click on [OK] to create the toolpaths.
The CAM view changes as follows:

Fig. 68: CAM view

11. Click on the tab "3D view".

Note

If the tab „3D view“ is not displayed, you can activate it by clicking on the menu item View > 3D View.

The 3D tab displays the 3D part:

Fig. 69: 3D view

Tip

You can rotate the object in the 3D view by activating this icon in the toolbar.

◆ The 2.5D toolpaths were created.
1.6 Loading the tool magazine and assigning tools to holder positions

- Loading the tool magazine and assigning the tools to holder positions

1. Click on Edit > Tool magazine…

   ➔ The following dialog is displayed:

   ![Tool magazine dialog](image)

   The tools shown in the tool magazine dialog must not correspond to your needed tools. The tools are examples.

   ➔ The tools required for the job are displayed in section “Required tools”. Tools that are missing in the tool magazine are marked by a red “X”. Required tools which are already inserted in the tool magazine are marked by a green checkmark.

2. Insert the required tools into the tool magazine:

   ![Inserting the tool](image)
3. In the dialog, assign the tools to the respective tool magazine positions used.

Fig. 72: Assigning the tools in the dialog

The tools which are displayed in the section “Required tools” are marked with a green checkmark:

Fig. 73: Assigned tools

4. Make sure that the tool life spent is sufficient for the current job to be processed.

Note

If there is a red „X“ displayed beside the progress bar “Tool life spent” the endurance of the tool is insufficient for the job to be processed:
5. If necessary, insert additional tools in the tool magazine to reach the required tool endurance:

![Fig. 74: Assigning additional tools]

6. Click on [OK].
   ➔ The dialog is closed.
   The tools are assigned to the corresponding tool holders:

![Fig. 75: Tools in the tool magazine]

◆ The tools were loaded.
1.7 Starting processing

- Starting processing

1. Click on Machining > Process all.

![Machining Process all](image)

**Note**

Make sure that <Process All> is selected in the combo box of the pane “Processing”, so that all phases of the job are executed. The phases included in the current job are displayed in the section “Phases” of the pane “Toolpath”.

Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

After the production started, the machine will process following phases in order. The phases are displayed via prompts.

**Phase “Mount Material”**

1. Mount the material onto the processing area.
2. Fasten the material to the table using double-sided adhesive tape.
3. Click on [OK].
Phase “Placement Top”

The following dialog is displayed:

![Material placement dialog](image)

- Defining the material corners

1. Move the camera head to the left corner of your base material:
   a) Click on the “Processing” pane.
   b) Use the arrow buttons in the X/Y section to move the camera head.

![Processing pane](image)

The camera head is activated automatically. You are able to tell this by the green frame around the camera symbol in section “Select a head” of the “Processing” pane.

![Select a head](image)

**Note**

The camera head is activated automatically. You are able to tell this by the green frame around the camera symbol in section “Select a head” of the “Processing” pane.
Creating a 3D part

You are able to click on the corner of your material in the machining view. The camera moves automatically to this point. Use the X/Y arrow buttons to do the fine adjustment.

2. Use the auto focus function to align the material corners in the pane “Camera”.
   a) Click on [Autofocus] in the “Processing” pane:

   ![Autofocus](image)

3. Move the camera head, so that the left lower corner of your material is positioned right in the cross hair:

   ![Cross hair of camera](image)

   If the cross hair is not displayed, you are able to activate it by clicking on Camera > Overlay > Switch Crosshair State

4. Click on following icon in the dialog “Material Placement”:
   - The coordinates for the lower left corner were saved.
   - Following message is displayed:

   ![Move to second position](image)
5. Confirm the message by clicking on [Yes].
   ➔ The camera moves automatically to the opposite corner of your material.
6. Place the cross hair right on the top of your material corner by using the X/Y arrow buttons.
7. Click on following icon in the dialog “Material Placement”:
   ➔ The coordinates for the upper right corner were saved.
   ➔ The coordinates of the material corners were defined.

Defining the material surface level

**Note**

To define the material surface level the camera’s Z offset must be determined first. If it is not already determined you are able to start this procedure in the dialog “Material placement” by clicking on the following icon:

For more information about teaching the Z focus offset please refer to the CircuitPro compendium.

After defining the coordinates of the material corners the following message is displayed:

1. Confirm the message by clicking on [Yes].
   ➔ The camera moves to the center of the material area and then performs an autofocus to determine the material height.
2. Check if the autofocus has been performed successfully and if the focused material surface is visible in the pane “Camera”.

   **Note**

   If the autofocus has not been performed successfully, perform it again by clicking on [Autofocus] in the pane “Processing”.

3. Now click on the following icon for determining the material height:
The material height is saved:

4. Click on [Continue].
   - The material surface level was defined.
   
   • If there is no depth limiter mounted, the phase “Processing 2.5D Top” is processed.
   • If there is a depth limiter mounted, the following message is displayed that prompts you to dismount it:

   1. Confirm the message by clicking on [OK] and follow the instructions to dismount the depth limiter.
Dismounting the pneumatic depth limiter (S103)

1. Pull down the depth limiter:

   

   /1/ Pneumatic depth limiter

2. Fasten the depth limiter above the machine head in the hose clamp:

   

   /1/ Pneumatic depth limiter  /2/ Hose clamp

◆ The pneumatic depth limiter was dismounted.
Dismounting the mechanical depth limiter (S63)

1. Pull down the mechanical depth limiter:

Fig. 87: Mechanical depth limiter

2. Put the mechanical depth limiter close to the machine in order to mount it again later.
   ✔ The mechanical depth limiter was dismounted.

Phase „Processing 2.5D Top“

Note

If the spindle motor has not run before, a warm-up phase is started.

✔ The required tools were picked up and the top side of the material is processed.

Phase „Board Production Finished“

✔ A message informs you that the board production has been finished.
   ✔ The 3D part was created.
2 Creating a 3D part from a STEP file

In this section you will learn how to create a 3D part from a STEP file. The 3D part is created from a work piece with the dimensions 28 mm x 18 mm x 6 mm and the used material is POM. Different slots and drill holes are placed on the top and bottom side.

To create a 3D part you need a ProtoMat S63 or S103!

Note

To create the 3D part you have to perform the following steps:

i. Starting the machine and CircuitPro
ii. Selecting the template and creating the new document
iii. Importing the data
iv. Creating 2.5D toolpaths
v. Inserting fiducials
vi. Creating toolpaths for the fiducials
vii. Loading the tool magazine and assigning tools to holder positions
viii. Start processing

The following material is required:

• Base material with the dimensions 28 mm x 18 mm x 6 mm

You are able to work with other base materials. In this case make sure that your material has at least the dimensions 28 mm x 18 mm x 6 mm and a thickness of 6 mm.
2.1 Starting the machine and CircuitPro

- Starting the machine and CircuitPro

1. Switch on the machine.
2. Start CircuitPro.

慎重:CircuitPro automatically connects to the machine. The connection steps are displayed:

- CircuitPro reads the settings from the machine.
- The machine moves to its reference points and subsequently moves to the Pause position.
2.2 Selecting a template and creating a new document

- Selecting a template and creating a new document
  1. Click on File > New…
     ➔ The following dialog is displayed:

     ![New document dialog](image)

     2. Select the template “25D_Double.cbf”.
     3. Click on [OK].
     ➔ The following dialog is displayed:

     ![Material properties dialog](image)

     4. Enter the material type (POM).
     5. Adjust the values in the fields \Width\ and \Length\ according to your base material used.
     6. Enter “6 mm” in the field \Height\.
     7. Click on [OK].
The CAM view is changing:

Fig. 91: CAM view

8. Click on File > Save As…
9. Enter a file name for the new file.
10. Click on [Save].

* The new document is created.

Note
You are able to change the material properties such as the dimensions of the base material. Therefore you have to right-click in the CAM view and click in the context menu on “Material properties…”.
### 2.3 Importing data

The LPKF tutor data is stored in “My Document\LPKF Laser&Electronics\LPKF CircuitPro 1.5\Example Data\UseCase_3DPartFromSTEP”.

First the STEP file is imported in CircuitPro. Afterwards the imported data will be aligned to the processing volume.

1. **Importing data**
   - Click on File > Import 3D shape...
   - The following dialog is displayed:

   ![Image of Importing the STEP file dialog](image)

2. In the folder “UseCase_3DPartFromSTEP”, select the file “Tutor_STEP.stp”.
3. Click on [OK].
The 3D view changes as follows:

The data was imported.

1. In the 3D view, right-click on the imported object. The context menu is shown.
2. In the context menu, click on “Transformation”.
3. Click on “Rotate [auto]”.

Aligning the imported data to the processing volume
The view changes as follows:

4. Enter “90” in the field \textit{Angle}.
5. Activate the standard axis “Z”.
6. Click on [Apply].

The object is rotated around the Z axis at an angle of 90°. The 3D view changes as follows:

7. Click on the tab “Translate”.
8. Activate the option \{Move to center of processing volume\}.
9. Click on [Apply].
The object is moved in X and Y direction to the center of the processing volume. The 3D view changes as follows:

10. In the tab “Translate”, activate the option {Move to coordinates}.
11. Enter “3” in the field \(Z\).
12. Click on [Apply].

The object is moved in Z direction. The 3D view changes as follows:

13. Click on [Close].

The dialog is closed.

The imported data was aligned to the processing volume.
2.4 Creating 2.5D toolpaths

Before you insert the fiducials in your layout it is useful to create the 2.5D toolpaths first.

Creating 2.5D toolpaths

1. Click on Toolpath > 2.5D milling…

The following dialog is displayed:

![Create 2.5D milling dialog](image)

2. In section Source, select the source data “Tutor_STEP_1” for creating the toolpath.

3. Select the tools that are available for the current job.

   - **Note**

   For creating uncontinuous drill holes you need an End Mill 0.8 mm. All other structures can be created with the End Mill 1 mm or 2 mm.

   Also make sure that you have selected the appropriate drilling tools if you want to generate start drills for the End Mill tools.

4. Click on [OK] to create the toolpaths.
The toolpaths are created and visible in the CAM and 3D view. The 3D view changes as follows:

Fig. 100: 3D view

Tip
You can rotate the object in the 3D view in any direction by activating this icon on your toolbar.

◆ The 2.5D toolpaths were created.
2.5 Inserting fiducials

For aligning the top and bottom sides of the circuit board you need fiducials. Fiducials are optical marks or drill holes on the surface of the circuit board. The fiducials are drilled into the board and have a diameter of 1.5 mm. They are recognised by the cameras of the ProtoMat systems.

For working with fiducials you need the camera system for fiducial recognition.

Note

Ideally you insert four fiducials for aligning the top and the bottom side. You are also able to work with two fiducials. In this case it is useful to insert them diagonally into the layout.

Tip

Inserting fiducials

1. Click on Insert > Fiducial > Create new layer…

Fig. 101: Creating circles

A new layer “Fiducial” is created. The following dialog is displayed:

2. Activate the option “Absolute” (the center point is calculated from the zero point).
3. Enter “1.5” in the field ‘Center X’.
4. Enter “26.5” in the field ‘Center Y’.
5. Click on [Apply].

The fiducial is created.

6. Repeat the steps 3 to 5 using the following coordinates to create three more fiducials:
   • Center X: 1.5; Center Y: 15
   • Center X: 16.5; Center Y: 26.5
   • Center X: 16.5; Center Y: 1.5
The CAM view now looks as follows:

Fig. 102: CAM view with fiducials

Note
You are able to create fiducials without entering any coordinate. Therefore left-click in the CAM view where you want to place the fiducials.

7. Click on [Close].

- The dialog is closed.
- The fiducials were inserted.
2.6 Creating toolpaths for fiducials

The toolpaths for the fiducials have to be created before starting the production of the 3D part.

Creating toolpaths for the fiducials

1. Click on Toolpath > Technology Dialog…
   ➔ The following dialog is shown:

   ![Technology Dialog](image)

2. Deactivate the following functions:
   - Insulate
   - Contour Routing
   - Drills
   - Pockets

3. Click on [Start] to create the toolpaths.
   ➔ The toolpaths are created and the computation results are displayed.

4. Click on [Close].
   ➔ The dialog displaying the computation results is closed.
   ➔ The toolpaths for the fiducials were created.
2.7 Loading the tool magazine and assigning tools to holder positions

- Loading the tool magazine and assigning the tools to holder positions
  
1. Click on Edit > Tool magazine…

   ➔ The following dialog is displayed:

   ![Tool magazine dialog](image)

   ![Fig. 104: Tool magazine](image)

   The tools shown in the tool magazine dialog must not correspond to your needed tools. These tools are examples.

   ➔ The tools required for the job are displayed. Tools that are missing in the tool magazine are marked by a red “X”.

2. Insert the required tools into the tool magazine:

   ![Fig. 105: Inserting the tool](image)
3. In the dialog, assign the tools to the respective tool magazine positions used.

4. Repeat the steps above until all required tools are assigned:

5. Click on [OK]
   - The tools were loaded and assigned to their positions.
2.8 Starting processing

- Starting processing
  1. Click on Machining > Process all.

Fig. 107: Machining > Process all

Note

Make sure that <Process All> is selected in the combo box of the pane “Processing”, so that all phases of the job are executed. The phases included in the current job are displayed in the section “Phases” of the pane “Toolpath”.

Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

After the production started, the machine will process following phases in order. The phases are displayed via prompts.

Note

Depending on which ProtoMat you use the following phases could differ from the phases and messages displayed on your screen. Please follow the instructions on your screen.

For machines with manual tool exchange you are regularly asked to change the tool in the collet, for example.

Phase “Mount Material”

1. Mount the material onto the processing area.
2. Fasten the material to the table using double-sided adhesive tape.
3. Click on [OK].
Phase “Placement Bottom”

The following dialog is displayed:

![Material placement dialog](image)

- Defining the material corners
  1. Move the camera head to the left corner of your base material:
     a) Click on the “Processing” pane.
     b) Use the arrow buttons in the X/Y section to move the camera head.

![Pane “Processing”](image)

- Note
  The camera head is activated automatically. You are able to tell this by the green frame around the camera symbol in section “Select a head” of the “Processing” pane.
You are able to click on the corner of your material in the machining view. The camera moves automatically to this point. Use the X/Y arrow buttons to do the fine adjustment.

2. Use the auto focus function to align the material corners in the pane “Camera”.
   b) Click on [Autofocus] in the “Processing” pane:

3. Move the camera head, so that the left lower corner of your material is positioned right in the cross hair:

   If you use dark/reflective materials the camera view could be too dark. In this case please adjust the camera lens.

4. Click on following icon in the dialog “Material Placement”:
   ➔ The coordinates for the lower left corner were saved.
Following message is displayed:

![Move to second position dialog]

5. Confirm the message by clicking on [Yes].

- The camera moves automatically to the opposite corner of your material.

6. Place the cross hair right on the top of your material corner by using the X/Y arrow buttons.

7. Click on following icon in the dialog “Material Placement”:

- The coordinates for the upper right corner were saved.
- The coordinates of the material corners were defined.

Defining the material surface level

To define the material surface level the camera’s Z offset must be determined first. If it is not already determined you are able to start this procedure in the dialog “Material placement” by clicking on the following icon:

![Surface level dialog]

For more information about teaching the Z focus offset please refer to the CircuitPro compendium.

After defining the coordinates of the material corners the following message is displayed:

![Move to measuring position dialog]

1. Confirm the message by clicking on [Yes].

- The camera moves to the center of the material area and then performs an autofocus to determine the material height.
2. Check if the autofocus has been performed successfully and if the focused material surface is visible in the pane “Camera”.

Note

If the autofocus has not been performed successfully, perform it again by clicking on [Autofocus] in the pane “Processing”.

3. Now click on the following icon for determining the material height:

➢ The material height is saved:

4. Click on [Continue].

◆ The material surface level was defined.

• If there is no depth limiter mounted, the phase “Processing 2.5D Top” is processed.

• If there is a depth limiter mounted, the following message is displayed that prompts you to dismount it:

1. Confirm the message by clicking on [OK] and follow the instructions to dismount the depth limiter.
Dismounting the pneumatic depth limiter (S103)

1. Pull down the depth limiter:

![Image of pneumatic depth limiter being pulled down]

2. Fasten the depth limiter above the machine head in the hose clamp:

![Image of depth limiter fastened in hose clamp]

- The pneumatic depth limiter was dismounted.
Dismounting the mechanical depth limiter (S63)

1. Pull down the mechanical depth limiter:

2. Put the mechanical depth limiter close to the machine in order to mount it again later.
   - The mechanical depth limiter was dismounted.

Phase “Drill Fiducial”

- If the spindle motor has not run before, a warm-up phase is started.

   ➔ The Spiral Drill 1.5 mm is picked up and the fiducials are drilled.

Phase “Flip Material ”

- A message prompts you to flip the material.
  1. Flip the material along the machine’s X-axis.
  2. Click on [OK].

   ➔ The display in the machining view changes. The position of the layout is adjusted to the position of the work piece. The side of the 3D part to be processed is now the top side.
Phase “Material Placement Top”

► See phase “Material Placement Bottom”.

Note
During the phase „Material Placement Top“ a rough alignment of the material is done. The exact alignment is done in the following phase “Read Fiducial Top”.

Phase “Read Fiducials_Top”

If the fiducial search is performed for the first time (after having started CircuitPro) the camera is performing an autofocus five times.

Afterwards the following message is displayed which prompts you to confirm the focus height:

The camera moves to the positions of the fiducials and determines the exact position.

If the material is placed at nearly the same position as before, the positions of the fiducials are recognised automatically.

The Top side is thus aligned to the Bottom side.

The following dialog is displayed if the fiducials have not been recognized automatically:
Manually detecting the fiducial using the camera

1. Using the X and Y arrows in the pane “Processing”, move the machine head, until the cross hair is placed centered on the fiducial:

![Centering the fiducial](image)

For centering the fiducial in the pane “Camera” you need to activate the cross hair. To do so, click on the menu item Camera > Overlay > Switch Crosshair State.

2. Click on [Accept Current Position].
   - The fiducials were recognized by the camera.

**Phase “Processing 2.5D Top”**

- The required tools are picked up and the top side of the material is processed.

**Phase “Board Production Finished”**

- A message informs you that the board production has been finished.
  - The 3D part was created.
3 Creating a multi-layer PCB with galvanic through-hole plating

This tutorial shows you how to produce a 4-layer circuit board with galvanic through-hole plating.

The following steps are necessary to complete the tutorial successfully:

i. Starting the machine and CircuitPro

ii. Selecting a template and creating a new document

iii. Importing data

iv. Inserting rubout areas

v. Multiplying the design (if necessary)

vi. Creating toolpaths

vii. Loading the tool magazine and assigning tools to holder positions

viii. Starting the processing

The following material is required:

• 1-mm-thick multi-layer core with 18-µm-thick copper layers on both sides (order no. 119574)

• 200-µm-thick laminate with a 5-µm-thick copper layer on one side for the outer layers (order no. 119571)
3.1 Starting the machine and CircuitPro

- Starting the machine and CircuitPro
1. Switch on the machine.
2. Start CircuitPro.
   ➨ CircuitPro automatically connects to the machine. The connection steps are displayed:

   ![Connection steps diagram]

   ➨ CircuitPro reads the settings from the machine.
   ➨ The machine moves to its reference points and subsequently moves to the Pause position.
3.2 Selecting a template and creating a new document

- Selecting a template and creating a new document
  1. Click on File > New…
     - The following dialog is displayed:

     ![New Document Dialog](image)

     2. Select the template “4Layer_GalvanicTHP.cbf”.
     3. Click on [OK].
     - The template is displayed in the CAM view:
The template "4Layer_GalvanicTHP.cbf" already contains fiducials. These do not have to be added anew.

The template contains four slot holes that can be used to affix the individual layers to the press plate for the pressing step. The template also contains two positioning holes for orientation during the alignment of the individual layers.

4. Click on File > Save As…
5. Enter a file name for the new file.
6. Click on [Save].

◆ The new document is created.
3.3 Importing data

The LPKF tutor data are stored in folder “My documents\LPKF Laser & Electronics\LPKF CircuitPro 1.5\Example Data\UseCase_Multilayer”.

- Importing data
  1. Click on File > Import…
  ➔ The following dialog is displayed:

Fig. 124: Import

2. Select all files in the folder “UseCase_Multilayer”.
3. Click on [OK].
4. Assign the imported files to the corresponding layers (see table):

<table>
<thead>
<tr>
<th>File extension</th>
<th>Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>.BOA</td>
<td>Board Outline</td>
</tr>
<tr>
<td>.BOT</td>
<td>Bottom Layer</td>
</tr>
<tr>
<td>.LY2</td>
<td>Layer 2</td>
</tr>
<tr>
<td>.LY3</td>
<td>Layer 3</td>
</tr>
<tr>
<td>.TOP</td>
<td>Top Layer</td>
</tr>
<tr>
<td>.DRL</td>
<td>Drill Plated</td>
</tr>
</tbody>
</table>
Instead of manually assigning the individual files to the layers, you can activate the options “Use layer name” and “Apply to all Gerber files”. Activate the corresponding checkboxes in the tab “Options”.

If a file contains layer names these are automatically assigned. Please note that this is only available for Gerber files. All other files require assigning the layers manually via the drop-down menu.

5. Click on [OK].

The data is shown in the CAM view:

- The files are imported.
3.4 Inserting rubout areas

Inserting rubout areas is used for creating a most precise isolation in certain areas by removing the redundant copper partially or as a whole depending on the insulation method.

In this tutorial, a rubout area covering the whole circuit board is created on the Top and Bottom layers.

- Inserting a rubout area
  1. Click on Insert > Rubout area > RuboutTop.
  2. The following dialog is displayed:

![Create Rectangle Dialog]

- Draw a rectangle across the whole area of the design using the mouse:

![Rubout Top]

4. Draw another rectangle across the whole area of the design using the mouse.
5. Click on [Close].

➤ The dialog is closed.

◆ The rubout areas are created.

---

**Note**

It may be helpful to hide other layers for drawing the rubout depending on which layer the rubout is to be created.

The display mode of the objects on the individual layers can be set in the “Layers” pane. You can select:

- True width (area objects are filled, paths are displayed with their true width)
- Outline (outlines of the area objects and paths are displayed)
- Thin line (outlines of area objects are displayed and thin lines without defined width in case of paths)
- Unknown (used when importing .cam files with undefined objects)
3.5 Multiplying the design (if necessary)

The design can be multiplied and placed arbitrarily on the base material for producing a panel depending on the design's size and on the material's size.

Please make sure, that all layers in the “Layer” pane are visible and selectable. Otherwise it may cause incorrect results when multiplying the design.

- Multiplying the design
  1. Select the whole design.
  2. Click on Modify > Step & Repeat…

  ➔ The following dialog is displayed:

  ![Step & Repeat dialog](image)

  3. Enter “2” in the \Repetition X\ field.
  4. Enter “50” in the \Distance X\ field.

  ➔ The “Distance” values are automatically set to the size of the design. The value for spacing between the designs has to be added.

  5. Click on [Apply].

  ➔ The design is multiplied in X direction.
6. Click on [Close].

➤ The dialog is closed.

◆ The design is multiplied.
Creating toolpaths

3.6 Creating toolpaths

Before the circuit board can be produced, the toolpaths have to be generated for the imported data.

- Creating toolpaths
  1. Click on Toolpath > Technology dialog…
  2. The following dialog is displayed:

![Technology Dialog]

In the technology dialog, several settings can be modified by clicking on the [Show details] buttons.

For a detailed description of the individual functions of the technology dialog see the corresponding chapter in the CircuitPro compendium.

For this tutorial, the default values of the technology dialog are used.

2. Click on the right arrow button in the “Insulate” section until the isolation method “Partial rubout” is displayed.
3. Disable the function “Pockets”.
4. Click on [Start].

Note

© 2013 LPKF AG
The computation results are displayed and the CAM view changes as displayed:

5. In the dialog “Computation Results” click on [Close].
   • The dialog with the computation results of the technology dialog is closed.
   • The toolpaths are created.
3.7 Loading the tool magazine and assigning tools to holder positions

This chapter is only relevant if you are using a ProtoMat with automatic tool change (S63 or S103).

- Loading the tool magazine and assigning tools to holder positions
  1. Click on Edit > Tool magazine…
     - The following dialog is displayed:

     ![Tool magazine dialog](image)

     The tools shown in the tool magazine dialog must not correspond to your needed tools. These tools are examples.

     - The tools required for the job are displayed. Tools required for the job that are missing are marked by a red “X”.

  2. Insert the required tools into the tool holders of the machine:

     ![Inserting a tool](image)

  3. Assign the tools to the corresponding positions in the dialog.
     - The tool holders of the machine are loaded:
4. Click on [OK].

- The dialog is closed.
- The tool magazine is loaded and the tools are assigned to the corresponding holder positions.
3.8 Starting the processing

- Starting the processing

1. Click on Machining > Process all.

![Machining > Process all](image)

**Note**

Make sure that <Process All> is selected in the combo box, so that all phases are executed.

Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

Once you have started the processing, the ProtoMat machine executes the job in individual phases. The phases are displayed in messages:

**Note**

Depending on which ProtoMat you use the following phases could differ from the phases and messages displayed on your screen. Please follow the instructions on your screen.

For machines with manual tool exchange you are regularly asked to change the tool in the collet, for example.

**Phase “MountMaterial”**

1. Mount the base material (multi-layer core) onto the processing area of the machine.
2. Fasten the material to the processing area using adhesive tape.
3. Click on [OK].
Phase “MaterialSettings”

The following dialog is displayed:

- Entering the material settings
  1. Enter the correct values for the base material used.

PCB is selected as default.

Note
2. Adapt the values for copper thickness and material thickness if necessary.

3. Define the processing area:
   a) Move the “Material Settings” dialog off to the side.
   b) Click on the position in the machining view that represents the right rear corner of your material:

   ➨ The machine head moves to this position.

   c) Click on the corresponding icon in the “Material Settings” dialog:

   ➨ The coordinates of the current head position are saved.
   d) Click on the position in the machining view that represents the front left corner of your material:

   ➨ The machine head moves to this position.
e) Click on the corresponding icon in the “Material Settings” dialog:

- The coordinates of the current head position are saved and the processing area has been fit to the material.

4. Click on [Continue].
- The material settings were entered.

**Phase “Placement”**

In this phase, the job can be placed arbitrarily on the base material, be rotated and be multiplied if necessary.

![Placement](image)

- Following dialog is displayed:

> At this point, the whole circuit board design including the template and the toolpaths possibly contained in the template are moved.

If only the design is to be moved within the template, you have to use the menu item Modify > Transform….
1. Click on the job and drag it to the desired position using the mouse.
   Or
   1. Enter the new position in the dialog.
   2. If desired, multiply the job data by entering the number of copies and spacing values in X and Y direction in the corresponding fields (Step and Repeat section).

**Phase “DrillFiducial”**
- The Spiral Drill 1.5 mm is picked up to drill the fiducials.
  
  If the spindle motor has not run before, a 2-minute warm-up phase is started.

**Note**

**Phase “Prepare Core”**
- Four slot holes are created near the edges of the circuit board.

**Phase “Milling Layer3”**
- The tools are picked up as required and Layer3 is processed.

**Phase “Flip Material”**
A message prompts you to turn the material over.
1. Turn the base material over.

  Turn the material over around the X axis if you are using an S43, S63, or S103 machine.
  Turn the material over around the Y axis if you are using an E33 machine.

**Note**

2. Click on [OK].

  The display in the machine view changes. The position of your design is adapted to the material. The material side to be processed now is Top.

**Note**
Phase “Read Fiducials Layer2”
S43, S63, and S103

If the fiducial search is performed for the first time (after having started CircuitPro) the camera is performing an autofocus five times.
Afterwards the following message is displayed which prompts you to confirm the focus height:

The camera moves to the positions of the fiducials and determines the exact position.
The Top side is thus aligned to the Bottom side.
The following dialog is displayed if the fiducials have not been recognized automatically:

1. Enlarge the search area by increasing the value of the field \Search Area Length\.
2. Restart the search by clicking on [Start].
3. Repeat steps one and two if necessary.
Note

Enlarging the search spiral increases the time required for searching the fiducials. Try to put the material at the same position as before when turning the material over (if this is not predetermined by reference pins).

E33, S43 without camera

If no camera is available for processing the “Read Fiducials_Top” phase, the Top side is aligned to the Bottom side using the reference pins. The “Read Fiducials_Top” phase is not processed in this case.

Phase “Milling Layer2”

- The tools are picked up as required and Layer2 is processed.

Phase “Dismount Material”

1. Dismount the base material from the machine.
2. Click on [OK].

Phase “Mount Laminate”

1. Mount the laminate for the Bottom side of the multi-layer PCB onto the processing area of the machine.
2. Fasten the material to the processing area using adhesive tape.
3. Click on [OK].

Phase “MaterialSettings”

1. Adapt the values for copper thickness and material thickness of the laminate if necessary.
2. Set the material size.
3. Click on [OK].

Phase “Prepare Laminate Bottom”

- The slot holes, position markers and fiducial exposures are processed.
Phase “Dismount Material_1”
1. Dismount the laminate for the Bottom side of the multi-layer PCB from the machine.
2. Click on [OK].

Phase “Mount Laminate_1”
1. Mount the laminate for the Top side of the multi-layer PCB onto the processing area of the machine.
2. Fasten the material to the processing area using adhesive tape.
3. Click on [OK].

Phase „Prepare Laminate Top”
- The slot holes, position markers and fiducial exposures are processed.

Phase “Dismount Material_2”
1. Dismount the laminate for the Top side of the multi-layer PCB from the machine.
2. Click on [OK].

Phase “Press Layer Top_Bottom”
- The outer layers Top and Bottom have to be laminated onto the core base material. This can be done using an LPKF MultiPress S system for example.

Phase “Mount Material Top”
1. Mount the laminated material onto the processing area of the machine, the Top side facing upwards.

Note: The Top and Bottom sides can be distinguished by the position markers. The Top side has the position markers in the right front corner.

2. Fasten the material to the processing area using adhesive tape.
Phase “MaterialSettings”
1. Adapt the values for copper thickness and material thickness of the laminated material as required.
2. Define the material area.
3. Click on [OK].

Phase “Read Fiducials Top”
➤ See Phase “Read Fiducials Layer2” above.

Phase “Marking Drills”
➤ The Universal Cutter is picked up and the drill positions are marked.

Phase “Drilling Plated”
➤ The tools are picked up as required and the holes are drilled.

This phase may use several drill tools according to the drill diameters.

Note

Phase “Dismount Material”
1. Dismount the laminated material from the machine.
2. Click on [OK].

Phase “Through Hole Plating”
➤ The hole have to be plated. This can be done using an LPKF Contac RS system for example.

Phase “Mount Material Bottom”
1. Mount the laminated material onto the processing area of the machine, the Bottom side facing upwards.

The Top and Bottom sides can be distinguished by the position markers. The Top side has the position markers in the right front corner.

Note
2. Fasten the material to the processing area using adhesive tape.
Phase “MaterialSettings”

1. Adapt the values for copper thickness and material thickness if necessary.

   Note
   Please note that the copper thickness has increased during the through-hole plating process. The additional copper thickness depends on the parameters of the through-hole plating process.

2. Define the material area.
3. Click on [OK].

Phase “Read Fiducials Bottom”

See Phase “Read Fiducials Layer2” above.

Phase “Milling Bottom”

The tools are picked up as required and the circuit board is milled.

Phase “Flip Material”

A message prompts you to turn the material over.

1. Turn the material over.

   Note
   Turn the material over around the X axis if you are using an S43, S63, or S103 machine.
   Turn the material over around the Y axis if you are using an E33 machine.

2. Click on [OK].

   Note
   The display in the machine view changes. The position of your design is adapted to the material. The material side to be processed now is Top.
Phase “Read Fiducials Top”

► See Phase “Read Fiducials Layer2” above.

Phase “Milling Top”

► The tools are picked up as required and the Top side of the circuit board is milled.

Phase “Contour Routing”

► The tools are picked up as required and the circuit board is drilled and routed.

Phase “Board Production Finished”

► A message informs you that the production is finished.

◆ The multi-layer circuit board is finished.
Creating a multi-layer PCB with galvanic through-hole plating
4 Creating a front panel

In this section you will learn how to create a front panel that contains following elements:
• Cutouts for switches and a fan
• Holes for fastening LED’s
• Labels
• Markings

Therefore you have to perform following steps:
  i. Starting the machine and CircuitPro
  ii. Selecting a template and creating a new document
  iii. Creating the front panel design
  iv. Creating toolpaths
  v. Loading the tool magazine and assigning tools to holder positions
  vi. Starting processing

The following material is required:
• 2-mm-thick aluminum sheet with the dimensions 250 mm x 120 mm
4.1 Starting the machine and CircuitPro

- Starting the machine and CircuitPro
  1. Switch on the machine.
  2. Start CircuitPro.

  ➔ CircuitPro automatically connects to the machine. The connection steps are displayed:

  ![Connection steps diagram]

  ➔ CircuitPro reads the settings from the machine.
  ➔ The machine moves to its reference points and subsequently moves to the Pause position.
4.2 Selecting a template and creating a new document

- Selecting a template and creating a new document
  1. Click on File > New.
  
 ➔ The following dialog is displayed:

![New document dialog](image)

2. Select the template “SingleSided_Top.cbf”.
3. Click on [OK].
4. Click on File > Save as…
5. Enter a new name for the file.
6. Select the storage location.
7. Click on [Save].

◆ The new document was created.
4.3 Creating the front panel design

To create the front panel design, following steps are required:

i. Defining the dimensions of the front panel
ii. Inserting cutouts for switches
iii. Inserting holes for LEDs
iv. Inserting markings
v. Creating legends
vi. Creating holes for mounting the front panel
vii. Creating cutouts for a fan

Defining the dimensions of the front panel

The dimensions of the front panel are defined by inserting a rectangle on the “BoardOutline” layer with the dimensions of 260 mm x 140 mm.

- Creating a rectangle
  1. Click on Insert > Rectangle.
  2. Select the layer BoardOutline.
  3. Ensure that (Absolute) is selected.
  4. Enter “0” into the \Start point X\ and \Start point Y\ fields.
  5. Enter “260” into the \End point X\ field.
  6. Enter “140” into the \End point Y\ field.
  7. Click on [Create].
The rectangle is created:

8. Click on [Close].

- The dialog is closed.
- The dimensions of the front panel are defined.
Displaying objects within the BoardOutline
1. In order to see the drawn objects in the CAM view that lie within the board outline, set the mode of layer “BoardOutline” in the “Layers” pane to “Thin Line”:

Fig. 149: Pane “Layers”

The mode has been changed:

Fig. 150: Mode “Thin Line”

The BoardOutline and all objects within are now displayed in the mode “Thin Line”.

Changing the zero point of the BoardOutline
The lower left corner of the board outline is now on the zero point. Thus, you can place all the subsequent objects at specific positions in relation to the board outline.

If you have the need to place objects in relation to a specific object, move the zero point as follows:
1. Click on the lower left corner of the reference object. The anchor point moves to this position.
2. Click on Edit > Set zero point. The zero point is moved to the anchor point and thus to the lower left corner.

The zero point has been moved to the anchor point and is now positioned on the lower left corner.
Inserting cutouts for switches

Two cutouts are needed for switches. Therefore rectangles are created.

- Creating rectangles.
  1. Click on Insert > Rectangle.
  ➔ Following dialog is displayed:

2. Select the layer “BoardOutline”.
3. Select {Absolute} (thus, the start and end point values are in relation to the zero point).
4. Enter “20” into the \Start point X\ field.
5. Enter “85” into the \Start point Y\ field.
6. Enter “40” into the \End point X\ field.
7. Enter “115” into the \End point Y\ field.
8. Click on [Create].
  ➔ The rectangle is created.
9. Repeat the steps above to create another rectangle with a start point of X=50 and Y=85 and an end point of X=70 and Y=115.
  ➔ The second rectangle is created.
10. Click on [Close].
  ➔ Both rectangles are displayed in the CAM View:
The objects have to be converted into closed paths to enable CircuitPro to generate the contour routing toolpaths in the Technology dialog.

**Converting the polygons into closed paths**

1. Select the rectangles that you have created.
2. Click on Modify > Convert to path.

→ The rectangles are converted to closed paths.

◆ The cutouts for the switches were inserted.
Creating and multiplying drill holes for LEDs

In this step holes are created for inserting LEDs. These holes must be multiplied afterwards. The drill holes are created by inserting and multiplying circles on the layer “DrillUnplated”.

- Creating a circle

1. Click on Insert > Circle.

   ➔ Following dialog is displayed:

   ![Create circle dialog]

2. Select the layer “DrillUnplated”.
3. Select {Absolute}.
4. Enter “20” into the \Center X\ field.
5. Enter “20” into the \Center Y\ field.
6. Enter “5” into the \Center ø\ diameter field.
7. Click on [Apply] to create the circle.

   ➔ The circle is created:

   ![Created circle]

8. Click on [Close].

   ➔ The dialog is closed.

   ➔ The circle was created.
Multiplying the circle

1. Select the circle to be multiplied.
2. Click on Modify > Step & Repeat.
3. Enter “9” into the ‘Repetition X’ field.
4. Enter “7” into the ‘Distance X’ field.
5. Click on [Apply] to multiply the drill hole.

▶ The circles were multiplied:

6. Click on [Close].

▶ The dialog is closed.

▶ The circle was multiplied.
Creating another series of drill holes

Another series of drill holes is needed, so that we have to insert circles again:

1. Click on Insert > Circle.
2. Select the layer “DrillUnplated”.
3. Select (Absolute).
4. Enter “105” into the \Center X\ field.
5. Enter “30” into the \Center Y\ field.
6. Enter “5” into the \Center ø\ diameter field.
7. Click on [Apply] to create the circle.
   ➔ The circle is created.

Fig. 156: Another series of drill holes

8. Click on [Close].
   ➔ The dialog is closed.
   ➔ Another series of drill holes was created.
Multiplying the circle
1. Multiply the drill hole in Y direction by using the “Step & Repeat” function.
2. Enter “5” into the ‘Repetition Y’ field.
3. Enter “20” into the ‘Distance Y’ field.
4. Click on [Apply] to multiply the drill holes in Y direction.

The design now looks as follows:

Fig. 157: Drill holes

The circle was multiplied.
Inserting markings

An indication of the charge status is to be created above the lower row of LEDs. This will be realized by a polygon.

Creating a polygon

1. Click on Insert > Polygon.

Following dialog is displayed:

Fig. 158: Create Polygon

2. Select the layer “Top Layer”.
3. Select {Absolute}.
4. Enter “17.5” into the Start point X field.
5. Enter “30” into the Start point Y field.
6. Select {Segment}.
7. Enter “80” into the X field.
8. Enter “30” into the Y field.
9. Click on [Set] to create the segment.
10. For the next segment, enter “80” into the End point X field.
11. Enter “50” into the End point Y field.
12. Click on “Set” to create the second segment.
13. Click on “Apply” to create the polygon.

Fig. 159: Polygon

CircuitPro automatically connects the end of the last segment with the start of the first segment:

The polygon is created.
Creating circular marks around the drill holes

1. Click on Insert > Circle.
2. Select the layer “Top Layer”.
3. Select {Absolute}.
4. Enter “105” into the \Center X\ field.
5. Enter “110” into the \Center Y\ field.
6. Enter “15” into the \Center ø\ diameter field.
7. Click on [Apply] to create the circle.

The circle is created:

8. Click on [Close].

The dialog is closed.

9. Multiply the circles created in Y direction by using the “Step & Repeat” function.
10. Enter “5” into the \Repetition Y\ field.
11. Enter “-20” into the \Distance Y\ field.
12. Click on [Apply] to multiply the circles in Y direction.

The circle is multiplied in Y direction.
13. Click on [Close].

➤ The dialog is closed and the design now looks as follows:

Fig. 161: Circular marks

➤ The circular marks are created around the drill holes.
Creating legends

In this step the elements on the front panel are labeled.
1. Click on Insert > Text.

Following dialog is displayed:

2. Enter the text “Power” in the red highlighted text field.
3. Select the layer “TextTop” in field \Destination\.
4. Modify the text attributes if necessary (in this example size=6 mm, bold, italic).
5. Enter “15” into the \Position X\ field.
6. Enter “120” into the \Position Y\ field.
7. Click on [Apply] to create the text object.

The text object is displayed in the CAM view.
8. Click on [Close].

The dialog is closed.
9. Click on an empty space in the CAM view.
10. Repeat the steps above to create other legends using the values listed in the following table:

<table>
<thead>
<tr>
<th>X position</th>
<th>Y position</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>50</td>
<td>120</td>
<td>Laser</td>
</tr>
<tr>
<td>20</td>
<td>45</td>
<td>Charge</td>
</tr>
<tr>
<td>115</td>
<td>107</td>
<td>Laser</td>
</tr>
<tr>
<td>115</td>
<td>87</td>
<td>Gate</td>
</tr>
<tr>
<td>115</td>
<td>67</td>
<td>Trigger</td>
</tr>
<tr>
<td>115</td>
<td>47</td>
<td>Overload</td>
</tr>
<tr>
<td>115</td>
<td>27</td>
<td>Error</td>
</tr>
</tbody>
</table>

The design now looks as follows:

The legends were created.
Creating holes for mounting the front panel

In this step drill holes are created for mounting the front panel later. Therefore circles must be created on the layer "Drill Unplated".

- Creating circles
  1. Click on Insert > Circle.
  2. Select the layer "Drill Unplated".
  3. Select {Absolute}.
  4. Enter "10" into the \Center X\ field.
  5. Enter "10" into the \Center Y\ field.
  6. Enter "2.4" into the \Center ø\ diameter field.
  7. Click on “Apply” to create the circle.
  8. Create another three circles using the following center points:
     • X=10; Y=130
     • X=250; Y=130
     • X=250; Y=10

- The new design now looks as follows:

9. Click on [Close].
- The dialog is closed.
- The circles for mounting the front panel were created.
Creating cutouts for a fan

This task is to create cutouts for a fan to be able to mount a fan later. The required objects are created by using the function “Open path”.

- Creating a open paths
  1. Click on Insert > Open Path…
  
  ➤ Following dialog is displayed:

2. Select the Layer “BoardOutline”.
  
  ➤ Thus, contour routing toolpaths are generated for the cutouts in the technology dialog.
3. Select {Absolute}.
4. Enter “173” into the \Start point X\ field.
5. Enter “38” into the \Start point Y\ field.
6. Enter “237” into the \Segment X\ field.
7. Enter “102” into the \Segment Y\ field.
8. Click on [Apply] to create the path.
9. Repeat the steps 4-9 to create six more paths using the following values (the setting “Absolute” remains unchanged for the individual paths):

<table>
<thead>
<tr>
<th>Start point X</th>
<th>Start point Y</th>
<th>Segment X</th>
<th>Segment Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>165,5</td>
<td>48</td>
<td>227</td>
<td>109,5</td>
</tr>
<tr>
<td>161</td>
<td>61</td>
<td>214</td>
<td>114</td>
</tr>
<tr>
<td>161</td>
<td>79</td>
<td>196</td>
<td>114</td>
</tr>
<tr>
<td>183</td>
<td>30,5</td>
<td>244,5</td>
<td>92</td>
</tr>
<tr>
<td>196</td>
<td>26</td>
<td>249</td>
<td>79</td>
</tr>
<tr>
<td>214</td>
<td>26</td>
<td>249</td>
<td>61</td>
</tr>
</tbody>
</table>

The new design now looks as follows:

10. Click on [Close].
   • The dialog is closed.
   • The open paths were created.

- Changing the line width afterwards
If you want to change the width of the open path afterwards, act as follows:
Now the width of the open paths has to be changed to create the cutouts.
1. Select one of the created paths.
2. Click in the pane “Properties”.
3. In the pane “Properties” select the field ‘Width’.
4. Overwrite the value by entering 5 mm.
5. Press “Enter” on your keyboard.
The line width has changed.

The line width of open or closed paths gets visible if switching to mode "Outline" in the pane "Layers". If mode "Thin Line" is selected, the open or closed path is always shown as a thin line.

6. Repeat the steps 10-14 to change the line width of the remaining six open paths to 5 mm.

The layout changes as follows:

The line width was changed.
Creating drill holes for mounting the fan

This task is to create drill holes for mounting the fan. The holes are created by using the function “Create circle”.

- Creating circles
  1. Click on Insert > Circle.

➤ The following dialog is displayed:

2. Select the layer „DrillingUnplated“.  
3. Select {Absolute}.  
4. Enter „165“ into the \Center X\ field.  
5. Enter „110“ into the \Center Y\ field.  
6. Enter „2.5“ into the \ø\ field.  
7. Click on [Apply] to create the circle:

➤ The circle was created.

8. Repeat the steps 4-7 using the following values to create three more circles:

<table>
<thead>
<tr>
<th>X Position</th>
<th>Y Position</th>
<th>Durchmesser</th>
</tr>
</thead>
<tbody>
<tr>
<td>165</td>
<td>30</td>
<td>2.5</td>
</tr>
<tr>
<td>245</td>
<td>110</td>
<td>2.5</td>
</tr>
<tr>
<td>245</td>
<td>30</td>
<td>2.5</td>
</tr>
</tbody>
</table>
The layout changes as follows:

Fig. 172: Created circles

9. Click on [Close].
   - The dialog is closed.
   - The circles were created.
4.4 Creating toolpaths

Before we start creating the toolpaths, we have to create filled characters instead of outlined characters.

If the characters of the legends are to be milled fully, the settings of the layer have to be modified.

In the pane “Layers” check the check box in the “Inv” column in the row of the “TextTop” layer:

![Diagram of the Layers pane showing the TextTop layer with the 'Inv' column checked.]

This means for a “Wiring” layer (see column “Tech”) that the inside of the object is filled with milling toolpaths instead of creating an insulating toolpath around the object when the toolpaths are generated.
Creating toolpaths

1. Click on Toolpath > Technology Dialog.

   ➨ The following dialog is displayed:

   ![Technology Dialog](image)

   In the technology dialog, several settings can be modified by clicking on the [Show details] buttons.
   For a detailed description of the individual functions of the technology dialog see the corresponding chapter in the CircuitPro compendium.
   This example just requires the “Basic” contour routing method.

2. Click on the left-pointing arrow button in the “Contour Routing” section until the “Basic” contour routing method is selected.
3. Click on [Start].

   ➨ The results of the toolpath generation are displayed.
4. Click on [Close].

   ➤ The dialog is closed.

Note

CircuitPro processes circular cutouts up to a diameter of 2.4 mm as drill holes. All larger cutouts are processed as inner contours and are cut using the contour router tool.

➤ The design now looks as follows:

The toolpaths were created
4.5 Loading the tool magazine and assigning tools to holder positions

- Loading the tool magazine and assigning the tools to holder positions
  1. Click on Edit > Tool magazine…
     ➨ The following dialog is displayed:

     ![Tool magazine dialog]

     The tools shown in the tool magazine dialog must not correspond to your needed tools. These tools are examples.

     ➨ The tools required for the job are displayed. Tools that are missing in the tool magazine are marked by a red “X”.

     2. Insert the required tools into the tool magazine:

     ![Inserting a tool]
3. In the dialog, assign the tools to the respective tool magazine positions used.

➤ The tool holders of the machine are loaded:

Fig. 178: Loaded tool holder

4. Click on [OK].

➤ The dialog is closed.

◆ The tools were assigned and the tool magazine was loaded.
### 4.6 Start processing

- **Start processing**

1. Click on Machining > Process all.

![Start processing](image)

**Note**

Make sure that <Process All> is selected in the combo box, so that all phases are executed.

Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

Once you have started the processing, the ProtoMat machine executes the job in individual phases. The phases are displayed in messages:

**Note**

Depending on which ProtoMat you use the following phases could differ from the phases and messages displayed on your screen. Please follow the instructions on your screen.

For machines with manual tool exchange you are regularly asked to change the tool in the collet, for example.

**Phase “Mount Material”**

1. Mount the material onto the processing area.
2. Fasten the material to the processing area using adhesive tape.
3. Click on [OK].
Phase “Material Settings”

The following dialog is displayed:

- Entering the material settings
  1. Enter the correct values for the material used.

  PCB is selected as default.

Note

2. Change the values of copper thickness and material thickness as necessary.
3. Define the processing area:
   a) Move the dialog „Material Settings“ off to the side.
   b) Click on the position in the machining view that represents the right rear corner of your material:
   - The machine head moves to this position.
   c) Click on the corresponding icon in the dialog “Material Settings”:
   - The coordinates of the current head position are saved and the processing area is adjusted.
d) Click on the position in the machining view that represents the front left corner of your material:

![Image of material settings dialog]

- The machine head moves to this position.

e) Click on the corresponding icon in the dialog “Material Settings”:

![Image of defined processing area]

- The coordinates of the current head position are saved and the processing area has been fit to the material.

4. Click on [Continue].
   - The material settings were entered.
Phase “Placement”

In this phase, the job can be positioned, rotated and multiplied within the processing area.

⇒ Following dialog is displayed:

1. Drag the job to the desired position or use the dialog to position the job.
2. If desired, rotate the job by entering a rotation angle.
3. If desired, multiply the job by using the settings in the “Step and Repeat” section of the dialog.
4. Click on [Continue].

Phase “Marking Drills”

⇒ The “Universal Cutter” tool is picked up and the drill positions are marked.

Phase “Drilling Unplated”

⇒ The tools are picked up as required and the holes are drilled.

Phase “Milling Top”

⇒ The tools are picked up as required and the material (Top side) is milled.

Phase “Contour Routing”

⇒ The tools are picked up as required and the material is drilled and routed.

Phase “Board Production Finished”

⇒ A message informs you that the production is finished.
⇒ Your front panel is created.
5 Creating a polyimide stencil

This tutorial shows you how to produce an SMT stencil made of polyimide that you can use in the later process stages to apply solder paste (using e.g. the LPKF ProtoPrint system).

![Note]

In order to create a stencil, the polyimide film must be fixed on the underlay with a spray adhesive.

The following steps are necessary to complete the tutorial successfully:

i. Starting the machine and CircuitPro
ii. Selecting a template and creating a new document
iii. Importing data
iv. Processing data
v. Creating toolpaths
vi. Loading the tool magazine and assigning tools to holder positions
vii. Starting the processing

The following material is required:

- Polyimide film 125 µm (order no. 108321)
5.1 Starting the machine and CircuitPro

- Starting the machine and CircuitPro
  1. Switch on the machine.
  2. Start CircuitPro.

- CircuitPro automatically connects to the machine. The connection steps are displayed:

  ![Connection steps diagram](image)

- CircuitPro reads the settings from the machine.
- The machine moves to its reference points and subsequently moves to the Pause position.
5.2 Selecting a template and creating a new document

- Selecting a template and creating a new document
  1. Click on File > New…
    - The following dialog is displayed:

    2. Select the template “Stencil QR 266x380.cbf”.
    3. Click on [OK].
    4. Click on File > Save As…
    5. Enter a file name for the new file.
    6. Select a memory location.
    7. Click on [Save].
    - The new document is created.
5.3 Importing data

The LPKF tutor data are stored in folder “My documents\LPKF Laser & Electronics\LPKF CircuitPro 1.5\Example Data\UseCase_PolyimideStencil”.

- Importing data
  1. Click on File > Import…
  2. The following dialog is displayed:
  3. In the folder “UseCase_PolyimideStencil”, select the files “Tutor.SPT” and “Tutor.TOP”.
  4. Click on [OK].

- Assign the imported files according to the following table:

<table>
<thead>
<tr>
<th>File extension</th>
<th>Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>.SPT</td>
<td>SolderPasteTop</td>
</tr>
<tr>
<td>.TOP</td>
<td>Top Layer</td>
</tr>
</tbody>
</table>
Instead of manually assigning the individual files to the layers, you can activate the options “Use layer name” and “Apply to all Gerber files”. Activate the corresponding checkboxes in the tab “Options”.

If a file contains layer names these are automatically assigned. Please note that this is only available for Gerber files. All other files require assigning the layers manually via the drop-down menu.

5. Click on [OK].

The data are displayed in the CAM view:

◆ The data is imported.
5.4 Processing data

In the CAM view you are able to check the proportion between the solder paste pads and the copper pads.

The imported data shows you, that both pads on the SolderPaste-Layer and on the Top-Layer have the same proportion:

In order to achieve better results when applying solder paste, LPKF recommends to minimize the pad dimension for the solder paste. This will prevent the solder to flow over the copper pads.

- Minimizing the pad dimension of the solder paste pads

1. Highlight the data on the layer “SolderPasteTop”:
   a) Click in the pane “Layer” on the layer “SolderPasteTop”.
   b) Now click in the pane “Layer” on the adjoining icon “Select objects on layer”, to highlight all objects on the layer.
2. Click on Modify > Convert to polygon.

   The objects on the layer “SolderPasteTop” are flash objects. These cannot be scaled and must be converted into polygons first.

3. Click on Modify > Transformation.
   ➔ The “Transformation” dialog is shown.
4. Select the tab “Scale”:

5. If not active, enable the option “Scale each object individually”.

6. Enter “70” in the ‘New size in percent’ field.

7. Click on [Apply].

8. Click on [Close].

   The dimension of the solder paste pads on the layer “SolderPasteTop” has changed:

   ◆ The dimension of the solder paste pads is minimized.
5.5 Creating toolpaths

The objects of layer “SolderPasteTop” displayed in the CAM view require an inner insulation in order to remove the material inside these areas. This requires that the check box in the “Inv” column of the “SolderPasteTop” row of the “Layers” pane is activated:

![Fig. 194: “Layers” pane](image)

This means for a “Wiring” layer (see column “Tech”) that the inside of the object is filled with milling toolpaths instead of creating an insulating toolpath around the object when the toolpaths are generated.

- Creating toolpaths
  1. Click on Toolpath > Technology dialog…

- The following dialog is displayed:

![Fig. 195: Technology Dialog](image)
In the technology dialog, several settings can be modified by clicking on the [Show details] buttons. For a detailed description of the individual functions of the technology dialog see the corresponding chapter in the CircuitPro compendium.

This example just requires the “Basic” contour routing method.

2. In the drop down list “Material type” select “Polyimide”.
3. Click on [Show Details] in the “Insulate” section.
   ➔ The details for insulation are displayed.

4. In the drop down list “Primary”, select the tool “Micro Cutter 0.1 mm.”
   ➔ All other tools are not qualified for milling the polyimide stencil.
   Deactivate all other tools in the drop down list „Available tools“.

5. Click on [Hide details].
   ➔ The details are hidden.
6. Deactivate all other functions of the technology dialog except insulation. To achieve this, click on the check marks next the individual sections:
The functions are deactivated.

7. Click on [Start].

CircuitPro creates the toolpaths.

8. Click on [Close].

The dialog is closed.

The toolpaths are created.
CircuitPro automatically creates several toolpaths for an inner insulation. There are two distinct kinds of toolpaths:

- Toolpath for insulating the inside of the selected objects.
- Toolpath for removing the material inside the insulated area.

The toolpath that removes the material inside the insulated area is marked with "_1" in the "Toolpath" pane.

The material is cut through when insulation the objects for producing the stencil. Thus the toolpath for removing the material inside the insulation (Insulate_SolderPasteTop_Micro Cutter 0.1 mm_1") is not necessary and can be deleted.

**Deleting a toolpath**

1. Select the desired toolpath in the “Toolpath” pane.
2. Press the “Del” key or select “Delete” in the context menu.
5.6 Loading the tool magazine and assigning tools to holder positions

This chapter is relevant, if you use a ProtoMat with automatic tool change (S63 or S103).

Note

- Loading the tool magazine and assigning tools to holder positions

1. Click on Edit > Tool magazine…

   ➔ The following dialog is displayed:

   ![Tool magazine dialog](image)

   The tool shown in the tool magazine dialog must not correspond to your needed tools. These tools are examples.

2. Insert the required tools into the tool holders of the machine:

   ![Insert tool](image)

   The tools required for the job are displayed. Tools required for the job that are missing are marked by a red “X”.

3. Assign the tools to the corresponding positions in the dialog.
   ➔ The tool holder in the machine is loaded:

4. Click on [OK].
   ➔ The dialog is closed.
   ➔ The tools are inserted into the tool holders and assigned accordingly.
5.7 Starting the processing

- Starting the processing

1. Click on Machining > Process all.

![Machining Process all](image)

**Note**

Make sure that <Process All> is selected in the combo box, so that all phases are executed.

Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

Once you have started the processing, the ProtoMat machine executes the job in individual phases. The phases are displayed in messages:

**Note**

Depending on which ProtoMat you use the following phases could differ from the phases and messages displayed on your screen. Please follow the instructions on your screen.

For machines with manual tool exchange you are regularly asked to change the tool in the collet, for example.
Phase “MountMaterial”

1. First spray adhesive (e.g. 3M type 75) onto the surface of the underlay.
2. Place the polyimide film centered on the underlay.
3. Press the polyimide film on the underlay.
4. Use a rubber roll to remove all air blisters:
5. Put the underlay on the working table using the dowel pins if a vacuum table is not assembled.

Or
5. Fasten the underlay on the vacuum table by using adhesive tape.
6. Click on [OK].

Phase “Material Settings”

The following dialog is displayed:

- Entering the material settings
1. Enter the correct values for the material used.

Note

PCB is selected as default.
Creating a polyimide stencil

1. Enter the thickness of your material (polyimide film) in the field "Copper Thickness".

2. If a vacuum table is **not** assembled: Enter “0” in the field "Material Thickness".

Or

3. If a vacuum table is assembled: Enter the thickness of your underlay in the field "Material Thickness".

---

**Note**

The polyimide film has no copper layer. Since the material is cut with an insulation tool, the thickness of the material (polyimide film) has to be entered in the field for the copper thickness.

4. Define the processing area:
   a) Move the dialog „Material Settings“ off to the side.
   b) Click on the position in the machining view that represents the right rear corner of your material:

   ➔ The machine head moves to this position.
   c) Click on the corresponding button in the dialog “Material Settings”:

   ➔ The coordinates of the current head position are saved and the processing area is adjusted.
d) Click on the position in the machining view that represents the front left corner of your material:

Fig. 205: Front left corner

- The machine head moves to this position.

e) Click on the corresponding button in the dialog “Material Settings”:

Fig. 206: Click on the button

- The coordinates of the current head position are saved and the processing area has been fit to the material.

5. Click on [Continue].

- The material settings were entered.
Phase “Placement”

In this phase, the job can be placed arbitrarily on the base material and be multiplied if necessary.

Following dialog is displayed:

1. Click on the job and drag it to the desired position using the mouse.
Or
2. Enter the new position in the dialog.

Note

At this point, the whole circuit board design including the template and the toolpaths possibly contained in the template are moved.

If only the design is to be moved within the template, you have to use the menu item Modify > Transform....

Phase “Milling Top”

The Micro Cutter is picked up. The stencil is milled.

Phase “Board Production Finished”

A message informs you that the production is finished.

1. Remove the stencil from the underlay:
2. Put the stencil on a table with the adhesive side facing upwards.
3. Take a lint-free cloth.
4. Moisten the cloth with rubbing alcohol.
5. Remove any remaining adhesive from the stencil.

The polyimide stencil is created.
At a later stage of the process, you can clamp the stencil in an LPKF ProtoPrint and apply solder paste onto the circuit board with high precision using the stencil.

You can also cut the stencil to size for other solder paste processes.
6 Creating a flex-rigid PCB

This tutorial shows you how to produce a flex-rigid circuit board. The following steps are necessary to complete the tutorial successfully:

i. Starting the machine and CircuitPro
ii. Selecting a template and creating a new document
iii. Importing data
iv. Drilling and milling the individual physical layers
v. Bonding the individual physical layers
vi. Routing the bonded PCB

Note

Thin materials like the flexible polyimide material and the prepreg can only be machined using a vacuum table and air-cushioned milling-depth limiter.

Following material is required:

- Base material FR4 18/18µm with the dimensions 229 x 305 mm (order no. 119 574)
- Polyimide film 150µm copper clad (18µm) with the dimensions 210 x 297 mm.
6.1 Starting the machine and CircuitPro

- Starting the machine and CircuitPro
  1. Switch on the machine.
  2. Start CircuitPro.

  ➤ CircuitPro automatically connects to the machine. The connection steps are displayed:

Fig. 208: Connection steps

- CircuitPro reads the settings from the machine.
- The machine moves to its reference points and subsequently moves to the Pause position.
6.2 Selecting a template and creating a new document

This section shows you how to create the new document move the fiducials into the prepreg area

- Selecting a template and creating a new document
  1. Click on File > New…
     - The following dialog is displayed:

   ![New document dialog](image)

   2. Select the template “4Layer_ProConduct_MultiPressS.cbf”.

   ![Note]

   You need to select a template that contains registration holes for the LPKF MultiPress S system because creating a flex-rigid PCB requires bonding of rigid and flexible materials. Thus, the different physical layers can be aligned for bonding using the registration system of the MultiPress S system.

   3. Click on [OK].
The fiducials in the selected template are outside the prepreg's area (see figure above) as the prepreg usually is not machined in a multi-layer application and thus does not need to be aligned to the other layers.

This tutorial's flex-rigid PCB, however, requires a cutout in the prepreg. Thus, the prepreg has to be aligned to the other physical layers for bonding. Follow these steps:
Moving the fiducials into the prepreg area:

1. Click on the “Toolpath” pane.
2. Click on the arrow symbol next to “Phases”.

The phases are displayed:

3. Delete the toolpaths of the phases “PrepareLaminatBottom” and “PrepareLaminatTop” marked in the figure above.
4. Move the fiducial into the prepreg area:
   - Highlight the fiducials to be moved.
   - Activate the icon “Move selected objects” on the toolbar “Modify”.
   - Drag the fiducial while pressing the left mouse button to the desired position in the CAM view.
Modify the distance between the fiducials on one side (see figure above) in order to orient and align the prepreg correctly to the other materials for bonding.

- The fiducials have been moved into the prepreg area.

5. Click on File > Save As…
6. Enter a file name for the new file.
6. Select the memory location.
7. Click on [Save].

- The new document is created.
6.3 Importing data

In this section you will pass through following steps:

i. Importing data
ii. Deleting unnecessary production phases
iii. Assigning imported data to production phases

Tip

The LPKF tutor data are stored in folder “My documents\LPKF Laser & Electronics\LPKF CircuitPro 1.5\Example Data\UseCase_FlexiRigidPCB”.

- Importing data
  1. Click on File > Import… ➨ The following dialog is displayed:

    ![Import Dialog](image)

    2. Select the file “Tutor_Starrflex.cam”.
    3. Click on [OK]. ➨ The data are displayed in the CAM view:
The modified template with imported .cam file now contains the following data:

<table>
<thead>
<tr>
<th>Material used</th>
<th>Layer</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>FR4</td>
<td>CuttingInside</td>
<td>Cutout for flexible section</td>
</tr>
<tr>
<td>FR4</td>
<td>CuttingLaminat+Core</td>
<td>Slots for registration system of the LPKF MultiPress S</td>
</tr>
<tr>
<td>FR4</td>
<td>CuttingLaminat</td>
<td>Cutout for fiducials</td>
</tr>
<tr>
<td>Prepreg</td>
<td>CuttingInside</td>
<td>Cutout for flexible section</td>
</tr>
<tr>
<td>Prepreg</td>
<td>CuttingLaminat</td>
<td>Cutout for fiducials</td>
</tr>
<tr>
<td>Flexible material</td>
<td>BottomLayer</td>
<td>Insulation</td>
</tr>
<tr>
<td>Flexible material</td>
<td>Fiducial</td>
<td>Fiducials for aligning the individual layers for bonding</td>
</tr>
<tr>
<td>Flexible material</td>
<td>CuttingLaminat+Core</td>
<td>Slots for registration system of the LPKF MultiPress S</td>
</tr>
<tr>
<td>Bonded FR4 and flexible material</td>
<td>BoardOutline</td>
<td>Contour routing of the PCB</td>
</tr>
</tbody>
</table>

Due to the selected template “4Layer_ProConduct_MultiPressS.cbf”, the job contains production phases that are not needed for processing this tutorial’s PCB. These can be deleted in the “toolpath” pane before processing.
Deleting unnecessary production phases

1. Click on the "Toolpath" pane.

2. Delete the following phases in the "toolpath" pane:
   - MillingTextLayer3 through to MillingTextBottom (phases 6-16)
   - MillingPocketBottom through to MarkingDrills (phases 18-30)
   - DismountMaterial3 through to ProcessProConduct (phases 33-39)
   - ReadTopography through to Dispense (phases 41-42)

3. Select the desired phases.
4. Press the right mouse button in order to open the context menu.
5. Select "Delete" in the context menu.
   - The selected phase is deleted.
6. Repeat steps 3 to 5 for all other production phases to be deleted.
   - The unnecessary production phases are deleted.
Assigning imported data to production phases

Some layers of the imported data need to be assigned to a production phase. The generated toolpaths are thus assigned to a specific process step.

1. Click on the “Layer” pane.
2. Select the row of the layer “CuttingLaminat”:

3. In the layer row, click on the arrow in the “Phase” column.

   ➔ The phase selection list is displayed:

4. Assign the phase according to the following table:

<table>
<thead>
<tr>
<th>Layer</th>
<th>Phase</th>
</tr>
</thead>
<tbody>
<tr>
<td>CuttingLaminat</td>
<td>DrillingUnplated</td>
</tr>
<tr>
<td>CuttingInside</td>
<td>ContourRouting</td>
</tr>
</tbody>
</table>

5. Repeat the steps 2-4 for the layer “CuttingInside”.
   ➔ The data are assigned to production phases.
In this tutorial, the various physical layers are processed only on one side and are not turned over during processing (no “FlipMaterial” phases).

As this tutorial uses a multi-layer template, some phases can contain Top-side data per default, other phases can contain Bottom-side data.

Ensure that the toolpaths of all production phases of this tutorial are on the same side, e.g. the Bottom side, so that the physical layers can be aligned correctly in the later process stages. You can check this as follows:

1. Click on the “Toolpath” pane.
2. Click on the desired phase using the right mouse button.
3. Click on “Edit” in the context menu.
4. Check the check box “The data are mirrored” if the phase contains toolpaths.
5. Click on [Apply].
6. Click on [Close].
6.4 Processing the individual physical layers

The imported .cam file contains the data for producing the whole flex-rigid PCB but these are needed at different stages of the production process. Creating the toolpaths should be done separately for each production stage. Thus, the data needed for each production stage can be selected correspondingly for generating the toolpaths.

Processing the individual physical layers is divided into three sections:

i. Processing the flexible material
ii. Processing the FR4 material
iii. Processing the prepreg material
6.4.1 Drilling and milling the flexible material

In this section, the flexible material of the flex-rigid PCB is drilled and milled. The following steps are necessary for drilling and milling the flexible material:

i. Creating toolpaths
ii. Loading the tool magazine and assigning tools to holder positions
iii. Starting the processing

Creating toolpaths

1. Click on Toolpath > Technology dialog…

The following dialog is displayed:

In the technology dialog, the settings for generating toolpaths can be modified by clicking on the [Show details] buttons. For a detailed description of the individual functions of the technology dialog see the corresponding chapter in the CircuitPro compendium.
2. In the dropdown list “Material type” select “Polyimide”.
3. Click on [Show Details] in the “Insulate” section.
   ➔ The details for insulation are displayed.

4. Select the layer “BottomLayer” in the “Source” selection list.
5. Click on [Hide details].
   ➔ The details are hidden.
6. Click on [Show Details] next to “Fiducials”.
   ➔ The details for fiducials are displayed.

7. Select the “Fiducials” layer in the “Source” selection list.
8. Click on [Hide details].
   ➔ The details are hidden.
9. Deactivate the following functions by clicking on the corresponding check marks:
   • Contour Routing
   • Drills
   • Pockets

10. Click on [Start].
   ➤ The toolpaths are created and the computation results are displayed.
   ◆ The toolpaths are created.
Loading the tool magazine and assigning tools to holder positions

This section is only relevant, if you use a ProtoMat with automatic tool change (S63 or S103).

1. Click on Edit > Tool magazine…
   ➔ The following dialog is displayed:

   ![Tool magazine dialog](image)

   The tools shown in the tool magazine dialog must not correspond to your needed tools. These tools are examples.

   ➔ The tools required for the job are displayed. Tools required for the job that are missing are marked by a red “X”.

2. Insert the required tools into the tool holders of the machine:

   ![Inserting a tool](image)
3. Assign the tools to the corresponding positions in the dialog.

- The tool holders of the machine are loaded:

- The tools are inserted into the tool holders and assigned accordingly.
Starting the processing

1. Click on Machining > Process all.

   ![Machining Process all](image)

   **Note**

   Make sure that <Process All> is selected in the combo box, so that all phases are executed.

   Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

   You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

Once you have started the processing, the ProtoMat machine executes the job in individual phases. The phases are displayed in messages:

**Phase “MountMaterial”**

1. Mount the flexible material, with the copper side up, onto the processing area of the machine.
2. Fasten the base material onto the table top using the adhesive tape.
3. Click on [OK].
Phase “Material Settings”

The following dialog is displayed:

![Material Settings dialog]

- Entering the material settings
  1. In the dropdown list “Material Type” select “Polyimide”.
     
     PCB is selected as default.

  Note

  2. Enter “18” µm into the field ‘Copper Thickness’.
  3. Enter “0.15” mm into the field ‘Material Thickness’.
4. Define the processing area:
   a) Move the “Material Settings” dialog off to the side.
   b) Click on the position in the machining view that represents the right rear corner of your material:

   ➔ The machine head moves to this position.
   c) Click on the corresponding icon in the “Material Settings” dialog:

   ➔ The coordinates of the current head position are saved and the processing area is adjusted.
   d) Click on the position in the machining view that represents the front left corner of your material:

   ➔ The machine head moves to this position.
e) Click on the corresponding icon in the “Material Settings” dialog:

- The coordinates of the current head position are saved and the processing area has been fit to the material.

5. Click on [Continue].
- The material settings were entered.

**Phase “Placement”**

In this phase, the job can be placed arbitrarily on the base material, be rotated and/or be multiplied if necessary.

Note

At this point, the whole circuit board design including the template and the toolpaths possibly contained in the template are moved.

If only the design is to be moved within the template, you have to use the menu item Modify > Transform….

- Following dialog is displayed:
1. Click on the job and drag it to the desired position using the mouse.
   Or
1. Enter the new position in the dialog.
2. If desired, rotate the job data by entering a rotation angle.
3. If desired, multiply the job data by entering the number of copies and
   spacing values in X and Y direction in the corresponding fields (Step and
   Repeat section).

Phase “DrillFiducial”

- The Spiral Drill 1.5 mm is picked up to drill the fiducials.

- If the spindle motor has not run before, a 2-minute warm-up
  phase is started.

Note

Phase “PrepareCore”

- The slots for registration system of the LPKF MultiPress S are drilled.

Phase “MillingBottom”

- The flexible material is milled.

Phase “Board Production Finished”

- A message informs you that the processing is finished.
- The milling and drilling of the flexible material is finished.
### 6.4.2 Processing the FR4 material

In this section, the FR4 material of the flex-rigid PCB is processed. The following steps are necessary in this section:

1. Deleting toolpaths
2. Creating toolpaths
3. Loading the tool magazine and assigning tools to holder positions
4. Starting the processing

**Deleting toolpaths**

The toolpaths that were generated in the previous section of this tutorial for insulation and drilling the fiducials have to be deleted. They are not needed for processing the FR4 material.

1. Click on the “Toolpath” pane.
2. Click on the arrow symbol next to phases “DrillFiducial” and “MillingBottom”.
   
   ➔ The toolpaths of the phases are displayed.

The following toolpaths have to be deleted:

<table>
<thead>
<tr>
<th>Phase</th>
<th>Toolpath</th>
</tr>
</thead>
<tbody>
<tr>
<td>DrillFiducial</td>
<td>Fiducials_Fiducial_Spiral Drill 1.5 mm</td>
</tr>
<tr>
<td>MillingBottom</td>
<td>Insulate_BottomLayer_Universal Cutter 0.2 mm</td>
</tr>
<tr>
<td></td>
<td>Insulate_BottomLayer_Universal Cutter 0.2 mm_1</td>
</tr>
</tbody>
</table>

3. Select the desired toolpath.
4. Press the right mouse button in order to open the context menu.
5. Select “Delete” in the context menu.
   
   ➔ The selected toolpaths are deleted.
6. Repeat steps 3 to 5 for all other toolpaths to be deleted.
Creating toolpaths

1. Click on Toolpath > Technology dialog…
   ➔ The following dialog is displayed:

   ![Technology Dialog](image)

   **Note**

   In the technology dialog, the settings for generating toolpaths can be modified by clicking on the [Show details] buttons. For a detailed description of the individual functions of the technology dialog see the corresponding chapter in the CircuitPro compendium.

2. Click on the left arrow icon in the “Contour Routing” section until the “Basic” contour routing method is displayed.
3. Click on [Show details].
   ➔ The details for contour routing are displayed:

   ![Contour routing details](image)
4. Select the layer “CuttingInside” in the “Source” selection list.
5. Activate the {Inside} radio button.
6. Click on [Hide details].
   ➔ The details are hidden.
7. Click on [Show Details] next to “Drills”.
   ➔ The details are displayed:

![Fig. 234: Drills details](image)

8. In the selection list “Source” select the layer “CuttingLaminat”, listed below the layer “BaseMaterial”.
9. Deactivate the option “Create marking drills”.
10. Click on [Hide details].
    ➔ The details are hidden.
11. Deactivate the following functions by clicking on the corresponding check marks:
    • Insulate
    • Fiducials
    • Pockets

![Fig. 235: Deactivate functions](image)

12. Click on [Start].
    ➔ The toolpaths are created and the computation results are displayed.
    ➔ The toolpaths are created.
Loading the tool magazine and assigning tools to holder positions

This section is only relevant, if you use a ProtoMat with automatic tool change (S63 or S103).

1. Click on Edit > Tool magazine…

   ➪ The following dialog is displayed:

   ![Tool magazine dialog](image)

   The tools shown in the tool magazine dialog must not correspond to your needed tools. These tools are examples.

   ➪ The tools required for the job are displayed. Tools required for the job that are missing are marked by a red “X”.

2. Insert the required tools into the tool holders of the machine:

   ![Inserting a tool](image)
3. Assign the tools to the corresponding positions in the dialog.

⇒ The tool holders of the machine are loaded:

- The tools are inserted into the tool holders and assigned accordingly.
Starting the processing

1. Click on Machining > Process all.

![Machining > Process all](image)

Make sure that <Process All> is selected in the combo box, so that all phases are executed. Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

Once you have started the processing, the ProtoMat machine executes the job in individual phases. The phases are displayed in messages:

**Phase “MountMaterial”**

1. Mount the base material onto the processing area of the machine.
2. Fasten the material to the processing area using adhesive tape.
3. Click on [OK].
Phase “Material Settings”

The following dialog is displayed:

- Entering the material settings
  1. Enter the correct values for the material used.
  
  PCB is selected as default.

  **Note**
  
  2. Enter “18” µm into the field \( \text{Copper Thickness} \).
  3. Enter “1” mm into the field \( \text{Material thickness} \).
  4. Define the processing area:
     a) Move the “Material Settings” dialog off to the side.
     b) Click on the position in the machining view that represents the right rear corner of your material:
The machine head moves to this position.

c) Click on the corresponding icon in the “Material Settings” dialog:

The coordinates of the current head position are saved.

d) Click on the position in the machining view that represents the left corner of your material:

The machine head moves to this position.
e) Click on the corresponding icon in the “Material Settings” dialog:

- The coordinates of the current head position are saved and the processing area has been fit to the material.

5. Click on [Continue].
- The material settings were entered.

Phase “Placement”

The job cannot be placed again at this stage as the position has already been defined by the flexible material in the previous steps.

1. Confirm the current placement by clicking on [OK].

Phase “PrepareCore”

- The slots for the registration system of the LPKF MultiPress S are drilled.

Phase “DrillingUnplated”

- The cutouts for aligning the prepreg for bonding are drilled.

Phase “ContourRouting”

- The cutout for the flexible section is cut out.

Phase “Board Production finished”

- A message informs you that the processing is finished.
- Processing of the FR4 material is finished.
6.4.3 Processing the prepreg material

This section of the tutorial is on processing the prepreg material of the flex-rigid PCB.

The following steps are necessary for processing the prepreg material:

i. Deleting toolpaths
ii. Enlarging the cutouts around the fiducials
iii. Creating toolpaths
iv. Loading the tool magazine and assigning tools to holder positions
v. Starting the processing

Deleting toolpaths

The toolpaths for processing the FR4 material have to be deleted as they are not necessary for processing the prepreg material or have to be re-computed.

- Deleting toolpaths
  1. Click on the “Toolpath” pane.
  2. Click on the arrow symbol next to phases “PrepareCore”, “DrillingUnplated”, and “ContourRouting”.

➨ The toolpaths of the phases are displayed.

The following toolpaths have to be deleted:

<table>
<thead>
<tr>
<th>Phase</th>
<th>Toolpath</th>
</tr>
</thead>
<tbody>
<tr>
<td>PrepareCore</td>
<td>PrepareCore_Contour router 2 mm</td>
</tr>
<tr>
<td></td>
<td>PrepareCore_Spiral Drill 2 mm</td>
</tr>
<tr>
<td>DrillingUnplated</td>
<td>Drills_CuttingLaminat_Contour router 2 mm</td>
</tr>
<tr>
<td></td>
<td>Drills_CuttingLaminat_Spiral Drill 2 mm</td>
</tr>
<tr>
<td>ContourRouting</td>
<td>ContourRouting_CuttingInside_Contour router 2 mm</td>
</tr>
<tr>
<td></td>
<td>ContourRouting_CuttingInside_Spiral Drill 2 mm</td>
</tr>
</tbody>
</table>

3. Select the desired toolpath.
4. Press the right mouse button in order to open the context menu.
5. Select “Delete” in the context menu.

➨ The selected toolpaths are deleted.
6. Repeat steps 3 to 5 for all other toolpaths to be deleted.
   ➨ The toolpaths are deleted.
Enlarging the cutouts around the fiducials

To enable recognising the holes in the flexible material for contour routing the PCB, the cutouts around the fiducials have to be enlarged in the prepreg material. This prevents the prepreg material from creeping into the fiducials during the bonding process.

1. Select the cutouts around the fiducials:

2. Click on the “Properties” pane.

3. Check the properties of the circular cutout around the fiducial:

The “Properties” pane displays the following information on the cutout:
- Aperture D12 is used to create the cutout.
- Aperture D12 is in aperture list “4LayersMPS.TOP”.

As the cutout around the fiducials is to be enlarged, check the diameter of the aperture next.

4. Click on the “Geometry” pane.

5. Click on the arrow symbol next to the aperture lists.
The aperture lists are displayed:

![Aperture lists](image)

6. Click on the arrow symbol next to aperture list “4LayerMPS.TOP”.
   - The apertures contained are listed. Among them, you find aperture D12 that is used for creating the cutout around the fiducial.
7. Select aperture D12.
8. Click on the “Properties” pane again.
   - The properties of aperture D12 are displayed:

![Aperture size](image)
The name of the aperture is displayed in the “General” section.

The diameter of the aperture is displayed in the “Dimensions” section. The diameter is 4 mm.

9. Click on the aperture size in order to modify it:

![Fig. 249: Modifying the aperture size]

10. Overwrite the “4” with an “8”.

- The aperture size is changed from 4 mm to 8 mm diameter.
- The cutouts around the fiducials are enlarged.
Creating toolpaths

1. Click on Toolpath > Technology dialog…

   ➨ The following dialog is displayed:

   ![Technology Dialog]

   In the technology dialog, the settings for generating toolpaths can be modified by clicking on the [Show details] buttons. For a detailed description of the individual functions of the technology dialog see the corresponding chapter in the CircuitPro compendium.

2. Click on the left arrow icon in the “Contour Routing” section until the “Basic” contour routing method is displayed.
3. Click on [Show details].

 ➔ The details for contour routing are displayed:

![Contour routing details](image)

4. Select the layer “CuttingInside” in the “Source” selection list.
5. Activate the {Outside} radio button.
6. Select the “Contour Router 2 mm” tool.

**Note**
Using the outside contour in combination with the 2-mm tool enlarges the cutout by 2 mm compared with the FR4 material. This is intentional as the prepreg material “creeps” during the bonding process.

7. Click on [Hide details].

 ➔ The details are hidden.
8. Click on [Show Details] next to “Drills”.

 ➔ The details are displayed:

![Drills details](image)
9. Select the layer “CuttingLaminat” in the “Source” selection list.
10. Deactivate the option “Create marking drills”.
11. Click on [Hide details].
   ➔ The details are hidden.

12. Deactivate the following functions by clicking on the corresponding check marks:
   • Insulate
   • Fiducials
   • Pockets

13. Click on [Start].
   ➔ The toolpaths are created and the computation results are displayed.
   ◆ The toolpaths are created.
Loading the tool magazine and assigning tools to holder positions

This section is only relevant, if you use a ProtoMat with automatic tool change (S63 or S103).

1. Click on Edit > Tool magazine…

   ➤ The following dialog is displayed:

   ![Tool magazine dialog]

   The tools shown in the tool magazine dialog must not correspond to your needed tools. These tools are examples.

   ➤ The tools required for the job are displayed. Tools required for the job that are missing are marked by a red “X”.

2. Insert the required tools into the tool holders of the machine:
3. Assign the tools to the corresponding positions in the dialog.

➤ The tool holders of the machine are loaded:

* The tools are inserted into the tool holders and assigned accordingly.
Starting the processing

1. Click on Machining > Process all.

![Machining > Process all](image)

**Note**

Make sure that <Process All> is selected in the combo box, so that all phases are executed.

Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the "Start processing" button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the "ladder" button. The selected phase and all following phases are processed in the correct order.

Once you have started the processing, the ProtoMat machine executes the job in individual phases. The phases are displayed in messages:

### Phase “MountMaterial”

1. Place the base material onto the processing area of the machine. In order to get a leveled result with clear-cut edges, press underlay plates from both sides onto the prepreg material. This prevents the material from slipping.

![Mounting the material](image)

2. Fasten the material to the processing area using adhesive tape.
3. Click on [OK].
Phase “Material Settings”

The following dialog is displayed:

- Entering the material settings
  1. Enter the correct values for the material used.

- PCB is selected as default.

Note

- Enter “0” µm into the field \Copper Thickness\.
- Enter “3.5” mm into the field \Material Thickness\.
4. Define the processing area:
   a) Move the “Material Settings” dialog off to the side.
   b) Click on the position in the machining view that represents the right rear corner of your material:

   ![Fig. 260: Defining the right rear corner]

   ➔ The machine head moves to this position.
   c) Click on the corresponding icon in the “Material Settings” dialog:

   ![Fig. 261: Click on the icon]

   ➔ The coordinates of the current head position are saved.
   d) Click on the position in the machining view that represents the front left corner of your material:

   ![Fig. 262: Defining the front left corner]

   ➔ The machine head moves to this position.
e) Click on the corresponding icon in the “Material Settings” dialog:

- The coordinates of the current head position are saved and the processing area has been fit to the material.

5. Click on [Continue].
- The material settings were entered.

Phase “Placement”

The job cannot be placed again at this stage as the position has already been defined by the flexible material in the previous steps.

1. Confirm the current placement by clicking on [OK].

Phase “DrillingUnplated”

- The cutouts for aligning the prepreg for bonding are drilled.

Phase “ContourRouting”

- The cutout for the flexible section is cut out.

Phase “Board Production Finished”

- A message informs you that the processing is finished.
- Processing of the prepreg material is finished.
6.5 Bonding the individual physical layers

The flexible material is bonded to the rigid FR4 material using the prepreg material.

Note

We recommend the LPKF MultiPress S system (order no. 120734/120736) for this process step.

- Bonding the physical layers
  1. Stack the physical layers produced in the previous steps in the following order:

     I. **Flexible material**
        → Ensure that the milled side faces downwards!

     II. **Prepreg material**
        → Align the prepreg material to the flexible material. Use the fiducials in the flexible material as reference.

     III. **FR4 material**
        → Align the FR4 material to the flexible material. Use the reference hole system as reference.

Note

Insert a strip of corresponding size into the cutout of the FR4 material (e.g. the material previously cut out). This supports the flexible material while bonding and achieves better results.

2. Bond the materials with constant temperature and constant pressure.
   ➤ If you use the MultiPress S system select the press profile “LPKF Set”.
   ➤ If you use another press system enter the following parameters:
      • Preheating temperature: 250 °C
      • Prepressing temperature: 180 °C
      • Main pressing temperature: 180 °C
      • Prepressing time: 10 min.
      • Main pressing time: 60min.
      • Prepressing force: 80 N/cm²
      • Main pressing force: 150 N/cm²

   ➤ The physical layers are bonded.
6.6 Contour routing the bonded PCB

The following steps are necessary for contour routing the bonded PCB:

i. Inserting a production phase
ii. Creating toolpaths
iii. Loading the tool magazine and assigning tools to holder positions
iv. Starting the processing

Inserting a production phase

An additional production phase for reading the fiducials has to be inserted before the toolpaths for contour routing the PCB are generated.

Note

The cutouts in the prepreg and FR4 material enable recognising the fiducials in the flexible material from the Top side (the flexible material facing downwards).

Note

Ensure that no existing production phase is selected in the "Toolpath" pane, otherwise no new production phase can be created!

1. Click on Machining > Production phase…

The following dialog is displayed:

2. Enter the name “ReadFiducials” for the new phase.
3. Select the processing step “Read fiducials top”.

You can enter this processing step manually if it does not exist.
4. Enter “8” for processing order.
5. Activate the check box “The phase contains toolpath data”.
6. Click on [Apply].

➤ The new phase ReadFiducials is inserted before the ContourRouting phase in order to read the fiducials from the Top side of the PCB.

Note

You can check in the “Phases” section of the “Toolpath” pane whether the new phase has been inserted.

◆ The new production phase has been inserted.
Deleting toolpaths

All toolpaths previously generated for processing the individual physical layers have to be deleted. They are not needed for routing the PCB.

- Deleting toolpaths
  1. Click on the “Toolpath” pane.
  2. Click on the arrow symbol next to “Toolpaths”.
  ➔ The toolpaths are displayed.

3. Select all existing toolpaths.
4. Press the right mouse button in order to open the context menu.
5. Click on “Delete” in the context menu.
  ➔ The toolpaths are deleted.
Creating toolpaths

The PCB has to be put on the processing area of the ProtoMat machine with the flexible material facing downwards to enable contour routing. The PCB is thus processed from the Top side.

Check in the “Toolpath” pane whether the “ContourRouting” phase is processed on the Top side.

Proceed as follows:
1. Right-click on the desired phase.
2. Click on “Edit” in the context menu.
3. Ensure that the check box “The data are mirrored” is unchecked. If not, uncheck the mark.

Creating toolpaths
1. Click on Toolpath > Technology Dialog…

The following dialog is displayed:

In the “Technology Dialog”, the settings for generating toolpaths can be modified by clicking on the [Show details] buttons. For a detailed description of the individual functions of the “Technology Dialog” see the corresponding chapter in the CircuitPro compendium.
2. Click on the right arrow icon in the “Contour Routing” section until the contour routing method “Equidistant gaps” is displayed.
3. Click on [Show details].
   ➔ The details for contour routing are displayed:

4. Select the “BoardOutline” layer in the “Source” drop-down list.
5. Activate the {Outside} radio button if it is not active.
6. Click on [Hide details].
   ➔ The details are hidden.
7. Click on [Show details] next to “Fiducials”.
   ➔ The details for fiducials are displayed:

8. Select the “Fiducial” layer in the “Source” drop-down list.
9. Click on [Hide details].
   ➔ The details are hidden.
10. Deactivate the following functions by clicking on the corresponding check marks:
   • Insulate
   • Drills
   • Pockets

11. Click on [Start].
    ➔ The toolpaths are created and the computation results are displayed.
    ➔ The CAM view changes as follows:

The next task is to create the toolpaths for the cutouts around the fiducials.
Creating a flex-rigid PCB

1. Select the row “CuttingLaminat” in the “Layers” pane:

2. Click on Toolpath > Technology dialog.
   ➔ The “Technology Dialog” is displayed.
3. Click on the left arrow icon in the “Contour Routing” section until the contour routing method “Basic” is displayed.
4. Click on [Show details].
   ➔ The details for the function “Contour routing” are displayed:

5. Select “<Current selection>“ in the “Source” drop-down list.
6. Activate the radio button “Inside” by clicking on it.
7. Deactivate the check box “Replace existing toolpath”.
8. Click on [Hide details].
   ➔ The details are hidden.
9. Deactivate the following functions by clicking on the corresponding check marks:
   • Insulate
   • Drills
   • Fiducials
   • Pockets
10. Click on [Start].
   ➔ The toolpaths are created and the computation results are displayed.
   ➔ The CAM view changes as follows:

   The toolpaths for the cutouts around the fiducials have been created.
**Editing the positions of the breakout tabs**

The positions of the breakout tabs have to be moved to achieve a clean-cut edge also around the rigid part of the flexi-rigid circuit board.

- Editing the breakout tabs
  1. Click on Toolpath > Edit breakout tabs…
  2. The following dialog is displayed:

![Edit breakout tabs dialog](image1)

- The positions of the breakout tabs are marked by circles in the CAM view.

![Breakout tab position zoomed in](image2)

2. Click on the breakout tab/circle to be moved.
3. Keep the left mouse button pressed and drag the circle to the right to the outer edge of the flexi-rigid design:

![Breakout tab position moved](image3)
The X and Y coordinates of the new breakout tab position are displayed in the dialog:

Fig. 277: Circle moved

4. Repeat the above steps and add another breakout tab position at the left side of the design:

Fig. 278: Left breakout tab

5. Click on [Apply] in the dialog.
6. Click on [Close] in the dialog.

The breakout tabs have been moved and the CAM view changes as follows:

Fig. 279: New breakout tab positions

- The breakout tab positions have been edited.
Loading the tool magazine and assigning tools to holder positions

1. Click on Edit > Tool magazine…

➡️ The following dialog is displayed:

The tools displayed in the tool magazine are only examples.

Note

➡️ The tools required for the job are displayed. Tools required for the job that are missing are marked by a red “X”.

2. Insert the required tools into the tool holders of the machine:
3. Assign the tools to the corresponding positions in the dialog.

▶ The tool holders of the machine are loaded:

Fig. 282: Loaded tool holder

▶ The tools have been inserted into the tool holders and assigned accordingly.
Starting the processing

1. Click on Machining > Process all.

Make sure that <Process All> is selected in the combo box, so that all phases are executed.

Instead of processing all phases automatically, you can process the phases individually. In the combo box, select the desired phase and click on the green “Start processing” button.

You can also start processing with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

Once you have started the processing, the ProtoMat machine executes the job in individual phases. The phases are displayed in messages:

Phase “Mount Material”

1. Mount the PCB onto the machine's processing area with the flexible material facing down (Top side up).

Ensure that the positioning holes are at the right front corner.

2. Fasten the material to the processing area using adhesive tape.
3. Click on [OK].
Phase “Material Settings”

The following dialog is displayed:

- Entering the material settings
  1. Select {PCB} in the section “Application”.
  2. Select the material type (FR4).
  3. Enter “18” µm into the field \Copper Thickness\.
  4. Enter the thickness of the bonded PCB into the field \Material Thickness\, in this case “1.75 mm”.

Tip

You can also measure the thickness using calipers.
5. Define the material area:
   a) Move the “Material Settings” dialog off to the side.
   b) Click on the position in the machining view that represents the right rear corner of your material:

![Fig. 285: Defining the right rear corner](image)

- The milling head moves to this position.

   c) Click on the corresponding icon in the “Material Settings” dialog.

![Fig. 286: Click on the icon](image)

- The coordinates of the current milling head position are adopted.

   d) Click on the position in the machining view that represents the front left corner of your material:

![Fig. 287: Defining the front left corner](image)
The milling head moves to this position.
e) Click on the corresponding icon in the “Material Settings” dialog.

Fig. 288: Defined material area

The coordinates of the current milling head position are adopted and the material area has been adjusted.

6. Click on [Continue].
   • The material settings have been configured.
Phase “Placement”

The job cannot be placed again at this stage as the position has already been defined by the flexible material in the previous steps.
1. Confirm the current placement by clicking on [OK].

Phase “Read Fiducial”

➤ The camera searches for the fiducials in the flexible material.

Note

If the fiducial search is performed for the first time (after having started CircuitPro) the camera is performing an autofocus five times.

Afterwards, the following message is displayed that prompts you to confirm the focus height:

![Confirmation of focus height](image)

If the material is placed at nearly the same position as before, the positions of the fiducials are recognised automatically.

The following dialog is displayed if the fiducials have not been recognized automatically:
1. Enlarge the search area by increasing the value of the field \Search Area Length\.
2. Restart the search by clicking on [Start].
3. Repeat steps one and two if necessary.

---

Note

Enlarging the search spiral increases the time required for searching the fiducials. Try to put the material at the same position as before when turning the material over (if this is not predetermined by reference pins).

---

**Phase “ContourRouting”**

➢ The PCB is cut out.

**Phase “Board Production Finished”**

➢ A message informs you that the processing is finished.
➢ The bonded PCB has been cut out.

Creating the flex-rigid PCB is finished successfully.
1 CircuitPro: Basic CAM operations

This tutorial shows you how to process basic CAM operations in CircuitPro. The following steps are necessary to complete the tutorial successfully:

i. Executing the Process Planning Wizard
ii. Importing the Gerber files
iii. Importing the drill file
iv. Establishing rubout boundaries
v. Inserting fiducials
vi. Creating toolpaths

Tip

You are able to perform these steps by using the virtual machine. This enables you to work without a real machine. Click on Machining > Connect > Virtual.
1.1 Executing Process planning wizard

Note
CircuitPro must be running.

- Executing the Process planning wizard
  1. Click the icon “Process planning Wizard” on the toolbar:

Or
  1. Click on Wizards > Process planning wizard…

⇒ The process planning wizard starts:

2. Select the type of process.
3. Click on [Next].
4. Select the number of copper layers you are going to use.

5. Click on [Next].

6. Select which substrate you are going to use.

The options will be presented based on what you told the system in the Equipment configuration wizard during the initial installation.
You can start the Equipment configuration wizard any time to customize the available systems.

7. Click on [Next].
8. Select which through-hole plating method will be used for PCB production.
9. Click on [Next].
10. Select if you are using any surface finishing (silkscreen or solder mask):
12. Verify the configuration and click on [Done].
   ✷ The Process planning wizard is finished.
1.2 Importing the Gerber files

Tip
The LPKF tutor data are stored in "My Documents\LPKF Laser & Electronics\LPKF CircuitPro 1.5\Example Data\UseCase_BasicCAMOperations".

- Importing the Gerber files
  1. Click on the icon "Import" on the toolbar:

Or

1. Click on File > Import…

The following dialog is displayed:

2. Select all required data according to the table below.
3. Click on [Open].
4. Assign the imported files to their corresponding layers according to the following table:

<table>
<thead>
<tr>
<th>File</th>
<th>Layer</th>
</tr>
</thead>
<tbody>
<tr>
<td>.BOA</td>
<td>Board Outline</td>
</tr>
<tr>
<td>.BOT</td>
<td>Bottom Layer</td>
</tr>
<tr>
<td>.SMB</td>
<td>Solder Mask Bottom</td>
</tr>
<tr>
<td>.SMT</td>
<td>Solder Mask Top</td>
</tr>
<tr>
<td>.SPT</td>
<td>Solder Paste Top</td>
</tr>
<tr>
<td>.TOP</td>
<td>Top Layer</td>
</tr>
</tbody>
</table>

5. Therefore, click on the column “Layer/Template” and choose the corresponding layer in the drop down list:

Instead of manually assigning the individual files to the layers, you can activate the options “Use layer name” and “Apply to all Gerber files”.

If a file contains layer names these are automatically assigned. Please note that this is only available for Gerber files. All other files require assigning the layers manually via the drop-down menu.
6. Click on [OK].
    The data are displayed in the CAM view.
   ◆ The Gerber files were imported.

Note

For more information about importing Gerber files, please refer to the tutorial “Processing Gerber and Excellon files”.

1.3 Importing the drill file

Note

This step can be completed at the same time as importing the Gerber files.

- Importing the drill file
  1. Click the icon “Import” on the toolbar:

Or
  1. Click on File > Import….

The following dialog is displayed:

2. Select the drill file “Tutor.DRL”.
3. Click on [Open].
In this document, the DRL file is the Excellon drill file. This may also be a text file, (.txt. extension) depending on your layout package.

4. Change the layer/template column to DrillPlated or DrillUnplated:

<table>
<thead>
<tr>
<th>Import</th>
<th>File Name</th>
<th>Format</th>
<th>Aperture/Tool List</th>
<th>Layer/Template</th>
<th>Size/Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔</td>
<td>Tutor.DRL</td>
<td>Excellon</td>
<td>☑ Tutor.DRL</td>
<td>Tutor.DRL</td>
<td>7.11 x 10.57 mm</td>
</tr>
</tbody>
</table>

This depends on whether you are using a through-hole plating system:
- If so, use the layer DrillPlated.
- If not, use the layer DrillUnplated.

This will also affect where the holes are drilled:
- DrillPlated is drilled on the bottom side of the board.
- DrillUnplated is drilled from the top side of the board.

If this is a single sided board, use DrillUnplated.

In the graphic display, the correct view of the drills, you should see the different sized apertures and the correct location of your drills.
- If the display is correct, continue with step 6.
- If the display is not correct, continue with step 5.

5. Check the settings in the tab “General”. If necessary change the settings until your design is displayed correctly.
For details about the settings, please refer to the tutorial “Processing Gerber and Excellon files”.

---

6. Click on [OK].

⇒ The design is now displayed on screen:

- The drill file was imported.
1.4 Inserting a rubout area (optional)

You can remove excess copper if desired. Therefore you have to insert rubout areas.

- Inserting a rubout area
  1. Click on Insert > Rubout area > Rubout all layers…:

    ![Rubout all layers dialog]

    ➔ The following dialog is displayed:

    ![Create rectangle dialog]

    2. Move the “Create rectangle” dialog off to the side.
    3. Single click on one corner of the board, or on the desired location.
    4. Single click on the opposite corner of the board, or on the desired location.
    5. Click on [Close].
The rubout area is created on your board:

Note

If you wish to create a rectangle by a specific size, you may use the coordinate system in the rectangle window.

The rubout area was inserted.
1.5 Inserting fiducials (optional)

For aligning the top and bottom sides of the circuit board you need fiducials. Fiducials are optical marks on the surface of the circuit board with a defined diameter of 1.5 mm.

The fiducials are drilled into the board and are recognised by the cameras of the ProtoMat systems.

Note

For working with fiducials you need the camera system for fiducial recognition.

Tip

Ideally you insert four fiducials for aligning the top and the bottom sides.

You are also able to work with two fiducials. In this case you have to insert them diagonally into the layout.

Inserting fiducials

1. Click on Insert > Fiducial > Fiducial:
The following dialog is displayed:

2. Move the “Create circle” dialog off to the side.
3. Left click where you want to place each fiducial hole:

Note

Best results are just off each corner of the board.

4. Click on [Close].
   • The fiducials were inserted.
1.6 Creating toolpaths

The Technology Dialog is used for creating toolpaths in CircuitPro.

Note

There are various options how to create toolpaths etc. For more detailed information please refer to the chapter “Technology Dialog” in the compendium.

You will pass through following steps:

i. Selecting the material type
ii. Selecting the insulation type
iii. Selecting the contour routing type
iv. Creating the toolpaths

1. Click the icon “Technology Dialog” on the toolbar:

Or

1. Click on Toolpath > Technology Dialog…

The following dialog is displayed:
Selecting the material type
1. Select your material type in the corresponding drop down list.
2. If your project is a radio frequency application, activate the corresponding check box <RF application>.
   ◆ The material type has been selected.

Selecting the insulation type.
1. Click on the right/left arrow keys in the section “Insulation” to choose the insulation type you desire.
2. Click on [Show Details] for more information about the insulation type.

The following insulation types are available:

a) Basic insulation
   → The method “Basic insulation” is isolating the traced pads from the copper only.

b) Basic insulation, pads double
   → The method “Basic insulation, double pads” isolates the traces and double isolates the pads.
c) Partial rubout

→ The method “Partial rubout” isolates the traces and pads and removes any excess copper within the rubout boundary inside of your board.

![Fig. 315: Partial rubout](image)

\[Equation\]

\[Image\]

d) Complete rubout

→ The method “Complete rubout” isolates the traces and pads along with removing the excess copper from the entire board.

![Fig. 316: Complete rubout](image)

After you have chosen the insulation method, continue with step 3.

3. Select the milling tools that you wish to use in the available tools drop-down menu by checking/unchecking the tool name.

Note

A recommended combination of tools is: Universal Cutter 0.2 mm, the End Mill 0.4 mm and the End Mill 1.0 mm.

For **RF boards** use the 0.25 mm End Mill instead of the Universal Cutter.

If your designs have smaller spacing requirements than 8 mils, use the End Mill 0.15 mm (6 mil), the End Mill 0.1 mm (4 mil) or the Micro Cutter 0.1 mm (4 mil).

If milling a **RF board**, change the primary tool!

4. Click on [Hide details].

◆ The insulation type has been selected.
Selecting the contour routing type

1. Click on the right/left arrow keys in the section “Contour Routing” to choose the option you would like to cut the board out.
2. Click on [Show Details] for more information about the contour routing types.

The following contour routing types are available:

a) **Basic**
   → The method “Basic” routes along the outside of your board without gaps.

   ![Fig. 317: Basic routing](image)

b) **Horizontal gaps**
   → The method “Horizontal gaps” routes along the outside of your board with gaps on top and bottom side.

   ![Fig. 318: Horizontal gaps routing](image)

c) **Vertical gaps**
   → The method “Vertical gaps” routes along the outside of your board with gaps on the left and right side.

   ![image]
**d) Edge gaps**

The method “Edge gaps” routes along the outside of your board leaving tabs in the center of each edge of the board.

**e) Corner gap**

The method “Corner gap” routes along the outside of your board leaving tabs in the corners.
f) Equidistant gaps

→ The method “Equidistant gaps” routes along the outside of your board leaving tabs at equal distance that you specify.

After you have chosen the contour routing method, continue with step 3.

3. If desired, change the tool used during the contour routing by clicking on the tool drop-down menu:

4. Change the 2.0 mm contour router to the 1.0 mm contour router.

Note

If your design is larger than 2x3 inches, the 2.0 mm Contour Router is recommended.

If your design is smaller than 2x3 inches, the 1.0 mm Contour Router is recommended.

Note

The 1.0 mm Contour Router is also recommended if the board outline is not a traditional rectangle. This helps minimize the risk of a rounded corner.

◆ The contour routing type has been selected.
Creating the toolpaths
After you have chosen your insulation method and your contour routing type, you have to start to create the toolpaths.

1. Click on [Start].
   ➨ The software will now create all toolpaths and identify which drills shall be used. When finished, you will get a report of which tools are used.

2. Click on [Close], to close the report window.
   ◆ The toolpaths have been created.

Now your design is ready to be produced as a PCB. Continue with the steps described in the tutorial “CircuitPro - Basic machining operations”.
2 CircuitPro: Basic machining operations

This tutorial shows you how to process basic machining operations (ProtoMat S series) in CircuitPro and is based on using a 2-sided template without Through-Hole Plating. Although the document follows a certain set of steps, the steps could vary in order depending on the template chosen by the user.

Therefore you have to perform following steps:

i. Switching to Machining view
ii. Loading the tool magazine
iii. Starting board production

Note

CircuitPro must be running and the machine must be connected.
2.1 Switching to Machining view

To start the board production, you have to switch to machining view first.

1. Click on the tab “Machining view”:

![Fig. 325: Tab “Machining view”]

You will see your board on your screen:

![Fig. 326: Machining view]
2.2 Loading the tool magazine

In this step you will learn, how to load the tool magazine and assign the tools to their tool holder positions.

This chapter is relevant, if you use a ProtoMat with automatic tool change (S63 or S103).

- Loading the tool magazine and assigning the tools to holder positions
1. Click on the icon “Tool magazine” on the toolbar:

   ![Fig. 327: Icon Tool magazine]

Or

1. Click on Edit > Tool magazine…

   ➔ The following dialog is displayed:

   ![Fig. 328: Tool magazine]

   The tools shown in the tool magazine dialog must not correspond to your needed tools.

   ![Note]

The required tools for producing the board are listed on the left of the screen (see arrow).
2. Click on the drop-down menu in each individual tool position.

- The list of available tools is shown:

![Tool list](image1)

3. Select one of the tools that are listed on the left in section “Required tools”.

4. Insert the chosen tool (in the dialog) physically into the corresponding tool holder:

![Insert tool into holder](image2)

5. Repeat this procedure until you have placed all required tools into the tool holder of the machine.
The tools you have placed are highlighted with a checkmark.

As you assign each tool to a tool holder, the corresponding tool is highlighted with a checkmark. You will also notice that if you have a tool loaded into the tool magazine and it is not required for this design, there is no highlight like a checkmark or a cross.

6. Click on [OK].

You will notice that the colors of the tool holders on the main layout screen match the colored rings on the physical tools, as shown below:

The tool magazine is loaded and the tools are assigned to holder positions.
2.3 Starting processing

This chapter describes the processing of the circuit board.

- Starting processing
  1. Click on the icon “Process Planning wizard” on the toolbar:

Or

1. Click on Machining > Process all.

Make sure that <Process All> is selected in the combo box, so that all phases are executed.

Instead of processing all phases automatically, you can process the phases individually. In the combo box select the desired phase and click on the “Start processing” button.

You can also start processing beginning with a specific phase. Select the desired phase in the combo box and click on the “ladder” button. The selected phase and all following phases are processed in the correct order.

After the production started, the machine will process following phases in order. The phases are displayed via prompts.

Depending on which ProtoMat you use the following phases could differ from the phases and messages displayed on your screen. Please follow the instructions on your screen.

For machines with manual tool exchange you are regularly asked to change the tool in the collet, for example.
Phase “MountMaterial”
1. Place the base material onto the machine’s table top.
2. Fasten the base material onto the table top using the adhesive tape.

Phase “MaterialSettings”

Following dialog is displayed:

![Material Settings Dialog](image)

- Entering the material settings
  1. Enter the correct values for the material used.

  PCB is selected as default.

Note

2. Adapt the values of copper thickness and material thickness if necessary.
3. Define the processing area:
   a) Move the dialog „Material Settings“ off to the side.
   b) Using your mouse in the machining view, click on the right rear corner of your material:

   ![Diagram of the machining view]

   /1/ Click in the machining view  /2/ Material

   ➤ The machine head moves to this position.
   c) Now click on the corresponding button in the dialog “Material Settings”:

   ![Diagram of the Material Settings dialog]

   ➤ The coordinates of the current head position are saved.
d) Using your mouse in the machining view, click on the front left corner of your material:

![Material Settings](image)

The machine head moves to this position.

e) Now click on the corresponding button in the dialog “Material Settings”:

![Defined processing area](image)

1/ Defined processing area

The coordinates of the current head position are saved and the processing area has been fit to the material.

4. Click on [Continue].

The material settings were entered.
Phase “Placement”

In this phase, the job can be placed arbitrarily on the base material and be multiplied if necessary.

Following dialog is displayed:

1. Click on the job and drag it to the desired position using the mouse.
Or
2. If desired, multiply the job data by entering the number of copies and spacing values in X and Y direction in the corresponding fields (Step and Repeat section).

Tip

If you wish to create multiple copies of your layout, enter in section “Step and Repeat” the number of copies for each axis. Then click on [OK].

The spacing between the copies is measured from the respective outer edge of the adjacent layout.
LPKF recommends increasing this distance slightly to produce a frame between the copies, as this makes it easier to cut out.
Phase “Drill Fiducial”

➤ The machine picks up the tool “Spiral Drill 1.5 mm” and drills the fiducials.

If the spindle motor has not been used before, the motor is warmed up for 2 minutes.

Note

Phase “Marking Drills”

➤ The machine picks up the tool “Universal Cutter” and marks the positions for the drill holes.

Phase “Drilling Unplated”

➤ The machine picks up the required tool and drills the holes.

This phase may use more than one tool.

Note

Phase “Milling Bottom”

➤ The machine picks up the required tool and mills the isolation tracks.

Phase “Flip Material”

1. Flip the material.

If you are using a ProtoMat S43, S63 or S103 flip the material along the machine’s X-axis.

Note

If you are using a ProtoMat E33 flip the material along the machine’s Y-axis.

2. Confirm by clicking [OK].

The display in the machining view changes. The position of the design is adjusted to the circuit board. The side of the circuit board to be processed is now the “Top” side.

Note
Phase “Read Fiducials_Top”
S43, S63 and S103

Note
If the fiducial search is performed for the first time (after having started CircuitPro) the camera is performing an autofocus five times.
Afterwards the following message is displayed which prompts you to confirm the focus height:

The camera moves to the positions of the fiducials and determines the exact position.
The Top side is thus aligned to the Bottom side.
The following dialog is displayed if the fiducials have not been recognized automatically:

1. Enlarge the search area by increasing the value of the field ‘Search Area Length’.
2. Start the search again.
3. Repeat above steps if necessary.
Enlarging the search spiral increases the time required for searching the fiducials.

Note

E33, S43 without camera
If no camera is available for processing the “Read Fiducials_Top” phase, the Top side is aligned to the Bottom side using the reference pins. The “Read Fiducials_Top” phase is not processed in this case.

Phase “Milling Top”
- The machine picks up the required tools and mills the isolation tracks on the Top side.

Phase “Contour Routing”
- The machine picks up the required tools and drills and mills the outline of the circuit board.

Phase “Board Production Finished”
- A message informs you that the production is finished.
- The production of the circuit board is finished.

If desired, continue with dispensing solder paste on your PCB. Therefore please refer to the tutorial “Dispensing solder paste using the ProtoMat S63 or S103”.

Note

Subsequent to the board production you are able to label your circuit board or apply solder resist. LPKF offers you various systems such as the ProMask or ProLegend for these processes. Furthermore LPKF systems for applying solder paste, for mounting components and for soldering circuit boards are available. Do not hesitate to ask us.
3  Processing DXF files in CircuitPro

This tutorial shows you how to process DXF files in CircuitPro. The following steps are necessary to complete the tutorial successfully:

i. Importing the DXF file
ii. Converting the DXF file

---

Tip

You are able to perform these steps by using the virtual machine. This enables you to work without a real machine. Click on Machining > Connect > Virtual.
3.1 Importing the DXF file

CircuitPro must be running.

Note

The LPKF tutor data are stored in “My Document\LPKF Laser & Electronics\ LPKF CircuitPro 1.5\Example Data\UseCase_DXFFiles”.

Tip

- Importing the file
  1. Click the icon “Import” on the toolbar:

Or
  1. Click on File > Import…

The following dialog is displayed:

2. Select the file “Tutor_dxf.dxf”.
3. Click on [Open].
The document’s information is shown in the table.

4. Change the layer/template column to “TopLayer”:

<table>
<thead>
<tr>
<th>Import</th>
<th>File Name</th>
<th>Format</th>
<th>Aperture/Tool List</th>
<th>Layer/Template</th>
<th>Size/Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️</td>
<td>Tutor_dxf.dxf</td>
<td>Dxf format</td>
<td>Tutor_dxf.dxf</td>
<td>TopLayer</td>
<td>200 x 62 mm</td>
</tr>
</tbody>
</table>

5. Select in the tab “General” the increment that the DXF file was originally drawn in:

Tip

The information given in the column “Size/Format” enables you to check, if the actual size corresponds to the real size of your design.

If the size does not correspond to the real size, change the unit in the tab “General”.

6. Click on [OK].
The data is shown in the CAM view:

- The file was imported.

**Note**

Please note that certain data of the DXF files could be on non-visible layers.

When importing these files the corresponding layer is also non-visible in CircuitPro.
3.2 Converting the DXF file

Converting the DXF file includes the following steps:
- Defining the Board Outline
- Assigning the objects to the corresponding layers
- Converting the objects to polygons
- Converting the drilling holes

■ Defining the Board Outline

Tip
You are able to highlight every single element of the board outline by clicking and holding down the Shift-key. After having highlighted all elements you can combine them to a closed path by using the functions “Convert to closed path”.

1. Click on the board outline:

![Board outline selected](image)

2. Press the right mouse button.
3. Select “Assign objects to layer”.

4. Click on “BoardOutline”:

- The color of the board outline changes.
- The board outline is defined.
Assigning the objects to the corresponding layers

1. Highlight all traces that will go onto the top layer.

You can also single click on the traces. Hold the control key down to select multiple items.

2. Press the right mouse button.
3. Select “Assign objects to layer”.
4. Click on “TopLayer”:
The traces were assigned to the top layer.

5. Assign the drill holes to the layer “DrillUnplated”:
   a) Highlight all drill holes.
   b) Follow steps 2 and 3.
   c) Click on “DrillUnplated”

The drill holes were assigned to the layer “DrillUnplated”.
The objects were assigned to the corresponding layers.
Converting the objects to polygons

1. Single left click on the “TopLayer” in the pane “Layers”:

2. Click on the icon “Select objects on layer” in the pane “Layers”:
3. Press the right mouse button.
4. In the context menu, select “Convert to polygon”:

![Fig. 353: Convert to polygon](image)

Note
This will combine all segments and fill the object.

- The objects were converted to polygons.
Converting the drill holes

1. Highlight all drill holes:

You can also single click on the drill holes. Hold the control key down to select multiple items.

2. Click on Modify > Draw to flash:
   ◆ The drill holes were converted.

The .dxf file was successfully imported and converted. Now you can insert rubout areas or/and fiducials before you start processing your board. Please refer to the tutorial “Basic CAM operations” in this case.

If you want to start processing your board without inserting rubout areas/fiducials, please refer to the tutorial “Basic machining operations”.

4 Processing Gerber and Excellon files

This tutorial shows you how to process Gerber and Excellon files in CircuitPro. The following steps are necessary to complete the tutorial successfully:

i. Selecting Gerber and Excellon files
ii. Selecting the file format
iii. Selecting the desired target layer
iv. Setting/correcting size and format
v. Setting apertures and tools
vi. Using the layer name defined in the Gerber file

Tip

You can perform these steps by using the virtual machine. Thus, you can work without a real machine. Click on Machining > Connect > Virtual and [Connect].
4.1 Selecting Gerber and Excellon files

CircuitPro must be running.

Note

Selecting files

The LPKF tutor data are stored in “My Documents\LPKF Laser & Electronics\LPKF CircuitPro 1.5\Example Data\UseCase_BasicCAMOperations”.

Tip

1. Click the icon “Import” on the toolbar:

![Fig. 355: Icon import](image)

Or

1. Click on File > Import…

   ➤ The following dialog is displayed:

   ![Fig. 356: Import dialog](image)

2. Select all files in the folder.
Instead of selecting individual Gerber or Excellon files, you can select a whole folder. In this case, all files in the selected folder are displayed in the table (see figure below).

3. Click on [Open].

The files to be imported are displayed in the table:

The columns of the table highlighted contain the following information/settings:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import</td>
<td>Checkmark the files that you want to import.</td>
</tr>
<tr>
<td>File name</td>
<td>The name of the selected file is displayed.</td>
</tr>
<tr>
<td>Format</td>
<td>The format of the selected file is displayed. If CircuitPro has not recognised the file format correctly, you can assign the correct format in the corresponding drop-down list (for more information please refer to chapter “Selecting the file format”).</td>
</tr>
<tr>
<td>Aperture/Tool List</td>
<td>The Aperture list is usually part of the Gerber or Excellon file. The apertures contained are displayed in the “Apertures/Tools” tab.</td>
</tr>
<tr>
<td>Layer/Template</td>
<td>Assign the layer that is to contain the imported data (for more information please refer to the chapter “Selecting the desired target layer”).</td>
</tr>
<tr>
<td>Size/Format</td>
<td>The size of the imported design is displayed in this column (for more information please refer to the chapter “Setting/correcting size and format”).</td>
</tr>
</tbody>
</table>

◆ The files are selected.
4.2 Selecting the file format

If CircuitPro does not recognise the file format, the corresponding row in the dialog is grayed-out:

In such a case, the information on aperture list, layer, and format are also missing. You can select the file format manually.

- Selecting the file format
  1. In the “Format” column, click on the arrow button of the file concerned.
     - The format selection list is displayed:

   ![Fig. 359: Selecting the file format manually](image)

   - Click on the corresponding file format (“GerberX” in this case).
     - The information in the columns “Aperture/Tool List”, “Layer/Template”, and “Size/Format” is displayed automatically if you have selected the correct file format.

   ![Fig. 360: File details](image)

   - The checkmark in the “Import” column is set automatically by CircuitPro.
   - The file format is selected.
4.3 Selecting the desired target layer

Once you have selected the files to be imported, these files have to be assigned to layers in CircuitPro. You can assign the files in the “Layer/Template” column:

There are three ways to assign the layer:

1. **Keeping the layer that is created during file selection:**
   In this case, CircuitPro creates a new layer during the file import if it does not exist in the template (see /1/).

2. **Selecting a layer that already exists in the template file of CircuitPro:**
   These layers are in the templates of CircuitPro and appear in the drop-down lists that are shown when you click on the list’s arrow button (see /2/).

3. **Creating a new layer:**
   If you want to create a new layer, you can enter a name for the layer in the “Layer/Template” column. CircuitPro creates a new layer for this file during the file import (see /3/).

After the file import, the layers are listed in the “Layers” pane of CircuitPro:
4.4 Setting/correcting size and format

In some cases, the design of the file is not displayed correctly. There are four possible causes for this:

- Wrong measurement unit: A wrong measurement unit was selected when importing the file (inch instead of mm).
- Wrong number of decimal digits: The number of decimal digits entered does not match the file's contents.
- Wrong declaration of the value (relative/absolute)
- Wrong null suppression (decimal)

■ Checking and modifying the measurement unit

The dimensions of the imported files are listed in the “Size/Format” column. Millimeters are used by default.

Note

If the imported files are GerberX files, the measurement unit is preset by default and cannot be modified.
You can modify the measurement unit for all other file types (Gerber, Excellon etc.) in the “General” tab of CircuitPro’s Import dialog.

If the design size of some files looks peculiar, you should check the measurement unit:

1. Click on the tab “General”.

![Fig. 363: Abnormal design size](image)

![Fig. 364: Wrong measurement unit](image)
2. Check the measurement unit.
3. If the measurement unit is set to “inch”, click on the arrow button.
   ➔ The measurement unit selection list is displayed.
4. Select “mm” as measurement unit.
   ➔ The design's dimensions change automatically.

◆ The measurement unit has been checked and corrected.
Checking and correcting the number of decimal digits

If the design is still not displayed correctly in the “2D View” tab, you should check the number of decimal digits. An incorrect display of the design data may look as follows:

1. Click on the tab “General”.
2. Change the “n” digit count from “4” to “3”.

The design’s preview changes as follows:

The number of decimal digits has been checked and corrected.
4.5 Viewing/modifying aperture properties

You can view the properties of the apertures contained in the files. You can also modify the aperture properties according to your needs.

- Modifying aperture properties
  1. Select the file whose apertures you want to regard.
     ➔ The aperture contained in the file is displayed in the “Apertures/Tools” tab.
     ➔ The aperture properties are displayed in the “Attributes” tab.

The following aperture properties can be modified in the “Attributes” tab:
- Shape of the aperture (circle, square, oval, etc.)
- Rotation of the aperture
- Parameters that define the aperture's geometry
If you change the aperture's attributes, the “Attributes” tab displays a preview of the aperture.

In this example, the aperture's shape is to be changed from “circle” to “rectangle”.

2. Click on the arrow button of the drop-down list “Type”.
   - The aperture shape selection list is displayed:

   ![Available aperture shapes diagram]

3. Click on “Rectangle” in the drop-down list.
4. Enter “1.5” in the field \( A \).
   - The aperture's shape and size are changed according to your input:

   ![Modified aperture shape and size diagram]

   - The aperture's properties are modified.
4.6 Using the layer name defined in the Gerber file

The Gerber files contain the name of the layer. You can see the layer name in the “Text View” tab of the Import dialog:

Note

The option “Use layer name” is only available for importing Gerber files as the layer name is defined in the Gerber file.

- Using the layer name for import

In CircuitPro, you can either
  • define globally that the layer name is read from the Gerber files during import or
  • you activate this option only once during import.

How to activate the option globally:
1. Click on Extras > Options…

The following dialog is displayed:
2. Click in the category tree on the left on General > Import/Export > Formats > Gerber.

The dialog changes as follows:

![Fig. 373: Extras > Options](image)

3. Click on the arrow button of the drop-down list “Use layer name”.

- If the value of “Use layer name” is set to “True”, the correct layer is assigned to the Gerber files automatically in CircuitPro:

![Fig. 374: Import using option “Use layer name”](image)

- If the value is left at “False”, the option is not globally activated.

In the latter case, you can define each time again when importing Gerber files whether to use the layer name.

**Using the layer name automatically when importing:**

1. Switch to the “Options” tab in the “Import” dialog.
2. Checkmark the check boxes “Use layer name” and “Apply to all Gerber files”.

- The name contained in the Gerber files is used as the layer name.

**Note**

You can also import Gerber files without using the option “Use layer name”. In this case, you have to assign the files manually to the corresponding layer.
## List of figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fig. 1</td>
<td>Connection steps</td>
<td>10</td>
</tr>
<tr>
<td>Fig. 2</td>
<td>New document</td>
<td>11</td>
</tr>
<tr>
<td>Fig. 3</td>
<td>Import</td>
<td>12</td>
</tr>
<tr>
<td>Fig. 4</td>
<td>Assigned layers</td>
<td>13</td>
</tr>
<tr>
<td>Fig. 5</td>
<td>CAM view</td>
<td>14</td>
</tr>
<tr>
<td>Fig. 6</td>
<td>Create rectangle</td>
<td>15</td>
</tr>
<tr>
<td>Fig. 7</td>
<td>Rectangle around the pads</td>
<td>15</td>
</tr>
<tr>
<td>Fig. 8</td>
<td>IC pads</td>
<td>15</td>
</tr>
<tr>
<td>Fig. 9</td>
<td>Step &amp; Repeat</td>
<td>17</td>
</tr>
<tr>
<td>Fig. 10</td>
<td>Layout in CAM view</td>
<td>17</td>
</tr>
<tr>
<td>Fig. 11</td>
<td>Create circle</td>
<td>18</td>
</tr>
<tr>
<td>Fig. 12</td>
<td>Four fiducials</td>
<td>18</td>
</tr>
<tr>
<td>Fig. 13</td>
<td>Technology Dialog</td>
<td>19</td>
</tr>
<tr>
<td>Fig. 14</td>
<td>Computation Results</td>
<td>20</td>
</tr>
<tr>
<td>Fig. 15</td>
<td>Tool magazine</td>
<td>21</td>
</tr>
<tr>
<td>Fig. 16</td>
<td>Inserting the tool</td>
<td>21</td>
</tr>
<tr>
<td>Fig. 17</td>
<td>Tools in the tool magazine</td>
<td>22</td>
</tr>
<tr>
<td>Fig. 18</td>
<td>Machining &gt; Process all</td>
<td>23</td>
</tr>
<tr>
<td>Fig. 19</td>
<td>Material settings</td>
<td>24</td>
</tr>
<tr>
<td>Fig. 20</td>
<td>Right rear corner</td>
<td>25</td>
</tr>
<tr>
<td>Fig. 21</td>
<td>Click on button</td>
<td>25</td>
</tr>
<tr>
<td>Fig. 22</td>
<td>Lower left corner</td>
<td>26</td>
</tr>
<tr>
<td>Fig. 23</td>
<td>Defined processing area</td>
<td>26</td>
</tr>
<tr>
<td>Fig. 24</td>
<td>Placement</td>
<td>27</td>
</tr>
<tr>
<td>Fig. 25</td>
<td>Alignment</td>
<td>29</td>
</tr>
<tr>
<td>Fig. 26</td>
<td>Connection steps</td>
<td>32</td>
</tr>
<tr>
<td>Fig. 27</td>
<td>New document</td>
<td>33</td>
</tr>
<tr>
<td>Fig. 28</td>
<td>Import</td>
<td>34</td>
</tr>
<tr>
<td>Fig. 29</td>
<td>Assign layer</td>
<td>35</td>
</tr>
<tr>
<td>Fig. 30</td>
<td>CAM view</td>
<td>36</td>
</tr>
<tr>
<td>Fig. 31</td>
<td>Dispense</td>
<td>37</td>
</tr>
<tr>
<td>Fig. 32</td>
<td>Machining view with solder paste paths</td>
<td>38</td>
</tr>
<tr>
<td>Fig. 33</td>
<td>Technology Dialog</td>
<td>39</td>
</tr>
<tr>
<td>Fig. 34</td>
<td>Wizards &gt; Dispense preparation wizard</td>
<td>40</td>
</tr>
<tr>
<td>Fig. 35</td>
<td>Prepare dispenser</td>
<td>40</td>
</tr>
<tr>
<td>Fig. 36</td>
<td>Assembling the dispenser</td>
<td>41</td>
</tr>
<tr>
<td>Fig. 37</td>
<td>Enter the thickness</td>
<td>41</td>
</tr>
<tr>
<td>Fig. 38</td>
<td>Position of auxiliary board</td>
<td>42</td>
</tr>
<tr>
<td>Fig. 39</td>
<td>Head touching the paper</td>
<td>43</td>
</tr>
<tr>
<td>Fig. 40</td>
<td>Dispense icon</td>
<td>43</td>
</tr>
<tr>
<td>Fig. 41</td>
<td>Camera offset</td>
<td>44</td>
</tr>
<tr>
<td>Fig. 42</td>
<td>Alignment</td>
<td>44</td>
</tr>
<tr>
<td>Fig. 43</td>
<td>Dispense preparation finished</td>
<td>45</td>
</tr>
<tr>
<td>Fig. 44</td>
<td>Wizards &gt; Dispense process wizard</td>
<td>46</td>
</tr>
<tr>
<td>Fig. 45</td>
<td>Mount board</td>
<td>46</td>
</tr>
<tr>
<td>Fig.</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>--------</td>
<td>--------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>46</td>
<td>Enter the thickness</td>
<td>47</td>
</tr>
<tr>
<td>47</td>
<td>Select drill hole</td>
<td>48</td>
</tr>
<tr>
<td>48</td>
<td>Message “Select drill hole”</td>
<td>48</td>
</tr>
<tr>
<td>49</td>
<td>Alignment</td>
<td>49</td>
</tr>
<tr>
<td>50</td>
<td>Dispense icon</td>
<td>50</td>
</tr>
<tr>
<td>51</td>
<td>Process dispensing</td>
<td>51</td>
</tr>
<tr>
<td>52</td>
<td>Connection steps</td>
<td>54</td>
</tr>
<tr>
<td>53</td>
<td>New document</td>
<td>55</td>
</tr>
<tr>
<td>54</td>
<td>Material properties</td>
<td>55</td>
</tr>
<tr>
<td>55</td>
<td>CAM view</td>
<td>56</td>
</tr>
<tr>
<td>56</td>
<td>Create rectangle</td>
<td>57</td>
</tr>
<tr>
<td>57</td>
<td>Rectangle in CAM view</td>
<td>57</td>
</tr>
<tr>
<td>58</td>
<td>Second rectangle</td>
<td>58</td>
</tr>
<tr>
<td>59</td>
<td>Create circle</td>
<td>59</td>
</tr>
<tr>
<td>60</td>
<td>Circle in CAM view</td>
<td>59</td>
</tr>
<tr>
<td>61</td>
<td>Step Repeat</td>
<td>60</td>
</tr>
<tr>
<td>62</td>
<td>Multiplying the circle in X direction</td>
<td>60</td>
</tr>
<tr>
<td>63</td>
<td>Select all objects</td>
<td>62</td>
</tr>
<tr>
<td>64</td>
<td>Context menu</td>
<td>62</td>
</tr>
<tr>
<td>65</td>
<td>Convert into 2.5D</td>
<td>63</td>
</tr>
<tr>
<td>66</td>
<td>Properties of the 2.5D object</td>
<td>63</td>
</tr>
<tr>
<td>67</td>
<td>Create 2.5D milling</td>
<td>65</td>
</tr>
<tr>
<td>68</td>
<td>CAM view</td>
<td>66</td>
</tr>
<tr>
<td>69</td>
<td>3D view</td>
<td>66</td>
</tr>
<tr>
<td>70</td>
<td>Tool magazine</td>
<td>67</td>
</tr>
<tr>
<td>71</td>
<td>Inserting the tool</td>
<td>67</td>
</tr>
<tr>
<td>72</td>
<td>Assigning the tools in the dialog</td>
<td>68</td>
</tr>
<tr>
<td>73</td>
<td>Assigned tools</td>
<td>68</td>
</tr>
<tr>
<td>74</td>
<td>Assigning additional tools</td>
<td>69</td>
</tr>
<tr>
<td>75</td>
<td>Tools in the tool magazine</td>
<td>69</td>
</tr>
<tr>
<td>76</td>
<td>Machining &gt; Process all</td>
<td>70</td>
</tr>
<tr>
<td>77</td>
<td>Material placement</td>
<td>71</td>
</tr>
<tr>
<td>78</td>
<td>Pane „Processing“</td>
<td>71</td>
</tr>
<tr>
<td>79</td>
<td>Autofocus</td>
<td>72</td>
</tr>
<tr>
<td>80</td>
<td>Cross hair of camera</td>
<td>72</td>
</tr>
<tr>
<td>81</td>
<td>Message for second position</td>
<td>72</td>
</tr>
<tr>
<td>82</td>
<td>Move to measuring position</td>
<td>72</td>
</tr>
<tr>
<td>83</td>
<td>Material surface level defined</td>
<td>73</td>
</tr>
<tr>
<td>84</td>
<td>Dismount the depth limiter</td>
<td>74</td>
</tr>
<tr>
<td>85</td>
<td>Pneumatic Depth limiter</td>
<td>75</td>
</tr>
<tr>
<td>86</td>
<td>Fasten depth limiter</td>
<td>75</td>
</tr>
<tr>
<td>87</td>
<td>Mechanical depth limiter</td>
<td>76</td>
</tr>
<tr>
<td>88</td>
<td>Connection steps</td>
<td>78</td>
</tr>
<tr>
<td>89</td>
<td>New document</td>
<td>79</td>
</tr>
<tr>
<td>90</td>
<td>Material properties</td>
<td>79</td>
</tr>
<tr>
<td>91</td>
<td>CAM view</td>
<td>80</td>
</tr>
<tr>
<td>92</td>
<td>Importing the STEP file</td>
<td>81</td>
</tr>
<tr>
<td>Fig.</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>-----</td>
<td>-----------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>93</td>
<td>3D view</td>
<td>82</td>
</tr>
<tr>
<td>94</td>
<td>Transformation</td>
<td>82</td>
</tr>
<tr>
<td>95</td>
<td>Rotate [auto]</td>
<td>83</td>
</tr>
<tr>
<td>96</td>
<td>3D view rotated around Z axis</td>
<td>83</td>
</tr>
<tr>
<td>97</td>
<td>Move in X and Y direction</td>
<td>84</td>
</tr>
<tr>
<td>98</td>
<td>Move object in Z direction</td>
<td>84</td>
</tr>
<tr>
<td>99</td>
<td>Create 2.5D milling</td>
<td>85</td>
</tr>
<tr>
<td>100</td>
<td>3D view</td>
<td>86</td>
</tr>
<tr>
<td>101</td>
<td>Creating circles</td>
<td>87</td>
</tr>
<tr>
<td>102</td>
<td>CAM view with fiducials</td>
<td>88</td>
</tr>
<tr>
<td>103</td>
<td>Technology Dialog</td>
<td>89</td>
</tr>
<tr>
<td>104</td>
<td>Tool magazine</td>
<td>90</td>
</tr>
<tr>
<td>105</td>
<td>Inserting the tool</td>
<td>90</td>
</tr>
<tr>
<td>106</td>
<td>Tools in the tool magazine</td>
<td>91</td>
</tr>
<tr>
<td>107</td>
<td>Machining &gt; Process all</td>
<td>92</td>
</tr>
<tr>
<td>108</td>
<td>Material placement</td>
<td>93</td>
</tr>
<tr>
<td>109</td>
<td>Pane „Processing“</td>
<td>93</td>
</tr>
<tr>
<td>110</td>
<td>Autofocus</td>
<td>94</td>
</tr>
<tr>
<td>111</td>
<td>Cross hair of camera</td>
<td>94</td>
</tr>
<tr>
<td>112</td>
<td>Message for second position</td>
<td>95</td>
</tr>
<tr>
<td>113</td>
<td>Move to measuring position</td>
<td>95</td>
</tr>
<tr>
<td>114</td>
<td>Material surface level defined</td>
<td>96</td>
</tr>
<tr>
<td>115</td>
<td>Dismount the depth limiter</td>
<td>96</td>
</tr>
<tr>
<td>116</td>
<td>Pneumatic Depth limiter</td>
<td>97</td>
</tr>
<tr>
<td>117</td>
<td>Fasten depth limiter</td>
<td>97</td>
</tr>
<tr>
<td>118</td>
<td>Mechanical depth limiter</td>
<td>98</td>
</tr>
<tr>
<td>119</td>
<td>Alignment</td>
<td>99</td>
</tr>
<tr>
<td>120</td>
<td>Centering the fiducial</td>
<td>100</td>
</tr>
<tr>
<td>121</td>
<td>Connection steps</td>
<td>102</td>
</tr>
<tr>
<td>122</td>
<td>New document</td>
<td>103</td>
</tr>
<tr>
<td>123</td>
<td>CAM view - multi-layer</td>
<td>103</td>
</tr>
<tr>
<td>124</td>
<td>Import</td>
<td>105</td>
</tr>
<tr>
<td>125</td>
<td>Assigned layers</td>
<td>106</td>
</tr>
<tr>
<td>126</td>
<td>CAM view</td>
<td>106</td>
</tr>
<tr>
<td>127</td>
<td>Create Rectangle</td>
<td>107</td>
</tr>
<tr>
<td>128</td>
<td>Rubout Top</td>
<td>107</td>
</tr>
<tr>
<td>129</td>
<td>Rubout Bottom</td>
<td>108</td>
</tr>
<tr>
<td>130</td>
<td>Step &amp; Repeat</td>
<td>109</td>
</tr>
<tr>
<td>131</td>
<td>Design in the CAM view</td>
<td>110</td>
</tr>
<tr>
<td>132</td>
<td>Technology Dialog</td>
<td>111</td>
</tr>
<tr>
<td>133</td>
<td>CAM view</td>
<td>112</td>
</tr>
<tr>
<td>134</td>
<td>Tool magazine</td>
<td>113</td>
</tr>
<tr>
<td>135</td>
<td>Inserting a tool</td>
<td>113</td>
</tr>
<tr>
<td>136</td>
<td>Loaded tool holder</td>
<td>114</td>
</tr>
<tr>
<td>137</td>
<td>Machining &gt; Process all</td>
<td>115</td>
</tr>
<tr>
<td>138</td>
<td>Material Settings</td>
<td>116</td>
</tr>
<tr>
<td>139</td>
<td>Defining the right rear corner</td>
<td>117</td>
</tr>
<tr>
<td>Fig.</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>------</td>
<td>------------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>140</td>
<td>Click on the icon</td>
<td>117</td>
</tr>
<tr>
<td>141</td>
<td>Defining the front left corner</td>
<td>117</td>
</tr>
<tr>
<td>142</td>
<td>Defined processing area</td>
<td>118</td>
</tr>
<tr>
<td>143</td>
<td>Placement</td>
<td>118</td>
</tr>
<tr>
<td>144</td>
<td>Alignment</td>
<td>120</td>
</tr>
<tr>
<td>145</td>
<td>Connection steps</td>
<td>128</td>
</tr>
<tr>
<td>146</td>
<td>New document</td>
<td>129</td>
</tr>
<tr>
<td>147</td>
<td>Create rectangle</td>
<td>130</td>
</tr>
<tr>
<td>148</td>
<td>Rectangle</td>
<td>131</td>
</tr>
<tr>
<td>149</td>
<td>Pane “Layers”</td>
<td>132</td>
</tr>
<tr>
<td>150</td>
<td>Mode “Thin Line”</td>
<td>132</td>
</tr>
<tr>
<td>151</td>
<td>Create rectangle</td>
<td>133</td>
</tr>
<tr>
<td>152</td>
<td>Rectangles in the CAM view</td>
<td>133</td>
</tr>
<tr>
<td>153</td>
<td>Create circle</td>
<td>135</td>
</tr>
<tr>
<td>154</td>
<td>Created circle</td>
<td>135</td>
</tr>
<tr>
<td>155</td>
<td>Multiplied circles</td>
<td>136</td>
</tr>
<tr>
<td>156</td>
<td>Another series of drill holes</td>
<td>137</td>
</tr>
<tr>
<td>157</td>
<td>Drill holes</td>
<td>138</td>
</tr>
<tr>
<td>158</td>
<td>Create Polygon</td>
<td>139</td>
</tr>
<tr>
<td>159</td>
<td>Polygon</td>
<td>139</td>
</tr>
<tr>
<td>160</td>
<td>Circular mark</td>
<td>140</td>
</tr>
<tr>
<td>161</td>
<td>Circular marks</td>
<td>141</td>
</tr>
<tr>
<td>162</td>
<td>Define text</td>
<td>142</td>
</tr>
<tr>
<td>163</td>
<td>Text in CAM view</td>
<td>143</td>
</tr>
<tr>
<td>164</td>
<td>Holes in CAM view</td>
<td>144</td>
</tr>
<tr>
<td>165</td>
<td>Create closed path</td>
<td>145</td>
</tr>
<tr>
<td>166</td>
<td>Open path</td>
<td>145</td>
</tr>
<tr>
<td>167</td>
<td>Cutouts for the fan</td>
<td>146</td>
</tr>
<tr>
<td>168</td>
<td>Pane „Properties“</td>
<td>147</td>
</tr>
<tr>
<td>169</td>
<td>Line width changed</td>
<td>147</td>
</tr>
<tr>
<td>170</td>
<td>Create Circle</td>
<td>148</td>
</tr>
<tr>
<td>171</td>
<td>Created circle</td>
<td>148</td>
</tr>
<tr>
<td>172</td>
<td>Created circles</td>
<td>149</td>
</tr>
<tr>
<td>173</td>
<td>Pane “Layers“</td>
<td>150</td>
</tr>
<tr>
<td>174</td>
<td>Technology Dialog</td>
<td>151</td>
</tr>
<tr>
<td>175</td>
<td>Created toolpaths</td>
<td>152</td>
</tr>
<tr>
<td>176</td>
<td>Tool magazine</td>
<td>153</td>
</tr>
<tr>
<td>177</td>
<td>Inserting a tool</td>
<td>153</td>
</tr>
<tr>
<td>178</td>
<td>Loaded tool holder</td>
<td>154</td>
</tr>
<tr>
<td>179</td>
<td>Machining &gt; Process all</td>
<td>155</td>
</tr>
<tr>
<td>180</td>
<td>Material settings</td>
<td>156</td>
</tr>
<tr>
<td>181</td>
<td>Defining the right rear corner</td>
<td>157</td>
</tr>
<tr>
<td>182</td>
<td>Click on the icon</td>
<td>157</td>
</tr>
<tr>
<td>183</td>
<td>Defining the front left corner</td>
<td>158</td>
</tr>
<tr>
<td>184</td>
<td>Defined processing area</td>
<td>158</td>
</tr>
<tr>
<td>185</td>
<td>Placement</td>
<td>159</td>
</tr>
<tr>
<td>186</td>
<td>Connection steps</td>
<td>162</td>
</tr>
</tbody>
</table>
List of figures

Fig. 187: New document ................................................................. 163
Fig. 188: Import .............................................................................. 164
Fig. 189: Assign layers ................................................................. 165
Fig. 190: CAM view ................................................................. 165
Fig. 191: Identical proportion .......................................................... 166
Fig. 192: Transformation >Scale .................................................. 167
Fig. 193: Dimensions changed ....................................................... 167
Fig. 194: “Layers” pane ............................................................... 168
Fig. 195: Technology Dialog ...................................................... 168
Fig. 196: Insulation details ......................................................... 169
Fig. 197: Deactivating functions .................................................. 170
Fig. 198: Tool magazine ............................................................. 172
Fig. 199: Insert tool ................................................................. 172
Fig. 200: Loaded tool holder ....................................................... 173
Fig. 201: Machining > Process all ................................................ 174
Fig. 202: Material Settings ........................................................ 175
Fig. 203: Right rear corner ......................................................... 176
Fig. 204: Click on button ........................................................... 176
Fig. 205: Front left corner .......................................................... 177
Fig. 206: Click on the button ....................................................... 177
Fig. 207: Placement ................................................................. 178
Fig. 208: Connection steps ......................................................... 182
Fig. 209: New document ............................................................ 183
Fig. 210: CAM view ................................................................. 184
Fig. 211: Phases ................................................................. 185
Fig. 212: Moving fiducials ........................................................... 185
Fig. 213: Import ................................................................. 187
Fig. 214: CAM view ................................................................. 188
Fig. 215: “Toolpath” pane .......................................................... 189
Fig. 216: “Layers” pane ............................................................ 190
Fig. 217: Phase selection list ...................................................... 190
Fig. 218: Technology Dialog ...................................................... 193
Fig. 219: Insulation details ......................................................... 194
Fig. 220: Fiducials - details ......................................................... 194
Fig. 221: Deactivate functions .................................................... 195
Fig. 222: Tool magazine ............................................................ 196
Fig. 223: Inserting a tool .......................................................... 196
Fig. 224: Loaded tool holder ...................................................... 197
Fig. 225: Machining > Process all ................................................ 198
Fig. 226: Material Settings ........................................................ 199
Fig. 227: Defining the right rear corner ........................................ 200
Fig. 228: Click on the icon ........................................................ 200
Fig. 229: Defining the front left corner ........................................ 200
Fig. 230: Defined processing area ............................................... 201
Fig. 231: Placement ............................................................... 201
Fig. 232: Technology Dialog ...................................................... 204
Fig. 233: Contour routing details ................................................ 204
Fig. 281: Inserting a tool ................................................................. 236
Fig. 282: Loaded tool holder .......................................................... 237
Fig. 283: Machining > Process all .................................................. 238
Fig. 284: Material Settings .............................................................. 239
Fig. 285: Defining the right rear corner ....................................... 240
Fig. 286: Click on the icon ............................................................. 240
Fig. 287: Defining the front left corner ....................................... 240
Fig. 288: Defined material area ..................................................... 241
Fig. 289: Alignment ................................................................. 242
Fig. 290: Icon Process Planning Wizard ...................................... 246
Fig. 291: Process planning wizard ............................................. 246
Fig. 292: Process planning wizard ............................................. 247
Fig. 293: Selecting the substrate ............................................... 247
Fig. 294: Through hole plating equipment ................................ 248
Fig. 295: Surface finishing ........................................................... 248
Fig. 296: Summary ................................................................. 249
Fig. 297: Icon import ............................................................... 250
Fig. 299: Assigned layers ............................................................ 251
Fig. 300: Icon import ............................................................... 253
Fig. 301: Import dialog ............................................................... 253
Fig. 302: Changing the layer column ......................................... 254
Fig. 303: Display correct ............................................................. 255
Fig. 304: Design displayed in CAM view .................................... 255
Fig. 311: Icon Technology Dialog ............................................. 260
Fig. 312: Technology Dialog ......................................................... 260
Fig. 313: Basic insulation ............................................................ 261
Fig. 314: Basic insulation, pads double ..................................... 261
Fig. 315: Partial rubout ............................................................... 262
Fig. 316: Complete rubout ............................................................ 262
Fig. 317: Basic routing ............................................................... 263
Fig. 318: Horizontal gaps routing ............................................. 263
Fig. 319: Vertical gaps routing ................................................. 264
Fig. 320: Edge gaps routing ......................................................... 264
Fig. 321: Corner gap routing ....................................................... 264
Fig. 322: Equidis-tant gaps routing ........................................... 265
Fig. 323: Tool drop-down menu ............................................... 265
Fig. 324: Computation Results .................................................... 266
Fig. 325: Tab “Machining view” .................................................. 268
Fig. 326: Machining view ............................................................ 268
Fig. 327: Icon Tool magazine ....................................................... 269
Fig. 328: Tool magazine ............................................................. 269
Fig. 329: Tool list ................................................................. 270
Fig. 330: Insert tool into holder ................................................ 270
Fig. 331: Tool magazine ............................................................. 271
Fig. 332: Colors of the tool holders .......................................... 271
Fig. 333: Icon “Process Planning wizard” .................................. 272
Fig. 334: Machining > Process all ............................................. 272
Fig. 335: Material settings ................................................................................. 273
Fig. 336: Right rear corner .................................................................................. 274
Fig. 337: Click on button ..................................................................................... 274
Fig. 338: Front left corner ................................................................................... 275
Fig. 339: Defined processing area ....................................................................... 275
Fig. 340: Placement ............................................................................................. 276
Fig. 341: Alignment ............................................................................................. 278
Fig. 342: Icon import .......................................................................................... 282
Fig. 343: Import dialog ....................................................................................... 282
Fig. 344: Change column ................................................................................... 283
Fig. 345: Selecting the increment ........................................................................ 283
Fig. 346: CAM view ............................................................................................ 284
Fig. 347: Icon import ......................................................................................... 294
Fig. 348: Import dialog ....................................................................................... 294
Fig. 349: Imported files ....................................................................................... 295
Fig. 350: Unrecognised files .............................................................................. 296
Fig. 351: Selecting the file format manually ....................................................... 296
Fig. 352: File details ........................................................................................... 296
Fig. 353: “Layer/Template” column .................................................................. 297
Fig. 354: “Layers” pane ...................................................................................... 297
Fig. 355: Abnormal design size ......................................................................... 298
Fig. 356: Wrong measurement unit ................................................................... 298
Fig. 357: Corrected measurement unit ................................................................. 299
Fig. 358: Incorrect preview .............................................................................. 300
Fig. 359: Correct preview ................................................................................. 300
Fig. 360: Aperture properties ............................................................................ 301
Fig. 361: Available aperture shapes ................................................................... 302
Fig. 362: Modified aperture shape and size ....................................................... 302
Fig. 363: Layer name in Gerber file .................................................................. 303
Fig. 364: Extras > Options ............................................................................... 303
Fig. 365: Extras > Options ............................................................................... 304
Fig. 366: Import using option “Use layer name” ................................................. 304
Fig. 367: “Options” tab ..................................................................................... 305